Sunday, July 21, 2013

Setting up My Cisco 871w Home Lab Router

I've searched on the Internet what's the best router for a CCNA lab and learned from Wendell Odom's blog that he chose the 1700 as the winner. But the idea of having a "wired" router doesn't appeal to me when networks nowadays have converted to wireless. It's still cool though to have a 1721 router someday for my lab (if budget permits it).

So I've decided to buy a Cisco 871w router on Ebay, which supports wireless (not to mention IOS 15.0), not too long ago and replaced my existing Linksys E1200 at home. I've configured it one night and here's the configuration that worked for me and the troubleshooting I went through. Another cool thing having this router is that I can configure it remotely using my iPhone or iPad with this free app.




We configure a bridge group and enable IRB (Integrated Routing and Bridging) to "bridge" network traffic and routing protocols between a logical bridge interface and the routed (Layer 3) interface. 


871W(config)#interface dot11radio0    // CONFIGURE THE RADIO INTERFACE
871W(config-if)#encryption vlan 1 mode ciphers tkip 
871W(config-if)#ssid Lagura
871W(config-if-ssid)#vlan 1
871W(config-if-ssid)#authentication open
871W(config-if-ssid)#authentication key-management wpa
871W(config-if-ssid)#wpa-psk ascii cisco
871W(config-if)#bridge-group 1   
871W(config-if)#no shutdown
871W(config-if)#interface bvi1
Integrated Routing and Bridging is not configured!
                       ^
% Invalid input detected at '^' marker.

*May 19 19:31:38.867: %DOT11-4-NO_SSID: No SSID configured. Dot11Radio0 not started.
*May 19 19:31:38.871: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset
871W(config)#bridge irb    // ENABLE IRB
871W(config-if)#interface bvi1   // LAYER 3 PROPERTIES FOR BVI LOGICAL INTERFACE
871W(config-if)#
*May 19 19:32:48.272: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to up
871W(config-if)#
*May 19 19:32:50.988: %LINK-3-UPDOWN: Interface BVI1, changed state to down
*May 19 19:32:51.989: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to down
871W(config-if)#ip address 192.168.1.1 255.255.255.0
871W(config-if)#
*May 19 19:33:22.460: %DOT11-4-NO_SSID: No SSID configured. Dot11Radio0 not started.
871W(config-if)#ip nat inside
871W(config-if)#exit
*May 19 19:33:36.134: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
871W(config)#ip nat inside source list 10 interface fastethernet4 overload   // NAT OVERLOAD/PAT
871W(config)#access-list 10 permit 192.168.1.0 0.0.0.255    // ACL FOR PAT
871W(config)#bridge 1 protocol ieee    // ENABLES BRIDGING
871W(config)#
*May 19 19:43:21.780: %DOT11-4-NO_SSID: No SSID configured. Dot11Radio0 not started.
871W(config)#bridge 1 route ip    // ENBALES BRIDGING AND ROUTING FOR IP PROTOCOL
871W(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.5
871W(config)#ip dhcp pool LAN_POOL    // DYNAMIC PRIVATE IP FOR CLIENTS
871W(dhcp-config)#network 192.168.1.0 /24
871W(dhcp-config)#default-router 192.168.1.1
871W(dhcp-config)#import all    // AUTO OBTAIN DEFAULT STATIC ROUTE AND DNS INFO
871W(dhcp-config)#exit
871W(config)#interface vlan 1
871W(config-if)#no ip address
871W(config-if)#ip nat inside
871W(config-if)#bridge-group 1
871W(config-if)#
*May 19 19:50:34.515: %LINK-3-UPDOWN: Interface BVI1, changed state to up
*May 19 19:50:35.515: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to up


My laptop's wireless NIC still couldn't detect the 871w wireless signal (SSID) and so I tweaked it further.


871W(config)#dot11 ssid Lagura
871W(config-ssid)#?
ssid configuration commands:
  accounting           radius accounting
  authentication       authentication method
  exit                 Exit from ssid sub mode
  guest-mode           guest ssid
  information-element  Add information element
  infrastructure-ssid  ssid used to associate to other infrastructure devices
  ip                   IP options
  max-associations     set maximum associations for ssid
  mbssid               Multiple BSSID
  mobility             enable L3 mobility
  no                   Negate a command or set its defaults
  vlan                 bind ssid to vlan
  wpa-psk              Configure Wi-Fi Protected Access pre-shared key
871W(config-ssid)#no vlan 1
871W(config-ssid)#
*May 19 19:32:03.434: %DOT11-6-FREQ_SCAN: Interface Dot11Radio0, Scanning frequencies for 19 seconds
871W(config-ssid)#
*May 19 19:32:22.897: %DOT11-6-FREQ_USED: Interface Dot11Radio0, frequency 2422 selected
871W(config-ssid)#
*May 19 19:32:22.901: %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up
*May 19 19:32:23.901: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up
871W(config-ssid)#
*May 19 19:32:28.414: %LINK-3-UPDOWN: Interface BVI1, changed state to up
*May 19 19:32:29.414: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to up
871W(config-ssid)#guest-mode     // SSID "Lagura" APPEARED ON MY PC's WIFI LIST
871W(config-ssid)#authentication  key-management  wpa optional
Dot11Radio0 Error: Encryption mode cipher is not configured
871W(config-if)#no encryption vlan 1 mode ciphers tkip
871W(config-if)#encryption mode cipher aes-ccm tkip  // MY PC ASSOCIATED TO THE 871w
871W(config-if)#
*May 19 19:46:11.830: %DOT11-6-ASSOC: Interface Dot11Radio0, Station  ec55.f901.f90c Associated SSID[Lagura] AUTH_TYPE[OPEN] KEY_MGMT[WPAv2 PSK]
871W(config-if)#
*May 19 19:46:50.226: %DOT11-6-ASSOC: Interface Dot11Radio0, Station   e0f8.47a0.3b2f Associated SSID[Lagura] AUTH_TYPE[OPEN] KEY_MGMT[WPAv2 PSK]
871W(config-if)#exit
*May 19 19:46:54.783: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station e0f8.47a0.3b2f Reason: Sending station has left the BSS SSID[Lagura]
871W(config)#interface fastethernet4    // WAN PORT FACING CABLE MODEM
871W(config-if)#ip address dhcp
871W(config-if)#ip nat outside
871W(config-if)#no shutdown
*May 19 19:51:25.373: %LINK-3-UPDOWN: Interface FastEthernet4, changed state to up
*May 19 19:51:26.373: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to up
871W(config-if)#do show interface f4
FastEthernet4 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 0026.99c6.db2e (bia 0026.99c6.db2e)
  Internet address will be negotiated using DHCP
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:11, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4 packets input, 240 bytes
     Received 4 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     9 packets output, 5562 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


I was pulling out my hair at this point while figuring out why the router doesn't get its dynamic IP from the ISP. So I ran some debugs to dig further.


871W#debug dhcp detail
DHCP client activity debugging is on (detailed)
871W#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
871W(config)#interface fastethernet4
871W(config-if)#shutdown
871W(config-if)#
*May 19 20:21:46.745 UTC: DHCP: Release IPL called for interface FastEthernet4 in state 11
*May 19 20:21:46.745 UTC: RAC: DHCP stopped on interface FastEthernet4
*May 19 20:21:48.157 UTC: DHCP: QScan: Purging entry
*May 19 20:21:48.157 UTC: DHCP: deleting entry 83113338 0.0.0.0 from list
*May 19 20:21:48.157 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:21:48.157 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:21:48.157 UTC:    DHCP Lease server: 0.0.0.0, state: 11 Purging
871W(config-if)#
*May 19 20:21:48.157 UTC:    DHCP transaction id: 15FA
*May 19 20:21:48.157 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:21:48.157 UTC:    No timer running
*May 19 20:21:48.157 UTC:    Retry count: 0   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:21:48.157 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:21:48.157 UTC:                        646232652D466134
*May 19 20:21:48.157 UTC:    Hostname: 871W
871W(config-if)#
*May 19 20:21:48.745 UTC: %LINK-5-CHANGED: Interface FastEthernet4, changed state to administratively down
*May 19 20:21:49.745 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to down
871W(config-if)#no shutdown
871W(config-if)#
*May 19 20:22:00.355 UTC: DHCP: DHCP client process started: 10
*May 19 20:22:00.355 UTC: DHCP: Waiting for 5 seconds on interface FastEthernet4 to come up
871W(config-if)#
*May 19 20:22:02.351 UTC: %LINK-3-UPDOWN: Interface FastEthernet4, changed state to up
*May 19 20:22:03.351 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to up
871W(config-if)#
*May 19 20:22:05.355 UTC: RAC: Starting DHCP discover on FastEthernet4
*May 19 20:22:05.355 UTC: DHCP: Try 1 to acquire address for FastEthernet4
*May 19 20:22:05.359 UTC: DHCP: allocate request
*May 19 20:22:05.359 UTC: DHCP: new entry. add to queue, interface FastEthernet4
*May 19 20:22:05.359 UTC: DHCP: SDiscover attempt # 1 for entry:
*May 19 20:22:05.359 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:05.359 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:05.359
871W(config-if)#UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:22:05.359 UTC:    DHCP transaction id: 2260
*May 19 20:22:05.359 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:05.359 UTC:    Next timer fires after: 00:00:04
*May 19 20:22:05.359 UTC:    Retry count: 1   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:05.359 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:05.359 UTC:                        646232652D466134
*May 19 20:22:05.359 UTC:    Hostname: 871W
*May 19 20:22:05.363 UTC: DHCP: SDiscover: sending 291 byte length DHCP packet
*May 19 20:22:05.363 UTC: DHCP: SDiscover 291 bytes
*May 19 20:22:05.363 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
871W(config-if)#
*May 19 20:22:09.160 UTC: DHCP: SDiscover attempt # 2 for entry:
*May 19 20:22:09.160 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:09.160 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:09.160 UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:22:09.160 UTC:    DHCP transaction id: 2260
*May 19 20:22:09.160 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:09.160 UTC:    Next timer fires after: 00:00:04
*May 19 20:22:09.160 UTC:    Retry count: 2   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:09.160 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:09.160 UTC:                        646232652D466134
*May 19 20:22:09.160 UTC:    Hostname: 871W
*May 19 20:22:09.160 UTC: DHCP: SDiscover: sending 291 byte length DHCP packet
*May 19 20:22:09.160 UTC: DHCP: SDiscover 291 bytes
*May 19 20:22:09.160 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
871W(config-if)#
*May 19 20:22:13.160 UTC: DHCP: SDiscover attempt # 3 for entry:
*May 19 20:22:13.160 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:13.160 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:13.160 UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:22:13.160 UTC:    DHCP transaction id: 2260
*May 19 20:22:13.160 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:13.160 UTC:    Next timer fires after: 00:00:04
*May 19 20:22:13.160 UTC:    Retry count: 3   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:13.160 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:13.160 UTC:                        646232652D466134
*May 19 20:22:13.160 UTC:    Hostname: 871W
*May 19 20:22:13.160 UTC: DHCP: SDiscover: sending 291 byte length DHCP packet
*May 19 20:22:13.160 UTC: DHCP: SDiscover 291 bytes
*May 19 20:22:13.160 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
871W(config-if)#
*May 19 20:22:17.161 UTC: DHCP: QScan: Timed out Selecting state
871W(config-if)#%Unknown DHCP problem.. No allocation possible
*May 19 20:22:25.882 UTC: DHCP: Waiting for 5 seconds on interface FastEthernet4
871W(config-if)#
*May 19 20:22:30.883 UTC: DHCP: Try 2 to acquire address for FastEthernet4
*May 19 20:22:30.887 UTC: DHCP: allocate request
*May 19 20:22:30.887 UTC: DHCP: zapping entry in DHC_PURGING state for Fa4
*May 19 20:22:30.887 UTC: DHCP: deleting entry 83A9A9EC 0.0.0.0 from list
*May 19 20:22:30.887 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:30.887 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:30.887 UTC:    DHCP Lease server: 0.0.0.0, state: 11 Purging
*May 19 20:22:
871W(config-if)#30.887 UTC:    DHCP transaction id: 2260
*May 19 20:22:30.887 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:30.887 UTC:    Next timer fires after: 00:00:26
*May 19 20:22:30.887 UTC:    Retry count: 0   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:30.887 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:30.887 UTC:                        646232652D466134
*May 19 20:22:30.887 UTC:    Hostname: 871W
*May 19 20:22:30.887 UTC: DHCP: new entry. add to queue, interface FastEthernet4
*May 19 20:22:30.887 UTC: DHCP: SDiscover attempt # 1 for entry:
*May 19 20:22:30.891 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:30.891 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:30.891 UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:22:30.891 UTC:    DHCP transaction id: 2261
*May 19 20:22:30.891 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:30.891 UTC:    Next timer fires after: 00:00
871W(config-if)#:04
*May 19 20:22:30.891 UTC:    Retry count: 1   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:30.891 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:30.891 UTC:                        646232652D466134
*May 19 20:22:30.891 UTC:    Hostname: 871W
*May 19 20:22:30.891 UTC: DHCP: SDiscover: sending 291 byte length DHCP packet
*May 19 20:22:30.891 UTC: DHCP: SDiscover 291 bytes
*May 19 20:22:30.891 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
*May 19
871W(config-if)#20:22:33.039 UTC: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station bc3b.af51.8448 Reason: Sending station has left the BSS SSID[Lagura]
*May 19 20:22:33.391 UTC: %DOT11-6-ASSOC: Interface Dot11Radio0, Station   bc3b.af51.8448 Associated SSID[Lagura] AUTH_TYPE[OPEN] KEY_MGMT[WPAv2 PSK]
*May 19 20:22:34.163 UTC: DHCP: SDiscover attempt # 2 for entry:
*May 19 20:22:34.163 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:34.163 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:34.163 UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:22:34.163 UTC:    DHCP transaction id: 2261
*May 19 20:22:34.163 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:34.163 UTC:    Next timer fires after: 00:00:04
*May 19 20:22:34.163 UTC:    Retry count: 2   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:34.163 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:34.163 UTC:                        646232652D466134
*May 19 20:22:34.163 UTC:    Hostname: 871W
*May 19 20:22:34.163 UTC: DHCP: SDiscover: sending 291 byte length DHCP packet
*May 19 20:22:34.163 UTC: DHCP: SDiscover 291 bytes
*May 19 20:22:34.163 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
871W(config-if)#
*May 19 20:22:38.164 UTC: DHCP: SDiscover attempt # 3 for entry:
*May 19 20:22:38.164 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:22:38.164 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:22:38.164 UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:22:38.164 UTC:    DHCP transaction id: 2261
*May 19 20:22:38.164 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:22:38.164 UTC:    Next timer fires after: 00:00:04
*May 19 20:22:38.164 UTC:    Retry count: 3   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:22:38.164 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:22:38.164 UTC:                        646232652D466134
*May 19 20:22:38.164 UTC: Hostname: 871W
*May 19 20:22:38.164 UTC: DHCP: SDiscover: sending 291 byte length DHCP packet
*May 19 20:22:38.164 UTC: DHCP: SDiscover 291 bytes
*May 19 20:22:38.164 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
871W(config-if)#
*May 19 20:22:42.164 UTC: DHCP: QScan: Timed out Selecting state
871W(config-if)#%Unknown DHCP problem.. No allocation possible  
*May 19 20:22:51.361 UTC: DHCP: Waiting for 10 seconds on interface FastEthernet4
871W(config-if)#do undebug all


I've hardcoded these commands under the FE4 (WAN) interface since I suspected the MAC address of my Linksys E1200 could still be cached or locked at the ISP side. After rebooting the cable modem and then BOOM there it was, I've finally got an IP address.


871W(config-if)#ip dhcp client client-id hex 002699c6db2e 
871W(config-if)#ip dhcp client hostname 871W
871W(config-if)#do debug dhcp detail
DHCP client activity debugging is on (detailed)
871W(config-if)#
871W(config-if)#shutdown
871W(config-if)#
*May 19 20:35:20.880 UTC: RAC: DHCP stopped on interface FastEthernet4
871W(config-if)#
*May 19 20:35:22.880 UTC: %LINK-5-CHANGED: Interface FastEthernet4, changed state to administratively down
*May 19 20:35:23.880 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to down
871W(config-if)#no shut
871W(config-if)#
*May 19 20:43:03.938 UTC: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 88c6.63b5.9e29 Reason: Sending station has left the BSS SSID[Lagura]
871W(config-if)#%Unknown DHCP problem.. No allocation possible
*May 19 20:43:04.294 UTC: DHCP: Waiting for 50 seconds on interface FastEthernet4
*May 19 20:43:05.691 UTC: %DOT11-6-ASSOC: Interface Dot11Radio0, Station   88c6.63b5.9e29 Associated SSID[Lagura] AUTH_TYPE[OPEN] KEY_MGMT[WPAv2 PSK]
871W(config-if)#
*May 19 20:43:05.707 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to down
871W(config-if)#
*May 19 20:43:29.562 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to up
871W(config-if)#
*May 19 20:43:34.654 UTC: DHCP: QScan: Purging entry
*May 19 20:43:34.654 UTC: DHCP: deleting entry 83A9ADE0 0.0.0.0 from list
*May 19 20:43:34.654 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:43:34.654 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:43:34.654 UTC:    DHCP Lease server: 0.0.0.0, state: 11 Purging
*May 19 20:43:34.654 UTC:    DHCP transaction id: BD6
*May 19 20:43:34.654 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:43:34.654 UTC:    No timer running
*May 19 20:43:34.654 UTC:    Retry count: 0   Client-ID: cisco-0026.99c6.db2e-Fa4
*May 19 20:43:34.654 UTC:    Client-ID hex dump: 636973636F2D303032362E393963362E
*May 19 20:43:34.654 UTC:                        646232652D466134
*May 19 20:43:34.654 UTC:    Hostname: 871W
871W(config-if)#
*May 19 20:43:54.297 UTC: DHCP: Try 11 to acquire address for FastEthernet4
*May 19 20:43:54.301 UTC: DHCP: allocate request
*May 19 20:43:54.301 UTC: DHCP: new entry. add to queue, interface FastEthernet4
*May 19 20:43:54.301 UTC: DHCP: SDiscover attempt # 1 for entry:
*May 19 20:43:54.301 UTC: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4
*May 19 20:43:54.301 UTC: Temp  sub net mask: 0.0.0.0
*May 19 20:43:54.301 UTC:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*May 19 20:43:5
871W(config-if)#4.301 UTC:    DHCP transaction id: BD7
*May 19 20:43:54.301 UTC:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:43:54.301 UTC:    Next timer fires after: 00:00:04
*May 19 20:43:54.301 UTC:    Retry count: 1   Client-ID: &F[.
*May 19 20:43:54.301 UTC:    Client-ID hex dump: 2699C6DB2E
*May 19 20:43:54.301 UTC:    Hostname: 871W
*May 19 20:43:54.301 UTC: DHCP: SDiscover: sending 272 byte length DHCP packet
*May 19 20:43:54.301 UTC: DHCP: SDiscover 272 bytes
*May 19 20:43:54.301 UTC: B'cast on FastEthernet4 interface from 0.0.0.0
*May 19 20:43:54.657 UTC: DHCP: Received a BOOTREP pkt
*May 19 20:43:54.657 UTC: DHCP: Scan: Message type: DHCP Offer
*May 19 20:43:54.657 UTC: DHCP: Scan: Subnet Address Option: 255.255.248.0
*May 19 20:43:54.657 UTC: DHCP: Scan: DNS Name Server Option: 218.186.2.16, 218.186.2.6, &202.156.1.16&
*May 19 20:43:54.657 UTC: DHCP: Scan: Router Option: 59.189.104.1
*May 19 20:43:54.657 UTC: DHCP: Scan: Lease Time: 14400
*May 19 20:43:54.657 UTC: DHCP: Scan: Rebind time: 12600
*May 19 20:43:54.657 UTC: DHCP: Scan: Renewal time: 7200
*May 19 20:43:54.657 UTC: DHCP: Scan: Server ID Option: 172.17.0.207 = AC1100CF
*May 19 20:43:54.657 UTC: DHCP: Scan: Log Server Option: 127.0.0.1
*May 19 20:43:54.657 UTC: DHCP: Scan: Bootfile Name: ^1/B10DC5AB/
*May 19 20:43:54.657 UTC: DHCP: rcvd pkt source: 59.189.104.1,  destination:  255.255.255.255
*May 19 20:43:54.657 UTC:    UDP  sport: 43,  dport: 44,  length: 336
*May 19 20:43:54.657 UTC:    DHCP op:2, htype: 1, hlen: 6, hops: 0
*May 19 20:43:54.657 UTC:    DHCP server identifier: 172.17.0.207
*May 19 20:43:54.657 UTC:         xid: BD7, secs: 0, flags: 8000
*May 19 20:43:54.657 UTC:         client: 0.0.0.0, your: 59.189.104.76
*May 19 20:43:54.657 UTC:         srvr:   0.0.0.0, gw: 59.189.104.1
*May 19 20:43:54.657 UTC:         options block length: 88

*May 19 20:43:54.657 UTC: DHCP Offer Message   Offered Address: 59.189.104.76
*May 19 20:43:54.657 UTC: DHCP: Lease Seconds: 14400    Renewal s
871W(config-if)#ecs:  7200    Rebind secs:   12600
*May 19 20:43:54.657 UTC: DHCP: Server ID Option: 172.17.0.207
*May 19 20:43:54.657 UTC: DHCP: offer received from 172.17.0.207
*May 19 20:43:54.657 UTC: DHCP: SRequest attempt # 1 for entry:
*May 19 20:43:54.657 UTC: Temp IP addr: 59.189.104.76  for peer on Interface: FastEthernet4
*May 19 20:43:54.657 UTC: Temp  sub net mask: 255.255.248.0
*May 19 20:43:54.657 UTC:    DHCP Lease server: 172.17.0.207, state: 4 Requesting
*May 19 20:43:54.657 UTC:    DHCP transaction id: BD7
*May 19 20:43:54.657 UTC:    Lease: 14400 secs,  Renewal: 0 secs,  Rebind: 0 secs
*May 19 20:43:54.661 UTC:    Next timer fires after: 00:00:03
*May 19 20:43:54.661 UTC:    Retry count: 1   Client-ID: &F[.
*May 19 20:43:54.661 UTC:    Client-ID hex dump: 2699C6DB2E
*May 19 20:43:54.661 UTC:    Hostname: 871W
*May 19 20:43:54.661 UTC: DHCP: SRequest- Server ID option: 172.17.0.207
*May 19 20:43:54.661 UTC: DHCP: SRequest- Requested IP addr option: 59.189.104.76
*May 19 20:43:54.661 UTC: DHCP: SRequest placed lease len option: 14400
*May 19 20:43:54.661 UTC: DHCP: SRequest: 290 bytes
*May 19 20:43:54.661 UTC: DHCP: SRequest: 290 bytes
*May 19 20:43:54.661 UTC:             B'cast on FastEthernet4 interface from 0.0.0.0
*May 19 20:43:54.681 UTC: DHCP: Received a BOOTREP pkt
*May 19 20:43:54.681 UTC: DHCP: Scan: Message type: DHCP Ack
*May 19 20:43:54.681 UTC: DHCP: Scan: Subnet Address Option: 255.255.248.0
*May 19 20:43:54.681 UTC: DHCP: Scan: DNS Name Server Option: 218.186.2.16, 218.186.2.6, &202.156.1.16&
*May 19 20:43:54.681 UTC: DHCP: Scan: Router Option: 59.189.104.1
*May 19 20:43:54.681 UTC: DHCP: Scan: Lease Time: 14400
*May 19 20:43:54.681 UTC: DHCP: Scan: Rebind time: 12600
*May 19 20:43:54.681 UTC: DHCP: Scan: Renewal time: 7200
*May 19 20:43:54.681 UTC: DHCP: Scan: Server ID Option: 172.17.0.207 = AC1100CF
*May 19 20:43:54.681 UTC: DHCP: Scan: Log Server Option: 127.0.0.1
*May 19 20:43:54.681 UTC: DHCP: Scan: Bootfile Name: ^1/B10DC5AB/
*May 19 20:43:54.681 UTC: DHCP: rcvd pkt source: 59.189.104.1,  destination:  255.255.255.255
*May 19 20:43:54.681 UTC:    UDP  sport: 43,  dport: 44,  length: 336
*May 19 20:43:54.681 UTC:    DHCP op: 2, htype: 1, hlen: 6, hops: 0
*May 19 20:43:54.681 UTC:    DHCP server identifier: 172.17.0.207
*May 19 20:43:54.681 UTC:         xid: BD7, secs: 0, flags: 8000
*May 19 20:43:54.681 UTC:         client: 0.0.0.0, your: 59.189.104.76
*May 19 20:43:54.681 UTC:         srvr:   0.0.0.0, gw: 59.189.104.1
*May 19 20:43:54.681 UTC:         options block length: 88

*May 19 20:43:54.681 UTC: DHCP Ack Message
*May 19 20:43:54.681 UTC: DHCP: Lease Seconds: 14400    Renewal secs:  7200    Rebind secs:   12600
*May 19 20:43:54.681 UTC: DHCP: Server ID Option: 172.17.0.207
*May 19 20:43:57.685 UTC: DHCP: Releasing ipl options:
*May 19 20:43:57.685 UTC: DHCP: Applying DHCP options:
*May 19 20:43:57.685 UTC:   Setting default_gateway to 59.189.104.1
*May 19 20:43:57.685 UTC:   Adding default route 59.189.104.1
*May 19 20:43:58.685 UTC:Adding route to DHCP server 172.17.0.207 via FastEthernet4 59.189.104.1
*May 19 20:43:58.685 UTC:   Adding DNS server address 218.186.2.16
*May 19 20:43:58.685 UTC:   Adding DNS server address 218.186.2.6
*May 19 20:43:58.685 UTC: DHCP Client Pooling: ***Allocated IP address: 59.189.104.76
*May 19 20:43:58.777 UTC: Allocated IP address = 59.189.104.76  255.255.248.0

*May 19 20:43:58.777 UTC: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet4 assigned DHCP address 59.189.104.76, mask 255.255.248.0, hostname 871W


871W(config-if)#do show interface fastethernet4
FastEthernet4 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 0026.99c6.db2e (bia 0026.99c6.db2e)
  Internet address is 59.189.104.76/21
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:04, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     332 packets input, 62216 bytes
     Received 147 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     359 packets output, 107959 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     1 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
871W(config-if)#do ping 8.8.8.8 source 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/22/28 ms
871W(config)#do ping www.google.com
Translating "www.google.com"
% Unrecognized host or address, or protocol not running.
871W(config)#ip name-server 8.8.8.8
871W(config)#ip domain-lookup
871W(config)#do ping www.google.com
Translating "www.google.com"...domain server (218.186.2.16) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 74.125.235.49, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms

871W#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 59.189.104.1 to network 0.0.0.0

     172.17.0.0/32 is subnetted, 1 subnets
S       172.17.0.207 [254/0] via 59.189.104.1, FastEthernet4
     59.0.0.0/21 is subnetted, 1 subnets
C       59.189.104.0 is directly connected, FastEthernet4
C    192.168.1.0/24 is directly connected, BVI1
S*   0.0.0.0/0 [254/0] via 59.189.104.1    // OBTAINED FROM 'import all' COMMAND


Other useful commands on the 871w for wireless:

871W#show dot11 ?
  aaa                Authentication, Authorization, and Accounting
  activity-timeout   Default/Maximum activity timeout values
  antenna-alignment  Display recent antenna alignment results
  arp-cache          Arp Cache
  associations       Association information
  bssid              Show SSID to BSSID mapping
  carrier            Display recent carrier test results
  interface          Interface statistics information
  linktest           Display recent linktest results
  mac-authen         MAC authentication details
  statistics         Statistics information
  vlan-name          Display VLAN name to ID map(s)


871W#show dot11 bssid
Interface      BSSID         Guest  SSID
Dot11Radio0   0026.9947.91a0  Yes  Lagura 


*May 20 04:12:26.281 SGT: %DOT11-6-ASSOC: Interface Dot11Radio0, Station   78ca.39e4.81e3 Reassociated SSID[Lagura] AUTH_TYPE[OPEN] KEY_MGMT[WPAv2 PSK]
 

871W#show dot11 associations

802.11 Client Stations on Dot11Radio0:

SSID [Lagura] :

MAC Address    IP address      Device        Name            Parent         State
703e.ac93.ef1a 0.0.0.0         unknown       -               self           Assoc
78ca.39e4.81e3 0.0.0.0         unknown       -               self           Assoc
bc3b.af51.8448 0.0.0.0         unknown       -               self           Assoc
ec55.f901.f90c 192.168.1.16    4500-radio    -               self           Assoc