Saturday, August 23, 2014

Cisco 2960S FlexStack Module and Cable

I was asked to stack some few Cisco 2960S switches for a site.


You can stack 2 or more switches (depending on the switch platform) using the Cisco FlexStack module and cable. The StackWise technology is used by Cisco 3750 switches.




Switch(config)#switch ?
  <1-4>  Switch Number   // 2960S CAN STACK UP TO 4 SWITCHES

Switch(config)#switch 1 ?
  priority   Set the priority of the specified switch
  provision  Configure Switch provision / offline config
  renumber   Renumber the specified switch number

Switch(config)#switch 1 priority ?
  <1-15>  Switch Priority

Switch(config)#switch 1 priority 15
Changing the Switch Priority of Switch Number 1 to 15
Do you want to continue?[confirm]
New Priority has been set successfully

Switch(config)#switch 2 priority 12   
There is no switch number 2 in the stack   // CAN ONLY ACTIVATE THIS COMMAND ONCE FLEXSTACK MODULE/CABLE IS CONNECTED

Switch(config)#switch 3 priority 10
There is no switch number 3 in the stack

Switch(config)#switch 2 priority 12
Changing the Switch Priority of Switch Number 2 to 12
Do you want to continue?[confirm]
New Priority has been set successfully

Switch(config)#switch 3 priority 10
Changing the Switch Priority of Switch Number 3 to 10
Do you want to continue?[confirm]
New Priority has been set successfully


You can pre-configure ports on member switches using the switch x provision y command. You can stack a Cisco 2960S 24-port together with a 48-port switch.

I needed this command since the VLANs and ports on our 2960S switches were already configured. Once stacking is done and switches are rebooted, our VLAN 1 management IP address on member switches were gone. The config on the master switch remained intact.

Switch(config)#switch 2 provision ?
  ws-c2960s-24pd-l   provision a Catalyst 2960s switch with 24GPwr+2SFP+ interfaces
  ws-c2960s-24ps-l   provision a Catalyst 2960s switch with 24GPwr+4SFP interfaces
  ws-c2960s-24td-l   provision a Catalyst 2960s switch with 24G+2SFP+ interfaces
  ws-c2960s-24ts-l   provision a Catalyst 2960s switch with 24G+4SFP interfaces
  ws-c2960s-24ts-s   provision a Catalyst 2960s switch with 24G+2SFP interfaces
  ws-c2960s-48fpd-l  provision a Catalyst 2960s switch with 48GPwr+2SFP+ interfaces
  ws-c2960s-48fps-l  provision a Catalyst 2960s switch with 48GPwr+4SFP interfaces
  ws-c2960s-48lpd-l  provision a Catalyst 2960s switch with 48GPwr+2SFP+ interfaces
  ws-c2960s-48lps-l  provision a Catalyst 2960s switch with 48GPwr+4SFP interfaces
  ws-c2960s-48td-l   provision a Catalyst 2960s switch with 48G+2SFP+ interfaces
  ws-c2960s-48ts-l   provision a Catalyst 2960s switch with 48G+4SFP interfaces
  ws-c2960s-48ts-s   provision a Catalyst 2960s switch with 48G+2SFP interfaces

Switch(config)#switch 2 provision ws-c2960s-24ps-l
Switch(config)#interface range GigabitEthernet2/0/1-24     // SWITCH 2; TAKE NOTE OF THE MODULE NUMBER (IN BOLD)
Switch(config-if)#switchport access vlan 110
Switch(config-if)#switchport mode access
Switch(config-if)#spanning-tree portfast

Switch(config)#switch 3 provision ws-c2960s-24ps-l
Switch(config)#interface range GigabitEthernet3/0/1-24    // SWITCH 3
Switch(config-if)#switchport access vlan 110
Switch(config-if)#switchport mode access
Switch(config-if)#spanning-tree portfast


Here are some useful show commands:

Switch#show switch ?
  <1-4>        Switch Number
  detail       show detailed information about the stack ring
  neighbors    show each switch's neighbors
  stack-ports  show the status of the stack ports
  stack-ring   show stack ring
  |            Output modifiers
  <cr>

Switch#show switch detail
Switch/Stack Mac Address : 6c9c.ed9d.g200
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 6c9c.ed9d.g200     15     1       Ready            //  BOOT UP MASTER SWITCH FIRST AND THEN BOOT UP MEMBER SWITCHES ACCORDINGLY
 2       Member 6c9c.edc2.4300    12      1       Ready              
 3       Member 2c36.f85e.6e00     10      1       Ready             
         Stack Port Status             Neighbors    
Switch#  Port 1     Port 2           Port 1   Port 2
--------------------------------------------------------
  1        Ok         Ok                2        3
  2        Ok         Ok                1        3
  3        Ok         Ok                2        1

Switch#show switch neighbor
  Switch #    Port 1       Port 2
  --------    ------       ------
      1         2             3 
      2         1             3 
      3         2             1 

Switch#show switch stack-ports
  Switch #    Port 1       Port 2
  --------    ------       ------
    1           Ok           Ok  
    2           Ok           Ok  
    3           Ok           Ok  

Switch#show switch stack-ring ?
  activity  show stack ring activity
  speed     show stack ring speed

Switch#show switch stack-ring speed  

Stack Ring Speed        : 10G     // AGGREGATED BACKPLANE BANDWIDTH
Stack Ring Configuration: Full
Stack Ring Protocol     : FlexStack   // YOU'LL SEE STACKWISE ON 3750

Switch#show switch

Switch/Stack Mac Address : 6c9c.ed9d.g200
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 6c9c.ed9d.g200     15     1       Ready              
 2       Member 6c9c.edc2.4300    12      1       Ready              
 3       Member 2c36.f85e.6e00     10      1       Ready 

Switch#show switch stack-port
  Switch #    Port 1       Port 2
  --------    ------       ------
    1           Ok           Ok  
    2           Ok           Ok  
    3           Ok           Ok  

Switch#show switch detail       
Switch/Stack Mac Address : 6c9c.ed9d.g200
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 6c9c.ed9d.g200     15     1       Ready              
 2       Member 6c9c.edc2.4300    12      1       Ready              
 3       Member 2c36.f85e.6e00     10      1       Ready              

         Stack Port Status             Neighbors    
Switch#  Port 1     Port 2           Port 1   Port 2
--------------------------------------------------------
  1        Ok         Ok                2        3
  2        Ok         Ok                1        3
  3        Ok         Ok                2        1