Friday, December 26, 2014

Configuring OSPF

I recently configured a Cisco Nexus 5672UP multilayer switch and a Cisco ASR1002-X router for our MPLS core upgrade. We're running OSPF on our core network and configurations made more sense after performing numerous labs on this routing protocol.

This is me patching and configuring these devices at our core data center.


This is my OSPF lab network topology, configuration and troubleshooting during my CCNP ROUTE study.


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#network 10.1.12.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#interface loopback1
R1(config-if)#ip ospf network ?
  broadcast            Specify OSPF broadcast multi-access network
  non-broadcast        Specify OSPF NBMA network
  point-to-multipoint  Specify OSPF point-to-multipoint network
  point-to-point       Specify OSPF point-to-point network

R1(config-if)#ip ospf network point-to-point


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#network 10.1.12.0 0.0.0.255 area 0
*Dec 13 15:01:48.131: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done
R2(config-router)#network 10.1.2.0 0.0.0.255 area 0
R2(config-router)#exit
R2(config)#interface loopback2
R2(config-if)#ip ospf network point-to-point


R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.2.1          0   FULL/  -        00:00:32    10.1.12.2       Serial0/0/0


R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.1.1          0   FULL/  -        00:00:35    10.1.12.1       Serial0/0/0


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.12.0 is directly connected, Serial0/0/0
O       10.1.2.0 [110/65] via 10.1.12.2, 00:01:27, Serial0/0/0
C       10.1.1.0 is directly connected, Loopback1


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.12.0 is directly connected, Serial0/0/0
C       10.1.2.0 is directly connected, Loopback2
O       10.1.1.0 [110/65] via 10.1.12.1, 00:01:41, Serial0/0/0
C       10.1.23.0 is directly connected, Serial0/0/1


R2(config)#interface serial0/0/1
R2(config-if)#ip ospf ?
  <1-65535>            Process ID
  authentication       Enable authentication
  authentication-key   Authentication password (key)
  cost                 Interface cost
  database-filter      Filter OSPF LSA during synchronization and flooding
  dead-interval        Interval after which a neighbor is declared dead
  demand-circuit       OSPF demand circuit
  flood-reduction      OSPF Flood Reduction
  hello-interval       Time between HELLO packets
  lls                  Link-local Signaling (LLS) support
  message-digest-key   Message digest authentication password (key)
  mtu-ignore           Ignores the MTU in DBD packets
  network              Network type
  prefix-suppression   OSPF prefix suppression
  priority             Router priority
  resync-timeout       Interval after which adjacency is reset if oob-resync is
                       not started
  retransmit-interval  Time between retransmitting lost link state
                       advertisements
  transmit-delay       Link state transmit delay

R2(config-if)#ip ospf 1 ?
  area  Set the OSPF area ID

R2(config-if)#ip ospf 1 area ?
  <0-4294967295>  OSPF area ID as a decimal value
  A.B.C.D         OSPF area ID in IP address format

R2(config-if)#ip ospf 1 area 23    // ANOTHER WAY OF CONFIGURING OSPF IN INTERFACE CONFIG MODE


R3(config)#interface s0/0/1
R3(config-if)#ip ospf 1 area 23
R3(config-if)#
*Dec 13 15:42:47.679: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/1 from LOADING to FULL, Loading Done
R3(config-if)#interface lo3
R3(config-if)#ip ospf 1 area 23
R3(config-if)#ip ospf network point-to-point


R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.1.1          0   FULL/  -        00:00:30    10.1.12.1       Serial0/0/0
172.20.200.1      0   FULL/  -        00:00:36    10.1.23.3       Serial0/0/1


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
C       10.1.12.0 is directly connected, Serial0/0/0
O IA    10.1.3.0 [110/129] via 10.1.12.2, 00:00:51, Serial0/0/0 
O       10.1.2.0 [110/65] via 10.1.12.2, 00:04:44, Serial0/0/0
C       10.1.1.0 is directly connected, Loopback1
O IA    10.1.23.0 [110/128] via 10.1.12.2, 00:01:50, Serial0/0/0



R2#show ip route     // NO INTER AREA ROUTE SINCE IT'S ABR
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
C       10.1.12.0 is directly connected, Serial0/0/0
O       10.1.3.0 [110/65] via 10.1.23.3, 00:01:33, Serial0/0/1
C       10.1.2.0 is directly connected, Loopback2
O       10.1.1.0 [110/65] via 10.1.12.1, 00:02:38, Serial0/0/0
C       10.1.23.0 is directly connected, Serial0/0/1


R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#10.1.12.1
+>(tcl)#10.1.12.2
+>(tcl)#10.1.23.2
+>(tcl)#10.1.23.3
+>(tcl)#172.20.200.1
+>(tcl)#} {
+>(tcl)#ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.200.1, timeout is 2 seconds:
.....     // NOT YET ADVERTISED IN OSPF
Success rate is 0 percent (0/5)


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#area ?
  <0-4294967295>  OSPF area ID as a decimal value
  A.B.C.D         OSPF area ID in IP address format

R2(config-router)#area 23 ?
  authentication  Enable authentication
  default-cost    Set the summary default-cost of a NSSA/stub area
  filter-list     Filter networks between OSPF areas
  nssa            Specify a NSSA area
  range           Summarize routes matching address/mask (border routers only)
  sham-link       Define a sham link and its parameters
  stub            Specify a stub area
  virtual-link    Define a virtual link and its parameters

R2(config-router)#area 23 stub
R2(config-router)#
*Dec 13 15:10:02.747: %OSPF-5-ADJCHG: Process 1, Nbr 172.20.200.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#area 23 stub
R3(config-router)#
*Dec 13 15:47:25.059: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R3(config-router)#
*Dec 13 15:47:31.323: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/1 from LOADING to FULL, Loading Done


R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.1.1          0   FULL/  -        00:00:32    10.1.12.1       Serial0/0/0
172.20.200.1      0   FULL/  -        00:00:36    10.1.23.3       Serial0/0/1


R3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.2.1          0   FULL/  -        00:00:36    10.1.23.2       Serial0/0/1


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.23.2 to network 0.0.0.0

     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.200.0 is directly connected, Loopback20
     10.0.0.0/24 is subnetted, 5 subnets
O IA    10.1.12.0 [110/128] via 10.1.23.2, 00:01:16, Serial0/0/1
C       10.1.3.0 is directly connected, Loopback3
O IA    10.1.2.0 [110/65] via 10.1.23.2, 00:01:16, Serial0/0/1
O IA    10.1.1.0 [110/129] via 10.1.23.2, 00:01:16, Serial0/0/1
C       10.1.23.0 is directly connected, Serial0/0/1
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:01:16, Serial0/0/1    // STUB AREA ONLY RECEIVES A DEFAULT AND IA ROUTES


R2#show ip ospf
 Routing Process "ospf 1" with ID 10.1.2.1
 Start time: 00:07:26.160, Time elapsed: 00:11:51.372
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 It is an area border router
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 2 (1 loopback)
        Area has no authentication
        SPF algorithm last executed 00:03:21.984 ago
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 4. Checksum Sum 0x01A65B
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 23
        Number of interfaces in this area is 1
        It is a stub area   
          generates stub default route with cost 1
        Area has no authentication
        SPF algorithm last executed 00:02:50.368 ago
        SPF algorithm executed 8 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x026C6C
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.23.2 to network 0.0.0.0

     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.200.0 is directly connected, Loopback20
     10.0.0.0/24 is subnetted, 5 subnets
O IA    10.1.12.0 [110/128] via 10.1.23.2, 00:04:23, Serial0/0/1
C       10.1.3.0 is directly connected, Loopback3
O IA    10.1.2.0 [110/65] via 10.1.23.2, 00:04:23, Serial0/0/1
O IA    10.1.1.0 [110/129] via 10.1.23.2, 00:04:23, Serial0/0/1
C       10.1.23.0 is directly connected, Serial0/0/1
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:04:23, Serial0/0/1


R2#show ip ospf database

            OSPF Router with ID (10.1.2.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.1.1        10.1.1.1        826         0x80000004 0x0056D6 3
10.1.2.1        10.1.2.1        617         0x80000004 0x0055D3 3

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.3.0        10.1.2.1        299         0x80000001 0x00EFEF
10.1.23.0       10.1.2.1        612         0x80000001 0x0009C3

                Router Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.2.1        10.1.2.1        303         0x80000004 0x00298C 2
172.20.200.1    172.20.200.1    304         0x80000005 0x00B563 3

                Summary Net Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         10.1.2.1        330         0x80000001 0x003BF4
10.1.1.0        10.1.2.1        332         0x80000002 0x0022C0
10.1.2.0        10.1.2.1        332         0x80000003 0x00928E
10.1.12.0       10.1.2.1        332         0x80000003 0x009C3B


R2(config)#router ospf 1
R2(config-router)#area 23 stub ?
  no-ext-capability  Do not send domain specific capabilities into stub area
  no-summary         Do not send summary LSA into stub area
  <cr>

R2(config-router)#area 23 stub no-summary   // TO CONFIGURE TOTALLY STUBBY AREA


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.23.2 to network 0.0.0.0

     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.200.0 is directly connected, Loopback20
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.3.0 is directly connected, Loopback3
C       10.1.23.0 is directly connected, Serial0/0/1
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:00:21, Serial0/0/1


R3#show ip ospf database

            OSPF Router with ID (172.20.200.1) (Process ID 1)

                Router Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.2.1        10.1.2.1        423         0x80000004 0x00298C 2
172.20.200.1    172.20.200.1    422         0x80000005 0x00B563 3

                Summary Net Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         10.1.2.1        72          0x80000002 0x0039F5



R2(config)#router ospf 1
R2(config-router)#no area 23 stub
*Dec 13 15:19:18.779: %OSPF-5-ADJCHG: Process 1, Nbr 172.20.200.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R2(config-router)#area 23 nssa    // CONVERTS TYPE 7 TO TYPE 5 LSA
*Dec 13 15:19:28.779: %OSPF-5-ADJCHG: Process 1, Nbr 172.20.200.1 on Serial0/0/1 from DOWN to DOWN, Neighbor Down: Adjacency forced to reset


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#no area 23 stub
R3(config-router)#area 23 ?
  authentication  Enable authentication
  default-cost    Set the summary default-cost of a NSSA/stub area
  filter-list     Filter networks between OSPF areas
  nssa            Specify a NSSA area
  range           Summarize routes matching address/mask (border routers only)
  sham-link       Define a sham link and its parameters
  stub            Specify a stub area
  virtual-link    Define a virtual link and its parameters

R3(config-router)#area 23 nssa
R3(config-router)#
*Dec 13 15:57:21.139: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/1 from LOADING to FULL, Loading Done
R3(config-router)#redistribute ?
  bgp             Border Gateway Protocol (BGP)
  connected       Connected
  eigrp           Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis            ISO IS-IS
  iso-igrp        IGRP for OSI networks
  maximum-prefix  Maximum number of prefixes redistributed to protocol
  metric          Metric for redistributed routes
  metric-type     OSPF/IS-IS exterior metric type for redistributed routes
  mobile          Mobile routes
  odr             On Demand stub Routes
  ospf            Open Shortest Path First (OSPF)
  rip             Routing Information Protocol (RIP)
  route-map       Route map reference
  static          Static routes
  subnets         Consider subnets for redistribution into OSPF
  tag             Set tag for routes redistributed into OSPF
  <cr>

R3(config-router)#redistribute connected ?
  metric       Metric for redistributed routes
  metric-type  OSPF/IS-IS exterior metric type for redistributed routes
  route-map    Route map reference
  subnets      Consider subnets for redistribution into OSPF
  tag          Set tag for routes redistributed into OSPF
  <cr>

R3(config-router)#redistribute connected subnets   // TO ADVERTISE EXTERNAL AND EXACT SUBNET INTO NSSA AREA INCLUDING LOOPBACK 20


R2#show ip ospf
 Routing Process "ospf 1" with ID 10.1.2.1
 Start time: 00:07:26.160, Time elapsed: 00:23:04.308
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 1. Checksum Sum 0x00CA2F
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 1 normal 0 stub 1 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 2 (1 loopback)
        Area has no authentication
        SPF algorithm last executed 00:05:04.072 ago
        SPF algorithm executed 10 times
        Area ranges are
        Number of LSA 4. Checksum Sum 0x01AA54
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 23
        Number of interfaces in this area is 1
        It is a NSSA area  
        Perform type-7/type-5 LSA translation  
        Area has no authentication
        SPF algorithm last executed 00:03:56.008 ago
        SPF algorithm executed 15 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x025299
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/24 is subnetted, 1 subnets
O N2    172.20.200.0 [110/20] via 10.1.23.3, 00:04:31, Serial0/0/1 
     10.0.0.0/24 is subnetted, 5 subnets
C       10.1.12.0 is directly connected, Serial0/0/0
O       10.1.3.0 [110/65] via 10.1.23.3, 00:04:49, Serial0/0/1
C       10.1.2.0 is directly connected, Loopback2
O       10.1.1.0 [110/65] via 10.1.12.1, 00:05:44, Serial0/0/0
C       10.1.23.0 is directly connected, Serial0/0/1


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/24 is subnetted, 1 subnets
O E2    172.20.200.0 [110/20] via 10.1.12.2, 00:05:12, Serial0/0/0   // TRANSLATED EXTERNAL ROUTE
     10.0.0.0/24 is subnetted, 5 subnets
C       10.1.12.0 is directly connected, Serial0/0/0
O IA    10.1.3.0 [110/129] via 10.1.12.2, 00:05:31, Serial0/0/0
O       10.1.2.0 [110/65] via 10.1.12.2, 00:23:26, Serial0/0/0
C       10.1.1.0 is directly connected, Loopback1
O IA    10.1.23.0 [110/128] via 10.1.12.2, 00:20:33, Serial0/0/0


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.200.0 is directly connected, Loopback20
     10.0.0.0/24 is subnetted, 5 subnets
O IA    10.1.12.0 [110/128] via 10.1.23.2, 00:06:23, Serial0/0/1  
C       10.1.3.0 is directly connected, Loopback3
O IA    10.1.2.0 [110/65] via 10.1.23.2, 00:06:23, Serial0/0/1  
O IA    10.1.1.0 [110/129] via 10.1.23.2, 00:06:23, Serial0/0/1 
C       10.1.23.0 is directly connected, Serial0/0/1


R2(config)#router ospf 1
R2(config-router)#area 23 nssa ?
  default-information-originate  Originate Type 7 default into NSSA area
  no-ext-capability              Do not send domain specific capabilities into
                                 NSSA
  no-redistribution              No redistribution into this NSSA area
  no-summary                     Do not send summary LSA into NSSA
  translate                      Translate LSA
  <cr>

R2(config-router)#area 23 nssa no-summary   // TOTALLY STUBBY NSSA


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.23.2 to network 0.0.0.0

     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.200.0 is directly connected, Loopback20
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.3.0 is directly connected, Loopback3
C       10.1.23.0 is directly connected, Serial0/0/1
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:00:47, Serial0/0/1  


R2#show ip ospf database

            OSPF Router with ID (10.1.2.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.1.1        10.1.1.1        1628        0x80000004 0x0056D6 3
10.1.2.1        10.1.2.1        566         0x80000005 0x0059CC 3

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.3.0        10.1.2.1        512         0x80000001 0x00EFEF
10.1.23.0       10.1.2.1        1415        0x80000001 0x0009C3

                Router Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.2.1        10.1.2.1        516         0x80000007 0x00B0F7 2
172.20.200.1    172.20.200.1    500         0x80000008 0x003DCE 3

                Summary Net Link States (Area 23) 

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         10.1.2.1        78          0x80000001 0x00C265

                Type-7 AS External Link States (Area 23)  

Link ID         ADV Router      Age         Seq#       Checksum Tag
172.20.200.0    172.20.200.1    501         0x80000001 0x0076FC 0

                Type-5 AS External Link States    

Link ID         ADV Router      Age         Seq#       Checksum Tag
172.20.200.0    10.1.2.1        495         0x80000001 0x00CA2F 0


R2(config)#interface serial0/0/1
R2(config-if)#ip ospf ?
  <1-65535>            Process ID
  authentication       Enable authentication
  authentication-key   Authentication password (key)
  cost                 Interface cost
  database-filter      Filter OSPF LSA during synchronization and flooding
  dead-interval        Interval after which a neighbor is declared dead
  demand-circuit       OSPF demand circuit
  flood-reduction      OSPF Flood Reduction
  hello-interval       Time between HELLO packets
  lls                  Link-local Signaling (LLS) support
  message-digest-key   Message digest authentication password (key)
  mtu-ignore           Ignores the MTU in DBD packets
  network              Network type
  prefix-suppression   OSPF prefix suppression
  priority             Router priority
  resync-timeout       Interval after which adjacency is reset if oob-resync is
                       not started
  retransmit-interval  Time between retransmitting lost link state
                       advertisements
  transmit-delay       Link state transmit delay

R2(config-if)#ip ospf authentication
R2(config-if)#ip ospf authentication-key ?
  <0-7>  Encryption type (0 for not yet encrypted, 7 for proprietary)
  LINE   The OSPF password (key) (maximum 8 characters)

R2(config-if)#ip ospf authentication-key cisco


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface serial0/0/1
R3(config-if)#ip ospf authentication
*Dec 13 16:07:45.779: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Dead timer expired
R3(config-if)#ip ospf authentication-key cisco
R3(config-if)#
*Dec 13 16:07:58.435: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/1 from LOADING to FULL, Loading Done


R3#show ip ospf interface s0/0/1
Serial0/0/1 is up, line protocol is up
  Internet Address 10.1.23.3/24, Area 23
  Process ID 1, Router ID 172.20.200.1, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.1.2.1
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled  


R1(config)#interface s0/0/0
R1(config-if)#ip ospf authentication ?
  message-digest  Use message-digest authentication
  null            Use no authentication
  <cr>

R1(config-if)#ip ospf authentication message-digest
R1(config-if)#ip ospf ?
  <1-65535>            Process ID
  authentication       Enable authentication
  authentication-key   Authentication password (key)
  cost                 Interface cost
  database-filter      Filter OSPF LSA during synchronization and flooding
  dead-interval        Interval after which a neighbor is declared dead
  demand-circuit       OSPF demand circuit
  flood-reduction      OSPF Flood Reduction
  hello-interval       Time between HELLO packets
  lls                  Link-local Signaling (LLS) support
  message-digest-key   Message digest authentication password (key)
  mtu-ignore           Ignores the MTU in DBD packets
  network              Network type
  prefix-suppression   OSPF prefix suppression
  priority             Router priority
  resync-timeout       Interval after which adjacency is reset if oob-resync is
                       not started
  retransmit-interval  Time between retransmitting lost link state
                       advertisements
  transmit-delay       Link state transmit delay

R1(config-if)#ip ospf message-digest-key ?
  <1-255>  Key ID

R1(config-if)#ip ospf message-digest-key 1 ?
  md5  Use MD5 algorithm

R1(config-if)#ip ospf message-digest-key 1 md5 ?
  <0-7>  Encryption type (0 for not yet encrypted, 7 for proprietary)
  LINE   The OSPF password (key) (maximum 16 characters)

R1(config-if)#ip ospf message-digest-key 1 md5 cisco
R1(config-if)#
*Dec 13 16:51:46.895: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Dead timer expired


R2(config)#interface s0/0/0
R2(config-if)#ip ospf authentication message-digest
R2(config-if)#ip ospf message-digest-key 1 md5 cisco
R2(config-if)#
*Dec 13 15:35:12.019: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done


R2#show ip ospf interface s0/0/0
Serial0/0/0 is up, line protocol is up
  Internet Address 10.1.12.2/24, Area 0
  Process ID 1, Router ID 10.1.2.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.1.1.1
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled  
    Youngest key id is 1  


R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#10.1.12.1
+>(tcl)#10.1.12.2
+>(tcl)#10.1.23.2
+>(tcl)#10.1.23.3
+>(tcl)#172.20.200.1
+>(tcl)#} {
+>(tcl)#ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.200.1, timeout is 2 seconds: 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms

Friday, December 19, 2014

E1 Crossover Cable

I was at "The Golden Land, Myanmar" doing an integration with a PABX vendor for our Cisco 2911 router. I got the chance to visit the Schwedagon Pagoda, which is a Buddhist temple that existed more than 2600 years. Its stupas or heaps are made of real gold!


I had to crimp and do a quick test on an E1 crossover cable that I prepared. Here's the cable pin out diagram:


I used an RJ45 straight-through cable and cut out the unused wires. There's a gap between wire pairs on pin 3. I used a paper clip to fill that gap while inserting the four wires.


This is what it looks like after crimping the cable to the RJ45 connector.


Since I don't have a cable tester, I used two Cisco 2811 routers with VWIC E1 cards inserted to check the physical layer. There's no configuration involved on the routers and just used their default settings. Notice there's an amber/orange alarm (AL) on the E1 if there's no connection detected and green light on Carrier Detect (CD) if both ends are connected.



We issue a show controller e1 to check the E1 status.

R1#show controller e1
E1 0/0/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20090113, FPGA: 20, spm_count = 0
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (172 seconds elapsed):
     10 Line Code Violations, 15 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 0 Unavail Secs


R2#show controller e1
E1 0/0/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20090113, FPGA: 20, spm_count = 0
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (220 seconds elapsed):
     15 Line Code Violations, 1197 Path Code Violations
     2 Slip Secs, 0 Fr Loss Secs, 3 Line Err Secs, 0 Degraded Mins
     1 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 114 Unavail Secs


*Nov 21 08:05:14.455: %CONTROLLER-5-UPDOWN: Controller E1 0/0/0, changed state to down (LOS detected)
*Nov 21 08:05:20.455: %CONTROLLER-5-UPDOWN: Controller E1 0/0/0, changed state to up

Saturday, December 13, 2014

Cisco E-License PAK Registration

I was at a client site and needed to register a Security license Product Authorization Key (PAK) via Cisco's License Administration Portal. I would need the Security license to be able to use the "crypto" commands and build an IPsec site-to-site IPsec back to our core network.

It's quite similar how licensing works on an ASA firewall, wherein you purchase a separate license to activate a particular feature. We can use either the show license udi or show version commands to get the UDI and Serial Number of the router's chassis.

Router#show license udi
Device#   PID                       SN                     UDI
-----------------------------------------------------------------------------
*0        CISCO2911/K9          FGL18091abc     CISCO2911/K9:FGL18091abc




Type the Product ID/PID (CISCO2911/K9) and device Serial Number (FGL18091abc) separately on its respective field. Check for any typo errors, otherwise you'll need to raise a Cisco License TAC case to retrieve the license manually.


 



You can choose to email the e-license and also download it and then TFTP the license to the router's flash.



Router#copy tftp://10.1.1.2/FGL18091abc_20141123183623264.lic flash
Destination filename [FGL18091abc_20141123183623264.lic]?
Accessing tftp://10.1.1.2/FGL18091abc_20141123183623264.lic...
Loading FGL18091abc_20141123183623264.lic from 10.1.1.2 (via GigabitEthernet0/0): !
[OK - 1155 bytes]

Router#show flash | inc FGL
245       1155 Nov 24 2014 02:37:36 +00:00 FGL18091abc_20141123183623264.lic

Router#show license
Index 1 Feature: ipbasek9                      
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 2 Feature: securityk9                    
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 3 Feature: uck9                          
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 4 Feature: datak9                        
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 5 Feature: gatekeeper                    
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 6 Feature: SSL_VPN                       
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: None
Index 7 Feature: ios-ips-update                
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 8 Feature: SNASw                         
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 9 Feature: hseck9                        
Index 10 Feature: cme-srst                      
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: None
Index 11 Feature: WAAS_Express                  
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 12 Feature: UCVideo                       
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None

Router#license ?      
  call-home  License call-home information
  clear      Clear license information
  comment    Comment license information
  install    Install license information
  modify     Modify license
  revoke     Revoke license information
  save       Save license information

Router#license install ?
  archive:  Install from archive: file system
  flash0:   Install from flash0: file system
  flash1:   Install from flash1: file system
  flash:    Install from flash: file system
  ftp:      Install from ftp: file system
  http:     Install from http: file system
  https:    Install from https: file system
  null:     Install from null: file system
  nvram:    Install from nvram: file system
  pram:     Install from pram: file system
  rcp:      Install from rcp: file system
  scp:      Install from scp: file system
  syslog:   Install from syslog: file system
  system:   Install from system: file system
  tftp:     Install from tftp: file system
  tmpsys:   Install from tmpsys: file system
  xmodem:   Install from xmodem: file system
  ymodem:   Install from ymodem: file system

Router#license install flash:FGL18091abc_20141123183623264.lic
Installing licenses from "flash:FGL18091abc_20141123183623264.lic"
Installing...Feature:securityk9...Successful:Supported
1/1 licenses were successfully installed
0/1 licenses were existing licenses
0/1 licenses were failed to install

*Nov 24 02:43:20.971: %LICENSE-6-INSTALL: Feature securityk9 1.0 was installed in this device. UDI=CISCO2911/K9:FGL18091abc; StoreIndex=2:Primary License Storage
*Nov 24 02:43:21.231: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module 
name = c2900 Next reboot level = securityk9 and License = securityk9


Router#reload
Proceed with reload? [confirm]

<OUTPUT TRUNCATED>

Router#show license
Index 1 Feature: ipbasek9                      
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 2 Feature: securityk9                    
        Period left: Life time
        License Type: Permanent
        License State: Active, Not in Use
        License Count: Non-Counted
        License Priority: Medium
Index 3 Feature: uck9                          
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 4 Feature: datak9                        
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 5 Feature: gatekeeper                    
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 6 Feature: SSL_VPN                       
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: None
Index 7 Feature: ios-ips-update                
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 8 Feature: SNASw                         
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 9 Feature: hseck9                        
Index 10 Feature: cme-srst                      
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: None
Index 11 Feature: WAAS_Express                  
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 12 Feature: UCVideo                       
        Period left: Not Activated
        Period Used: 0  minute  0  second 
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None

Router>show version     // ALTERNATE COMMAND TO VERIFY PERMANENT LICENSE
Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Fri 13-Sep-13 14:59 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)

Router uptime is 1 minute
System returned to ROM by reload at 02:44:35 UTC Mon Nov 24 2014
System image file is "flash0:c2900-universalk9-mz.SPA.152-4.M5.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco CISCO2911/K9 (revision 1.0) with 479232K/45056K bytes of memory.
Processor board ID FGL18091abc
3 Gigabit Ethernet interfaces
1 terminal line
1 Channelized (E1 or T1)/PRI port
1 Virtual Private Network (VPN) Module
4 Voice FXS interfaces
DRAM configuration is 64 bits wide with parity enabled.
255K bytes of non-volatile configuration memory.
250880K bytes of ATA System CompactFlash 0 (Read/Write)


License Info:

License UDI:
         
-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO2911/K9          FGL18091abc    



Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot 
------------------------------------------------------------------
ipbase        ipbasek9      Permanent      ipbasek9
security      securityk9    Permanent      securityk9
uc            uck9          Permanent      uck9
data          None          None           None

Configuration register is 0x2102

Friday, December 5, 2014

Serial WIC Cable and Cisco Router as Frame Relay Switch

I finally got my smart serial cross-cable (CAB-SS-2626X) when I visited my mom in New York a couple of months back. With these cables, I can emulate a Frame Relay cloud and use serial interfaces for WAN connection in my lab routers.



I was doing some EIGRP labs for my ROUTE studies and configured my 2811 router as a Frame Relay Switch. I was also able to do a Tool Command Language (TCL) script on a Cisco router, which in my opinion is the coolest feature I've learned in CCNP ROUTE.


2811(config)#hostname FRS
FRS(config)#frame-relay ?
  address    Address Registration with neighbor
  de-list    Build a classification list to be used in setting the DE bit
  switching  enable frame relay pvc switching

FRS(config)#frame-relay switching
FRS(config)#interface serial0/0/0
FRS(config-if)#description FR to HQ
FRS(config-if)#clock rate 128000
FRS(config-if)#encapsulation ?
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

FRS(config-if)#encapsulation frame-relay ?
  MFR   Multilink Frame Relay bundle interface
  ietf  Use RFC1490/RFC2427 encapsulation
  <cr>

FRS(config-if)#encapsulation frame-relay ietf   // SIGNIFICANT ONLY ON END DEVICES, NOT ON FR SWITCH
FRS(config-if)#frame-relay ?
  accounting             Special accounting instruction
  address-reg            ELMI address registration
  broadcast-queue        Define a broadcast queue and transmit rate
  class                  Define a map class on the interface
  congestion-management  Enable Frame Relay congestion management
  de-group               Associate a DE group with a DLCI
  fragment               Enable end-to-end fragmentation for all PVCs
  fragmentation          Adaptive fragmentation
  ifmib-counter64        Support IF-MIB's total packet/byte counts of Counter64
                         on FR if/subif when main interface's ifSpeed < 20 Mbps
  interface-dlci         Define a DLCI on an interface/subinterface
  interface-queue        configure PVC interface queueing
  intf-type              Configure a FR DTE/DCE/NNI interface
  inverse-arp            Enable/disable FR inverse ARP
  ip                     Frame Relay Internet Protocol config commands
  lapf                   set LAPF parameter
  lmi-n391dte            set full status polling counter
  lmi-n392dce            LMI error threshold
  lmi-n392dte            LMI error threshold
  lmi-n393dce            set LMI monitored event count
  lmi-n393dte            set LMI monitored event count
  lmi-t392dce            set DCE polling verification timer
  lmi-type               Use CISCO-ANSI-CCITT type LMI
  local-dlci             Set source DLCI when LMI is not supported
  map                    Map a protocol address to a DLCI address
  multicast-dlci         Set DLCI of a multicast group
  payload-compression    Use payload compression
  policing               Enable Frame Relay policing
  priority-dlci-group    Define a priority group of DLCIs
  qos-autosense          enable QOS autosense
  route                  frame relay route for pvc switching
  svc                    Enable frame relay SVCs
  traffic-shaping        Enable Frame Relay Traffic Shaping
  traps-maximum          set max traps FR generates at link up or when getting
                         LMI Full Status message
  vc-bundle              configure a frame-relay vc-bundle

FRS(config-if)#frame-relay lmi-type ?
  cisco
  ansi
  q933a

FRS(config-if)#frame-relay lmi-type cisco    // DEFAULT LMI TYPE
FRS(config-if)#frame-relay intf-type ?
  dce  Configure a FR DCE
  dte  Configure a FR DTE
  nni  Configure a FR NNI

FRS(config-if)#frame-relay intf-type dce
FRS(config-if)#frame-relay route ?
  <16-1007>  input dlci to be switched

FRS(config-if)#frame-relay route 102 ?
  interface  outgoing interface for pvc switching

FRS(config-if)#frame-relay route 102 interface ?
  MFR     Multilink Frame Relay bundle interface
  Serial  Serial
  Tunnel  Tunnel interface

FRS(config-if)#frame-relay route 102 interface serial0/0/1 ?
  <16-1007>  output dlci to use when switching

FRS(config-if)#frame-relay route 102 interface serial0/0/1 201
FRS(config-if)#frame-relay route 103 interface serial0/1/0 301
FRS(config-if)#no shutdown
FRS(config-if)#
*Oct 26 11:51:22.995: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
FRS(config-if)#interface serial0/0/1
FRS(config-if)#description FR to EAST
FRS(config-if)#encapsulation frame-relay ietf
FRS(config-if)#frame-relay lmi-type cisco
FRS(config-if)#frame-relay intf-type dce
FRS(config-if)#frame-relay route 201 interface serial0/0/0 102
FRS(config-if)#no shutdown
FRS(config-if)#
*Oct 26 11:52:31.307: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
FRS(config-if)#interface serial0/1/0
FRS(config-if)#description FR to WEST
FRS(config-if)#encapsulation frame-relay ietf
FRS(config-if)#clock rate 64000
FRS(config-if)#frame-relay lmi-type cisco
FRS(config-if)#frame-relay intf-type dce
FRS(config-if)#frame-relay route 301 interface serial0/0/0 103
FRS(config-if)#no shutdown
FRS(config-if)#
*Oct 26 11:53:36.139: %LINK-3-UPDOWN: Interface Serial0/1/0, changed state to up
FRS(config-if)#


HQ#show controllers serial 0/0/1
Interface Serial0/0/1
Hardware is GT96K
DTE V.35 TX and RX clocks detected.

<OUTPUT TRUNCATED>

HQ#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
HQ(config)#interface serial0/0/1
HQ(config-if)#ip address 172.16.124.1 255.255.255.248
HQ(config-if)#encapsulation ?
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

HQ(config-if)#encapsulation frame-relay ?
  MFR   Multilink Frame Relay bundle interface
  ietf  Use RFC1490/RFC2427 encapsulation
  <cr>

HQ(config-if)#encapsulation frame-relay ietf
HQ(config-if)#no frame-relay ?
  accounting             Special accounting instruction
  address-reg            ELMI address registration
  broadcast-queue        Define a broadcast queue and transmit rate
  class                  Define a map class on the interface
  congestion-management  Enable Frame Relay congestion management
  de-group               Associate a DE group with a DLCI
  fragment               Enable end-to-end fragmentation for all PVCs
  fragmentation          Adaptive fragmentation
  ifmib-counter64        Support IF-MIB's total packet/byte counts of Counter64
                         on FR if/subif when main interface's ifSpeed < 20 Mbps
  interface-dlci         Define a DLCI on an interface/subinterface
  interface-queue        configure PVC interface queueing
  intf-type              Configure a FR DTE/DCE/NNI interface
  inverse-arp            Enable/disable FR inverse ARP
  ip                     Frame Relay Internet Protocol config commands
  lapf                   set LAPF parameter
  lmi-n391dte            set full status polling counter
  lmi-n392dce            LMI error threshold
  lmi-n392dte            LMI error threshold
  lmi-n393dce            set LMI monitored event count
  lmi-n393dte            set LMI monitored event count
  lmi-t392dce            set DCE polling verification timer
  lmi-type               Use CISCO-ANSI-CCITT type LMI
  local-dlci             Set source DLCI when LMI is not supported
  map                    Map a protocol address to a DLCI address
  multicast-dlci         Set DLCI of a multicast group
  payload-compression    Use payload compression
  policing               Enable Frame Relay policing
  priority-dlci-group    Define a priority group of DLCIs
  qos-autosense          enable QOS autosense
  route                  frame relay route for pvc switching
  svc                    Enable frame relay SVCs
  traffic-shaping        Enable Frame Relay Traffic Shaping
  traps-maximum          set max traps FR generates at link up or when getting
                         LMI Full Status message
  vc-bundle              configure a frame-relay vc-bundle

HQ(config-if)#no frame-relay inverse-arp   // DISABLE INVERSE ARP SINCE STATIC MAPPINGS WILL BE USED
HQ(config-if)#frame-relay ?
  accounting             Special accounting instruction
  address-reg            ELMI address registration
  broadcast-queue        Define a broadcast queue and transmit rate
  class                  Define a map class on the interface
  congestion-management  Enable Frame Relay congestion management
  de-group               Associate a DE group with a DLCI
  fragment               Enable end-to-end fragmentation for all PVCs
  fragmentation          Adaptive fragmentation
  ifmib-counter64        Support IF-MIB's total packet/byte counts of Counter64
                         on FR if/subif when main interface's ifSpeed < 20 Mbps
  interface-dlci         Define a DLCI on an interface/subinterface
  interface-queue        configure PVC interface queueing
  intf-type              Configure a FR DTE/DCE/NNI interface
  inverse-arp            Enable/disable FR inverse ARP
  ip                     Frame Relay Internet Protocol config commands
  lapf                   set LAPF parameter
  lmi-n391dte            set full status polling counter
  lmi-n392dce            LMI error threshold
  lmi-n392dte            LMI error threshold
  lmi-n393dce            set LMI monitored event count
  lmi-n393dte            set LMI monitored event count
  lmi-t392dce            set DCE polling verification timer
  lmi-type               Use CISCO-ANSI-CCITT type LMI
  local-dlci             Set source DLCI when LMI is not supported
  map                    Map a protocol address to a DLCI address
  multicast-dlci         Set DLCI of a multicast group
  payload-compression    Use payload compression
  policing               Enable Frame Relay policing
  priority-dlci-group    Define a priority group of DLCIs
  qos-autosense          enable QOS autosense
  route                  frame relay route for pvc switching
  svc                    Enable frame relay SVCs
  traffic-shaping        Enable Frame Relay Traffic Shaping
  traps-maximum          set max traps FR generates at link up or when getting
                         LMI Full Status message
  vc-bundle              configure a frame-relay vc-bundle

HQ(config-if)#frame-relay map ?
  appletalk  AppleTalk
  bridge     Bridging
  bstun      Block Serial Tunnel
  clns       ISO CLNS
  decnet     DECnet
  dlsw       Data Link Switching (Direct encapsulation only)
  ip         IP
  ipv6       IPV6
  ipx        Novell IPX
  llc2       llc2
  qllc       qllc protocol
  rsrb       Remote Source-Route Bridging
  stun       Serial Tunnel

HQ(config-if)#frame-relay map ip ?
  A.B.C.D  Protocol specific address

HQ(config-if)#frame-relay map ip 172.16.124.2 ?
  <16-1007>  DLCI
  vc-bundle  vc-bundle

HQ(config-if)#frame-relay map ip 172.16.124.2 102 ?
  broadcast            Broadcasts should be forwarded to this address
  cisco                Use CISCO Encapsulation
  compress             Enable TCP/IP and RTP/IP header compression
  ietf                 Use RFC1490/RFC2427 Encapsulation
  nocompress           Do not compress TCP/IP headers
  payload-compression  Use payload compression
  rtp                  RTP header compression parameters
  tcp                  TCP header compression parameters
  <cr>

HQ(config-if)#frame-relay map ip 172.16.124.2 102 broadcast   // STATIC IP TO DLCI MAPPING
HQ(config-if)#frame-relay map ip 172.16.124.3 103 broadcast   // ALLOWS EIGRP BROADCAST/MULTICAST THROUGH THE FRAME RELAY CLOUD
HQ(config-if)#no shutdown
*Oct 26 11:54:57.275: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Oct 26 11:55:08.275: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


EAST#show controllers serial0/0/1
Interface Serial0/0/1
Hardware is GT96K
DCE V.35, clock rate 64000

<OUTPUT TRUNCATED>

EAST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
EAST(config)#interface serial0/0/1
EAST(config-if)#ip address 172.16.124.2 255.255.255.248
EAST(config-if)#clock rate 64000
EAST(config-if)#encapsulation frame-relay ietf
EAST(config-if)#no frame-relay inverse-arp
EAST(config-if)#frame-relay map ip 172.16.124.1 201 broadcast
EAST(config-if)#frame-relay map ip 172.16.124.3 301   // NO broadcast KEYWORD TO AVOID DUPLICATE BROADCAST AND MULTICAST TRAFFIC
EAST(config-if)#no shutdown
*Oct 26 10:45:00.615: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Oct 26 10:45:11.615: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


WEST#show controller serial0/0/0
Interface Serial0/0/0
Hardware is GT96K
DTE V.35 TX and RX clocks detected.

<OUTPUT TRUNCATED>

WEST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
WEST(config)#interface serial 0/0/0
WEST(config-if)#ip address 172.16.124.3 255.255.255.248
WEST(config-if)#encapsulation frame-relay ietf
WEST(config-if)#no frame inverse-arp
*Oct 26 11:24:40.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
WEST(config-if)#frame-relay map ip 172.16.124.1 301 broadcast
WEST(config-if)#frame-relay map ip 172.16.124.2 301
WEST(config-if)#no shutdown


HQ#ping 172.16.124.1   // FR INTERFACE IS UNABLE TO PING ITSELF

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
HQ#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
HQ(config)#interface serial0/0/1
HQ(config-if)#frame-relay map ip 172.16.124.1 102  // TO ALLOW FR INTERFACE TO PING ITSELF
HQ(config-if)#do ping 172.16.124.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/84 ms


Configure the same on EAST and WEST routers.

EAST#ping 172.16.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
EAST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
EAST(config)#interface serial0/0/1
EAST(config-if)#frame-relay map ip 172.16.124.2 201
EAST(config-if)#do ping 172.16.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/84 ms


WEST#ping 172.16.124.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
WEST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
WEST(config)#interface serial0/0/0
WEST(config-if)#frame-relay map ip 172.16.124.3 301
WEST(config-if)#do ping 172.16.124.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/84 ms


Configure interface bandwidth for proper EIGRP metric calculations.

HQ(config)#interface serial 0/0/1
HQ(config-if)#bandwidth 128

EAST(config)#interface serial0/0/1
EAST(config-if)#bandwidth 64

WEST(config)#interface serial0/0/0
WEST(config-if)#bandwidth 64


HQ(config-if)#interface serial0/0/1
HQ(config-if)#ip bandwidth-percent ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)

HQ(config-if)#ip bandwidth-percent eigrp ?
  <1-65535>  Autonomous system number

HQ(config-if)#ip bandwidth-percent eigrp 1 ?
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

HQ(config-if)#ip bandwidth-percent eigrp 1 40


HQ(config)#router eigrp 1
HQ(config-router)#network 10.0.0.0
HQ(config-router)#network 172.16.0.0
HQ(config-router)#no auto-summary


WEST(config)#router eigrp 1
WEST(config-router)#network 10.0.0.0
WEST(config-router)#network 172.16.0.0
WEST(config-router)#no auto-summary
*Oct 26 12:08:08.715: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/0) is up: new adjacency
WEST(config-router)#
*Oct 26 12:08:10.839: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/0) is resync:summary configured


WEST(config)#router eigrp 1
WEST(config-router)#network 10.0.0.0
WEST(config-router)#network 172.16.0.0
WEST(config-router)#no auto-summary


EAST(config)#router eigrp 1
EAST(config-router)#network 10.0.0.0
EAST(config-router)#network 172.16.0.0
EAST(config-router)#no auto-summary
*Oct 26 11:35:09.431: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/1) is up: new adjacency
*Oct 26 11:35:10.591: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/1) is down:summary configured


EAST#show ip eigrp topology    // MISSING 10.3.x.x ROUTES
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/1


WEST#show ip eigrp topology    // MISSING 10.2.x.x ROUTES
IP-EIGRP Topology Table for AS(1)/ID(10.3.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.3.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/0


HQ(config)#interface serial0/0/1
HQ(config-if)#no ip split-horizon ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  <cr>

HQ(config-if)#no ip split-horizon eigrp ?
  <1-65535>  Autonomous system number

HQ(config-if)#no ip split-horizon eigrp 1   // ALLOWS EAST ROUTES TO BE ADVERTISED IN WEST ROUTER AND VICE VERSA
HQ(config-if)#
*Oct 26 12:54:25.383: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.2 (Serial0/0/1) is resync:split horizon changed
*Oct 26 12:54:25.383: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.3 (Serial0/0/1) is resync:split horizon changed


EAST#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.3.0.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.3.32.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.3.64.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.3.96.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.3.128.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.3.160.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/1
        via 172.16.124.1 (41024000/20512000), Serial0/0/1


WEST#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.3.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.32.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.64.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.128.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.160.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/0
        via 172.16.124.1 (41024000/20512000), Serial0/0/0


HQ#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.124.2            Se0/0/1          174 00:06:20 1053  5000  0  8
0   172.16.124.3            Se0/0/1          137 00:10:40   59  1422  0  9


EAST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/1          163 00:06:41   55  2280  0  14


WEST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/0          145 00:10:25  535  3210  0  14


HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/19 is subnetted, 18 subnets
D       10.2.0.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.0.0 [90/20640000] via 172.16.124.3, 00:11:53, Serial0/0/1
C       10.1.0.0 is directly connected, Loopback1
D       10.2.32.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.32.0 [90/20640000] via 172.16.124.3, 00:11:53, Serial0/0/1
C       10.1.32.0 is directly connected, Loopback33
D       10.2.64.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.64.0 [90/20640000] via 172.16.124.3, 00:11:53, Serial0/0/1
C       10.1.64.0 is directly connected, Loopback65
D       10.2.96.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.96.0 [90/20640000] via 172.16.124.3, 00:11:54, Serial0/0/1
C       10.1.96.0 is directly connected, Loopback97
D       10.2.128.0 [90/20640000] via 172.16.124.2, 00:07:34, Serial0/0/1
D       10.3.128.0 [90/20640000] via 172.16.124.3, 00:11:54, Serial0/0/1
C       10.1.128.0 is directly connected, Loopback129
D       10.2.160.0 [90/20640000] via 172.16.124.2, 00:07:34, Serial0/0/1
D       10.3.160.0 [90/20640000] via 172.16.124.3, 00:11:54, Serial0/0/1
C       10.1.160.0 is directly connected, Loopback161


EAST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/19 is subnetted, 18 subnets
C       10.2.0.0 is directly connected, Loopback1
D       10.3.0.0 [90/41152000] via 172.16.124.1, 00:04:56, Serial0/0/1
D       10.1.0.0 [90/40640000] via 172.16.124.1, 00:07:14, Serial0/0/1
C       10.2.32.0 is directly connected, Loopback33
D       10.3.32.0 [90/41152000] via 172.16.124.1, 00:04:56, Serial0/0/1
D       10.1.32.0 [90/40640000] via 172.16.124.1, 00:07:14, Serial0/0/1
C       10.2.64.0 is directly connected, Loopback65
D       10.3.64.0 [90/41152000] via 172.16.124.1, 00:04:56, Serial0/0/1
D       10.1.64.0 [90/40640000] via 172.16.124.1, 00:07:14, Serial0/0/1
C       10.2.96.0 is directly connected, Loopback97
D       10.3.96.0 [90/41152000] via 172.16.124.1, 00:04:58, Serial0/0/1
D       10.1.96.0 [90/40640000] via 172.16.124.1, 00:07:17, Serial0/0/1
C       10.2.128.0 is directly connected, Loopback129
D       10.3.128.0 [90/41152000] via 172.16.124.1, 00:04:58, Serial0/0/1
D       10.1.128.0 [90/40640000] via 172.16.124.1, 00:07:17, Serial0/0/1
C       10.2.160.0 is directly connected, Loopback161
D       10.3.160.0 [90/41152000] via 172.16.124.1, 00:04:58, Serial0/0/1
D       10.1.160.0 [90/40640000] via 172.16.124.1, 00:07:17, Serial0/0/1


WEST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/0
     10.0.0.0/19 is subnetted, 18 subnets
D       10.2.0.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.0.0 is directly connected, Loopback1
D       10.1.0.0 [90/40640000] via 172.16.124.1, 00:12:29, Serial0/0/0
D       10.2.32.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.32.0 is directly connected, Loopback33
D       10.1.32.0 [90/40640000] via 172.16.124.1, 00:12:29, Serial0/0/0
D       10.2.64.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.64.0 is directly connected, Loopback65
D       10.1.64.0 [90/40640000] via 172.16.124.1, 00:12:29, Serial0/0/0
D       10.2.96.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.96.0 is directly connected, Loopback97
D       10.1.96.0 [90/40640000] via 172.16.124.1, 00:12:30, Serial0/0/0
D       10.2.128.0 [90/41152000] via 172.16.124.1, 00:05:52, Serial0/0/0
C       10.3.128.0 is directly connected, Loopback129
D       10.1.128.0 [90/40640000] via 172.16.124.1, 00:12:30, Serial0/0/0
D       10.2.160.0 [90/41152000] via 172.16.124.1, 00:05:52, Serial0/0/0
C       10.3.160.0 is directly connected, Loopback161
D       10.1.160.0 [90/40640000] via 172.16.124.1, 00:12:30, Serial0/0/0


HQ#tclsh     // TCL SCRIPT
HQ(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.33.1
+>(tcl)#10.1.65.1
+>(tcl)#10.1.97.1
+>(tcl)#10.1.129.1
+>(tcl)#10.1.161.1
+>(tcl)#172.16.124.1
+>(tcl)#10.2.1.1
+>(tcl)#10.2.33.1
+>(tcl)#10.2.65.1
+>(tcl)#10.2.97.1
+>(tcl)#10.2.129.1
+>(tcl)#10.2.161.1
+>(tcl)#172.16.124.2
+>(tcl)#10.3.1.1
+>(tcl)#10.3.33.1
+>(tcl)#10.3.65.1
+>(tcl)#10.3.97.1
+>(tcl)#10.3.129.1
+>(tcl)#10.3.161.1
+>(tcl)#172.16.124.3
+>(tcl)#} { ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.65.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.97.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.129.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.161.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/88 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.65.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.97.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.129.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.161.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.65.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.97.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.129.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.161.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms


HQ(config)#router eigrp 1
HQ(config-router)#neighbor ?
  A.B.C.D  Neighbor address

HQ(config-router)#neighbor 172.16.124.2 ?
  Async               Async interface
  Auto-Template       Auto-Template interface
  BVI                 Bridge-Group Virtual Interface
  CDMA-Ix             CDMA Ix interface
  CTunnel             CTunnel interface
  Dialer              Dialer interface
  FastEthernet        FastEthernet IEEE 802.3
  Lex                 Lex interface
  Loopback            Loopback interface
  MFR                 Multilink Frame Relay bundle interface
  Multilink           Multilink-group interface
  Null                Null interface
  SSLVPN-VIF          SSLVPN Virtual Interface
  Serial              Serial
  Tunnel              Tunnel interface
  Vif                 PGM Multicast Host interface
  Virtual-Dot11Radio  Virtual dot11 interface
  Virtual-PPP         Virtual PPP interface
  Virtual-Template    Virtual Template interface
  Virtual-TokenRing   Virtual TokenRing
  vmi                 Virtual Multipoint Interface

HQ(config-router)#neighbor 172.16.124.2 serial0/0/1  // NOT ALL FRAME RELAY SUPPORTS MULTICAST
*Oct 26 13:07:07.423: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.2 (Serial0/0/1) is down: Static peer configured
*Oct 26 13:07:07.423: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.3 (Serial0/0/1) is down: Static peer configured
HQ(config-router)#neighbor 172.16.124.3 serial0/0/1  // SENDS UNICAST INSTEAD OF MULTICAST ON A PER-INTERFACE BASIS


EAST(config)#router eigrp 1
EAST(config-router)#neighbor 172.16.124.1 serial0/0/1


WEST(config)#router eigrp 1
WEST(config-router)#neighbor 172.16.124.1 serial0/0/0


HQ#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.124.3            Se0/0/1          136 00:01:35   48  1422  0  14
0   172.16.124.2            Se0/0/1          160 00:02:05   63  1422  0  14


EAST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/1          169 00:02:34   54  2280  0  24


WEST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/0          123 00:01:53   86  2280  0  24


HQ(config)#interface serial0/0/0
HQ(config-if)#ip summary-address eigrp 1 ?
  A.B.C.D  IP address

HQ(config-if)#ip summary-address eigrp 1 10.1.0.0 ?
  A.B.C.D  IP network mask

HQ(config-if)#ip summary-address eigrp 1 10.1.0.0 255.255.0.0 ?


EAST(config)#interface serial0/0/1
EAST(config-if)#ip summary-address eigrp 1 10.2.0.0 255.255.0.0
EAST(config-if)#
*Oct 26 11:59:20.927: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/1) is resync:summary configured


WEST(config)#interface serial0/0/0
WEST(config-if)#ip summary-address eigrp 1 10.3.0.0 255.255.0.0
*Oct 26 12:36:52.907: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/0) is resync:summary configured


HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
D       10.2.0.0/16 [90/20640000] via 172.16.124.2, 00:03:29, Serial0/0/1
D       10.3.0.0/16 [90/20640000] via 172.16.124.3, 00:02:19, Serial0/0/1
C       10.1.0.0/19 is directly connected, Loopback1
C       10.1.32.0/19 is directly connected, Loopback33
C       10.1.64.0/19 is directly connected, Loopback65
C       10.1.96.0/19 is directly connected, Loopback97
C       10.1.128.0/19 is directly connected, Loopback129
C       10.1.160.0/19 is directly connected, Loopback161


EAST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/8 is variably subnetted, 14 subnets, 3 masks
C       10.2.0.0/19 is directly connected, Loopback1
D       10.2.0.0/16 is a summary, 00:02:27, Null0
D       10.3.0.0/16 [90/41152000] via 172.16.124.1, 00:01:17, Serial0/0/1
D       10.1.0.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.32.0/19 is directly connected, Loopback33
D       10.1.32.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.64.0/19 is directly connected, Loopback65
D       10.1.64.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.96.0/19 is directly connected, Loopback97
D       10.1.96.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.128.0/19 is directly connected, Loopback129
D       10.1.128.0/19 [90/40640000] via 172.16.124.1, 00:07:55, Serial0/0/1
C       10.2.161.0/29 is directly connected, Loopback161
D       10.1.160.0/19 [90/40640000] via 172.16.124.1, 00:07:55, Serial0/0/1


WEST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 14 subnets, 2 masks
D       10.2.0.0/16 [90/41152000] via 172.16.124.1, 00:01:25, Serial0/0/0
C       10.3.0.0/19 is directly connected, Loopback1
D       10.3.0.0/16 is a summary, 00:00:15, Null0
D       10.1.0.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.32.0/19 is directly connected, Loopback33
D       10.1.32.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.64.0/19 is directly connected, Loopback65
D       10.1.64.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.96.0/19 is directly connected, Loopback97
D       10.1.96.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.128.0/19 is directly connected, Loopback129
D       10.1.128.0/19 [90/40640000] via 172.16.124.1, 00:06:22, Serial0/0/0
C       10.3.160.0/19 is directly connected, Loopback161
D       10.1.160.0/19 [90/40640000] via 172.16.124.1, 00:06:22, Serial0/0/0