Friday, March 25, 2016

Basic OSPF Configuration Lab

I finally got my CompTIA network+ cert kit, which includes a congratulatory letter, hard copy cert and wallet ID, after nine agonizing weeks of waiting. According to CompTIA's website, it usually takes up to eight weeks for the cert to be delivered. This is after you've received an email from CompTIA (usually the next business day passing their exam) confirming your name and shipping address. I got my Security+ cert kit after a month last time so it's unusual for it to take this long. So I opened a support case and was advised that it was delivered and have to wait for about eight weeks.


I'm currently going for my Check Point CCSA certification and I might take up CompTIA Linux+ next if time at work permits it. Below is the final lab that I did while stuyding for my Network+


R1(config)#no ip domain-lookup
R1(config)#enable secret cisco
R1(config)#banner motd $
Enter TEXT message.  End with the character '$'
********************************
   AUTHORIZED ACCESS ONLY
********************************
$
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous


R2(config)#no ip domain-lookup
R2(config)#enable secret cisco
R2(config)#banner motd $
Enter TEXT message.  End with the character '$'
********************************
   AUTHORIZED ACCESS ONLY
********************************
$
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#logging synchronous
R2(config-line)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#logging synchronous


R3(config)#no ip domain-lookup
R3(config)#enable secret cisco
R3(config)#banner motd $
Enter TEXT message.  End with the character '$'
********************************
   AUTHORIZED ACCESS ONLY
********************************
$
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#logging synchronous
R3(config-line)#line vty 0 4
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#logging synchronous


R1(config)#interface fastethernet0/0
R1(config-if)#ip address 172.16.1.17 255.255.255.240
R1(config-if)#no shutdown
R1(config-if)#
*Jan  9 08:53:23.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed
state to up
R1(config-if)#interface serial0/0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#
*Jan  9 08:53:56.091: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#interface serial0/0/1
R1(config-if)#ip address 192.168.10.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#
*Jan  9 08:54:21.639: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down


R2(config)#interface fastethernet0/0
R2(config-if)#ip address 10.10.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
*Jan  9 08:45:52.319: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed
state to up
R2(config-if)#interface serial0/0/0
R2(config-if)#ip address 192.168.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Jan  9 08:46:15.763: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan  9 08:46:16.763: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state
to up
R2(config-if)#interface serial0/0/1
R2(config-if)#ip address 192.168.10.9 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#
*Jan  9 08:46:42.483: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down


R3(config)#interface fastethernet0/0
R3(config-if)#ip address 172.16.1.33 255.255.255.248
R3(config-if)#no shutdown
R3(config-if)#
*Jan  9 08:55:00.139: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  9 08:55:01.139: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed
state to up
R3(config-if)#interface serial0/0/0
R3(config-if)#ip address 192.168.10.6 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no shutdown
R3(config-if)#
*Jan  9 08:55:26.939: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan  9 08:55:27.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state
to up
R3(config-if)#interface serial0/0/1
R3(config-if)#ip address 192.168.10.10 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#
*Jan  9 08:55:50.003: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan  9 08:55:51.003: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state
to up


R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.17     YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                192.168.10.1    YES manual up                    up 
Serial0/0/1                192.168.10.5    YES manual up                    up 
Serial0/1/0                unassigned      YES NVRAM  administratively down down
Serial0/1/1                unassigned      YES NVRAM  administratively down down


R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.10.10.1      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                192.168.10.2    YES manual up                    up 
Serial0/0/1                192.168.10.9    YES manual up                    up


R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.33     YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                192.168.10.6    YES manual up                    up 
Serial0/0/1                192.168.10.10   YES manual up                    up


R1(config)#router ospf ?
  <1-65535>  Process ID

R1(config)#router ospf 1
R1(config-router)#?
Router configuration commands:
  area                   OSPF area parameters
  auto-cost              Calculate OSPF interface cost according to bandwidth
  bfd                    BFD configuration commands
  capability             Enable specific OSPF feature
  compatible             OSPF compatibility list
  default                Set a command to its defaults
  default-information    Control distribution of default information
  default-metric         Set metric of redistributed routes
  discard-route          Enable or disable discard-route installation
  distance               Define an administrative distance
  distribute-list        Filter networks in routing updates
  domain-id              OSPF domain-id
  domain-tag             OSPF domain-tag
  exit                   Exit from routing protocol configuration mode
  help                   Description of the interactive help system
  ignore                 Do not complain about specific event
  interface-id           Source of the interface ID
  ispf                   Enable incremental SPF computation
  limit                  Limit a specific OSPF feature
  local-rib-criteria     Enable or disable usage of local RIB as route criteria
  log-adjacency-changes  Log changes in adjacency state
  max-lsa                maximum number of LSAs OSPF process will receive
  max-metric             Set maximum metric
  maximum-paths          Forward packets over multiple paths
  mpls                   Configure MPLS routing protocol parameters
  neighbor               Specify a neighbor router
  network                Enable routing on an IP network
  no                     Negate a command or set its defaults
  nsf                    Non-stop forwarding
  passive-interface      Suppress routing updates on an interface
  prefix-suppression     OSPF prefix suppression
  process-min-time       Percentage of quantum to be used before releasing CPU
  queue-depth            OSPF Hello/Router process queue depth
  redistribute           Redistribute information from another routing protocol
  router-id              router-id for this OSPF process
  summary-address        Configure IP address summaries
  timers                 Adjust routing timers
  traffic-share          How to compute traffic share over alternate paths

R1(config-router)#network 172.16.1.16 0.0.0.15 ?
  area  Set the OSPF area ID

R1(config-router)#network 172.16.1.16 0.0.0.15 area ?
  <0-4294967295>  OSPF area ID as a decimal value
  A.B.C.D         OSPF area ID in IP address format

R1(config-router)#network 172.16.1.16 0.0.0.15 area 0   // INCLUDE 172.16.1.16/28 IN R1'S OSPF

UPDATES; NETWORK COMMAND IN OSPF IS SIMILAR TO OSPF; WILDCARD MASK IN OSPF IS REQUIRED
R1(config-router)#network 192.168.10.0 0.0.0.3 area 0
R1(config-router)#network 192.168.10.4 0.0.0.3 area 0


R2(config)#router ospf 1
R2(config-router)#network 10.10.10.0 0.0.0.255 area 0
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#
*Jan  9 08:55:01.783: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from LOADING to FULL, Loading Done    // R2 FORMED AN OSPF ADJACENCY WITH R1 VIA S0/0/0 LINK
R2(config-router)#network 192.168.10.8 0.0.0.3 area 0


R3(config)#router ospf 1
R3(config-router)#network 172.16.1.32 0.0.0.7 area 0
R3(config-router)#network 192.168.10.4 0.0.0.3 area 0
R3(config-router)#
*Jan  9 09:04:16.811: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from LOADING to FULL, Loading Done   
R3(config-router)#network 192.168.10.8 0.0.0.3 area 0
R3(config-router)#
*Jan  9 09:04:25.855: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.9 on Serial0/0/1 from LOADING to FULL, Loading Done   


R3#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.10    // OSPF ROUTER IS USED TO UNIQUELY IDENTIFY THE ROUTER IS OSPF ROUTING DOMAIN; ROUTER ID IS AN IP ADDRESS FORMAT; OSPF CHOOSE THE ROUTER ID WITH THE FOLLOWING ORDER: IP ADDRESS COFNIGURED VIA router-id COMMAND; LOOPBACK INTERFACE WITH HIGHEST IP ADDRESS; HIGHEST ACTIVE PHYSICAL IP ADDRESS
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.32 0.0.0.7 area 0
    192.168.10.4 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.5         110      00:01:20
    192.168.10.9         110      00:01:10
  Distance: (default is 110)

R3#show ip ospf
 Routing Process "ospf 1" with ID 192.168.10.10  
 Start time: 00:18:07.352, Time elapsed: 00:01:52.056
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm last executed 00:01:16.160 ago
        SPF algorithm executed 3 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x01398D
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R3#show ip ospf interface
Serial0/0/1 is up, line protocol is up
  Internet Address 192.168.10.10/30, Area 0
  Process ID 1, Router ID 192.168.10.10, Network Type POINT_TO_POINT, Cost: 64  
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.10.9
  Suppress hello for 0 neighbor(s)
Serial0/0/0 is up, line protocol is up
  Internet Address 192.168.10.6/30, Area 0
  Process ID 1, Router ID 192.168.10.10, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.10.5
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 172.16.1.33/29, Area 0
  Process ID 1, Router ID 192.168.10.10, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.10.10, Interface address 172.16.1.33
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)


R1#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.5   
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.16 0.0.0.15 area 0
    192.168.10.0 0.0.0.3 area 0
    192.168.10.4 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.10        110      00:09:03
    192.168.10.9         110      00:10:29
  Distance: (default is 110)


R2#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.9  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    10.10.10.0 0.0.0.255 area 0
    192.168.10.0 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.5         110      00:11:22
    192.168.10.10        110      00:09:32
  Distance: (default is 110)


R1(config)#interface loopback0
R1(config-if)#
*Jan  9 09:16:47.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.1.1.1 255.255.255.255


R2(config)#interface loopback0
R2(config-if)#
*Jan  9 09:08:09.991: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 10.2.2.2 255.255.255.255


R3(config)#interface loopback0
R3(config-if)#
*Jan  9 09:16:59.455: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 10.3.3.3 255.255.255.255


R3#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.10   // OSPF WILL NOT CHOOSE A NEW ROUTER ID UNLESS OSPF PROCESS IS RESTARTED
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.32 0.0.0.7 area 0
    192.168.10.4 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.5         110      00:13:13
    192.168.10.9         110      00:13:03
  Distance: (default is 110)

R3#clear ip ospf ?
  <1-65535>       Process ID number
  counters        OSPF counters
  process         Reset OSPF process
  redistribution  Clear OSPF route redistribution
  traffic         Traffic related statistics

R3#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R3#
*Jan  9 09:24:14.075: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.9 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:24:14.075: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:24:14.215: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.9 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:24:14.215: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from LOADING to FULL, Loading Done

R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R1#
*Jan  9 09:25:15.659: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from FULL to
DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:25:15.659: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.9 on Serial0/0/0 from FULL to
DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:25:15.791: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:25:15.791: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.9 on Serial0/0/0 from LOADING to FULL, Loading Done


R2#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R2#
*Jan  9 09:15:06.451: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:15:06.451: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:15:06.583: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:15:06.583: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from LOADING to FULL, Loading Done

R2#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.9   // ROUTER ID DIDN'T CHANGE AFTER OSPF PROCESS RESET
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    10.10.10.0 0.0.0.255 area 0
    192.168.10.0 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.5         110      00:02:47
    192.168.10.10        110      00:02:14
  Distance: (default is 110)

R2#reload
Proceed with reload? [confirm]

<OUTPUT TRUNCATED>

R2#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.2.2.2   // ROUTER ID CHANGED AFTER R2 REBOOTS
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    10.10.10.0 0.0.0.255 area 0
    192.168.10.0 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.5         110      00:00:11
    192.168.10.10        110      00:00:11
  Distance: (default is 110)

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.10.10     0   FULL/  -        00:00:32    192.168.10.6    Serial0/0/1
10.2.2.2          0   FULL/  -        00:00:37    192.168.10.2    Serial0/0/0  


R1(config)#router ospf 1
R1(config-router)#router-id ?
  A.B.C.D  OSPF router-id in IP address format

R1(config-router)#router-id 10.4.4.4   // HARCODE ROUTER ID VIA router-id COMMAND
Reload or use "clear ip ospf process" command, for this to take effect   
R1(config-router)#end
R1#
*Jan  9 09:33:04.199: %SYS-5-CONFIG_I: Configured from console by console
R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R1#
*Jan  9 09:33:12.271: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from FULL to

DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:33:12.271: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:33:12.403: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:33:12.403: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/0 from LOADING to FULL, Loading Done

R1#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.4.4.4  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.16 0.0.0.15 area 0
    192.168.10.0 0.0.0.3 area 0
    192.168.10.4 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.2.2.2             110      00:00:58
    192.168.10.10        110      00:00:58
    192.168.10.9         110      00:08:55
  Distance: (default is 110)

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.10.10     0   FULL/  -        00:00:36    192.168.10.10   Serial0/0/1
10.4.4.4          0   FULL/  -        00:00:35    192.168.10.1    Serial0/0/0   // VERIFY R1's ROUTER ID ON R2

R1(config)#router ospf 1
R1(config-router)#no router-id 10.4.4.4   // REMOVE router-id TO FORCE R1 TO USE LOOPBACK IP ADDRESS AS ITS ROUTER ID; VERY USEFUL TRICK AND THERE'S NO NEED TO RELOAD R1
Reload or use "clear ip ospf process" command, for this to take effect
R1(config-router)#end
R1#
*Jan  9 09:41:42.479: %SYS-5-CONFIG_I: Configured from console by console
R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R1#
*Jan  9 09:41:48.779: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:41:48.779: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:41:48.911: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.10 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:41:48.911: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/0 from LOADING to FULL, Loading Done

R1#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.1.1.1   // LOOPBACK IP ADDRESS BECOMES THE ROUTER ID; NO REBOOT NEEDED
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.16 0.0.0.15 area 0
    192.168.10.0 0.0.0.3 area 0
    192.168.10.4 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.2.2.2             110      00:00:45
    192.168.10.10        110      00:00:45
    192.168.10.9         110      00:17:18
  Distance: (default is 110)


R3#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.10  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.32 0.0.0.7 area 0
    192.168.10.4 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.2.2.2             110      00:03:30
    10.1.1.1             110      00:02:15
    10.4.4.4             110      00:10:52
    192.168.10.5         110      00:13:05
    192.168.10.9         110      00:18:15
  Distance: (default is 110)

R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#router-id 1.1.1.1
Reload or use "clear ip ospf process" command, for this to take effect
R3(config-router)#do clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R3(config-router)#
*Jan  9 09:43:07.639: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:43:07.639: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:43:07.771: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:43:07.771: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done
R3(config-router)#
R3(config-router)#do show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.32 0.0.0.7 area 0
    192.168.10.4 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.2.2.2             110      00:00:01
    10.1.1.1             110      00:00:01
    10.4.4.4             110      00:11:31
    192.168.10.5         110      00:13:44
    192.168.10.9         110      00:18:54
  Distance: (default is 110)

R3(config-router)#no router-id 1.1.1.1   //
Reload or use "clear ip ospf process" command, for this to take effect
R3(config-router)#end
R3#clear
*Jan  9 09:43:24.003: %SYS-5-CONFIG_I: Configured from console by console
R3#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R3#
*Jan  9 09:43:29.475: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:43:29.475: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan  9 09:43:29.615: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/1 from LOADING to FULL, Loading Done
*Jan  9 09:43:29.615: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done
R3#
R3#shoow ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.3.3.3   // ROUTER ID USING R3 LOOPBACK IP ADDRESS; NO REBOOT NEEDED
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.32 0.0.0.7 area 0
    192.168.10.4 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.2.2.2             110      00:00:01
    10.1.1.1             110      00:00:01
    10.4.4.4             110      00:11:53
    192.168.10.5         110      00:14:06
    192.168.10.9         110      00:19:16
  Distance: (default is 110)


R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.3.3.3          0   FULL/  -        00:00:31    192.168.10.6    Serial0/0/1
10.2.2.2          0   FULL/  -        00:00:38    192.168.10.2    Serial0/0/0


R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.3.3.3          0   FULL/  -        00:00:38    192.168.10.10   Serial0/0/1
10.1.1.1          0   FULL/  -        00:00:32    192.168.10.1    Serial0/0/0


R3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.2.2.2          0   FULL/  -        00:00:30    192.168.10.9    Serial0/0/1
10.1.1.1          0   FULL/  -        00:00:38    192.168.10.5    Serial0/0/0


R1#show ip route    // OSPF ROUTES ARE DENOTED WITH AN "O" AND DOESN'T AUTO SUMMARIZE AT MAJOR

NETWORK BOUNDARY
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 3 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
C       192.168.10.4 is directly connected, Serial0/0/1
O       192.168.10.8 [110/128] via 192.168.10.6, 00:02:15, Serial0/0/1   
                     [110/128] via 192.168.10.2, 00:02:15, Serial0/0/0   
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.1.32/29 [110/65] via 192.168.10.6, 00:02:15, Serial0/0/1  
C       172.16.1.16/28 is directly connected, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       10.10.10.0/24 [110/65] via 192.168.10.2, 00:01:47, Serial0/0/0   // R1'S COST TO 10.10.10.0/24 IS 65
C       10.1.1.1/32 is directly connected, Loopback0


R1#show interface serial0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 192.168.10.1/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,   // SERIAL LINKS DEFAULTS TO 1.544 Kbps
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     134 packets input, 10716 bytes, 0 no buffer
     Received 66 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     135 packets output, 11016 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     7 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R1(config)#interface serial0/0/0
R1(config-if)#bandwidth 64    // CHANGE BANDWIDTH TO CALCULATE CORRECT OSPF COST
R1(config-if)#interface serial0/0/1
R1(config-if)#bandwidth 64


R2(config)#interface serial0/0/0
R2(config-if)#bandwidth 64
R2(config-if)#interface serial0/0/1
R2(config-if)#bandwidth 64


R1#show ip ospf interface
Serial0/0/1 is up, line protocol is up
  Internet Address 192.168.10.5/30, Area 0
  Process ID 1, Router ID 10.1.1.1, Network Type POINT_TO_POINT, Cost: 1562   // OSPF COST = 10^8 / 64,000
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.3.3.3
  Suppress hello for 0 neighbor(s)
Serial0/0/0 is up, line protocol is up
  Internet Address 192.168.10.1/30, Area 0
  Process ID 1, Router ID 10.1.1.1, Network Type POINT_TO_POINT, Cost: 1562  
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.2.2.2
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 172.16.1.17/28, Area 0
  Process ID 1, Router ID 10.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.1.1.1, Interface address 172.16.1.17
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)


R3(config)#interface serial0/0/0
R3(config-if)#ip ospf ?
  <1-65535>            Process ID
  authentication       Enable authentication
  authentication-key   Authentication password (key)
  cost                 Interface cost
  database-filter      Filter OSPF LSA during synchronization and flooding
  dead-interval        Interval after which a neighbor is declared dead
  demand-circuit       OSPF demand circuit
  flood-reduction      OSPF Flood Reduction
  hello-interval       Time between HELLO packets
  lls                  Link-local Signaling (LLS) support
  message-digest-key   Message digest authentication password (key)
  mtu-ignore           Ignores the MTU in DBD packets
  network              Network type
  prefix-suppression   OSPF prefix suppression
  priority             Router priority
  resync-timeout       Interval after which adjacency is reset if oob-resync is
                       not started
  retransmit-interval  Time between retransmitting lost link state
                       advertisements
  transmit-delay       Link state transmit delay

R3(config-if)#ip ospf cost ?
  <1-65535>  Cost

R3(config-if)#ip ospf cost 1562   // ALTERNATIVE METHOD TO USING BANDWIDTH COMMAND
R3(config-if)#interface serial0/0/1
R3(config-if)#ip ospf cost 1562

R3#show ip ospf interface
Serial0/0/1 is up, line protocol is up
  Internet Address 192.168.10.10/30, Area 0
  Process ID 1, Router ID 10.3.3.3, Network Type POINT_TO_POINT, Cost: 1562  
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.2.2.2
  Suppress hello for 0 neighbor(s)
Serial0/0/0 is up, line protocol is up
  Internet Address 192.168.10.6/30, Area 0
  Process ID 1, Router ID 10.3.3.3, Network Type POINT_TO_POINT, Cost: 1562  
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.1.1.1
  Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
  Internet Address 172.16.1.33/29, Area 0
  Process ID 1, Router ID 10.3.3.3, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.3.3.3, Interface address 172.16.1.33
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)


R1(config)#interface loopback1   // SIMULATE A LINK TO ISP ROUTER
R1(config-if)#
*Jan  9 12:10:19.339: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 172.30.1.1 255.255.255.252
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback1   // CONFIGURE A STATIC DEFAULT ROUTE

R1(config)#router ospf 1
R1(config-router)#default-information ?
  originate  Distribute a default route

R1(config-router)#default-information originate   // INCLUDE STATIC ROUTE IN OSPF UPDATE FROM R1


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0  

     192.168.10.0/30 is subnetted, 3 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
O       192.168.10.4 [110/3124] via 192.168.10.10, 00:04:07, Serial0/0/1
                     [110/3124] via 192.168.10.1, 00:04:07, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.1.32/29 [110/1563] via 192.168.10.10, 00:06:24, Serial0/0/1
O       172.16.1.16/28 [110/1563] via 192.168.10.1, 00:06:24, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.2.2.2/32 is directly connected, Loopback0
C       10.10.10.0/24 is directly connected, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:38, Serial0/0/0  


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.5 to network 0.0.0.0   

     192.168.10.0/30 is subnetted, 3 subnets
O       192.168.10.0 [110/3124] via 192.168.10.9, 00:04:32, Serial0/0/1
                     [110/3124] via 192.168.10.5, 00:04:32, Serial0/0/0
C       192.168.10.4 is directly connected, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.1.32/29 is directly connected, FastEthernet0/0
O       172.16.1.16/28 [110/1563] via 192.168.10.5, 00:04:42, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.3.3.3/32 is directly connected, Loopback0
O       10.10.10.0/24 [110/1563] via 192.168.10.9, 00:04:32, Serial0/0/1
O*E2 0.0.0.0/0 [110/1] via 192.168.10.5, 00:01:13, Serial0/0/0   


R1(config)#router ospf 1
R1(config-router)#auto-cost ?
  reference-bandwidth  Use reference bandwidth method to assign OSPF cost
  <cr>

R1(config-router)#auto-cost reference-bandwidth ?
  <1-4294967>  The reference bandwidth in terms of Mbits per second

R1(config-router)#auto-cost reference-bandwidth 10000   // ADJUST THE REFERENCE BANDWIDTH VALUE TO SIMULATE TO 10 GIG SPEED; CONFIGURE ON ALL ROUTERS IN OSPF ROUTING DOMAIN
% OSPF: Reference bandwidth is changed.   
        Please ensure reference bandwidth is consistent across all routers.  


R2(config)#router ospf 1

R2(config-router)#auto-cost reference-bandwidth 10000
% OSPF: Reference bandwidth is changed.
        Please ensure reference bandwidth is consistent across all routers.

R3(config)#router ospf 1
R3(config-router)#auto-cost reference-bandwidth 10000
% OSPF: Reference bandwidth is changed.
        Please ensure reference bandwidth is consistent across all routers.


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 3 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
C       192.168.10.4 is directly connected, Serial0/0/1
O       192.168.10.8 [110/67097] via 192.168.10.6, 00:02:29, Serial0/0/1   
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.1.32/29 [110/65635] via 192.168.10.6, 00:01:27, Serial0/0/1  
C       172.16.1.16/28 is directly connected, FastEthernet0/0
     172.30.0.0/30 is subnetted, 1 subnets
C       172.30.1.0 is directly connected, Loopback1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       10.10.10.0/24 [110/65635] via 192.168.10.2, 00:01:55, Serial0/0/0  
C       10.1.1.1/32 is directly connected, Loopback0
S*   0.0.0.0/0 is directly connected, Loopback1


R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.3.3.3          0   FULL/  -        00:00:31    192.168.10.6    Serial0/0/1  // DEAD TIMER IS 40 SECONDS BY DEFAULT
10.2.2.2          0   FULL/  -        00:00:36    192.168.10.2    Serial0/0/0

R1(config)#interface serial0/0/0
R1(config-if)#ip ospf ?
  <1-65535>            Process ID
  authentication       Enable authentication
  authentication-key   Authentication password (key)
  cost                 Interface cost
  database-filter      Filter OSPF LSA during synchronization and flooding
  dead-interval        Interval after which a neighbor is declared dead
  demand-circuit       OSPF demand circuit
  flood-reduction      OSPF Flood Reduction
  hello-interval       Time between HELLO packets
  lls                  Link-local Signaling (LLS) support
  message-digest-key   Message digest authentication password (key)
  mtu-ignore           Ignores the MTU in DBD packets
  network              Network type
  prefix-suppression   OSPF prefix suppression
  priority             Router priority
  resync-timeout       Interval after which adjacency is reset if oob-resync is
                       not started
  retransmit-interval  Time between retransmitting lost link state
                       advertisements
  transmit-delay       Link state transmit delay

R1(config-if)#ip ospf hello-interval ?
  <1-65535>  Seconds

R1(config-if)#ip ospf hello-interval 5
R1(config-if)#ip ospf dead-interval ?
  <1-65535>  Seconds
  minimal    Set to 1 second

R1(config-if)#ip ospf dead-interval 20
R1(config-if)#
*Jan  9 12:24:16.687: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Dead timer expired    // HELLO AND DEAD TIMER INTERVAL MUST BE IDENTICAL WITH R2 S0/0/0


R2(config)#interface serial0/0/0
R2(config-if)#ip ospf hello-interval 5
R2(config-if)#ip ospf de
*Jan  9 12:16:22.383: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done    // OSPF ADJACENCY FORMED WITH R1
R2(config-if)#ip ospf dead-interval 20

R2#show ip ospf interface serial0/0/0
Serial0/0/0 is up, line protocol is up
  Internet Address 192.168.10.2/30, Area 0
  Process ID 1, Router ID 10.2.2.2, Network Type POINT_TO_POINT, Cost: 65535
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 5, Dead 20, Wait 20, Retransmit 5  
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.1.1.1
  Suppress hello for 0 neighbor(s)


R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.3.3.3          0   FULL/  -        00:00:35    192.168.10.6    Serial0/0/1
10.2.2.2          0   FULL/  -        00:00:17    192.168.10.2    Serial0/0/0    // OSPF ADJACENCY FORMED WITH R2



Scenario B: Configure OSPF on a Multi-access Network


R1(config)#no ip domain-lookup
R1(config)#enable secret cisco
R1(config)#banner motd $
Enter TEXT message.  End with the character '$'
********************************
   AUTHORIZED ACCESS ONLY
********************************
$
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous


R2(config)#no ip domain-lookup
R2(config)#enable secret cisco
R2(config)#banner motd $
Enter TEXT message.  End with the character '$'
********************************
   AUTHORIZED ACCESS ONLY
********************************
$
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#logging synchronous
R2(config-line)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#logging synchronous


R3(config)#no ip domain-lookup
R3(config)#enable secret cisco
R3(config)#banner motd $
Enter TEXT message.  End with the character '$'
********************************
   AUTHORIZED ACCESS ONLY
********************************
$
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#logging synchronous
R3(config-line)#line vty 0 4
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#logging synchronous


R1(config)#interface fastethernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan 10 10:57:08.419: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 10 10:57:09.419: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#interface loopback1
R1(config-if)#
*Jan 10 10:57:17.439: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 192.168.31.11 255.255.255.255


R2(config)#interface fastethernet0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
*Jan 10 10:49:15.895: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 10 10:49:16.895: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed
state to up
R2(config-if)#interface loopback1
R2(config-if)#
*Jan 10 10:49:23.119: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 192.168.31.22 255.255.255.255


R3(config)#interface fastethernet0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Jan 10 10:59:13.107: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 10 10:59:14.107: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed
state to up
R3(config-if)#interface loopback1
R3(config-if)#
*Jan 10 10:59:19.383: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 192.168.31.33 255.255.255.255


R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES manual up                    up 
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/0/0                unassigned      YES unset  administratively down down
Serial0/0/1                unassigned      YES unset  administratively down down
Serial0/1/0                unassigned      YES unset  administratively down down
Serial0/1/1                unassigned      YES unset  administratively down down
Loopback1                  192.168.31.11   YES manual up                    up


R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES manual up                    up 
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/0/0                unassigned      YES unset  administratively down down
Serial0/0/1                unassigned      YES unset  administratively down down
Loopback1                  192.168.31.22   YES manual up                    up


R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.3     YES manual up                    up 
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/0/0                unassigned      YES unset  administratively down down
Serial0/0/1                unassigned      YES unset  administratively down down
Loopback1                  192.168.31.33   YES manual up                    up


R3(config)#router ospf 1
R3(config-router)#network 192.168.1.0 0.0.0.255 area 0
R3(config-router)#end
R3#
*Jan 10 11:03:00.407: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 192.168.31.33, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State WAITING, Priority 1   
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
    Wait time before Designated router selection 00:00:12
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

R3#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 192.168.31.33, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1   // DR AND BDR ELECTION TAKES PLACE AS SSON AS THE FIRST ROUTER HAS AN OSPF INTERFACE ENABLED ON A MULTIACCESS NETWORK; A NEW ROUTER WILL NOT BECOME THE DR OR BDR EVEN IT HAS A HIGHER OSPF INTERFACE PRIORITY OR ROUTER ID THAN THE CURRENT DR OR BDR
  Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)


R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#
*Jan 10 10:59:09.171: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from LOADING to FULL, Loading Done   
R2(config-router)#do show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 192.168.31.22, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1    // R2 BECOMES BDR SINCE IT HAS THE SECOND
HIGHEST IP ADDRESS
  Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
  Backup Designated router (ID) 192.168.31.22, Interface address 192.168.1.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.31.33  (Designated Router)
  Suppress hello for 0 neighbor(s)

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.31.33     1   FULL/DR         00:00:35    192.168.1.3     FastEthernet0/0   // R1 IS DR


R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#
*Jan 10 11:10:36.343: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from LOADING to FULL, Loading Done   
R1(config-router)#
*Jan 10 11:10:37.967: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from LOADING to FULL, Loading Done   
R1(config-router)#do show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
  Process ID 1, Router ID 192.168.31.11, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DROTHER, Priority 1   // R1 IS A DROTHER SINCE IT HAS THE LOWEST ROUTER ID
  Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
  Backup Designated router (ID) 192.168.31.22, Interface address 192.168.1.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 192.168.31.22  (Backup Designated Router)
    Adjacent with neighbor 192.168.31.33  (Designated Router)
  Suppress hello for 0 neighbor(s)

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.31.22     1   FULL/BDR        00:00:37    192.168.1.2     FastEthernet0/0
192.168.31.33     1   FULL/DR         00:00:35    192.168.1.3     FastEthernet0/0


R1(config)#interface fastethernet0/0
R1(config-if)#ip ospf ?
  <1-65535>            Process ID
  authentication       Enable authentication
  authentication-key   Authentication password (key)
  bfd                  Enable BFD on this interface
  cost                 Interface cost
  database-filter      Filter OSPF LSA during synchronization and flooding
  dead-interval        Interval after which a neighbor is declared dead
  demand-circuit       OSPF demand circuit
  flood-reduction      OSPF Flood Reduction
  hello-interval       Time between HELLO packets
  lls                  Link-local Signaling (LLS) support
  message-digest-key   Message digest authentication password (key)
  mtu-ignore           Ignores the MTU in DBD packets
  network              Network type
  prefix-suppression   OSPF prefix suppression
  priority             Router priority
  resync-timeout       Interval after which adjacency is reset if oob-resync is
                       not started
  retransmit-interval  Time between retransmitting lost link state
                       advertisements
  transmit-delay       Link state transmit delay

R1(config-if)#ip ospf priority 255   // USE THE ip ospf priority COMMAND TO MANUALLY DETERMINE THE DR AND BDR


R3(config)#interface fastethernet0/0
R3(config-if)#ip ospf priority 100


R2(config)#interface fastethernet0/0
R2(config-if)#ip ospf priority 0    // OSPF PRIORITY OF 0 MEANS IT WON'T JOIN THE DR AND BDR ELECTION PROCESS


R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R1#
*Jan 10 11:14:59.887: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 10 11:14:59.887: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 10 11:14:59.923: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from LOADING to FULL, Loading Done
*Jan 10 11:14:59.923: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from LOADING to FULL, Loading Done


R2#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R2#
*Jan 10 11:06:06.839: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 10 11:06:06.839: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 10 11:06:06.867: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from LOADING to FULL, Loading Done
*Jan 10 11:06:06.871: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from LOADING to FULL, Loading Done


R3#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
R3#
*Jan 10 11:14:05.127: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 10 11:14:05.127: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jan 10 11:14:05.163: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from LOADING to FULL, Loading Done


R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.31.22     0   FULL/DROTHER    00:00:33    192.168.1.2     FastEthernet0/0   // EVEN THOUGH R2 HAS A HIGHER ROUTER ID THAN R1, IT BECAME DROTHER SINCE PRIORITY IS 0
192.168.31.33   100   FULL/BDR        00:00:35    192.168.1.3     FastEthernet0/0


R3#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 192.168.31.33, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 100  
  Designated Router (ID) 192.168.31.11, Interface address 192.168.1.1
  Backup Designated router (ID) 192.168.31.33, Interface address 192.168.1.3
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 192.168.31.11  (Designated Router)
    Adjacent with neighbor 192.168.31.22
  Suppress hello for 0 neighbor(s)

Thursday, March 3, 2016

Cisco WLC MAC Filtering

There was a client site wherein the design for the "wired" MAC address filtering will be done either on a router or the DHCP server and the wireless MAC address filtering will be done on the WLC. To enable MAC filtering on a Csico WLC 2504, you go to SECURITY > MAC Filtering and click New... on the upper right hand side (below Home icon).

You type the MAC address in a pair of HEX character separated by a colon (ab:cd:ef:12:34:56), choose the Profile Name (which is tied to the SSID) and Interface Name. Click Apply and Save Configuration (on the upper portion beside Ping).