I finally bought my very first own VM server, which is a Dell PowerEdge 1950 server. I tried to search for an HP ProLiant MicroServer but it's a bit pricey and I've already bagged a great online deal on this Dell server instead. This VM server will help me create more complex topologies (which means more virtual routers) without worrying too much about RAM issue. It's has 500GB HDD, 16GB RAM, two 1Gbps RJ45 LAN ports and dual power supply. I still have to see if there's a need to upgrade to its maximum RAM of 32GB.
I've installed Windows 7, VM Workstation 11 and slowly updating my GNS3 components such as Virtual Box for running Windows 10 PC, SecureCRT for console connections and integrating an actual Internet connection.
I did a Basic RIPv1 lab on my previous post. Below is my RIPv2 lab during my Network+ studies.
R1(config)#interface fastethernet0/0
R1(config-if)#ip address 172.30.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 02:43:50.783: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 1 02:43:51.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#interface fastethernet0/1
R1(config-if)#ip address 172.30.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 02:44:12.635: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Jan 1 02:44:13.635: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#
*Jan 1 02:44:19.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#interface serial0/0/0
R1(config-if)#ip address 209.165.200.230 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 02:45:30.043: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#router rip
R1(config-router)#passive-interface fastethernet0/0
R1(config-router)#passive-interface fastethernet0/1
R1(config-router)#network 172.30.0.0
R1(config-router)#network 209.165.200.0
R2(config)#interface fastethernet0/0
R2(config-if)#ip address 10.1.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#
*Jan 1 02:38:04.683: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 1 02:38:05.683: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#interface serial0/0/0
R2(config-if)#ip address 209.165.200.229 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Jan 1 02:38:33.851: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 1 02:38:34.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#interface serial0/0/1
R2(config-if)#ip address 209.165.200.233 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#
*Jan 1 02:39:13.599: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
R2(config-if)#router rip
R2(config-router)#passive-interface fastethernet0/0
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0
R3(config)#interface fastethernet0/0
R3(config-if)#ip address 172.30.100.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Jan 1 02:47:53.151: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 1 02:47:54.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial0/0/1
R3(config-if)#ip address 209.165.200.234 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#
*Jan 1 02:48:14.663: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 1 02:48:15.663: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R3(config-if)#interface loopback0
R3(config-if)#
*Jan 1 02:48:23.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.30.110.1 255.255.255.0
R3(config-if)#interface loopback1
R3(config-if)#
*Jan 1 02:48:42.083: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 172.30.200.17 255.255.255.240
R3(config-if)#interface loopback2
R3(config-if)#
*Jan 1 02:49:04.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R3(config-if)#ip address 172.30.200.33 255.255.255.240
R3(config-if)#router rip
R3(config-router)#passive-interface fastethernet0/0
R3(config-router)#network 172.30.0.0
R3(config-router)#network 209.165.200.0
R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.0.1 YES manual up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial0/0/0 209.165.200.229 YES manual up up
Serial0/0/1 209.165.200.233 YES manual up up
C:\Users\PC1>ipconfig
Windows IP Configuration
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::4562:9b92:c15f:91ff%10
IPv4 Address. . . . . . . . . . . : 172.30.1.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 172.30.1.1
C:\Users\PC1>ping 172.30.2.10 // PING TO PC2
Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time<1ms TTL=255
Ping statistics for 172.30.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
C:\Users\PC1>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
C:\Users\PC1>ping 172.30.100.10 // PING TO PC4
Pinging 172.30.100.10 with 32 bytes of data:
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Ping statistics for 172.30.100.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
C:\Users\PC4>ipconfig
Windows IP Configuration
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::4562:9b92:c15f:91ff%10
IPv4 Address. . . . . . . . . . . : 172.30.100.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 172.30.100.1
C:\Users\PC4>ping 172.30.100.1
Pinging 172.30.100.1 with 32 bytes of data:
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Ping statistics for 172.30.100.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
C:\Users\PC4>ping 172.20.2.10 // PING TO PC2
Pinging 172.20.2.10 with 32 bytes of data:
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Ping statistics for 172.20.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
C:\Users\PC4>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
R2#show ip route // R2 ALTERNATES ROUTING TO CLASSFUL SUBNET 172.30.0.0/16
HOP) ARE THE SAME FROM R1 AND R3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:07, Serial0/0/1 // ROUTE FROM R3
[120/1] via 209.165.200.230, 00:00:12, Serial0/0/0 // ROUTE FROM R1
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, Loopback0
R1#show ip route // RIPv1 WILL SUMMARIZE 172.30.0.0/24 TO 172.30.0.0/16; SINCE R1 DOESN'T HAVE SPECIFIC 172.30.0.0 SUBNETS AND R1 KNOWS THAT 172.30.0.0/16 SUBNET IS DIRECTLY CONNECTED, PACKETS
TO R3 LAN SUBNETS WILL NOT BE FORWARDED
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 2 subnets
C 172.30.2.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:21, Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
R 10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:21, Serial0/0/0
R3#show ip route // R3 ONLY KNOWS ITS OWN 172.30.0.0 SUBNETS; R3 DOESN'T HAVE ANY SPECIFIC 172.30.0.0 SUBNETS ON R1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
C 172.30.100.0/24 is directly connected, FastEthernet0/0
C 172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
R 209.165.200.228 [120/1] via 209.165.200.233, 00:00:17, Serial0/0/1
R 10.0.0.0/8 [120/1] via 209.165.200.233, 00:00:17, Serial0/0/1
R2#debug ip rip // R2 RECEIVES 172.30.0.0 WITH 1 HOP FROM BOTH R1 AND R3; BECAUSE THEY'RE EQUAL COST, BOTH ROUTES ARE ADDED TO R2 ROUTING TABLE
RIP protocol debugging is on
R2#
*Jan 1 03:18:14.911: RIP: received v1 update from 209.165.200.230 on Serial0/0/0 //
*Jan 1 03:18:14.911: 172.30.0.0 in 1 hops
*Jan 1 03:18:17.007: RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:18:17.007: RIP: build update entries
*Jan 1 03:18:17.007: network 10.0.0.0 metric 1
*Jan 1 03:18:17.007: subnet 209.165.200.232 metric 1
*Jan 1 03:18:19.095: RIP: received v1 update from 209.165.200.234 on Serial0/0/1
*Jan 1 03:18:19.095: 172.30.0.0 in 1 hops
*Jan 1 03:18:25.651: RIP: sending v1 update to 255.255.255.255 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:18:25.651: RIP: build update entries
*Jan 1 03:18:25.651: network 10.0.0.0 metric 1
*Jan 1 03:18:25.651: subnet 209.165.200.228 metric 1
*Jan 1 03:18:30.223: RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.0.1)
*Jan 1 03:18:30.223: RIP: build update entries
*Jan 1 03:18:30.223: network 172.30.0.0 metric 2
R1(config)#router rip
R1(config-router)#version ?
<1-2> rip version 1 or 2
R1(config-router)#version 2 // ENABLE RIP VERSION 2; INCLUDE SUBNET MASK IN ROUTING UPDATES; RIPv2 SUMMARIZES NETWORKS AT MAJOR NETWORK BOUNDARIES (LIKE RIPv1) BY DEFAULT
R2(config)#router rip
R2(config-router)#version 2
R3(config)#router rip
R3(config-router)#version 2
R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
Loopback0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.30.0.0
209.165.200.0
Passive Interface(s):
FastEthernet0/0
FastEthernet0/1
Routing Information Sources:
Gateway Distance Last Update
209.165.200.229 120 00:00:16
Distance: (default is 120)
R2#show ip route // R2 STILL SHOWS EQUAL COST ROUTE TO 172.30.0.0/16; IT STILL DOESN'T SHOW SPECIFIC SUBNETS
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:08, Serial0/0/1
[120/1] via 209.165.200.230, 00:00:00, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, Loopback0
R1#show ip route // R1 STILL ONLY SHOWS ITS 172.30.0.0 SUBNET; R1 STILL DOESN'T HAVE SPECIFIC
172.30.0.0 SUBNETS ON R3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 2 subnets
C 172.30.2.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:26, Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
R 10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:26, Serial0/0/0
R3#show ip route // R3 STILL SHOWS IT'S OWN 172.30.0.0 SUBNET; R3 STILL DOESN'T HAVE SPECIFIC 172.30.0.0 SUBNETS ON R1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
C 172.30.100.0/24 is directly connected, FastEthernet0/0
C 172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
R 209.165.200.228 [120/1] via 209.165.200.233, 00:00:18, Serial0/0/1
R 10.0.0.0/8 [120/1] via 209.165.200.233, 00:00:18, Serial0/0/1
R3#debug ip rip
RIP protocol debugging is on
R3#
*Jan 1 03:36:16.587: RIP: sending v2 update to 224.0.0.9 via Loopback2 (172.30.200.33)
*Jan 1 03:36:16.587: RIP: build update entries
*Jan 1 03:36:16.587: 10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:36:16.587: 172.30.100.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: 172.30.110.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: 172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: RIP: ignored v2 packet from 172.30.200.33 (sourced from one of our
addresses)
*Jan 1 03:36:17.043: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.234)
*Jan 1 03:36:17.043: RIP: build update entries
*Jan 1 03:36:17.043: 172.30.0.0/16 via 0.0.0.0, metric 1, tag 0 // R3 SENDING 172.30.0.0/16
SUMMARY ROUTE
*Jan 1 03:36:25.391: RIP: sending v2 update to 224.0.0.9 via Loopback0 (172.30.110.1)
*Jan 1 03:36:25.391: RIP: build update entries
*Jan 1 03:36:25.391: 10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:36:25.391: 172.30.100.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: 172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: 172.30.200.32/28 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: RIP: ignored v2 packet from 172.30.110.1 (sourced from one of our addresses)
*Jan 1 03:36:28.139: RIP: received v2 update from 209.165.200.233 on Serial0/0/1
*Jan 1 03:36:28.139: 10.0.0.0/8 via 0.0.0.0 in 1 hops
*Jan 1 03:36:28.139: 209.165.200.228/30 via 0.0.0.0 in 1 hops
R2#debug ip rip
RIP protocol debugging is on
R2#
*Jan 1 03:30:22.239: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:30:22.239: RIP: build update entries
*Jan 1 03:30:22.239: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:22.239: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:25.843: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan 1 03:30:25.843: RIP: build update entries
*Jan 1 03:30:25.843: 172.30.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:30:25.843: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:25.843: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
*Jan 1 03:30:29.199: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan 1 03:30:29.199: 172.30.0.0/16 via 0.0.0.0 in 1 hops
*Jan 1 03:30:34.523: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:30:34.523: RIP: build update entries
*Jan 1 03:30:34.523: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:34.523: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:47.027: RIP: received v2 update from 209.165.200.234 on Serial0/0/1
*Jan 1 03:30:47.027: 172.30.0.0/16 via 0.0.0.0 in 1 hops
*Jan 1 03:30:48.403: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:30:48.403: RIP: build update entries
*Jan 1 03:30:48.403: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:48.403: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:52.419: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan 1 03:30:52.419: RIP: build update entries
*Jan 1 03:30:52.419: 172.30.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:30:52.419: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:52.419: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
R1(config)#router rip
R1(config-router)#no ?
address-family Enter Address Family command mode
auto-summary Enable automatic network number summarization
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter networks in routing updates
flash-update-threshold Specify flash update threshold in second
input-queue Specify input queue depth
maximum-paths Forward packets over multiple paths
neighbor Specify a neighbor router
network Enable routing on an IP network
offset-list Add or subtract offset from RIP metrics
output-delay Interpacket delay for RIP updates
passive-interface Suppress routing updates on an interface
redistribute Redistribute information from another routing
protocol
timers Adjust routing timers
traffic-share How to compute traffic share over alternate paths
validate-update-source Perform sanity checks against source address of
routing updates
version Set routing protocol version
R1(config-router)#no auto-summary // DISABLE ROUTE SUMMARIZATION AT MAJOR NETWORK BOUNDARIES (USING DEFAULT SUBNET MASK)
R2(config)#router rip
R2(config-router)#no auto-summary
R3(config)#router rip
R3(config-router)#no auto-summary
R2#show ip route // R1 AND R3 SPECIFIC LAN SUBNETS ARE NOW IN THE ROUTING TABLE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 7 subnets, 3 masks
R 172.30.200.32/28 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R 172.30.200.16/28 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R 172.30.2.0/24 [120/1] via 209.165.200.230, 00:00:01, Serial0/0/0
R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:01:12, Serial0/0/1
[120/1] via 209.165.200.230, 00:01:53, Serial0/0/0
R 172.30.1.0/24 [120/1] via 209.165.200.230, 00:00:01, Serial0/0/0
R 172.30.100.0/24 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R 172.30.110.0/24 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, Loopback0
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
R 172.30.200.32/28 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
R 172.30.200.16/28 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
C 172.30.2.0/24 is directly connected, Loopback0
C 172.30.1.0/24 is directly connected, FastEthernet0/0
R 172.30.100.0/24 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
R 172.30.110.0/24 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:20, Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 10.0.0.0/8 is possibly down,
routing via 209.165.200.229, Serial0/0/0
R 10.1.0.0/16 [120/1] via 209.165.200.229, 00:00:22, Serial0/0/0
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
R 172.30.2.0/24 [120/2] via 209.165.200.233, 00:00:03, Serial0/0/1
R 172.30.1.0/24 [120/2] via 209.165.200.233, 00:00:03, Serial0/0/1
C 172.30.100.0/24 is directly connected, FastEthernet0/0
C 172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
R 209.165.200.228 [120/1] via 209.165.200.233, 00:00:03, Serial0/0/1
10.0.0.0/16 is subnetted, 1 subnets
R 10.1.0.0 [120/1] via 209.165.200.233, 00:00:03, Serial0/0/1
R1#debug ip rip // R1 NOW SENDS ITS SPECIFIC SUBNETS IN RIPv2 UPDATE TO R2
RIP protocol debugging is on
R1#
*Jan 1 03:46:53.503: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.230)
*Jan 1 03:46:53.503: RIP: build update entries
*Jan 1 03:46:53.503: 172.30.1.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:46:53.503: 172.30.2.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:47:04.571: RIP: sending v2 update to 224.0.0.9 via Loopback0 (172.30.2.10)
*Jan 1 03:47:04.571: RIP: build update entries
*Jan 1 03:47:04.571: 10.1.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:47:04.571: 172.30.1.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:47:04.571: 172.30.100.0/24 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 172.30.110.0/24 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 172.30.200.16/28 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 172.30.200.32/28 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:47:04.571: 209.165.200.232/30 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:47:04.571: RIP: ignored v2 packet from 172.30.2.10 (sourced from one of our addresses)
*Jan 1 03:47:06.679: RIP: received v2 update from 209.165.200.229 on Serial0/0/0
*Jan 1 03:47:06.679: 10.1.0.0/16 via 0.0.0.0 in 1 hops
*Jan 1 03:47:06.679: 172.30.100.0/24 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 172.30.110.0/24 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 172.30.200.16/28 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 172.30.200.32/28 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 209.165.200.232/30 via 0.0.0.0 in 1 hops
R2#debug ip rip // R2 RECEIVES SPECIFIC SUBNETS IN R1
RIP protocol debugging is on
R2#
*Jan 1 03:39:22.219: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:39:22.219: RIP: build update entries
*Jan 1 03:39:22.219: 10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:22.219: 172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:22.219: 172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:22.219: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:23.083: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan 1 03:39:23.083: 172.30.1.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:23.083: 172.30.2.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: RIP: received v2 update from 209.165.200.234 on Serial0/0/1
*Jan 1 03:39:31.155: 172.30.100.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: 172.30.110.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: 172.30.200.16/28 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: 172.30.200.32/28 via 0.0.0.0 in 1 hops
*Jan 1 03:39:36.431: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:39:36.431: RIP: build update entries
*Jan 1 03:39:36.431: 10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:36.431: 172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:50.311: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan 1 03:39:50.311: RIP: build update entries
*Jan 1 03:39:50.311: 172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:50.311: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:50.311: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
*Jan 1 03:39:51.127: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:39:51.127: RIP: build update entries
*Jan 1 03:39:51.127: 10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:51.127: 172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:51.127: 172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:51.127: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:51.367: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan 1 03:39:51.367: 172.30.1.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:51.367: 172.30.2.0/24 via 0.0.0.0 in 1 hops
R2#ping 172.30.100.10 // PING TO PC4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
R2#ping 172.30.1.10 // PING TO PC1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
C:\Users\PC1>ping 172.30.2.10 // PING TO PC2
Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Ping statistics for 172.30.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
C:\Users\PC1>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 18ms, Maximum = 18ms, Average = 18ms
C:\Users\PC1>ping 172.30.100.10 // PING TO PC4
Pinging 172.30.100.10 with 32 bytes of data:
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Ping statistics for 172.30.100.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 36ms, Average = 36ms
C:\Users\PC4>ping 172.30.2.10 // PING TO PC2
Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Ping statistics for 172.30.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 36ms, Average = 36ms
C:\Users\PC4>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 18ms, Maximum = 18ms, Average = 18ms
I've installed Windows 7, VM Workstation 11 and slowly updating my GNS3 components such as Virtual Box for running Windows 10 PC, SecureCRT for console connections and integrating an actual Internet connection.
I did a Basic RIPv1 lab on my previous post. Below is my RIPv2 lab during my Network+ studies.
R1(config-if)#ip address 172.30.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 02:43:50.783: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 1 02:43:51.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#interface fastethernet0/1
R1(config-if)#ip address 172.30.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 02:44:12.635: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Jan 1 02:44:13.635: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#
*Jan 1 02:44:19.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#interface serial0/0/0
R1(config-if)#ip address 209.165.200.230 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 02:45:30.043: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#router rip
R1(config-router)#passive-interface fastethernet0/0
R1(config-router)#passive-interface fastethernet0/1
R1(config-router)#network 172.30.0.0
R1(config-router)#network 209.165.200.0
R2(config)#interface fastethernet0/0
R2(config-if)#ip address 10.1.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#
*Jan 1 02:38:04.683: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 1 02:38:05.683: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#interface serial0/0/0
R2(config-if)#ip address 209.165.200.229 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Jan 1 02:38:33.851: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 1 02:38:34.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#interface serial0/0/1
R2(config-if)#ip address 209.165.200.233 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#
*Jan 1 02:39:13.599: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
R2(config-if)#router rip
R2(config-router)#passive-interface fastethernet0/0
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0
R3(config)#interface fastethernet0/0
R3(config-if)#ip address 172.30.100.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Jan 1 02:47:53.151: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 1 02:47:54.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial0/0/1
R3(config-if)#ip address 209.165.200.234 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#
*Jan 1 02:48:14.663: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 1 02:48:15.663: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R3(config-if)#interface loopback0
R3(config-if)#
*Jan 1 02:48:23.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.30.110.1 255.255.255.0
R3(config-if)#interface loopback1
R3(config-if)#
*Jan 1 02:48:42.083: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 172.30.200.17 255.255.255.240
R3(config-if)#interface loopback2
R3(config-if)#
*Jan 1 02:49:04.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R3(config-if)#ip address 172.30.200.33 255.255.255.240
R3(config-if)#router rip
R3(config-router)#passive-interface fastethernet0/0
R3(config-router)#network 172.30.0.0
R3(config-router)#network 209.165.200.0
R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.0.1 YES manual up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial0/0/0 209.165.200.229 YES manual up up
Serial0/0/1 209.165.200.233 YES manual up up
C:\Users\PC1>ipconfig
Windows IP Configuration
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::4562:9b92:c15f:91ff%10
IPv4 Address. . . . . . . . . . . : 172.30.1.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 172.30.1.1
C:\Users\PC1>ping 172.30.2.10 // PING TO PC2
Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time<1ms TTL=255
Ping statistics for 172.30.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
C:\Users\PC1>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
C:\Users\PC1>ping 172.30.100.10 // PING TO PC4
Pinging 172.30.100.10 with 32 bytes of data:
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Ping statistics for 172.30.100.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
C:\Users\PC4>ipconfig
Windows IP Configuration
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::4562:9b92:c15f:91ff%10
IPv4 Address. . . . . . . . . . . : 172.30.100.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 172.30.100.1
C:\Users\PC4>ping 172.30.100.1
Pinging 172.30.100.1 with 32 bytes of data:
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Ping statistics for 172.30.100.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
C:\Users\PC4>ping 172.20.2.10 // PING TO PC2
Pinging 172.20.2.10 with 32 bytes of data:
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Ping statistics for 172.20.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
C:\Users\PC4>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
R2#show ip route // R2 ALTERNATES ROUTING TO CLASSFUL SUBNET 172.30.0.0/16
HOP) ARE THE SAME FROM R1 AND R3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:07, Serial0/0/1 // ROUTE FROM R3
[120/1] via 209.165.200.230, 00:00:12, Serial0/0/0 // ROUTE FROM R1
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, Loopback0
R1#show ip route // RIPv1 WILL SUMMARIZE 172.30.0.0/24 TO 172.30.0.0/16; SINCE R1 DOESN'T HAVE SPECIFIC 172.30.0.0 SUBNETS AND R1 KNOWS THAT 172.30.0.0/16 SUBNET IS DIRECTLY CONNECTED, PACKETS
TO R3 LAN SUBNETS WILL NOT BE FORWARDED
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 2 subnets
C 172.30.2.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:21, Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
R 10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:21, Serial0/0/0
R3#show ip route // R3 ONLY KNOWS ITS OWN 172.30.0.0 SUBNETS; R3 DOESN'T HAVE ANY SPECIFIC 172.30.0.0 SUBNETS ON R1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
C 172.30.100.0/24 is directly connected, FastEthernet0/0
C 172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
R 209.165.200.228 [120/1] via 209.165.200.233, 00:00:17, Serial0/0/1
R 10.0.0.0/8 [120/1] via 209.165.200.233, 00:00:17, Serial0/0/1
R2#debug ip rip // R2 RECEIVES 172.30.0.0 WITH 1 HOP FROM BOTH R1 AND R3; BECAUSE THEY'RE EQUAL COST, BOTH ROUTES ARE ADDED TO R2 ROUTING TABLE
RIP protocol debugging is on
R2#
*Jan 1 03:18:14.911: RIP: received v1 update from 209.165.200.230 on Serial0/0/0 //
*Jan 1 03:18:14.911: 172.30.0.0 in 1 hops
*Jan 1 03:18:17.007: RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:18:17.007: RIP: build update entries
*Jan 1 03:18:17.007: network 10.0.0.0 metric 1
*Jan 1 03:18:17.007: subnet 209.165.200.232 metric 1
*Jan 1 03:18:19.095: RIP: received v1 update from 209.165.200.234 on Serial0/0/1
*Jan 1 03:18:19.095: 172.30.0.0 in 1 hops
*Jan 1 03:18:25.651: RIP: sending v1 update to 255.255.255.255 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:18:25.651: RIP: build update entries
*Jan 1 03:18:25.651: network 10.0.0.0 metric 1
*Jan 1 03:18:25.651: subnet 209.165.200.228 metric 1
*Jan 1 03:18:30.223: RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.0.1)
*Jan 1 03:18:30.223: RIP: build update entries
*Jan 1 03:18:30.223: network 172.30.0.0 metric 2
R1(config)#router rip
R1(config-router)#version ?
<1-2> rip version 1 or 2
R1(config-router)#version 2 // ENABLE RIP VERSION 2; INCLUDE SUBNET MASK IN ROUTING UPDATES; RIPv2 SUMMARIZES NETWORKS AT MAJOR NETWORK BOUNDARIES (LIKE RIPv1) BY DEFAULT
R2(config)#router rip
R2(config-router)#version 2
R3(config)#router rip
R3(config-router)#version 2
R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
Loopback0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.30.0.0
209.165.200.0
Passive Interface(s):
FastEthernet0/0
FastEthernet0/1
Routing Information Sources:
Gateway Distance Last Update
209.165.200.229 120 00:00:16
Distance: (default is 120)
R2#show ip route // R2 STILL SHOWS EQUAL COST ROUTE TO 172.30.0.0/16; IT STILL DOESN'T SHOW SPECIFIC SUBNETS
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:08, Serial0/0/1
[120/1] via 209.165.200.230, 00:00:00, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, Loopback0
R1#show ip route // R1 STILL ONLY SHOWS ITS 172.30.0.0 SUBNET; R1 STILL DOESN'T HAVE SPECIFIC
172.30.0.0 SUBNETS ON R3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 2 subnets
C 172.30.2.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:26, Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
R 10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:26, Serial0/0/0
R3#show ip route // R3 STILL SHOWS IT'S OWN 172.30.0.0 SUBNET; R3 STILL DOESN'T HAVE SPECIFIC 172.30.0.0 SUBNETS ON R1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
C 172.30.100.0/24 is directly connected, FastEthernet0/0
C 172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
R 209.165.200.228 [120/1] via 209.165.200.233, 00:00:18, Serial0/0/1
R 10.0.0.0/8 [120/1] via 209.165.200.233, 00:00:18, Serial0/0/1
R3#debug ip rip
RIP protocol debugging is on
R3#
*Jan 1 03:36:16.587: RIP: sending v2 update to 224.0.0.9 via Loopback2 (172.30.200.33)
*Jan 1 03:36:16.587: RIP: build update entries
*Jan 1 03:36:16.587: 10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:36:16.587: 172.30.100.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: 172.30.110.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: 172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:16.587: RIP: ignored v2 packet from 172.30.200.33 (sourced from one of our
addresses)
*Jan 1 03:36:17.043: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.234)
*Jan 1 03:36:17.043: RIP: build update entries
*Jan 1 03:36:17.043: 172.30.0.0/16 via 0.0.0.0, metric 1, tag 0 // R3 SENDING 172.30.0.0/16
SUMMARY ROUTE
*Jan 1 03:36:25.391: RIP: sending v2 update to 224.0.0.9 via Loopback0 (172.30.110.1)
*Jan 1 03:36:25.391: RIP: build update entries
*Jan 1 03:36:25.391: 10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:36:25.391: 172.30.100.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: 172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: 172.30.200.32/28 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:36:25.391: RIP: ignored v2 packet from 172.30.110.1 (sourced from one of our addresses)
*Jan 1 03:36:28.139: RIP: received v2 update from 209.165.200.233 on Serial0/0/1
*Jan 1 03:36:28.139: 10.0.0.0/8 via 0.0.0.0 in 1 hops
*Jan 1 03:36:28.139: 209.165.200.228/30 via 0.0.0.0 in 1 hops
R2#debug ip rip
RIP protocol debugging is on
R2#
*Jan 1 03:30:22.239: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:30:22.239: RIP: build update entries
*Jan 1 03:30:22.239: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:22.239: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:25.843: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan 1 03:30:25.843: RIP: build update entries
*Jan 1 03:30:25.843: 172.30.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:30:25.843: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:25.843: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
*Jan 1 03:30:29.199: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan 1 03:30:29.199: 172.30.0.0/16 via 0.0.0.0 in 1 hops
*Jan 1 03:30:34.523: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:30:34.523: RIP: build update entries
*Jan 1 03:30:34.523: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:34.523: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:47.027: RIP: received v2 update from 209.165.200.234 on Serial0/0/1
*Jan 1 03:30:47.027: 172.30.0.0/16 via 0.0.0.0 in 1 hops
*Jan 1 03:30:48.403: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:30:48.403: RIP: build update entries
*Jan 1 03:30:48.403: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:48.403: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:52.419: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan 1 03:30:52.419: RIP: build update entries
*Jan 1 03:30:52.419: 172.30.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:30:52.419: 209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:30:52.419: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
R1(config)#router rip
R1(config-router)#no ?
address-family Enter Address Family command mode
auto-summary Enable automatic network number summarization
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter networks in routing updates
flash-update-threshold Specify flash update threshold in second
input-queue Specify input queue depth
maximum-paths Forward packets over multiple paths
neighbor Specify a neighbor router
network Enable routing on an IP network
offset-list Add or subtract offset from RIP metrics
output-delay Interpacket delay for RIP updates
passive-interface Suppress routing updates on an interface
redistribute Redistribute information from another routing
protocol
timers Adjust routing timers
traffic-share How to compute traffic share over alternate paths
validate-update-source Perform sanity checks against source address of
routing updates
version Set routing protocol version
R1(config-router)#no auto-summary // DISABLE ROUTE SUMMARIZATION AT MAJOR NETWORK BOUNDARIES (USING DEFAULT SUBNET MASK)
R2(config)#router rip
R2(config-router)#no auto-summary
R3(config)#router rip
R3(config-router)#no auto-summary
R2#show ip route // R1 AND R3 SPECIFIC LAN SUBNETS ARE NOW IN THE ROUTING TABLE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 7 subnets, 3 masks
R 172.30.200.32/28 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R 172.30.200.16/28 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R 172.30.2.0/24 [120/1] via 209.165.200.230, 00:00:01, Serial0/0/0
R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:01:12, Serial0/0/1
[120/1] via 209.165.200.230, 00:01:53, Serial0/0/0
R 172.30.1.0/24 [120/1] via 209.165.200.230, 00:00:01, Serial0/0/0
R 172.30.100.0/24 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R 172.30.110.0/24 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, Loopback0
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
R 172.30.200.32/28 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
R 172.30.200.16/28 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
C 172.30.2.0/24 is directly connected, Loopback0
C 172.30.1.0/24 is directly connected, FastEthernet0/0
R 172.30.100.0/24 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
R 172.30.110.0/24 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:20, Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 10.0.0.0/8 is possibly down,
routing via 209.165.200.229, Serial0/0/0
R 10.1.0.0/16 [120/1] via 209.165.200.229, 00:00:22, Serial0/0/0
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
R 172.30.2.0/24 [120/2] via 209.165.200.233, 00:00:03, Serial0/0/1
R 172.30.1.0/24 [120/2] via 209.165.200.233, 00:00:03, Serial0/0/1
C 172.30.100.0/24 is directly connected, FastEthernet0/0
C 172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
R 209.165.200.228 [120/1] via 209.165.200.233, 00:00:03, Serial0/0/1
10.0.0.0/16 is subnetted, 1 subnets
R 10.1.0.0 [120/1] via 209.165.200.233, 00:00:03, Serial0/0/1
R1#debug ip rip // R1 NOW SENDS ITS SPECIFIC SUBNETS IN RIPv2 UPDATE TO R2
RIP protocol debugging is on
R1#
*Jan 1 03:46:53.503: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.230)
*Jan 1 03:46:53.503: RIP: build update entries
*Jan 1 03:46:53.503: 172.30.1.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:46:53.503: 172.30.2.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:47:04.571: RIP: sending v2 update to 224.0.0.9 via Loopback0 (172.30.2.10)
*Jan 1 03:47:04.571: RIP: build update entries
*Jan 1 03:47:04.571: 10.1.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:47:04.571: 172.30.1.0/24 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:47:04.571: 172.30.100.0/24 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 172.30.110.0/24 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 172.30.200.16/28 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 172.30.200.32/28 via 0.0.0.0, metric 3, tag 0
*Jan 1 03:47:04.571: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:47:04.571: 209.165.200.232/30 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:47:04.571: RIP: ignored v2 packet from 172.30.2.10 (sourced from one of our addresses)
*Jan 1 03:47:06.679: RIP: received v2 update from 209.165.200.229 on Serial0/0/0
*Jan 1 03:47:06.679: 10.1.0.0/16 via 0.0.0.0 in 1 hops
*Jan 1 03:47:06.679: 172.30.100.0/24 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 172.30.110.0/24 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 172.30.200.16/28 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 172.30.200.32/28 via 0.0.0.0 in 2 hops
*Jan 1 03:47:06.679: 209.165.200.232/30 via 0.0.0.0 in 1 hops
R2#debug ip rip // R2 RECEIVES SPECIFIC SUBNETS IN R1
RIP protocol debugging is on
R2#
*Jan 1 03:39:22.219: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:39:22.219: RIP: build update entries
*Jan 1 03:39:22.219: 10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:22.219: 172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:22.219: 172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:22.219: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:23.083: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan 1 03:39:23.083: 172.30.1.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:23.083: 172.30.2.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: RIP: received v2 update from 209.165.200.234 on Serial0/0/1
*Jan 1 03:39:31.155: 172.30.100.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: 172.30.110.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: 172.30.200.16/28 via 0.0.0.0 in 1 hops
*Jan 1 03:39:31.155: 172.30.200.32/28 via 0.0.0.0 in 1 hops
*Jan 1 03:39:36.431: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan 1 03:39:36.431: RIP: build update entries
*Jan 1 03:39:36.431: 10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:36.431: 172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:36.431: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:50.311: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan 1 03:39:50.311: RIP: build update entries
*Jan 1 03:39:50.311: 172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:50.311: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:50.311: 209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:50.311: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
*Jan 1 03:39:51.127: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan 1 03:39:51.127: RIP: build update entries
*Jan 1 03:39:51.127: 10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:51.127: 172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:51.127: 172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan 1 03:39:51.127: 209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan 1 03:39:51.367: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan 1 03:39:51.367: 172.30.1.0/24 via 0.0.0.0 in 1 hops
*Jan 1 03:39:51.367: 172.30.2.0/24 via 0.0.0.0 in 1 hops
R2#ping 172.30.100.10 // PING TO PC4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
R2#ping 172.30.1.10 // PING TO PC1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
C:\Users\PC1>ping 172.30.2.10 // PING TO PC2
Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Ping statistics for 172.30.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms
C:\Users\PC1>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 18ms, Maximum = 18ms, Average = 18ms
C:\Users\PC1>ping 172.30.100.10 // PING TO PC4
Pinging 172.30.100.10 with 32 bytes of data:
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Ping statistics for 172.30.100.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 36ms, Average = 36ms
C:\Users\PC4>ping 172.30.2.10 // PING TO PC2
Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Ping statistics for 172.30.2.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 36ms, Average = 36ms
C:\Users\PC4>ping 10.1.0.10 // PING TO PC3
Pinging 10.1.0.10 with 32 bytes of data:
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Ping statistics for 10.1.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 18ms, Maximum = 18ms, Average = 18ms
No comments:
Post a Comment