Friday, September 14, 2018

Port Application Mapping (PAM) on a Cisco Router

The Cisco IOS router has a built-in feature called Port Application Mapping (PAM). This feature is commonly used in Context-Based Access Control (CBAC) or Zone-Based Policy Firewall (ZBF). You can use the show ip port-map command on a Cisco router to do a quick lookup of its built-in well-known TCP or UDP port numbers instead of going to the IANA website. You can use pipe (|) to narrow down a specific port. This is useful when creating access control list (ACL) on a router.

R1#show ip ?
  access-lists            List IP access lists
  accounting              The active IP accounting database
  address                 show ip address commands
  admission               Network Admission Control information
  aliases                 IP alias table
  arp                     IP ARP table
  as-path-access-list     List AS path access lists
  auth-proxy              Authentication Proxy information
  bgp                     BGP information
  cache                   IP fast-switching route cache
  cef                     Cisco Express Forwarding
  community-list          List community-list
  ddns                    Dynamic DNS
  dfp                     DFP information
  dhcp                    Show items in the DHCP database
  dns                     Show DNS information
  dns-cache               Show addresses in DNS cache
  drp                     Director response protocol
  eigrp                   Show IPv4 EIGRP
  explicit-paths          Show IP explicit paths
  extcommunity-list       List extended-community list
  flow                    NetFlow switching
  helper-address          helper-address table
  host-list               Host list
  http                    HTTP information
  icmp                    ICMP information
  igmp                    IGMP information
  inspect                 CBAC (Context Based Access Control) information
  interface               IP interface status and configuration
  ips                     IPS (Intrusion Prevention System) information
  irdp                    ICMP Router Discovery Protocol
  lisp                    Locator/ID Separation Protocol
  local                   IP local options
  masks                   Masks associated with a network
  mfib                    IP multicast forwarding information base
  mobile                  IP Mobility information
  mrib                    Multicast Routing Information Base
  mrm                     IP Multicast Routing Monitor information
  mroute                  IP multicast routing table
  msdp                    Multicast Source Discovery Protocol (MSDP)
  multicast               Multicast global information
  nat                     IP NAT information
  nbar                    Network-Based Application Recognition
  nhrp                    NHRP information
  ospf                    OSPF information
  pgm                     PGM Reliable Transport Protocol
  pim                     PIM information
  policy                  Policy routing
  policy-list             List IP Policy list
  port-map                Port to Application Mapping (PAM) information
  prefix-list             List IP prefix lists
  protocols               IP routing protocol process parameters and statistics
  redirects               IP redirects
  rib                     Routing Information Base
  rip                     IP RIP show commands
  route                   IP routing table
  rpf                     Display RPF information for multicast source
  rsvp                    RSVP show commands
  rtp                     RTP/UDP/IP header-compression statistics
  sap                     Session Announcement Protocol cache
  sdee                    SDEE (Security Device Event Exchange) information
  sla                     Service Level Agreement (SLA)
  slb                     SLB information
  snat                    IP NAT SNAT information
  ssh                     Information on SSH
  static                  Static operation
  tcp                     TCP/IP header-compression statistics
  traffic                 IP protocol statistics
  traffic-export          Show ip traffic-export statistics
  trigger-authentication  Trigger-authentication host table
  urlfilter               IOS URL Filtering Information
  virtual-reassembly      IP Virtual Fragment Reassembly (VFR) information
  vrf                     VPN Routing/Forwarding instance information
  wccp                    WCCP IPv4 information

R1#show ip port-map
Default mapping:  snmp                 udp port 161                        system defined
Default mapping:  echo                 tcp port 7                          system defined
Default mapping:  echo                 udp port 7                          system defined
Default mapping:  telnet               tcp port 23                         system defined
Default mapping:  wins                 tcp port 1512                       system defined
Default mapping:  n2h2server           tcp port 9285                       system defined
Default mapping:  n2h2server           udp port 9285                       system defined
Default mapping:  nntp                 tcp port 119                        system defined
Default mapping:  pptp                 tcp port 1723                       system defined
Default mapping:  rtsp                 tcp port 554,8554                   system defined
Default mapping:  bootpc               udp port 68                         system defined
Default mapping:  gdoi                 udp port 848                        system defined
Default mapping:  h323-nxg             udp port 2099                       system defined
Default mapping:  h323-nxg             tcp port 2099                       system defined
Default mapping:  tacacs               udp port 49                         system defined
Default mapping:  gopher               tcp port 70                         system defined
Default mapping:  icabrowser           udp port 1604                       system defined
Default mapping:  skinny               tcp port 2000                       system defined
Default mapping:  sunrpc               tcp port 111                        system defined
Default mapping:  sunrpc               udp port 111                        system defined
Default mapping:  biff                 udp port 512                        system defined
Default mapping:  router               udp port 520                        system defined
Default mapping:  entrust-svc-hdlr     tcp port 709,710                    system defined
Default mapping:  entrust-svc-hdlr     udp port 709,710                    system defined
Default mapping:  ircs                 tcp port 994                        system defined
Default mapping:  orasrv               tcp port 1525...1529                system defined
Default mapping:  ms-cluster-net       udp port 3343                       system defined
Default mapping:  kermit               tcp port 1649                       system defined
Default mapping:  isakmp               udp port 500                        system defined
Default mapping:  sshell               tcp port 614                        system defined
Default mapping:  sshell               udp port 614                        system defined
Default mapping:  realsecure           tcp port 2998                       system defined
Default mapping:  ircu                 tcp port 6665,6666                  system defined
Default mapping:  ircu                 udp port 6665,6666                  system defined
Default mapping:  appleqtc             udp port 458                        system defined
Default mapping:  pwdgen               tcp port 129                        system defined
Default mapping:  pwdgen               udp port 129                        system defined
Default mapping:  rdb-dbs-disp         tcp port 1571                       system defined
Default mapping:  rdb-dbs-disp         udp port 1571                       system defined
Default mapping:  creativepartnr       udp port 455                        system defined
Default mapping:  creativepartnr       tcp port 455                        system defined
Default mapping:  finger               tcp port 79                         system defined
Default mapping:  ftps                 tcp port 990                        system defined
Default mapping:  giop                 udp port 2481,2482                  system defined
Default mapping:  giop                 tcp port 2481,2482                  system defined
Default mapping:  rsvd                 tcp port 168                        system defined
Default mapping:  rsvd                 udp port 168                        system defined
Default mapping:  hp-alarm-mgr         udp port 383                        system defined
Default mapping:  hp-alarm-mgr         tcp port 383                        system defined
Default mapping:  uucp                 tcp port 540,541                    system defined
Default mapping:  uucp                 udp port 540,541                    system defined
Default mapping:  kerberos             tcp port 88,464,749                 system defined
Default mapping:  kerberos             udp port 464,750                    system defined
Default mapping:  imap                 tcp port 143                        system defined
Default mapping:  time                 udp port 37                         system defined
Default mapping:  bootps               udp port 67                         system defined
Default mapping:  tftp                 udp port 69                         system defined
Default mapping:  oracle               udp port 2005                       system defined
Default mapping:  snmptrap             udp port 162                        system defined
Default mapping:  http                 tcp port 80                         system defined
Default mapping:  qmtp                 tcp port 209                        system defined
Default mapping:  qmtp                 udp port 209                        system defined
Default mapping:  radius               udp port 1812,1813                  system defined
Default mapping:  oracle-em-vp         tcp port 1748...1809                system defined
Default mapping:  oracle-em-vp         udp port 1748,1754                  system defined
Default mapping:  tarantella           tcp port 3144                       system defined
Default mapping:  pcanywheredata       tcp port 5631                       system defined
Default mapping:  ldap                 tcp port 389                        system defined
Default mapping:  mgcp                 udp port 2427                       system defined
Default mapping:  sqlsrv               tcp port 156                        system defined
Default mapping:  hsrp                 udp port 1985                       system defined
Default mapping:  cisco-net-mgmt       tcp port 1741,1993                  system defined
Default mapping:  cisco-net-mgmt       udp port 1993                       system defined
Default mapping:  smtp                 tcp port 25                         system defined
Default mapping:  pcanywherestat       udp port 5632                       system defined
Default mapping:  exec                 tcp port 512                        system defined
Default mapping:  send                 tcp port 169                        system defined
Default mapping:  send                 udp port 169                        system defined
Default mapping:  stun                 udp port 1990...1994                system defined
Default mapping:  stun                 tcp port 1990...1994                system defined
Default mapping:  syslog               udp port 514                        system defined
Default mapping:  ms-sql-m             udp port 1434                       system defined
Default mapping:  citrix               udp port 2512...2897                system defined
Default mapping:  citrix               tcp port 2512...2897                system defined
Default mapping:  creativeserver       udp port 453                        system defined
Default mapping:  creativeserver       tcp port 453                        system defined
Default mapping:  cifs                 udp port 3020                       system defined
Default mapping:  cifs                 tcp port 3020                       system defined
Default mapping:  cisco-sys            tcp port 132                        system defined
Default mapping:  cisco-sys            udp port 132                        system defined
Default mapping:  cisco-tna            tcp port 131                        system defined
Default mapping:  cisco-tna            udp port 131                        system defined
Default mapping:  ms-dotnetster        udp port 3126                       system defined
Default mapping:  ms-dotnetster        tcp port 3126                       system defined
Default mapping:  gtpv1                tcp port 2123                       system defined
Default mapping:  gtpv1                udp port 2123                       system defined
Default mapping:  gtpv0                tcp port 3386                       system defined
Default mapping:  gtpv0                udp port 3386                       system defined
Default mapping:  imap3                tcp port 220                        system defined
Default mapping:  fcip-port            tcp port 3225                       system defined
Default mapping:  netbios-dgm          udp port 138                        system defined
Default mapping:  netbios-ssn          tcp port 139                        system defined
Default mapping:  sip-tls              tcp port 5061                       system defined
Default mapping:  sip-tls              udp port 5061                       system defined
Default mapping:  pop3s                tcp port 995                        system defined
Default mapping:  cisco-fna            tcp port 130                        system defined
Default mapping:  cisco-fna            udp port 130                        system defined
Default mapping:  802-11-iapp          udp port 3517                       system defined
Default mapping:  802-11-iapp          tcp port 3517                       system defined
Default mapping:  oem-agent            udp port 3872                       system defined
Default mapping:  oem-agent            tcp port 3872                       system defined
Default mapping:  cisco-tdp            tcp port 711                        system defined
Default mapping:  cisco-tdp            udp port 711                        system defined
Default mapping:  tr-rsrb              udp port 1987...1996                system defined
Default mapping:  tr-rsrb              tcp port 1987...1996                system defined
Default mapping:  r-winsock            udp port 1745                       system defined
Default mapping:  sql-net              tcp port 1521,150                   system defined
Default mapping:  syslog-conn          tcp port 601                        system defined
Default mapping:  tacacs-ds            tcp port 65                         system defined
Default mapping:  h225ras              udp port 1719                       system defined
Default mapping:  ace-svr              udp port 2475,2476                  system defined
Default mapping:  ace-svr              tcp port 2475,2476                  system defined
Default mapping:  dhcp-failover        tcp port 647                        system defined
Default mapping:  igmpv3lite           udp port 465                        system defined
Default mapping:  irc-serv             udp port 529                        system defined
Default mapping:  entrust-svcs         tcp port 640,680,681                system defined
Default mapping:  entrust-svcs         udp port 640,680,681                system defined
Default mapping:  dbcontrol_agent      udp port 3938                       system defined
Default mapping:  dbcontrol_agent      tcp port 3938                       system defined
Default mapping:  cisco-svcs           tcp port 1986...1999                system defined
Default mapping:  cisco-svcs           udp port 1986...1997                system defined
Default mapping:  ipsec-msft           udp port 4500                       system defined
Default mapping:  microsoft-ds         udp port 445                        system defined
Default mapping:  ms-sna               tcp port 1477,1478                  system defined
Default mapping:  rsvp_tunnel          udp port 363                        system defined
Default mapping:  rsvp-encap           tcp port 1698,1699                  system defined
Default mapping:  rsvp-encap           udp port 1698,1699                  system defined
Default mapping:  hp-collector         udp port 381                        system defined
Default mapping:  hp-collector         tcp port 381                        system defined
Default mapping:  netbios-ns           udp port 137                        system defined
Default mapping:  msexch-routing       tcp port 691                        system defined
Default mapping:  h323                 tcp port 1720                       system defined
Default mapping:  l2tp                 udp port 1701                       system defined
Default mapping:  ldap-admin           udp port 3407                       system defined
Default mapping:  ldap-admin           tcp port 3407                       system defined
Default mapping:  pop3                 tcp port 110                        system defined
Default mapping:  ms-sql               tcp port 1433                       system defined
Default mapping:  iscsi-target         tcp port 3260                       system defined
Default mapping:  webster              tcp port 765                        system defined
Default mapping:  lotusnote            tcp port 1352                       system defined
Default mapping:  ipx                  udp port 213                        system defined
Default mapping:  citriximaclient      tcp port 2598                       system defined
Default mapping:  rtc-pm-port          udp port 3891                       system defined
Default mapping:  rtc-pm-port          tcp port 3891                       system defined
Default mapping:  ftp                  tcp port 21                         system defined
Default mapping:  aol                  tcp port 5190-5192                  system defined
Default mapping:  aol                  udp port 5190-5192                  system defined
Default mapping:  xdmcp                udp port 177                        system defined
Default mapping:  oraclenames          udp port 1575                       system defined
Default mapping:  oraclenames          tcp port 1575                       system defined
Default mapping:  login                tcp port 513                        system defined
Default mapping:  iscsi                tcp port 860                        system defined
Default mapping:  ttc                  udp port 2483,2484                  system defined
Default mapping:  ttc                  tcp port 2483,2484                  system defined
Default mapping:  imaps                tcp port 993                        system defined
Default mapping:  socks                tcp port 1080                       system defined
Default mapping:  ssh                  tcp port 22                         system defined
Default mapping:  ssh                  udp port 22                         system defined
Default mapping:  dnsix                tcp port 90                         system defined
Default mapping:  daytime              tcp port 13                         system defined
Default mapping:  daytime              udp port 13                         system defined
Default mapping:  sip                  udp port 5060                       system defined
Default mapping:  sip                  tcp port 5060                       system defined
Default mapping:  discard              tcp port 9                          system defined
Default mapping:  discard              udp port 9                          system defined
Default mapping:  ntp                  udp port 123                        system defined
Default mapping:  ldaps                tcp port 636                        system defined
Default mapping:  ldaps                udp port 636                        system defined
Default mapping:  https                tcp port 443                        system defined
Default mapping:  vdolive              tcp port 7000                       system defined
Default mapping:  msrpc-smb-netbio     tcp port 445                        system defined
Default mapping:  ica                  tcp port 1494                       system defined
Default mapping:  net8-cman            udp port 1630,1830                  system defined
Default mapping:  net8-cman            tcp port 1630,1830                  system defined
Default mapping:  cuseeme              tcp port 7648                       system defined
Default mapping:  netstat              tcp port 15                         system defined
Default mapping:  netstat              udp port 15                         system defined
Default mapping:  sms                  udp port 2701...2703                system defined
Default mapping:  sms                  tcp port 2701...2703                system defined
Default mapping:  h323-annexe          udp port 2517                       system defined
Default mapping:  h323-annexe          tcp port 2517                       system defined
Default mapping:  streamworks          udp port 1558                       system defined
Default mapping:  rtelnet              tcp port 107                        system defined
Default mapping:  who                  udp port 513                        system defined
Default mapping:  ssp                  udp port 3249                       system defined
Default mapping:  ssp                  tcp port 3249                       system defined
Default mapping:  dbase                tcp port 217                        system defined
Default mapping:  dbase                udp port 217                        system defined
Default mapping:  timed                udp port 525                        system defined
Default mapping:  cddbp                tcp port 888                        system defined
Default mapping:  telnets              tcp port 992                        system defined
Default mapping:  ymsgr                tcp port 5050                       system defined
Default mapping:  ident                tcp port 113                        system defined
Default mapping:  bgp                  tcp port 179                        system defined
Default mapping:  h225rasMcast         udp port 1718                       system defined
Default mapping:  ddns-v3              udp port 2164                       system defined
Default mapping:  ddns-v3              tcp port 2164                       system defined
Default mapping:  vqp                  tcp port 1589                       system defined
Default mapping:  vqp                  udp port 1589                       system defined
Default mapping:  irc                  tcp port 194                        system defined
Default mapping:  ipass                udp port 2549                       system defined
Default mapping:  ipass                tcp port 2549                       system defined
Default mapping:  x11                  tcp port 6000-6606                  system defined
Default mapping:  dns                  udp port 53                         system defined
Default mapping:  dns                  tcp port 53                         system defined
Default mapping:  lotusmtap            udp port 3007                       system defined
Default mapping:  lotusmtap            tcp port 3007                       system defined
Default mapping:  mysql                udp port 3306                       system defined
Default mapping:  mysql                tcp port 3306                       system defined
Default mapping:  nfs                  tcp port 2049                       system defined
Default mapping:  nfs                  udp port 2049                       system defined
Default mapping:  msnmsgr              tcp port 1863                       system defined
Default mapping:  sxp                  tcp port 64999                      system defined
Default mapping:  netshow              tcp port 1755                       system defined
Default mapping:  sqlserv              tcp port 118                        system defined
Default mapping:  sqlserv              udp port 118                        system defined
Default mapping:  hp-managed-node      udp port 382                        system defined
Default mapping:  hp-managed-node      tcp port 382                        system defined
Default mapping:  ncp                  tcp port 524                        system defined
Default mapping:  ncp                  udp port 524                        system defined
Default mapping:  shell                tcp port 514                        system defined
Default mapping:  realmedia            tcp port 7070                       system defined
Default mapping:  msrpc                tcp port 135                        system defined
Default mapping:  clp                  udp port 2567                       system defined
Default mapping:  clp                  tcp port 2567                       system defined

R1#show ip port-map | include http
Default mapping:  http                 tcp port 80                         system defined
Default mapping:  https                tcp port 443                        system defined

Friday, September 7, 2018

Configuring EIGRP for IPv6

EIGRP for IPv6 follows the same basic configuration style as for RIPng. The specific EIGRP for IPv6 configuration steps are as follows:

Step 1. Enable IPv6 routing with the ipv6 unicast-routing global command.

Step 2. Enable EIGRP using the ipv6 router eigrp <1 – 65535> global configuration command.

Step 3. Enable IPv6 on the interface, typically with one of these two methods:
* Configure an IPv6 unicast address on each interface, using the ipv6 address address/prefix-length [ eui-64 ] interface command.

* Configure the ipv6 enable command, which enables IPv6 and causes the router to derive its link-local address.

Step 4. Enable EIGRP on the interface with the ipv6 eigrp <ASN> interface subcommand (where the ASN matches the ipv6 router eigrp <ASN> global configuration command).

Step 5. Enable EIGRP for IPv6 with a no shutdown command while in EIGRP configuration mode, if EIGRP is currently disabled.

Step 6. If no EIGRP router ID has been automatically chosen, because of not having at least one working interface with an IPv4 address, configure an EIGRP router ID with the router-id rid command in EIGRP configuration mode.


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 0
R1(config-if)#
*Jun 25 10:01:28.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ipv6 address 2001:db8:cafe:1::1/64
R1(config-if)#
R1(config-if)#interface serial 2/0
R1(config-if)#ipv6 address 2001:db8:cafe:2::1/64
R1(config-if)#no shut
R1(config-if)#
*Jun 25 10:02:11.523: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R1(config-if)#
*Jun 25 10:02:12.535: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R1(config-if)#end
R1#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface loop 0
R2(config-if)#
*Jun 25 10:02:04.719: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ipv6 address 2001:db8:cafe:3::1/64
R2(config-if)#
R2(config-if)#interface serial 2/0
R2(config-if)#ipv6 address 2001:db8:cafe:2::2/64
R2(config-if)#no shut
R2(config-if)#
*Jun 25 10:02:45.631: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R2(config-if)#
*Jun 25 10:02:46.643: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#do ping 2001:db8:cafe:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:CAFE:2::1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 28/31/36 ms
R2(config-if)#
R2(config-if)#interface serial 2/1
R2(config-if)#ipv6 address 2001:db8:cafe:4::1/64
R2(config-if)#no shut
R2(config-if)#
*Jun 25 10:03:31.039: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R2(config-if)#
*Jun 25 10:03:32.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R2(config-if)#end
R2#

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface loop 0
R3(config-if)#
*Jun 25 10:03:05.243: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ipv6 address 2001:db8:cafe:5::1/64
R3(config-if)#
R3(config-if)#interface loop 1                 
R3(config-if)#
*Jun 25 10:03:36.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ipv6 address 2001:db8:abcd:1::1/64
R3(config-if)#
R3(config-if)#interface loop 2                 
R3(config-if)#
*Jun 25 10:04:01.839: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R3(config-if)#ipv6 address 2001:db8:abcd:2::1/64
R3(config-if)#
R3(config-if)#interface loop 3                 
R3(config-if)#
*Jun 25 10:04:14.275: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
R3(config-if)#ipv6 address 2001:db8:abcd:3::1/64
R3(config-if)#
R3(config-if)#interface loop 4                 
R3(config-if)#
*Jun 25 10:04:32.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback4, changed state to up
R3(config-if)#ipv6 address 2001:db8:abcd:4::1/64
R3(config-if)#
R3(config-if)#interface loop 5                 
R3(config-if)#
*Jun 25 10:04:43.279: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback5, changed state to up
R3(config-if)#ipv6 address 2001:db8:abcd:5::1/64
R3(config-if)#
R3(config-if)#interface serial 2/1
R3(config-if)#ipv6 address 2001:db8:cafe:4::2/64
R3(config-if)#no shut
R3(config-if)#
*Jun 25 10:05:17.031: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R3(config-if)#
*Jun 25 10:05:18.043: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R3(config-if)#do ping 2001:db8:cafe:4::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:CAFE:4::1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/35/40 ms
R3(config-if)#
R3(config-if)#interface serial 2/2
R3(config-if)#ipv6 address 2001:db8:feed:77::2/64
R3(config-if)#no shut
R3(config-if)#
*Jun 25 10:06:14.235: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R3(config-if)#
*Jun 25 10:06:15.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to up
R3(config-if)#end
R3#


R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#interface serial 2/2
R4(config-if)#ipv6 address 2001:db8:feed:77::1/64
R4(config-if)#no shut
R4(config-if)#
*Jun 25 10:05:22.023: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R4(config-if)#
*Jun 25 10:05:23.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to up
R4(config-if)#do ping 2001:db8:feed:77::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:FEED:77::2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 28/31/32 ms
R4(config-if)#end
R4(config)#ipv6 route 2001:db8:cafe::/48 2001:db8:feed:77::2
R4(config)#ipv6 route 2001:db8:abcd::/48 2001:db8:feed:77::2
R4(config)#end
R4#
*Jun 25 10:07:11.007: %SYS-5-CONFIG_I: Configured from console by console
R4#
R4#ping 2001:db8:abcd:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/17/24 ms


R1#show ipv6 interface brief
FastEthernet0/0        [administratively down/down]
    unassigned
FastEthernet1/0        [administratively down/down]
    unassigned
FastEthernet1/1        [administratively down/down]
    unassigned
Serial2/0              [up/up]
    FE80::C801:15FF:FEB0:0
    2001:DB8:CAFE:2::1
Serial2/1              [administratively down/down]
    unassigned
Serial2/2              [administratively down/down]
    unassigned
Serial2/3              [administratively down/down]
    unassigned
Loopback0              [up/up]
    FE80::C801:15FF:FEB0:0
    2001:DB8:CAFE:1::1


R2#show ipv6 interface brief
FastEthernet0/0        [administratively down/down]
    unassigned
FastEthernet1/0        [administratively down/down]
    unassigned
FastEthernet1/1        [administratively down/down]
    unassigned
Serial2/0              [up/up]
    FE80::C802:16FF:FECC:0
    2001:DB8:CAFE:2::2
Serial2/1              [up/up]
    FE80::C802:16FF:FECC:0
    2001:DB8:CAFE:4::1
Serial2/2              [administratively down/down]
    unassigned
Serial2/3              [administratively down/down]
    unassigned
Loopback0              [up/up]
    FE80::C802:16FF:FECC:0
    2001:DB8:CAFE:3::1


R3#show ipv6 interface brief
FastEthernet0/0        [administratively down/down]
    unassigned
FastEthernet1/0        [administratively down/down]
    unassigned
FastEthernet1/1        [administratively down/down]
    unassigned
Serial2/0              [administratively down/down]
    unassigned
Serial2/1              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:CAFE:4::2
Serial2/2              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:FEED:77::2
Serial2/3              [administratively down/down]
    unassigned
Loopback0              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:CAFE:5::1
Loopback1              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:ABCD:1::1
Loopback2              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:ABCD:2::1
Loopback3              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:ABCD:3::1
Loopback4              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:ABCD:4::1
Loopback5              [up/up]
    FE80::C803:1BFF:FE10:0
    2001:DB8:ABCD:5::1


R4#show ipv6 interface brief
FastEthernet0/0        [administratively down/down]
    unassigned
FastEthernet1/0        [administratively down/down]
    unassigned
FastEthernet1/1        [administratively down/down]
    unassigned
Serial2/0              [administratively down/down]
    unassigned
Serial2/1              [administratively down/down]
    unassigned
Serial2/2              [up/up]
    FE80::C804:10FF:FE70:0
    2001:DB8:FEED:77::1
Serial2/3              [administratively down/down]
    unassigned


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 router ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  ospf   Open Shortest Path First (OSPF)
  rip    IPv6 Routing Information Protocol (RIPv6)

R1(config)#ipv6 router eigrp ?
  <1-65535>  Autonomous system number

R1(config)#ipv6 router eigrp 1
R1(config-rtr)#?
  default            Set a command to its defaults
  default-metric     Set metric of redistributed routes
  distance           Define an administrative distance
  distribute-list    Filter networks in routing updates
  eigrp              EIGRP specific commands
  exit               Exit from IPv6 routing protocol configuration mode
  maximum-paths      Forward packets over multiple paths
  metric             Modify metrics and parameters for advertisement
  neighbor           Specify a neighbor router
  no                 Negate a command or set its defaults
  passive-interface  Suppress routing updates on an interface
  redistribute       Redistribute IPv6 prefixes from another routing protocol
  shutdown           Shutdown topology
  summary-metric     Specify summary to apply metric/filtering
  timers             Adjust topology specific timers
  variance           Control load balancing variance

R1(config-rtr)#eigrp ?
  event-log-size         Set EIGRP maximum event log entries
  log-neighbor-changes   Enable/Disable EIGRP neighbor logging
  log-neighbor-warnings  Enable/Disable EIGRP neighbor warnings
  router-id              router id for this EIGRP process
  stub                   Set address-family in stubbed mode

R1(config-rtr)#eigrp router-id ?
  A.B.C.D  EIGRP Router-ID in IP address format

R1(config-rtr)#eigrp router-id 1.1.1.1     // EIGRP FOR IPV6 REQUIRES A 32-BIT IPv4 ADDRESS ROUTER-ID
R1(config-rtr)#no shutdown     // EIGRP PROCESS IS SHUTDOWN BY DEFAULT PRIOR TO IOS 15.2


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv6 unicast-routing
R2(config)#ipv6 router eigrp 1
R2(config-rtr)#eigrp router-id 2.2.2.2
R2(config-rtr)#no shutdown


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 router eigrp 1
R3(config-rtr)#eigrp router-id 3.3.3.3
R3(config-rtr)#do show run | sec eigrp
ipv6 router eigrp 1
 eigrp router-id 3.3.3.3
R3(config-rtr)#do show version     // NO NEED FOR no shutdown COMMAND SINCE USING IOS 15.2
Cisco IOS Software, 7200 Software (C7200-ADVIPSERVICESK9-M), Version 15.2(4)M11, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Sun 16-Oct-16 07:53 by prod_rel_team

ROM: ROMMON Emulation Microcode
BOOTLDR: 7200 Software (C7200-ADVIPSERVICESK9-M), Version 15.2(4)M11, RELEASE SOFTWARE (fc2)

R3 uptime is 15 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
System image file is "tftp://255.255.255.255/unknown"
Last reload reason: unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 7206VXR (NPE400) processor (revision A) with 491520K/32768K bytes of memory.
Processor board ID 4279256517
R7000 CPU at 150MHz, Implementation 39, Rev 2.1, 256KB L2 Cache
6 slot VXR midplane, Version 2.1

Last reset from power-on

PCI bus mb0_mb1 (Slots 0, 1, 3 and 5) has a capacity of 600 bandwidth points.
Current configuration on bus mb0_mb1 has a total of 600 bandwidth points.
This configuration is within the PCI bus capacity and is supported.

PCI bus mb2 (Slots 2, 4, 6) has a capacity of 600 bandwidth points.
Current configuration on bus mb2 has a total of 0 bandwidth points
This configuration is within the PCI bus capacity and is supported.

Please refer to the following document "Cisco 7200 Series Port Adaptor
Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
for c7200 bandwidth points oversubscription and usage guidelines.


3 FastEthernet interfaces
4 Serial interfaces
509K bytes of NVRAM.

8192K bytes of Flash internal SIMM (Sector size 256K).


Configuration register is 0x2102


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 0
R1(config-if)#ipv6 eigrp ?
  <1-65535>  AS number

R1(config-if)#ipv6 eigrp 1     // EIGRP FOR IPv6 DOES NOT USE network COMMAND
R1(config-if)#
R1(config-if)#interface serial 2/0
R1(config-if)#ipv6 eigrp 1   
R1(config-if)#
*Jun 25 10:20:59.355: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::C802:16FF:FECC:0 (Serial2/0) is up: new adjacency


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface loop 0
R2(config-if)#ipv6 eigrp 1
R2(config-if)#
R2(config-if)#interface serial 2/0
R2(config-if)#ipv6 eigrp 1       
R2(config-if)#
*Jun 25 10:19:09.091: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::C801:15FF:FEB0:0 (Serial2/0) is up: new adjacency    
R2(config-if)#
R2(config-if)#interface serial 2/1
R2(config-if)#ipv6 eigrp 1  
R2(config-if)#  
*Jun 25 10:21:00.799: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::C803:1BFF:FE10:0 (Serial2/1) is up: new adjacency


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface loop 0
R3(config-if)#ipv6 eigrp 1
R3(config-if)#
R3(config-if)#interface serial 2/1
R3(config-if)#ipv6 eigrp 1       
R3(config-if)#
*Jun 25 10:20:10.355: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::C802:16FF:FECC:0 (Serial2/1) is up: new adjacency
R3(config-if)#
R3(config-if)#interface loop 1   
R3(config-if)#ipv6 eigrp 1   
R3(config-if)#
R3(config-if)#interface loop 2
R3(config-if)#ipv6 eigrp 1   
R3(config-if)#
R3(config-if)#interface loop 3
R3(config-if)#ipv6 eigrp 1   
R3(config-if)#
R3(config-if)#interface loop 4
R3(config-if)#ipv6 eigrp 1   
R3(config-if)#
R3(config-if)#interface loop 5
R3(config-if)#ipv6 eigrp 1


R2#show ipv6 eigrp ?
  <1-65535>       Autonomous System
  events          Events logged
  interfaces      interfaces
  neighbors       Neighbors
  sia-statistics  SIA Statistics
  timers          Timers
  topology        Select Topology
  traffic         Traffic Statistics

R2#show ipv6 eigrp neighbors    // USES IPv6 LINK-LOCAL ADDRESS TO FORM EIGRP NEIGHBOR ADJACENCY
EIGRP-IPv6 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   Link-local address:     Se2/1                    11 00:03:17   31   186  0  8
    FE80::C803:1BFF:FE10:0
0   Link-local address:     Se2/0                    14 00:05:08   26   156  0  10
    FE80::C801:15FF:FEB0:0



R1#show ipv6 route eigrp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, ND - ND Default
       NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
       OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, l - LISP
D   2001:DB8:ABCD:1::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:2::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:3::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:4::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:5::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:3::/64 [90/2297856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:4::/64 [90/2681856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:5::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
R1#
R1#ping 2001:db8:cafe:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:CAFE:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/26/36 ms
R1#
R1#ping 2001:db8:abcd:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/32 ms


R1#show ipv6 eigrp topology
EIGRP-IPv6 Topology Table for AS(1)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 2001:DB8:CAFE:5::/64, 1 successors, FD is 2809856
        via FE80::C802:16FF:FECC:0 (2809856/2297856), Serial2/0
P 2001:DB8:ABCD:1::/64, 1 successors, FD is 2809856
        via FE80::C802:16FF:FECC:0 (2809856/2297856), Serial2/0
P 2001:DB8:ABCD:2::/64, 1 successors, FD is 2809856
        via FE80::C802:16FF:FECC:0 (2809856/2297856), Serial2/0
P 2001:DB8:CAFE:3::/64, 1 successors, FD is 2297856
        via FE80::C802:16FF:FECC:0 (2297856/128256), Serial2/0
P 2001:DB8:CAFE:4::/64, 1 successors, FD is 2681856
        via FE80::C802:16FF:FECC:0 (2681856/2169856), Serial2/0
P 2001:DB8:CAFE:2::/64, 1 successors, FD is 2169856
        via Connected, Serial2/0
P 2001:DB8:ABCD:3::/64, 1 successors, FD is 2809856
        via FE80::C802:16FF:FECC:0 (2809856/2297856), Serial2/0
P 2001:DB8:ABCD:5::/64, 1 successors, FD is 2809856
        via FE80::C802:16FF:FECC:0 (2809856/2297856), Serial2/0
P 2001:DB8:ABCD:4::/64, 1 successors, FD is 2809856
        via FE80::C802:16FF:FECC:0 (2809856/2297856), Serial2/0
P 2001:DB8:CAFE:1::/64, 1 successors, FD is 128256
        via Connected, Loopback0


R1#show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 1"
EIGRP-IPv6 Protocol for AS(1)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  NSF-aware route hold timer is 240
  Router-ID: 1.1.1.1
  Topology : 0 (base)
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1

  Interfaces:
    Loopback0
    Serial2/0
  Redistribution:
    None


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv6 router eigrp 1
R1(config-rtr)#passive-interface loop 0


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ipv6 router eigrp 1
R2(config-rtr)#passive-interface loop 0


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv6 router eigrp 1
R3(config-rtr)#passive-interface loop 0


R1#show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 1"
EIGRP-IPv6 Protocol for AS(1)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  NSF-aware route hold timer is 240
  Router-ID: 1.1.1.1
  Topology : 0 (base)
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1

  Interfaces:
    Serial2/0
    Loopback0 (passive)
  Redistribution:
    None


R3#show ipv6 route eigrp
IPv6 Routing Table - default - 20 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, ND - ND Default
       NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
       OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, l - LISP
D   2001:DB8:CAFE:1::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/1
D   2001:DB8:CAFE:2::/64 [90/2681856]
     via FE80::C802:16FF:FECC:0, Serial2/1
D   2001:DB8:CAFE:3::/64 [90/2297856]
     via FE80::C802:16FF:FECC:0, Serial2/1
R3#
R3#ping 2001:db8:cafe:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:CAFE:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/36/48 ms


R1#show ipv6 route eigrp
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, ND - ND Default
       NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
       OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, l - LISP
D   2001:DB8:ABCD:1::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:2::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:3::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:4::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD:5::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:3::/64 [90/2297856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:4::/64 [90/2681856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:5::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface serial 2/1
R3(config-if)#ipv6 summary-address ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)

R3(config-if)#ipv6 summary-address eigrp ?
  <1-65535>  AS number

R3(config-if)#ipv6 summary-address eigrp 1 ?
  X:X:X:X::X/<0-128>  IPv6 prefix

R3(config-if)#ipv6 summary-address eigrp 1 2001:db8:abcd::/61
R3(config-if)#
*Jun 25 10:33:17.443: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::C802:16FF:FECC:0 (Serial2/1) is resync: summary configured      // CONFIGURING AN EIGRP SUMMARY ROUTE RESYNC NEIGHBOR ADJACENCY


R1#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, ND - ND Default
       NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
       OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, l - LISP
D   2001:DB8:ABCD::/61 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:3::/64 [90/2297856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:4::/64 [90/2681856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:5::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0


R1#ping 2001:db8:abcd:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/33/48 ms
R1#
R1#ping 2001:db8:abcd:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/27/36 ms
R1#
R1#ping 2001:db8:abcd:3::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:3::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/22/32 ms
R1#                      
R1#ping 2001:db8:abcd:4::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/31/48 ms
R1#
R1#ping 2001:db8:abcd:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ABCD:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/24 ms


R3#show ipv6 protocols     // EIGRP COMMAND TO VERIFY ROUTE SUMMARIZATION
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 1"
EIGRP-IPv6 Protocol for AS(1)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  NSF-aware route hold timer is 240
  Router-ID: 3.3.3.3
  Topology : 0 (base)
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1

  Interfaces:
    Serial2/1
    Loopback1
    Loopback2
    Loopback3
    Loopback4
    Loopback5
    Loopback0 (passive)
  Redistribution:
    None
  Address Summarization:
    2001:DB8:ABCD::/61 for Se2/1
      Summarizing 5 components with metric 128256


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv6 route ::/0 2001:db8:feed:77::1
R3(config)#ipv6 router eigrp 1
R3(config-rtr)#redistribute ?
  bgp        Border Gateway Protocol (BGP)
  connected  Connected Routes
  eigrp      Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis       ISO IS-IS
  mobile     Mobile
  nemo       Network Mobility (NEMO)
  ospf       Open Shortest Path First (OSPF)
  rip        IPv6 Routing Information Protocol (RIPv6)
  static     Static Routes

R3(config-rtr)#redistribute static


R1#show ipv6 route eigrp    // REDISTRIBUTED EIGRP ROUTE SHOWS EX CODE FOR EXTERNAL WITH AD OF 170
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, ND - ND Default
       NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
       OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, l - LISP
EX  ::/0 [170/2681856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:ABCD::/61 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:3::/64 [90/2297856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:4::/64 [90/2681856]
     via FE80::C802:16FF:FECC:0, Serial2/0
D   2001:DB8:CAFE:5::/64 [90/2809856]
     via FE80::C802:16FF:FECC:0, Serial2/0



R1#ping 2001:db8:feed:77::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:FEED:77::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/26/32 ms

R1#traceroute 2001:db8:feed:77::1
Type escape sequence to abort.
Tracing the route to 2001:DB8:FEED:77::1

  1 2001:DB8:CAFE:2::2 16 msec 12 msec 16 msec
  2 2001:DB8:CAFE:4::2 12 msec 16 msec 16 msec
  3 2001:DB8:FEED:77::1 16 msec 28 msec 28 msec


R1#show run | i cef    // IPv6 CEF IS AUTOMATICALLY ENABLED WHEN ISSUING ipv6 unicast-routing COMMAND
ip cef 
ipv6 cef
R1#
R1#show ipv6 cef ?
  Async               Async interface
  Auto-Template       Auto-Template interface
  BVI                 Bridge-Group Virtual Interface
  CDMA-Ix             CDMA Ix interface
  CTunnel             CTunnel interface
  Dialer              Dialer interface
  FastEthernet        FastEthernet IEEE 802.3
  GMPLS               MPLS interface
  Group-Async         Async Group interface
  LISP                Locator/ID Separation Protocol Virtual Interface
  LongReachEthernet   Long-Reach Ethernet interface
  Loopback            Loopback interface
  MFR                 Multilink Frame Relay bundle interface
  Multilink           Multilink-group interface
  Null                Null interface
  Port-channel        Ethernet Channel of interfaces
  Serial              Serial
  Tunnel              Tunnel interface
  Vif                 PGM Multicast Host interface
  Virtual-PPP         Virtual PPP interface
  Virtual-Template    Virtual Template interface
  Virtual-TokenRing   Virtual TokenRing
  X:X:X:X::X          address of entry to show
  X:X:X:X::X/<0-128>  prefix of entries to show
  adjacency           Display all prefixes resolving through adjacency
  checksum            Display FIB entry checksums
  detail              Display full information
  epoch               CEF table epoch summary
  events              Show CEF table events
  exact-route         Display exact route for a session
  internal            Display internal data structures
  neighbor            neighbor
  non-recursive       Display non-recursive routes only
  platform            Display platform specific data structures
  prefix-statistics   Display non-zero prefix statistics
  summary             CEF table summary
  switching           Show IPv6 CEF switching information
  traffic             Display traffic statistics
  tree                Display forwarding database state
  unresolved          Display unresolved routes only
  vmi                 Virtual Multipoint Interface
  vrf                 Apply to particular VRF
  with                Filter on prefix properties
  |                   Output modifiers
  <cr>
         
R1#show ipv6 cef summary
IPv6 CEF is enabled and running centrally.
VRF Default
 12 prefixes (12/0 fwd/non-fwd)
 Table id 0x1E000000
 Database epoch:        0 (12 entries at this epoch)