Saturday, January 30, 2016

Basic EIGRP Configuration Lab (and Check Point UserCenter Portal)

I started to join the Check Point User Group (CPUG) forum, which is an open community and non-profit group. Check Point also has their official forum community on their website. So I signed up on Check Point UserCenter portal in order to get the latest news, track certifications and avail tech support. Having these two will help me jumpstart in learning Check Point network security products and technologies.






I'm also going to create a separate blog for my Check Point Certified Security Administrator (CCSA) track. I've already started studying and building my CCSA lab and will soon share my notes and experience with it. Below is the EIGRP lab which I did while studying for my Network+ certification.


R1(config)#no ip domain-lookup
R1(config)#enable secret cisco
R1(config)#banner motd &
Enter TEXT message.  End with the character '&'
********************************
   AUTHORIZED ACCESS ONLY
********************************
&
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous


R2(config)#no ip domain-lookup
R2(config)#enable secret cisco
R2(config)#banner motd &
Enter TEXT message.  End with the character '&'
********************************
   AUTHORIZED ACCESS ONLY
********************************
&
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#logging synchronous
R2(config-line)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#logging synchronous


R3(config)#no ip domain-lookup
R3(config)#enable secret cisco
R3(config)#banner motd &
Enter TEXT message.  End with the character '&'
********************************
   AUTHORIZED ACCESS ONLY
********************************
&
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#logging synchronous
R3(config-line)#line vty 0 4
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#logging synchronous


R1(config)#interface fastethernet0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan  3 12:22:58.807: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  3 12:22:59.807: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#
R1(config-if)#interface serial0/0/0
R1(config-if)#ip address 172.16.3.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#
*Jan  3 12:23:34.007: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#
R1(config-if)#interface serial0/0/1
R1(config-if)#ip address 192.168.10.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#
*Jan  3 12:24:00.435: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down


R2(config)#interface fastethernet0/0
R2(config-if)#ip address 172.16.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
*Jan  3 12:17:35.099: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  3 12:17:36.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#
R2(config-if)#interface serial0/0/0
R2(config-if)#ip address 172.16.3.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Jan  3 12:17:59.887: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan  3 12:18:00.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#
R2(config-if)#interface serial0/0/1
R2(config-if)#ip address 192.168.10.9 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#
*Jan  3 12:18:27.527: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
R2(config-if)#
R2(config-if)#interface loopback1
R2(config-if)#
*Jan  3 12:18:45.003: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#
R2(config-if)#ip address 10.1.1.1 255.255.255.252


R3(config)#interface fastethernet0/0
R3(config-if)#ip address 192.168.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Jan  3 12:27:18.551: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  3 12:27:19.551: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#
R3(config-if)#interface serial0/0/0
R3(config-if)#ip address 192.168.10.6 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no shutdown
R3(config-if)#
*Jan  3 12:29:31.859: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan  3 12:29:32.859: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R3(config-if)#
R3(config-if)#interface serial0/0/1
R3(config-if)#ip address 192.168.10.10 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#
*Jan  3 12:29:54.923: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan  3 12:29:55.923: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.1      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                172.16.3.1      YES manual up                    up 
Serial0/0/1                192.168.10.5    YES manual up                    up 
Serial0/1/0                unassigned      YES NVRAM  administratively down down
Serial0/1/1                unassigned      YES NVRAM  administratively down down


R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.2.1      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                172.16.3.2      YES manual up                    up 
Serial0/0/1                192.168.10.9    YES manual up                    up 
Loopback1                  10.1.1.1        YES manual up                    up


R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                192.168.10.6    YES manual up                    up 
Serial0/0/1                192.168.10.10   YES manual up                    up


R1(config)#router eigrp ?
  <1-65535>  Autonomous system number

R1(config)#router eigrp 1
R1(config-router)#?
Router configuration commands:
  address-family       Enter Address Family command mode
  auto-summary         Enable automatic network number summarization
  bfd                  BFD configuration commands
  default              Set a command to its defaults
  default-information  Control distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Define an administrative distance
  distribute-list      Filter networks in routing updates
  eigrp                EIGRP specific commands
  exit                 Exit from routing protocol configuration mode
  help                 Description of the interactive help system
  maximum-paths        Forward packets over multiple paths
  metric               Modify EIGRP routing metrics and parameters
  neighbor             Specify a neighbor router
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  offset-list          Add or subtract offset from RIP metrics
  passive-interface    Suppress routing updates on an interface
  redistribute         Redistribute information from another routing protocol
  timers               Adjust routing timers
  traffic-share        How to compute traffic share over alternate paths
  variance             Control load balancing variance

R1(config-router)#network 172.16.0.0   // CLASSFUL NETWORK IF NO WILD CARD MASK; EIGRP UPDATES WILL BE SENT OUT ON FE0/0 AND S0/0/0 INTERFACES

R1(config-router)#network 192.168.10.4 ?
  A.B.C.D  EIGRP wild card bits
  <cr>

R1(config-router)#network 192.168.10.4 0.0.0.3    // ADVERTISE 192.168.10.4/30 NETWORK OUT S0/0/1 INTERFACE


R2(config)#router eigrp 1
R2(config-router)#network 172.16.0.0
R2(config-router)#
*Jan  3 13:10:52.959: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.3.1 (Serial0/0/0) is up: new adjacency    // R2 FORMED EIGRP NEIGHBOR ADJACENCY WITH R1 VIA S0/0/0 INTERFACE

R2(config-router)#network 192.168.10.8 0.0.0.3


R3(config)#router eigrp 1
R3(config-router)#network 192.168.1.0
R3(config-router)#network 192.168.10.4 0.0.0.3
R3(config-router)#
*Jan  3 13:23:27.675: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.5 (Serial0/0/0) is up: new adjacency   // R3 FORMED EIGRP NEIGHBOR ADJACENCY WITH R1 VIA S0/0/0 INTERFACE
R3(config-router)#network 192.168.10.8 0.0.0.3
R3(config-router)#
*Jan  3 13:24:12.911: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.9 (Serial0/0/1) is up: new adjacency    // R3 FORMED EIGRP NEIGHBOR ADJACENCY WITH R2 VIA S0/0/1 INTERFACE


R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.10.6            Se0/0/1           14 00:02:06   21   200  0  10   
0   172.16.3.2              Se0/0/0           12 00:07:15   20   200  0  12   


R1#show ip protocols
Routing Protocol is "eigrp 1"    // AS NUMBER MUST BE THE SAME ON ALL ROUTERS IN ORDER TO ESTABLISH NEIGHBOR ADJACENCIES AND SHARE ROUTING INFO
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1   
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Automatic address summarization:
    192.168.10.0/24 for FastEthernet0/0, Serial0/0/0
      Summarizing with metric 2169856
    172.16.0.0/16 for Serial0/0/1
      Summarizing with metric 28160
  Maximum path: 4
  Routing for Networks:
    172.16.0.0   
    192.168.10.4/30   
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:05:07
    Gateway         Distance      Last Update
    192.168.10.6          90      00:03:24   
    172.16.3.2            90      00:03:24   
  Distance: internal 90 external 170


R1#show ip route    // EIGRP ROUTES ARE DENOTED WITH D FOR DUAL (DIFFUSING UPDATE ALGORITHM), WHICH IS THE ROUTING ALGORITHM USED BY EIGRP
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.10.0/24 is a summary, 00:06:50, Null0    //   EIGRP SUMMARY ROUTE
C       192.168.10.4/30 is directly connected, Serial0/0/1
D       192.168.10.8/30 [90/2681856] via 192.168.10.6, 00:05:09, Serial0/0/1   
     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks   // PARENT/LEVEL 1 ROUTE
D       172.16.0.0/16 is a summary, 00:13:15, Null0    // EIGRP AUTO CREATES A SUMMARY ROUTE POINTING TO NULL0; IF A PACKET DESTINED FOR 172.16.0.0/16 IS SENT TO NULL0 INTERFACE IF IT DOESN'T MATCH ANY OF THE CHILD/LEVEL 2 ROUTE
C       172.16.1.0/24 is directly connected, FastEthernet0/0   // CHILD/LEVEL 2 ROUTE
D       172.16.2.0/24 [90/2172416] via 172.16.3.2, 00:11:03, Serial0/0/0    //  CHILD/LEVEL 2 ROUTE
C       172.16.3.0/30 is directly connected, Serial0/0/0    // CHILD/LEVEL 2 ROUTE
D    192.168.1.0/24 [90/2172416] via 192.168.10.6, 00:05:07, Serial0/0/1    //


R3#show ip route   // R3 IS GETTING 172.16.0.0/16 SUMMARIZED ROUTE FROM BOTH R1 AND R2; IT'S INCLUDED IN THE ROUTING TABLE SINCE THE TWO ARE EQUAL COST ROUTES (2172416)
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.10.0/24 is a summary, 00:14:46, Null0
C       192.168.10.4/30 is directly connected, Serial0/0/0
C       192.168.10.8/30 is directly connected, Serial0/0/1
D    172.16.0.0/16 [90/2172416] via 192.168.10.9, 00:13:59, Serial0/0/1  
                   [90/2172416] via 192.168.10.5, 00:13:59, Serial0/0/0   
C    192.168.1.0/24 is directly connected, FastEthernet0/0


R1#show interface serial0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.3.1/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,    // EIGRP METRIC: BANDWIDTH, DELAY, RELIABILITY AND LOAD (MTU NOT INCLUDED)
     reliability 255/255, txload 1/255, rxload 1/255   //
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:03, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     843 packets input, 56982 bytes, 0 no buffer
     Received 534 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     896 packets output, 59524 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R1(config)#interface serial0/0/0
R1(config-if)#bandwidth ?
  <1-10000000>  Bandwidth in kilobits
  inherit       Specify that bandwidth is inherited
  receive       Specify receive-side bandwidth

R1(config-if)#bandwidth 64    // SERIAL LINK DEFAULTS TO 1544 Kbps; CHANGE BANDWIDTH TO CALCULATE CORRECT EIGRP METRIC; IT ONLY MODIFIES BANDWITH METRIC USED BY ROUTING PROTOCOL AND NOT THE PHYSICAL BANDWIDTH


R2(config)#interface serial0/0/0
R2(config-if)#bandwidth 64
R2(config-if)#interface serial0/0/1
R2(config-if)#bandwidth 1024


R3(config)#interface serial0/0/1
R3(config-if)#bandwidth 1024


R1#show interface serial0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.3.1/30
  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,   
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:00, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     962 packets input, 64848 bytes, 0 no buffer
     Received 573 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1012 packets output, 66854 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R2#show interface serial0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.3.2/30
  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,   
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1005 packets input, 66486 bytes, 0 no buffer
     Received 567 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     953 packets output, 64092 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     3 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R3#show interface serial0/0/1
Serial0/0/1 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 192.168.10.10/30
  MTU 1500 bytes, BW 1024 Kbit/sec, DLY 20000 usec,   
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  CRC checking enabled
  Last input 00:00:03, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 768 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     840 packets input, 56267 bytes, 0 no buffer
     Received 531 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     822 packets output, 55556 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.10.0/24 is a summary, 00:03:07, Null0
D       192.168.10.4/30 [90/3523840] via 192.168.10.10, 00:03:07, Serial0/0/1
C       192.168.10.8/30 is directly connected, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.16.0.0/16 is a summary, 00:02:45, Null0
D       172.16.1.0/24 [90/40514560] via 172.16.3.1, 00:03:12, Serial0/0/0   // SUCCESSOR ROUTE GOING TO PC1; CURRENTLY FORWARDING PACKET; FEASIBLE DISTANCE (FD) IS 40514560
C       172.16.2.0/24 is directly connected, FastEthernet0/0
C       172.16.3.0/30 is directly connected, Serial0/0/0
     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback1
D    192.168.1.0/24 [90/3014400] via 192.168.10.10, 00:03:07, Serial0/0/1


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.10.0/24 is a summary, 00:06:13, Null0
C       192.168.10.4/30 is directly connected, Serial0/0/1
D       192.168.10.8/30 [90/3523840] via 192.168.10.6, 00:06:01, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.16.0.0/16 is a summary, 00:34:15, Null0
C       172.16.1.0/24 is directly connected, FastEthernet0/0
D       172.16.2.0/24 [90/40514560] via 172.16.3.2, 00:07:30, Serial0/0/0
C       172.16.3.0/30 is directly connected, Serial0/0/0
D    192.168.1.0/24 [90/2172416] via 192.168.10.6, 00:07:30, Serial0/0/1   //  REPORTED DISTANCE (RD) IS 2172416 FEASIBILITY CONDITION (FC) IS MET WHEN A NEIGHBOR'S RD TO A NETWORK (192.168.1.0/24) IS LESS THAN THE LOCAL ROUTER'S FD TO THE SAME NETWORK


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.10.0/24 is a summary, 00:03:07, Null0
D       192.168.10.4/30 [90/3523840] via 192.168.10.10, 00:03:07, Serial0/0/1
C       192.168.10.8/30 is directly connected, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.16.0.0/16 is a summary, 00:02:45, Null0
D       172.16.1.0/24 [90/40514560] via 172.16.3.1, 00:03:12, Serial0/0/0  
C       172.16.2.0/24 is directly connected, FastEthernet0/0
C       172.16.3.0/30 is directly connected, Serial0/0/0
     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback1
D    192.168.1.0/24 [90/3014400] via 192.168.10.10, 00:03:07, Serial0/0/1    // FD IS 3014400
2172416 < 3014400; THEREFORE R2 WILL CONSIDER R1 TO BE FEASIBLE SUCCESSOR (FS) TO 192.168.1.0/24


R2#show ip eigrp ?
  <1-65535>   Autonomous System
  accounting  IP-EIGRP Accounting
  interfaces  IP-EIGRP interfaces
  neighbors   IP-EIGRP neighbors
  topology    IP-EIGRP Topology Table
  traffic     IP-EIGRP Traffic Statistics
  vrf         Select a VPN Routing/Forwarding instance

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.10.0/24, 1 successors, FD is 2169856
        via Summary (3011840/0), Null0
P 192.168.10.4/30, 1 successors, FD is 2681856
        via 192.168.10.10 (3523840/2169856), Serial0/0/1
P 192.168.1.0/24, 1 successors, FD is 2172416   
        via 192.168.10.10 (3014400/28160), Serial0/0/1 
P 192.168.10.8/30, 1 successors, FD is 3011840
        via Connected, Serial0/0/1
P 172.16.0.0/16, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 172.16.1.0/24, 1 successors, FD is 2172416  
        via 172.16.3.1 (40514560/28160), Serial0/0/0
P 172.16.2.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 172.16.3.0/30, 1 successors, FD is 40512000
        via Connected, Serial0/0/0

R2#show ip eigrp topology 192.168.1.0
IP-EIGRP (AS 1): Topology entry for 192.168.1.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2172416
  Routing Descriptor Blocks:
  192.168.10.10 (Serial0/0/1), from 192.168.10.10, Send flag is 0x0
      Composite metric is (3014400/28160), Route is Internal
      Vector metric:
        Minimum bandwidth is 1024 Kbit
        Total delay is 20100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  172.16.3.1 (Serial0/0/0), from 172.16.3.1, Send flag is 0x0
      Composite metric is (41026560/2172416), Route is Internal
      Vector metric:
        Minimum bandwidth is 64 Kbit
        Total delay is 40100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.10.0/24 is a summary, 00:37:51, Null0
C       192.168.10.4/30 is directly connected, Serial0/0/0
C       192.168.10.8/30 is directly connected, Serial0/0/1
D    172.16.0.0/16 [90/2172416] via 192.168.10.5, 00:16:48, Serial0/0/0   // R1 IS THE SUCCESSOR FOR 172.16.0.0/16
C    192.168.1.0/24 is directly connected, FastEthernet0/0

R3#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.10.10)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.10.0/24, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 192.168.10.4/30, 1 successors, FD is 2169856
        via Connected, Serial0/0/0
P 192.168.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 192.168.10.8/30, 1 successors, FD is 3011840
        via Connected, Serial0/0/1
P 172.16.0.0/16, 1 successors, FD is 2172416
        via 192.168.10.5 (2172416/28160), Serial0/0/0   
        via 192.168.10.9 (3014400/28160), Serial0/0/1

R2 RD (3014400) > R1 FD 2172416


R1(config)#router eigrp 1
R1(config-router)#no auto-summary   // DISABLES AUTO SUMMARIZATION
R1(config-router)#
*Jan  3 14:08:15.379: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.3.2 (Serial0/0/0) is resync: summary configured
*Jan  3 14:08:15.383: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.6 (Serial0/0/1) is resync: summary configured


R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#
*Jan  3 13:59:56.223: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.3.1 (Serial0/0/0) is resync: summary configured
*Jan  3 13:59:56.223: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.10 (Serial0/0/1) is resync: summary configured


R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#
*Jan  3 14:07:44.391: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.5 (Serial0/0/0) is resync: summary configured
*Jan  3 14:07:44.391: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.9 (Serial0/0/1) is resync: summary configured


R3#show ip route    // INDIVIDUAL ROUTES ARE NOW PRESENT AND SUMMARY NULL ROUTE IS GONE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.1.0/24 [90/2172416] via 192.168.10.5, 00:01:48, Serial0/0/0   
D       172.16.2.0/24 [90/3014400] via 192.168.10.9, 00:01:09, Serial0/0/1   
D       172.16.3.0/30 [90/41024000] via 192.168.10.9, 00:01:09, Serial0/0/1  
                      [90/41024000] via 192.168.10.5, 00:01:09, Serial0/0/0  
C    192.168.1.0/24 is directly connected, FastEthernet0/0


R3(config)#interface loopback1    // ADD NEW SUBNETS ON R3
R3(config-if)#
*Jan  3 14:09:54.919: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#interface loopback2
R3(config-if)#
*Jan  3 14:10:09.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#router eigrp 1
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.3.0


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, Serial0/0/1
D       192.168.10.8 [90/3523840] via 192.168.10.6, 00:04:03, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.1.0/24 is directly connected, FastEthernet0/0
D       172.16.2.0/24 [90/3526400] via 192.168.10.6, 00:04:03, Serial0/0/1
C       172.16.3.0/30 is directly connected, Serial0/0/0
D    192.168.1.0/24 [90/2172416] via 192.168.10.6, 00:28:33, Serial0/0/1
D    192.168.2.0/24 [90/2297856] via 192.168.10.6, 00:00:52, Serial0/0/1
D    192.168.3.0/24 [90/2297856] via 192.168.10.6, 00:00:50, Serial0/0/1


R3(config)#interface serial0/0/0   //  APPLY MANUAL ROUTE SUMMARIZATION ON OUTBOUND INTERFACES
R3(config-if)#ip summary-address ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  rip    Routing Information Protocol (RIP)

R3(config-if)#ip summary-address eigrp ?
  <1-65535>  Autonomous system number

R3(config-if)#ip summary-address eigrp 1 ?
  A.B.C.D  IP address

R3(config-if)#ip summary-address eigrp 1 192.168.0.0 ?
  A.B.C.D  IP network mask

R3(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3(config-if)#
*Jan  3 14:12:49.307: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.5 (Serial0/0/0) is resync: summary configured
R3(config-if)#interface serial0/0/1  
R3(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3(config-if)#
*Jan  3 14:12:56.303: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.10.9 (Serial0/0/1) is resync: summary configured


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, Serial0/0/1
D       192.168.10.8 [90/3523840] via 192.168.10.6, 00:06:36, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.1.0/24 is directly connected, FastEthernet0/0
D       172.16.2.0/24 [90/3526400] via 192.168.10.6, 00:06:36, Serial0/0/1
C       172.16.3.0/30 is directly connected, Serial0/0/0
D    192.168.0.0/22 [90/2172416] via 192.168.10.6, 00:01:02, Serial0/0/1   // EIGRP SUMMARY ROUTE FROM R3


R2(config)#ip route 0.0.0.0 0.0.0.0 loopback1    // CONFIGURE STATIC DEFAULT ROUTE ON R2 TO EXIT TO ISP
R2(config)#router eigrp 1
R2(config-router)#?
Router configuration commands:
  address-family       Enter Address Family command mode
  auto-summary         Enable automatic network number summarization
  bfd                  BFD configuration commands
  default              Set a command to its defaults
  default-information  Control distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Define an administrative distance
  distribute-list      Filter networks in routing updates
  eigrp                EIGRP specific commands
  exit                 Exit from routing protocol configuration mode
  help                 Description of the interactive help system
  maximum-paths        Forward packets over multiple paths
  metric               Modify EIGRP routing metrics and parameters
  neighbor             Specify a neighbor router
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  offset-list          Add or subtract offset from RIP metrics
  passive-interface    Suppress routing updates on an interface
  redistribute         Redistribute information from another routing protocol
  timers               Adjust routing timers
  traffic-share        How to compute traffic share over alternate paths
  variance             Control load balancing variance

R2(config-router)#redistribute ?
  bgp        Border Gateway Protocol (BGP)
  connected  Connected
  eigrp      Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis       ISO IS-IS
  iso-igrp   IGRP for OSI networks
  metric     Metric for redistributed routes
  mobile     Mobile routes
  odr        On Demand stub Routes
  ospf       Open Shortest Path First (OSPF)
  rip        Routing Information Protocol (RIP)
  route-map  Route map reference
  static     Static routes
  <cr>

R2(config-router)#redistribute static    // INCLUDE STATIC ROUTE IN EIGRP UPDATES


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.6 to network 0.0.0.0   

     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, Serial0/0/1
D       192.168.10.8 [90/3523840] via 192.168.10.6, 00:09:56, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.1.0/24 is directly connected, FastEthernet0/0
D       172.16.2.0/24 [90/3526400] via 192.168.10.6, 00:09:56, Serial0/0/1
C       172.16.3.0/30 is directly connected, Serial0/0/0
D*EX 0.0.0.0/0 [170/3651840] via 192.168.10.6, 00:01:33, Serial0/0/1  
D    192.168.0.0/22 [90/2172416] via 192.168.10.6, 00:04:22, Serial0/0/1


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.9 to network 0.0.0.0  

     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.1.0/24 [90/2172416] via 192.168.10.5, 00:11:22, Serial0/0/0
D       172.16.2.0/24 [90/3014400] via 192.168.10.9, 00:10:44, Serial0/0/1
D       172.16.3.0/30 [90/41024000] via 192.168.10.9, 00:10:44, Serial0/0/1
                      [90/41024000] via 192.168.10.5, 00:10:44, Serial0/0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Loopback1
C    192.168.3.0/24 is directly connected, Loopback2
D*EX 0.0.0.0/0 [170/3139840] via 192.168.10.9, 00:02:21, Serial0/0/1  
D    192.168.0.0/22 is a summary, 00:05:09, Null0

Saturday, January 23, 2016

RIPv2 Basic Configuration Lab

I finally bought my very first own VM server, which is a Dell PowerEdge 1950 server. I tried to search for an HP ProLiant MicroServer but it's a bit pricey and I've already bagged a great online deal on this Dell server instead. This VM server will help me create more complex topologies (which means more virtual routers) without worrying too much about RAM issue. It's has 500GB HDD, 16GB RAM, two 1Gbps RJ45 LAN ports and dual power supply. I still have to see if there's a need to upgrade to its maximum RAM of 32GB.

I've installed Windows 7, VM Workstation 11 and slowly updating my GNS3 components such as Virtual Box for running Windows 10 PC, SecureCRT for console connections and integrating an actual Internet connection.





I did a Basic RIPv1 lab on my previous post. Below is my RIPv2 lab during my Network+ studies.


R1(config)#interface fastethernet0/0
R1(config-if)#ip address 172.30.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan  1 02:43:50.783: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  1 02:43:51.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#interface fastethernet0/1
R1(config-if)#ip address 172.30.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Jan  1 02:44:12.635: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Jan  1 02:44:13.635: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#
*Jan  1 02:44:19.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#interface serial0/0/0
R1(config-if)#ip address 209.165.200.230 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#
*Jan  1 02:45:30.043: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#router rip
R1(config-router)#passive-interface fastethernet0/0
R1(config-router)#passive-interface fastethernet0/1
R1(config-router)#network 172.30.0.0
R1(config-router)#network 209.165.200.0


R2(config)#interface fastethernet0/0
R2(config-if)#ip address 10.1.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#
*Jan  1 02:38:04.683: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  1 02:38:05.683: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#interface serial0/0/0
R2(config-if)#ip address 209.165.200.229 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
*Jan  1 02:38:33.851: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan  1 02:38:34.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#interface serial0/0/1
R2(config-if)#ip address 209.165.200.233 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#
*Jan  1 02:39:13.599: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
R2(config-if)#router rip
R2(config-router)#passive-interface fastethernet0/0
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0


R3(config)#interface fastethernet0/0
R3(config-if)#ip address 172.30.100.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Jan  1 02:47:53.151: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan  1 02:47:54.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial0/0/1
R3(config-if)#ip address 209.165.200.234 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#
*Jan  1 02:48:14.663: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan  1 02:48:15.663: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R3(config-if)#interface loopback0
R3(config-if)#
*Jan  1 02:48:23.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.30.110.1 255.255.255.0
R3(config-if)#interface loopback1
R3(config-if)#
*Jan  1 02:48:42.083: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 172.30.200.17 255.255.255.240
R3(config-if)#interface loopback2
R3(config-if)#
*Jan  1 02:49:04.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R3(config-if)#ip address 172.30.200.33 255.255.255.240
R3(config-if)#router rip
R3(config-router)#passive-interface fastethernet0/0
R3(config-router)#network 172.30.0.0
R3(config-router)#network 209.165.200.0


R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.0.1        YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                209.165.200.229 YES manual up                    up 
Serial0/0/1                209.165.200.233 YES manual up                    up


C:\Users\PC1>ipconfig

Windows IP Configuration

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::4562:9b92:c15f:91ff%10
   IPv4 Address. . . . . . . . . . . : 172.30.1.10
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 172.30.1.1


C:\Users\PC1>ping 172.30.2.10    // PING TO PC2

Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time<1ms TTL=255

Ping statistics for 172.30.2.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms


C:\Users\PC1>ping 10.1.0.10   // PING TO PC3

Pinging 10.1.0.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 10.1.0.10:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


C:\Users\PC1>ping 172.30.100.10   // PING TO PC4

Pinging 172.30.100.10 with 32 bytes of data:
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.
Reply from 172.30.1.1: Destination host unreachable.

Ping statistics for 172.30.100.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),


C:\Users\PC4>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::4562:9b92:c15f:91ff%10
   IPv4 Address. . . . . . . . . . . : 172.30.100.10
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 172.30.100.1

C:\Users\PC4>ping 172.30.100.1

Pinging 172.30.100.1 with 32 bytes of data:
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255
Reply from 172.30.100.1: bytes=32 time=1ms TTL=255

Ping statistics for 172.30.100.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Users\PC4>ping 172.20.2.10   // PING TO PC2

Pinging 172.20.2.10 with 32 bytes of data:
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.
Reply from 172.30.100.1: Destination host unreachable.

Ping statistics for 172.20.2.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),


C:\Users\PC4>ping 10.1.0.10   // PING TO PC3

Pinging 10.1.0.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 10.1.0.10:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


R2#show ip route   // R2 ALTERNATES ROUTING TO CLASSFUL SUBNET 172.30.0.0/16

HOP) ARE THE SAME FROM R1 AND R3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:07, Serial0/0/1   // ROUTE FROM R3
                   [120/1] via 209.165.200.230, 00:00:12, Serial0/0/0   // ROUTE FROM R1
     209.165.200.0/30 is subnetted, 2 subnets
C       209.165.200.232 is directly connected, Serial0/0/1
C       209.165.200.228 is directly connected, Serial0/0/0
     10.0.0.0/16 is subnetted, 1 subnets
C       10.1.0.0 is directly connected, Loopback0


R1#show ip route   // RIPv1 WILL SUMMARIZE 172.30.0.0/24 TO 172.30.0.0/16; SINCE R1 DOESN'T HAVE SPECIFIC 172.30.0.0 SUBNETS AND R1 KNOWS THAT 172.30.0.0/16 SUBNET IS DIRECTLY CONNECTED, PACKETS

TO R3 LAN SUBNETS WILL NOT BE FORWARDED
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/24 is subnetted, 2 subnets  
C       172.30.2.0 is directly connected, Loopback0  
C       172.30.1.0 is directly connected, FastEthernet0/0  
     209.165.200.0/30 is subnetted, 2 subnets
R       209.165.200.232 [120/1] via 209.165.200.229, 00:00:21, Serial0/0/0
C       209.165.200.228 is directly connected, Serial0/0/0
R    10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:21, Serial0/0/0


R3#show ip route   // R3 ONLY KNOWS ITS OWN 172.30.0.0 SUBNETS; R3 DOESN'T HAVE ANY SPECIFIC 172.30.0.0 SUBNETS ON R1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/16 is variably subnetted, 4 subnets, 2 masks  
C       172.30.200.32/28 is directly connected, Loopback2  
C       172.30.200.16/28 is directly connected, Loopback1  
C       172.30.100.0/24 is directly connected, FastEthernet0/0  
C       172.30.110.0/24 is directly connected, Loopback0  
     209.165.200.0/30 is subnetted, 2 subnets
C       209.165.200.232 is directly connected, Serial0/0/1
R       209.165.200.228 [120/1] via 209.165.200.233, 00:00:17, Serial0/0/1
R    10.0.0.0/8 [120/1] via 209.165.200.233, 00:00:17, Serial0/0/1


R2#debug ip rip   // R2 RECEIVES 172.30.0.0 WITH 1 HOP FROM BOTH R1 AND R3; BECAUSE THEY'RE EQUAL COST, BOTH ROUTES ARE ADDED TO R2 ROUTING TABLE
RIP protocol debugging is on
R2#
*Jan  1 03:18:14.911: RIP: received v1 update from 209.165.200.230 on Serial0/0/0   //
*Jan  1 03:18:14.911:      172.30.0.0 in 1 hops
*Jan  1 03:18:17.007: RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (209.165.200.229)


*Jan  1 03:18:17.007: RIP: build update entries
*Jan  1 03:18:17.007:   network 10.0.0.0 metric 1  
*Jan  1 03:18:17.007:   subnet 209.165.200.232 metric 1  
*Jan  1 03:18:19.095: RIP: received v1 update from 209.165.200.234 on Serial0/0/1  
*Jan  1 03:18:19.095:      172.30.0.0 in 1 hops
*Jan  1 03:18:25.651: RIP: sending v1 update to 255.255.255.255 via Serial0/0/1 (209.165.200.233)


*Jan  1 03:18:25.651: RIP: build update entries
*Jan  1 03:18:25.651:   network 10.0.0.0 metric 1  
*Jan  1 03:18:25.651:   subnet 209.165.200.228 metric 1  
*Jan  1 03:18:30.223: RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.0.1)  
*Jan  1 03:18:30.223: RIP: build update entries
*Jan  1 03:18:30.223:   network 172.30.0.0 metric 2


R1(config)#router rip
R1(config-router)#version ?
  <1-2>  rip version 1 or 2

R1(config-router)#version 2    // ENABLE RIP VERSION 2; INCLUDE SUBNET MASK IN ROUTING UPDATES; RIPv2 SUMMARIZES NETWORKS AT MAJOR NETWORK BOUNDARIES (LIKE RIPv1) BY DEFAULT


R2(config)#router rip
R2(config-router)#version 2


R3(config)#router rip
R3(config-router)#version 2


R1#show ip protocols
Routing Protocol is "rip"   
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 20 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2   
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0/0           2     2
    Loopback0             2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.30.0.0
    209.165.200.0
  Passive Interface(s):
    FastEthernet0/0
    FastEthernet0/1
  Routing Information Sources:
    Gateway         Distance      Last Update
    209.165.200.229      120      00:00:16
  Distance: (default is 120)


R2#show ip route   // R2 STILL SHOWS EQUAL COST ROUTE TO 172.30.0.0/16; IT STILL DOESN'T SHOW SPECIFIC SUBNETS
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:08, Serial0/0/1  
                   [120/1] via 209.165.200.230, 00:00:00, Serial0/0/0  
     209.165.200.0/30 is subnetted, 2 subnets
C       209.165.200.232 is directly connected, Serial0/0/1
C       209.165.200.228 is directly connected, Serial0/0/0
     10.0.0.0/16 is subnetted, 1 subnets
C       10.1.0.0 is directly connected, Loopback0


R1#show ip route   // R1 STILL ONLY SHOWS ITS 172.30.0.0 SUBNET; R1 STILL DOESN'T HAVE SPECIFIC

172.30.0.0 SUBNETS ON R3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/24 is subnetted, 2 subnets   
C       172.30.2.0 is directly connected, Loopback0  
C       172.30.1.0 is directly connected, FastEthernet0/0  
     209.165.200.0/30 is subnetted, 2 subnets
R       209.165.200.232 [120/1] via 209.165.200.229, 00:00:26, Serial0/0/0
C       209.165.200.228 is directly connected, Serial0/0/0
R    10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:26, Serial0/0/0


R3#show ip route   // R3 STILL SHOWS IT'S OWN 172.30.0.0 SUBNET; R3 STILL DOESN'T HAVE SPECIFIC 172.30.0.0 SUBNETS ON R1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/16 is variably subnetted, 4 subnets, 2 masks  
C       172.30.200.32/28 is directly connected, Loopback2  
C       172.30.200.16/28 is directly connected, Loopback1  
C       172.30.100.0/24 is directly connected, FastEthernet0/0   
C       172.30.110.0/24 is directly connected, Loopback0  
     209.165.200.0/30 is subnetted, 2 subnets
C       209.165.200.232 is directly connected, Serial0/0/1
R       209.165.200.228 [120/1] via 209.165.200.233, 00:00:18, Serial0/0/1
R    10.0.0.0/8 [120/1] via 209.165.200.233, 00:00:18, Serial0/0/1


R3#debug ip rip
RIP protocol debugging is on
R3#
*Jan  1 03:36:16.587: RIP: sending v2 update to 224.0.0.9 via Loopback2 (172.30.200.33)
*Jan  1 03:36:16.587: RIP: build update entries
*Jan  1 03:36:16.587:   10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:36:16.587:   172.30.100.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:16.587:   172.30.110.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:16.587:   172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:16.587:   209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:16.587: RIP: ignored v2 packet from 172.30.200.33 (sourced from one of our
addresses)
*Jan  1 03:36:17.043: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.234) 
*Jan  1 03:36:17.043: RIP: build update entries
*Jan  1 03:36:17.043:   172.30.0.0/16 via 0.0.0.0, metric 1, tag 0   // R3 SENDING 172.30.0.0/16
SUMMARY ROUTE
*Jan  1 03:36:25.391: RIP: sending v2 update to 224.0.0.9 via Loopback0 (172.30.110.1)
*Jan  1 03:36:25.391: RIP: build update entries
*Jan  1 03:36:25.391:   10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:36:25.391:   172.30.100.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:25.391:   172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:25.391:   172.30.200.32/28 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:25.391:   209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:36:25.391: RIP: ignored v2 packet from 172.30.110.1 (sourced from one of our addresses)
*Jan  1 03:36:28.139: RIP: received v2 update from 209.165.200.233 on Serial0/0/1
*Jan  1 03:36:28.139:      10.0.0.0/8 via 0.0.0.0 in 1 hops
*Jan  1 03:36:28.139:      209.165.200.228/30 via 0.0.0.0 in 1 hops


R2#debug ip rip
RIP protocol debugging is on
R2#
*Jan  1 03:30:22.239: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan  1 03:30:22.239: RIP: build update entries
*Jan  1 03:30:22.239:   10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:22.239:   209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:25.843: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan  1 03:30:25.843: RIP: build update entries
*Jan  1 03:30:25.843:   172.30.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:30:25.843:   209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:25.843: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
*Jan  1 03:30:29.199: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan  1 03:30:29.199:      172.30.0.0/16 via 0.0.0.0 in 1 hops
*Jan  1 03:30:34.523: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan  1 03:30:34.523: RIP: build update entries
*Jan  1 03:30:34.523:   10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:34.523:   209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:47.027: RIP: received v2 update from 209.165.200.234 on Serial0/0/1  
*Jan  1 03:30:47.027:      172.30.0.0/16 via 0.0.0.0 in 1 hops   
*Jan  1 03:30:48.403: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan  1 03:30:48.403: RIP: build update entries
*Jan  1 03:30:48.403:   10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:48.403:   209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:52.419: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan  1 03:30:52.419: RIP: build update entries
*Jan  1 03:30:52.419:   172.30.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:30:52.419:   209.165.200.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:30:52.419: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)


R1(config)#router rip
R1(config-router)#no ?
  address-family          Enter Address Family command mode
  auto-summary            Enable automatic network number summarization
  default-information     Control distribution of default information
  default-metric          Set metric of redistributed routes
  distance                Define an administrative distance
  distribute-list         Filter networks in routing updates
  flash-update-threshold  Specify flash update threshold in second
  input-queue             Specify input queue depth
  maximum-paths           Forward packets over multiple paths
  neighbor                Specify a neighbor router
  network                 Enable routing on an IP network
  offset-list             Add or subtract offset from RIP metrics
  output-delay            Interpacket delay for RIP updates
  passive-interface       Suppress routing updates on an interface
  redistribute            Redistribute information from another routing
                          protocol
  timers                  Adjust routing timers
  traffic-share           How to compute traffic share over alternate paths
  validate-update-source  Perform sanity checks against source address of
                          routing updates
  version                 Set routing protocol version

R1(config-router)#no auto-summary   // DISABLE ROUTE SUMMARIZATION AT MAJOR NETWORK BOUNDARIES (USING DEFAULT SUBNET MASK)


R2(config)#router rip
R2(config-router)#no auto-summary


R3(config)#router rip
R3(config-router)#no auto-summary


R2#show ip route   // R1 AND R3 SPECIFIC LAN SUBNETS ARE NOW IN THE ROUTING TABLE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/16 is variably subnetted, 7 subnets, 3 masks
R       172.30.200.32/28 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R       172.30.200.16/28 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R       172.30.2.0/24 [120/1] via 209.165.200.230, 00:00:01, Serial0/0/0
R       172.30.0.0/16 [120/1] via 209.165.200.234, 00:01:12, Serial0/0/1
                      [120/1] via 209.165.200.230, 00:01:53, Serial0/0/0
R       172.30.1.0/24 [120/1] via 209.165.200.230, 00:00:01, Serial0/0/0
R       172.30.100.0/24 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
R       172.30.110.0/24 [120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
     209.165.200.0/30 is subnetted, 2 subnets
C       209.165.200.232 is directly connected, Serial0/0/1
C       209.165.200.228 is directly connected, Serial0/0/0
     10.0.0.0/16 is subnetted, 1 subnets
C       10.1.0.0 is directly connected, Loopback0


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks   
R       172.30.200.32/28 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
R       172.30.200.16/28 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
C       172.30.2.0/24 is directly connected, Loopback0
C       172.30.1.0/24 is directly connected, FastEthernet0/0
R       172.30.100.0/24 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
R       172.30.110.0/24 [120/2] via 209.165.200.229, 00:00:20, Serial0/0/0
     209.165.200.0/30 is subnetted, 2 subnets
R       209.165.200.232 [120/1] via 209.165.200.229, 00:00:20, Serial0/0/0
C       209.165.200.228 is directly connected, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       10.0.0.0/8 is possibly down,
          routing via 209.165.200.229, Serial0/0/0
R       10.1.0.0/16 [120/1] via 209.165.200.229, 00:00:22, Serial0/0/0


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       172.30.200.32/28 is directly connected, Loopback2
C       172.30.200.16/28 is directly connected, Loopback1
R       172.30.2.0/24 [120/2] via 209.165.200.233, 00:00:03, Serial0/0/1
R       172.30.1.0/24 [120/2] via 209.165.200.233, 00:00:03, Serial0/0/1
C       172.30.100.0/24 is directly connected, FastEthernet0/0
C       172.30.110.0/24 is directly connected, Loopback0
     209.165.200.0/30 is subnetted, 2 subnets
C       209.165.200.232 is directly connected, Serial0/0/1
R       209.165.200.228 [120/1] via 209.165.200.233, 00:00:03, Serial0/0/1
     10.0.0.0/16 is subnetted, 1 subnets
R       10.1.0.0 [120/1] via 209.165.200.233, 00:00:03, Serial0/0/1


R1#debug ip rip   // R1 NOW SENDS ITS SPECIFIC SUBNETS IN RIPv2 UPDATE TO R2
RIP protocol debugging is on
R1#
*Jan  1 03:46:53.503: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.230)
*Jan  1 03:46:53.503: RIP: build update entries
*Jan  1 03:46:53.503:   172.30.1.0/24 via 0.0.0.0, metric 1, tag 0  
*Jan  1 03:46:53.503:   172.30.2.0/24 via 0.0.0.0, metric 1, tag 0 
*Jan  1 03:47:04.571: RIP: sending v2 update to 224.0.0.9 via Loopback0 (172.30.2.10)
*Jan  1 03:47:04.571: RIP: build update entries
*Jan  1 03:47:04.571:   10.1.0.0/16 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:47:04.571:   172.30.1.0/24 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:47:04.571:   172.30.100.0/24 via 0.0.0.0, metric 3, tag 0
*Jan  1 03:47:04.571:   172.30.110.0/24 via 0.0.0.0, metric 3, tag 0
*Jan  1 03:47:04.571:   172.30.200.16/28 via 0.0.0.0, metric 3, tag 0
*Jan  1 03:47:04.571:   172.30.200.32/28 via 0.0.0.0, metric 3, tag 0
*Jan  1 03:47:04.571:   209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:47:04.571:   209.165.200.232/30 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:47:04.571: RIP: ignored v2 packet from 172.30.2.10 (sourced from one of our addresses)
*Jan  1 03:47:06.679: RIP: received v2 update from 209.165.200.229 on Serial0/0/0
*Jan  1 03:47:06.679:      10.1.0.0/16 via 0.0.0.0 in 1 hops
*Jan  1 03:47:06.679:      172.30.100.0/24 via 0.0.0.0 in 2 hops
*Jan  1 03:47:06.679:      172.30.110.0/24 via 0.0.0.0 in 2 hops
*Jan  1 03:47:06.679:      172.30.200.16/28 via 0.0.0.0 in 2 hops
*Jan  1 03:47:06.679:      172.30.200.32/28 via 0.0.0.0 in 2 hops
*Jan  1 03:47:06.679:      209.165.200.232/30 via 0.0.0.0 in 1 hops


R2#debug ip rip   // R2 RECEIVES SPECIFIC SUBNETS IN R1
RIP protocol debugging is on
R2#
*Jan  1 03:39:22.219: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan  1 03:39:22.219: RIP: build update entries
*Jan  1 03:39:22.219:   10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:22.219:   172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:22.219:   172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:22.219:   209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:23.083: RIP: received v2 update from 209.165.200.230 on Serial0/0/0  
*Jan  1 03:39:23.083:      172.30.1.0/24 via 0.0.0.0 in 1 hops  
*Jan  1 03:39:23.083:      172.30.2.0/24 via 0.0.0.0 in 1 hops  
*Jan  1 03:39:31.155: RIP: received v2 update from 209.165.200.234 on Serial0/0/1
*Jan  1 03:39:31.155:      172.30.100.0/24 via 0.0.0.0 in 1 hops
*Jan  1 03:39:31.155:      172.30.110.0/24 via 0.0.0.0 in 1 hops
*Jan  1 03:39:31.155:      172.30.200.16/28 via 0.0.0.0 in 1 hops
*Jan  1 03:39:31.155:      172.30.200.32/28 via 0.0.0.0 in 1 hops
*Jan  1 03:39:36.431: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
*Jan  1 03:39:36.431: RIP: build update entries
*Jan  1 03:39:36.431:   10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:36.431:   172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:36.431:   172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:36.431:   172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:36.431:   172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:36.431:   209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:50.311: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.1.0.1)
*Jan  1 03:39:50.311: RIP: build update entries
*Jan  1 03:39:50.311:   172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:50.311:   172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:50.311:   172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:50.311:   172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:50.311:   172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:50.311:   172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:50.311:   209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:50.311:   209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:50.311: RIP: ignored v2 packet from 10.1.0.1 (sourced from one of our addresses)
*Jan  1 03:39:51.127: RIP: sending v2 update to 224.0.0.9 via Serial0/0/1 (209.165.200.233)
*Jan  1 03:39:51.127: RIP: build update entries
*Jan  1 03:39:51.127:   10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:51.127:   172.30.1.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:51.127:   172.30.2.0/24 via 0.0.0.0, metric 2, tag 0
*Jan  1 03:39:51.127:   209.165.200.228/30 via 0.0.0.0, metric 1, tag 0
*Jan  1 03:39:51.367: RIP: received v2 update from 209.165.200.230 on Serial0/0/0
*Jan  1 03:39:51.367:      172.30.1.0/24 via 0.0.0.0 in 1 hops
*Jan  1 03:39:51.367:      172.30.2.0/24 via 0.0.0.0 in 1 hops


R2#ping 172.30.100.10   // PING TO PC4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms

R2#ping 172.30.1.10   // PING TO PC1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms


C:\Users\PC1>ping 172.30.2.10   // PING TO PC2

Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255
Reply from 172.30.2.10: bytes=32 time=1ms TTL=255

Ping statistics for 172.30.2.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms


C:\Users\PC1>ping 10.1.0.10   // PING TO PC3

Pinging 10.1.0.10 with 32 bytes of data:
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254

Ping statistics for 10.1.0.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 18ms, Maximum = 18ms, Average = 18ms


C:\Users\PC1>ping 172.30.100.10    // PING TO PC4

Pinging 172.30.100.10 with 32 bytes of data:
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253
Reply from 172.30.100.10: bytes=32 time=36ms TTL=253

Ping statistics for 172.30.100.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 36ms, Maximum = 36ms, Average = 36ms


C:\Users\PC4>ping 172.30.2.10   // PING TO PC2

Pinging 172.30.2.10 with 32 bytes of data:
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253
Reply from 172.30.2.10: bytes=32 time=36ms TTL=253

Ping statistics for 172.30.2.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 36ms, Maximum = 36ms, Average = 36ms


C:\Users\PC4>ping 10.1.0.10   // PING TO PC3

Pinging 10.1.0.10 with 32 bytes of data:
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254
Reply from 10.1.0.10: bytes=32 time=18ms TTL=254

Ping statistics for 10.1.0.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 18ms, Maximum = 18ms, Average = 18ms