Friday, January 8, 2016

Basic Static Route Configuration (and CompTIA Network+)

I started studying for CompTIA Network+ around July 2015 but I stopped for a while in order to give way for my last CCNP Security exam (SITCS 300-207) and prioritize some work related projects. I've been working with computer networks for more than 10 years now and I thought of taking this exam just to gauge myself how far I've gone in this technology. I also had my Security+ last year, so I thought why not take Network+ as well. Studying for Network+ also gave me a refresher for my routing and switching basics and help prepare for my CCIE R/S.

The Network+ N10-005 has been retired last year and was replaced by N10-006 exam. The N10-006 exam objectives covers a plethora of wired, wireless and a bit of security topics. I've used Todd Lammle Network+ N10-006 Study Guide and Keith Barker's Network+ CBT nuggets for my studies. I also did some labs using the Cisco CCNA Academy Student Lab Manual to reinforce the routing and switching concepts. This is probably the last "hardware" lab that I'll be doing. I'll be virtualizing my lab soon in order to perform CCNA SP, Check Point (CCSA) and CCIE R/S v5 labs. Below is the rack gear that I've used which is composed of a Cisco 2511 as terminal server, Cisco 3560 8-port switch, two Cisco 3560 24-port switch, and three Cisco 1841 routers.


This is the first lab that I did while studying for Network+.


R1(config)#no ip domain-lookup
R1(config)#enable secret cisco


R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous   // AVOIDS CLI INTERRUPTION
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#logging synchronous


R1(config-line)#line console 0
R1(config-line)#exec-timeout ?
  <0-35791>  Timeout in minutes

R1(config-line)#exec-timeout 0 ?
  <0-2147483>  Timeout in seconds
  <cr>

R1(config-line)#exec-timeout 0 0   // DISABLES CONSOLE ACCESS TIME OUT; DEFAULT IS 10 MINS

R1(config-line)#line vty 0 4
R1(config-line)#no exec-timeout   // SAME AS exec-timeout 0 0



R1#debug ip routing    // SHOWS WHEN ROUTES ARE ADDED, MODIFIED, AND DELTED FROM THE ROUTING TABLE
IP routing debugging is on
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fastethernet0/0
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#
*Dec 26 03:16:11.699: RT: is_up: FastEthernet0/0 0 state: 6 sub state: 1 line: 1 has_route: False
*Dec 26 03:16:11.699: RT: is_up: FastEthernet0/0 0 state: 6 sub state: 1 line: 1 has_route: False
R1(config-if)#no shutdown
R1(config-if)#
*Dec 26 03:16:44.783: RT: is_up: FastEthernet0/0 1 state: 4 sub state: 1 line: 1 has_route: False
*Dec 26 03:16:44.787: RT: add 172.16.3.0/24 via 0.0.0.0, connected metric [0/0]
*Dec 26 03:16:44.787: RT: NET-RED 172.16.3.0/24
*Dec 26 03:16:44.787: RT: interface FastEthernet0/0 added to routing table   //
R1(config-if)#
*Dec 26 03:16:46.771: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
R1(config-if)#
*Dec 26 03:16:46.771: RT: is_up: FastEthernet0/0 1 state: 4 sub state: 1 line: 1 has_route: True
*Dec 26 03:16:47.771: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#
*Dec 26 03:16:49.999: RT: is_up: FastEthernet0/0 1 state: 4 sub state: 1 line: 1 has_route: True


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.3.0 is directly connected, FastEthernet0/0


R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface serial0/0/0
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#
*Dec 26 03:19:45.343: RT: is_up: Serial0/0/0 0 state: 6 sub state: 1 line: 0 has_route: False
*Dec 26 03:19:45.343: RT: is_up: Serial0/0/0 0 state: 6 sub state: 1 line: 0 has_route: False
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#
*Dec 26 03:21:38.747: RT: is_up: Serial0/0/0 0 state: 0 sub state: 1 line: 0 has_route: False
R1(config-if)#
*Dec 26 03:21:40.747: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#
*Dec 26 03:21:40.747: RT: is_up: Serial0/0/0 0 state: 0 sub state: 1 line: 0 has_route: False  //

FOR SERIAL INTERFACE, THE OTHER SIDE OF THE WAN LINK MUST BE CONFIGURED FOR ROUTE TO SHOW UP

R1#show ip route
*Dec 26 03:22:49.111: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.3.0 is directly connected, FastEthernet0/0


R2#debug ip routing
IP routing debugging is on
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface serial0/0/0
R2(config-if)#ip address 172.16.2.2 255.255.255.0
R2(config-if)#
*Dec 26 03:15:36.631: RT: is_up: Serial0/0/0 0 state: 6 sub state: 1 line: 0 has_route: False
*Dec 26 03:15:36.631: RT: is_up: Serial0/0/0 0 state: 6 sub state: 1 line: 0 has_route: False
R2(config-if)#no shutdown
R2(config-if)#
*Dec 26 03:15:48.171: RT: is_up: Serial0/0/0 0 state: 4 sub state: 1 line: 0 has_route: False
*Dec 26 03:15:50.167: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Dec 26 03:15:50.167: RT: is_up: Serial0/0/0 1 state: 4 sub state: 1 line: 0 has_route: False
*Dec 26 03:15:50.171: RT: add 172.16.2.0/24 via 0.0.0.0, connected metric [0/0]
*Dec 26 03:15:50.171: RT: NET-RED 172.16.2.0/24
*Dec 26 03:15:50.171: RT: interface Serial0/0/0 added to routing table
*Dec 26 03:15:50.171: RT: is_up: Serial0/0/0 1 state: 4 sub state: 1 line: 0 has_route: True
*Dec 26 03:15:51.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Dec 26 03:15:51.167: RT: is_up: Serial0/0/0 1 state: 4 sub state: 1 line: 0 has_route: True


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.2.0 is directly connected, Serial0/0/0    //
C       172.16.3.0 is directly connected, FastEthernet0/0


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.2.0 is directly connected, Serial0/0/0   //


R2#no debug ip routing
IP routing debugging is off


R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface fastethernet0/0
R2(config-if)#ip address 172.16.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
*Dec 26 03:19:00.339: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed

state to up
R2(config-if)#interface serial0/0/1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
*Dec 26 03:19:31.059: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down


R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface fastethernet0/0
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Dec 26 03:27:58.395: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial0/0/1
R3(config-if)#ip address 192.168.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
*Dec 26 03:28:18.923: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
*Dec 26 03:29:48.651: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Dec 26 03:29:49.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


C:\Users\PC1>ping 172.16.3.1

Pinging 172.16.3.1 with 32 bytes of data:
Reply from 172.16.3.1: bytes=32 time=1ms TTL=255
Reply from 172.16.3.1: bytes=32 time=1ms TTL=255
Reply from 172.16.3.1: bytes=32 time=1ms TTL=255
Reply from 172.16.3.1: bytes=32 time=1ms TTL=255

Ping statistics for 172.16.3.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms


C:\Users\PC2>ping 172.16.1.1

Pinging 172.16.1.1 with 32 bytes of data:
Reply from 172.16.1.1: bytes=32 time=9ms TTL=251
Reply from 172.16.1.1: bytes=32 time=10ms TTL=251
Reply from 172.16.1.1: bytes=32 time=13ms TTL=251
Reply from 172.16.1.1: bytes=32 time=10ms TTL=251

Ping statistics for 172.16.1.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 9ms, Maximum = 13ms, Average = 10ms


C:\Users\PC3>ping 172.16.1.1

Pinging 172.16.1.1 with 32 bytes of data:
Reply from 172.16.1.1: bytes=32 time=9ms TTL=251
Reply from 172.16.1.1: bytes=32 time=10ms TTL=251
Reply from 172.16.1.1: bytes=32 time=13ms TTL=251
Reply from 172.16.1.1: bytes=32 time=10ms TTL=251

Ping statistics for 172.16.1.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 9ms, Maximum = 13ms, Average = 10ms


R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.3.1      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                172.16.2.1      YES manual up                    up 
Serial0/0/1                unassigned      YES NVRAM  administratively down down
Serial0/1/0                unassigned      YES NVRAM  administratively down down
Serial0/1/1                unassigned      YES NVRAM  administratively down down


R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.1      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                172.16.2.2      YES manual up                    up 
Serial0/0/1                192.168.1.2     YES manual up                    up


R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.2.1     YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Serial0/0/1                192.168.1.1     YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.2.0 is directly connected, Serial0/0/0
C       172.16.3.0 is directly connected, FastEthernet0/0


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial0/0/0
C    192.168.1.0/24 is directly connected, Serial0/0/1


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0/0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0


R3(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2
R3(config)#end
R3#
*Dec 26 03:43:28.979: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
S       172.16.1.0 [1/0] via 192.168.1.2   // S MEANS STATIC ROUTE
C    192.168.1.0/24 is directly connected, Serial0/0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0


R3#ping 172.16.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms

R3#ping 172.16.1.10 source 192.168.2.1   // PING FAILED SINCE R2 HAS NO RETURN ROUTE TO

192.168.2.0/24

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1
.....
Success rate is 0 percent (0/5)


R2(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial0/0/0
C    192.168.1.0/24 is directly connected, Serial0/0/1
S    192.168.2.0/24 [1/0] via 192.168.1.1   //


R3#ping 172.16.1.10 source 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms


R3(config)#ip route 172.16.2.0 255.255.255.0 serial0/0/1

R3#show run | include ip route
ip route 172.16.1.0 255.255.255.0 192.168.1.2
ip route 172.16.2.0 255.255.255.0 Serial0/0/1


R2(config)#ip route 172.16.3.0 255.255.255.0 serial0/0/0

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial0/0/0
S       172.16.3.0 is directly connected, Serial0/0/0
C    192.168.1.0/24 is directly connected, Serial0/0/1
S    192.168.2.0/24 [1/0] via 192.168.1.1


C:\Users\PC2>ping 172.16.3.1   // PING FAILED SINCE R1 HAS NO RETURN ROUTE TO 172.16.1.0/24

Pinging 172.16.3.1 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 172.16.3.1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2   // DEFAULT STATIC ROUTE;
R1(config)#
*Dec 26 04:44:50.843: RT: add 0.0.0.0/0 via 172.16.2.2, static metric [1/0]
*Dec 26 04:44:50.843: RT: NET-RED 0.0.0.0/0
*Dec 26 04:44:50.843: RT: default path is now 0.0.0.0 via 172.16.2.2
*Dec 26 04:44:50.843: RT: new default network 0.0.0.0
*Dec 26 04:44:50.843: RT: NET-RED 0.0.0.0/0
R1(config)#end
*Dec 26 04:44:55.367: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.2.2 to network 0.0.0.0   //

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.2.0 is directly connected, Serial0/0/0
C       172.16.3.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 172.16.2.2    //


C:\Users\PC2>ping 172.16.3.1   // PC2 SHOULD BE ABLE TO PING PC1/GW

Pinging 172.16.3.1 with 32 bytes of data:
Reply from 172.16.3.1: bytes=32 time=18ms TTL=254
Reply from 172.16.3.1: bytes=32 time=18ms TTL=254
Reply from 172.16.3.1: bytes=32 time=18ms TTL=254
Reply from 172.16.3.1: bytes=32 time=18ms TTL=254

Ping statistics for 172.16.3.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 18ms, Maximum = 18ms, Average = 18ms


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets   //
S       172.16.1.0 [1/0] via 192.168.1.2  
S       172.16.2.0 is directly connected, Serial0/0/1
C    192.168.1.0/24 is directly connected, Serial0/0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ip route 172.16.0.0 255.255.252.0 192.168.1.2
R3(config)#end
R3#
*Dec 26 04:49:53.755: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
S       172.16.0.0/22 [1/0] via 192.168.1.2   //  SUMMARY ROUTE DIDN'T REMOVE STATIC ROUTES BELOW

SINCE THEY'RE MORE SPECIFIC ROUTES; WE CAN REMOVE STATIC ROUTES
S       172.16.1.0/24 [1/0] via 192.168.1.2
S       172.16.2.0/24 is directly connected, Serial0/0/1
C    192.168.1.0/24 is directly connected, Serial0/0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0


R3#show run | inc ip route
ip route 172.16.0.0 255.255.252.0 192.168.1.2
ip route 172.16.1.0 255.255.255.0 192.168.1.2
ip route 172.16.2.0 255.255.255.0 Serial0/0/1
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#no ip route 172.16.1.0 255.255.255.0 192.168.1.2
R3(config)#no ip route 172.16.2.0 255.255.255.0 Serial0/0/1

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/22 is subnetted, 1 subnets
S       172.16.0.0 [1/0] via 192.168.1.2   //
C    192.168.1.0/24 is directly connected, Serial0/0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0


C:\Users\PC3>ping 172.16.3.1   // PC3 CAN PING PC1/GW

Pinging 172.16.3.1 with 32 bytes of data:
Reply from 172.16.3.1: bytes=32 time=36ms TTL=253
Reply from 172.16.3.1: bytes=32 time=35ms TTL=253
Reply from 172.16.3.1: bytes=32 time=35ms TTL=253
Reply from 172.16.3.1: bytes=32 time=35ms TTL=253

Ping statistics for 172.16.3.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 35ms, Maximum = 36ms, Average = 35ms

No comments:

Post a Comment