Friday, December 5, 2014

Serial WIC Cable and Cisco Router as Frame Relay Switch

I finally got my smart serial cross-cable (CAB-SS-2626X) when I visited my mom in New York a couple of months back. With these cables, I can emulate a Frame Relay cloud and use serial interfaces for WAN connection in my lab routers.



I was doing some EIGRP labs for my ROUTE studies and configured my 2811 router as a Frame Relay Switch. I was also able to do a Tool Command Language (TCL) script on a Cisco router, which in my opinion is the coolest feature I've learned in CCNP ROUTE.


2811(config)#hostname FRS
FRS(config)#frame-relay ?
  address    Address Registration with neighbor
  de-list    Build a classification list to be used in setting the DE bit
  switching  enable frame relay pvc switching

FRS(config)#frame-relay switching
FRS(config)#interface serial0/0/0
FRS(config-if)#description FR to HQ
FRS(config-if)#clock rate 128000
FRS(config-if)#encapsulation ?
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

FRS(config-if)#encapsulation frame-relay ?
  MFR   Multilink Frame Relay bundle interface
  ietf  Use RFC1490/RFC2427 encapsulation
  <cr>

FRS(config-if)#encapsulation frame-relay ietf   // SIGNIFICANT ONLY ON END DEVICES, NOT ON FR SWITCH
FRS(config-if)#frame-relay ?
  accounting             Special accounting instruction
  address-reg            ELMI address registration
  broadcast-queue        Define a broadcast queue and transmit rate
  class                  Define a map class on the interface
  congestion-management  Enable Frame Relay congestion management
  de-group               Associate a DE group with a DLCI
  fragment               Enable end-to-end fragmentation for all PVCs
  fragmentation          Adaptive fragmentation
  ifmib-counter64        Support IF-MIB's total packet/byte counts of Counter64
                         on FR if/subif when main interface's ifSpeed < 20 Mbps
  interface-dlci         Define a DLCI on an interface/subinterface
  interface-queue        configure PVC interface queueing
  intf-type              Configure a FR DTE/DCE/NNI interface
  inverse-arp            Enable/disable FR inverse ARP
  ip                     Frame Relay Internet Protocol config commands
  lapf                   set LAPF parameter
  lmi-n391dte            set full status polling counter
  lmi-n392dce            LMI error threshold
  lmi-n392dte            LMI error threshold
  lmi-n393dce            set LMI monitored event count
  lmi-n393dte            set LMI monitored event count
  lmi-t392dce            set DCE polling verification timer
  lmi-type               Use CISCO-ANSI-CCITT type LMI
  local-dlci             Set source DLCI when LMI is not supported
  map                    Map a protocol address to a DLCI address
  multicast-dlci         Set DLCI of a multicast group
  payload-compression    Use payload compression
  policing               Enable Frame Relay policing
  priority-dlci-group    Define a priority group of DLCIs
  qos-autosense          enable QOS autosense
  route                  frame relay route for pvc switching
  svc                    Enable frame relay SVCs
  traffic-shaping        Enable Frame Relay Traffic Shaping
  traps-maximum          set max traps FR generates at link up or when getting
                         LMI Full Status message
  vc-bundle              configure a frame-relay vc-bundle

FRS(config-if)#frame-relay lmi-type ?
  cisco
  ansi
  q933a

FRS(config-if)#frame-relay lmi-type cisco    // DEFAULT LMI TYPE
FRS(config-if)#frame-relay intf-type ?
  dce  Configure a FR DCE
  dte  Configure a FR DTE
  nni  Configure a FR NNI

FRS(config-if)#frame-relay intf-type dce
FRS(config-if)#frame-relay route ?
  <16-1007>  input dlci to be switched

FRS(config-if)#frame-relay route 102 ?
  interface  outgoing interface for pvc switching

FRS(config-if)#frame-relay route 102 interface ?
  MFR     Multilink Frame Relay bundle interface
  Serial  Serial
  Tunnel  Tunnel interface

FRS(config-if)#frame-relay route 102 interface serial0/0/1 ?
  <16-1007>  output dlci to use when switching

FRS(config-if)#frame-relay route 102 interface serial0/0/1 201
FRS(config-if)#frame-relay route 103 interface serial0/1/0 301
FRS(config-if)#no shutdown
FRS(config-if)#
*Oct 26 11:51:22.995: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
FRS(config-if)#interface serial0/0/1
FRS(config-if)#description FR to EAST
FRS(config-if)#encapsulation frame-relay ietf
FRS(config-if)#frame-relay lmi-type cisco
FRS(config-if)#frame-relay intf-type dce
FRS(config-if)#frame-relay route 201 interface serial0/0/0 102
FRS(config-if)#no shutdown
FRS(config-if)#
*Oct 26 11:52:31.307: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
FRS(config-if)#interface serial0/1/0
FRS(config-if)#description FR to WEST
FRS(config-if)#encapsulation frame-relay ietf
FRS(config-if)#clock rate 64000
FRS(config-if)#frame-relay lmi-type cisco
FRS(config-if)#frame-relay intf-type dce
FRS(config-if)#frame-relay route 301 interface serial0/0/0 103
FRS(config-if)#no shutdown
FRS(config-if)#
*Oct 26 11:53:36.139: %LINK-3-UPDOWN: Interface Serial0/1/0, changed state to up
FRS(config-if)#


HQ#show controllers serial 0/0/1
Interface Serial0/0/1
Hardware is GT96K
DTE V.35 TX and RX clocks detected.

<OUTPUT TRUNCATED>

HQ#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
HQ(config)#interface serial0/0/1
HQ(config-if)#ip address 172.16.124.1 255.255.255.248
HQ(config-if)#encapsulation ?
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

HQ(config-if)#encapsulation frame-relay ?
  MFR   Multilink Frame Relay bundle interface
  ietf  Use RFC1490/RFC2427 encapsulation
  <cr>

HQ(config-if)#encapsulation frame-relay ietf
HQ(config-if)#no frame-relay ?
  accounting             Special accounting instruction
  address-reg            ELMI address registration
  broadcast-queue        Define a broadcast queue and transmit rate
  class                  Define a map class on the interface
  congestion-management  Enable Frame Relay congestion management
  de-group               Associate a DE group with a DLCI
  fragment               Enable end-to-end fragmentation for all PVCs
  fragmentation          Adaptive fragmentation
  ifmib-counter64        Support IF-MIB's total packet/byte counts of Counter64
                         on FR if/subif when main interface's ifSpeed < 20 Mbps
  interface-dlci         Define a DLCI on an interface/subinterface
  interface-queue        configure PVC interface queueing
  intf-type              Configure a FR DTE/DCE/NNI interface
  inverse-arp            Enable/disable FR inverse ARP
  ip                     Frame Relay Internet Protocol config commands
  lapf                   set LAPF parameter
  lmi-n391dte            set full status polling counter
  lmi-n392dce            LMI error threshold
  lmi-n392dte            LMI error threshold
  lmi-n393dce            set LMI monitored event count
  lmi-n393dte            set LMI monitored event count
  lmi-t392dce            set DCE polling verification timer
  lmi-type               Use CISCO-ANSI-CCITT type LMI
  local-dlci             Set source DLCI when LMI is not supported
  map                    Map a protocol address to a DLCI address
  multicast-dlci         Set DLCI of a multicast group
  payload-compression    Use payload compression
  policing               Enable Frame Relay policing
  priority-dlci-group    Define a priority group of DLCIs
  qos-autosense          enable QOS autosense
  route                  frame relay route for pvc switching
  svc                    Enable frame relay SVCs
  traffic-shaping        Enable Frame Relay Traffic Shaping
  traps-maximum          set max traps FR generates at link up or when getting
                         LMI Full Status message
  vc-bundle              configure a frame-relay vc-bundle

HQ(config-if)#no frame-relay inverse-arp   // DISABLE INVERSE ARP SINCE STATIC MAPPINGS WILL BE USED
HQ(config-if)#frame-relay ?
  accounting             Special accounting instruction
  address-reg            ELMI address registration
  broadcast-queue        Define a broadcast queue and transmit rate
  class                  Define a map class on the interface
  congestion-management  Enable Frame Relay congestion management
  de-group               Associate a DE group with a DLCI
  fragment               Enable end-to-end fragmentation for all PVCs
  fragmentation          Adaptive fragmentation
  ifmib-counter64        Support IF-MIB's total packet/byte counts of Counter64
                         on FR if/subif when main interface's ifSpeed < 20 Mbps
  interface-dlci         Define a DLCI on an interface/subinterface
  interface-queue        configure PVC interface queueing
  intf-type              Configure a FR DTE/DCE/NNI interface
  inverse-arp            Enable/disable FR inverse ARP
  ip                     Frame Relay Internet Protocol config commands
  lapf                   set LAPF parameter
  lmi-n391dte            set full status polling counter
  lmi-n392dce            LMI error threshold
  lmi-n392dte            LMI error threshold
  lmi-n393dce            set LMI monitored event count
  lmi-n393dte            set LMI monitored event count
  lmi-t392dce            set DCE polling verification timer
  lmi-type               Use CISCO-ANSI-CCITT type LMI
  local-dlci             Set source DLCI when LMI is not supported
  map                    Map a protocol address to a DLCI address
  multicast-dlci         Set DLCI of a multicast group
  payload-compression    Use payload compression
  policing               Enable Frame Relay policing
  priority-dlci-group    Define a priority group of DLCIs
  qos-autosense          enable QOS autosense
  route                  frame relay route for pvc switching
  svc                    Enable frame relay SVCs
  traffic-shaping        Enable Frame Relay Traffic Shaping
  traps-maximum          set max traps FR generates at link up or when getting
                         LMI Full Status message
  vc-bundle              configure a frame-relay vc-bundle

HQ(config-if)#frame-relay map ?
  appletalk  AppleTalk
  bridge     Bridging
  bstun      Block Serial Tunnel
  clns       ISO CLNS
  decnet     DECnet
  dlsw       Data Link Switching (Direct encapsulation only)
  ip         IP
  ipv6       IPV6
  ipx        Novell IPX
  llc2       llc2
  qllc       qllc protocol
  rsrb       Remote Source-Route Bridging
  stun       Serial Tunnel

HQ(config-if)#frame-relay map ip ?
  A.B.C.D  Protocol specific address

HQ(config-if)#frame-relay map ip 172.16.124.2 ?
  <16-1007>  DLCI
  vc-bundle  vc-bundle

HQ(config-if)#frame-relay map ip 172.16.124.2 102 ?
  broadcast            Broadcasts should be forwarded to this address
  cisco                Use CISCO Encapsulation
  compress             Enable TCP/IP and RTP/IP header compression
  ietf                 Use RFC1490/RFC2427 Encapsulation
  nocompress           Do not compress TCP/IP headers
  payload-compression  Use payload compression
  rtp                  RTP header compression parameters
  tcp                  TCP header compression parameters
  <cr>

HQ(config-if)#frame-relay map ip 172.16.124.2 102 broadcast   // STATIC IP TO DLCI MAPPING
HQ(config-if)#frame-relay map ip 172.16.124.3 103 broadcast   // ALLOWS EIGRP BROADCAST/MULTICAST THROUGH THE FRAME RELAY CLOUD
HQ(config-if)#no shutdown
*Oct 26 11:54:57.275: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Oct 26 11:55:08.275: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


EAST#show controllers serial0/0/1
Interface Serial0/0/1
Hardware is GT96K
DCE V.35, clock rate 64000

<OUTPUT TRUNCATED>

EAST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
EAST(config)#interface serial0/0/1
EAST(config-if)#ip address 172.16.124.2 255.255.255.248
EAST(config-if)#clock rate 64000
EAST(config-if)#encapsulation frame-relay ietf
EAST(config-if)#no frame-relay inverse-arp
EAST(config-if)#frame-relay map ip 172.16.124.1 201 broadcast
EAST(config-if)#frame-relay map ip 172.16.124.3 301   // NO broadcast KEYWORD TO AVOID DUPLICATE BROADCAST AND MULTICAST TRAFFIC
EAST(config-if)#no shutdown
*Oct 26 10:45:00.615: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Oct 26 10:45:11.615: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


WEST#show controller serial0/0/0
Interface Serial0/0/0
Hardware is GT96K
DTE V.35 TX and RX clocks detected.

<OUTPUT TRUNCATED>

WEST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
WEST(config)#interface serial 0/0/0
WEST(config-if)#ip address 172.16.124.3 255.255.255.248
WEST(config-if)#encapsulation frame-relay ietf
WEST(config-if)#no frame inverse-arp
*Oct 26 11:24:40.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
WEST(config-if)#frame-relay map ip 172.16.124.1 301 broadcast
WEST(config-if)#frame-relay map ip 172.16.124.2 301
WEST(config-if)#no shutdown


HQ#ping 172.16.124.1   // FR INTERFACE IS UNABLE TO PING ITSELF

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
HQ#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
HQ(config)#interface serial0/0/1
HQ(config-if)#frame-relay map ip 172.16.124.1 102  // TO ALLOW FR INTERFACE TO PING ITSELF
HQ(config-if)#do ping 172.16.124.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/84 ms


Configure the same on EAST and WEST routers.

EAST#ping 172.16.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
EAST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
EAST(config)#interface serial0/0/1
EAST(config-if)#frame-relay map ip 172.16.124.2 201
EAST(config-if)#do ping 172.16.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/84 ms


WEST#ping 172.16.124.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
WEST#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
WEST(config)#interface serial0/0/0
WEST(config-if)#frame-relay map ip 172.16.124.3 301
WEST(config-if)#do ping 172.16.124.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/84 ms


Configure interface bandwidth for proper EIGRP metric calculations.

HQ(config)#interface serial 0/0/1
HQ(config-if)#bandwidth 128

EAST(config)#interface serial0/0/1
EAST(config-if)#bandwidth 64

WEST(config)#interface serial0/0/0
WEST(config-if)#bandwidth 64


HQ(config-if)#interface serial0/0/1
HQ(config-if)#ip bandwidth-percent ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)

HQ(config-if)#ip bandwidth-percent eigrp ?
  <1-65535>  Autonomous system number

HQ(config-if)#ip bandwidth-percent eigrp 1 ?
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

HQ(config-if)#ip bandwidth-percent eigrp 1 40


HQ(config)#router eigrp 1
HQ(config-router)#network 10.0.0.0
HQ(config-router)#network 172.16.0.0
HQ(config-router)#no auto-summary


WEST(config)#router eigrp 1
WEST(config-router)#network 10.0.0.0
WEST(config-router)#network 172.16.0.0
WEST(config-router)#no auto-summary
*Oct 26 12:08:08.715: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/0) is up: new adjacency
WEST(config-router)#
*Oct 26 12:08:10.839: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/0) is resync:summary configured


WEST(config)#router eigrp 1
WEST(config-router)#network 10.0.0.0
WEST(config-router)#network 172.16.0.0
WEST(config-router)#no auto-summary


EAST(config)#router eigrp 1
EAST(config-router)#network 10.0.0.0
EAST(config-router)#network 172.16.0.0
EAST(config-router)#no auto-summary
*Oct 26 11:35:09.431: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/1) is up: new adjacency
*Oct 26 11:35:10.591: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/1) is down:summary configured


EAST#show ip eigrp topology    // MISSING 10.3.x.x ROUTES
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/1


WEST#show ip eigrp topology    // MISSING 10.2.x.x ROUTES
IP-EIGRP Topology Table for AS(1)/ID(10.3.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.3.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.3.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/0


HQ(config)#interface serial0/0/1
HQ(config-if)#no ip split-horizon ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  <cr>

HQ(config-if)#no ip split-horizon eigrp ?
  <1-65535>  Autonomous system number

HQ(config-if)#no ip split-horizon eigrp 1   // ALLOWS EAST ROUTES TO BE ADVERTISED IN WEST ROUTER AND VICE VERSA
HQ(config-if)#
*Oct 26 12:54:25.383: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.2 (Serial0/0/1) is resync:split horizon changed
*Oct 26 12:54:25.383: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.3 (Serial0/0/1) is resync:split horizon changed


EAST#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.3.0.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.3.32.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.3.64.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.3.96.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.3.128.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 10.2.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.3.160.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/1
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/1
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/1
        via 172.16.124.1 (41024000/20512000), Serial0/0/1


WEST#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.3.161.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.0.0/19, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.32.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.32.0/19, 1 successors, FD is 128256
        via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.64.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.64.0/19, 1 successors, FD is 128256
        via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.96.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.96.0/19, 1 successors, FD is 128256
        via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.128.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.128.0/19, 1 successors, FD is 128256
        via Connected, Loopback129
P 10.1.128.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.160.0/19, 1 successors, FD is 41152000
        via 172.16.124.1 (41152000/20640000), Serial0/0/0
P 10.3.160.0/19, 1 successors, FD is 128256
        via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
        via 172.16.124.1 (40640000/128256), Serial0/0/0
P 172.16.124.0/29, 1 successors, FD is 40512000
        via Connected, Serial0/0/0
        via 172.16.124.1 (41024000/20512000), Serial0/0/0


HQ#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.124.2            Se0/0/1          174 00:06:20 1053  5000  0  8
0   172.16.124.3            Se0/0/1          137 00:10:40   59  1422  0  9


EAST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/1          163 00:06:41   55  2280  0  14


WEST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/0          145 00:10:25  535  3210  0  14


HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/19 is subnetted, 18 subnets
D       10.2.0.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.0.0 [90/20640000] via 172.16.124.3, 00:11:53, Serial0/0/1
C       10.1.0.0 is directly connected, Loopback1
D       10.2.32.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.32.0 [90/20640000] via 172.16.124.3, 00:11:53, Serial0/0/1
C       10.1.32.0 is directly connected, Loopback33
D       10.2.64.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.64.0 [90/20640000] via 172.16.124.3, 00:11:53, Serial0/0/1
C       10.1.64.0 is directly connected, Loopback65
D       10.2.96.0 [90/20640000] via 172.16.124.2, 00:07:33, Serial0/0/1
D       10.3.96.0 [90/20640000] via 172.16.124.3, 00:11:54, Serial0/0/1
C       10.1.96.0 is directly connected, Loopback97
D       10.2.128.0 [90/20640000] via 172.16.124.2, 00:07:34, Serial0/0/1
D       10.3.128.0 [90/20640000] via 172.16.124.3, 00:11:54, Serial0/0/1
C       10.1.128.0 is directly connected, Loopback129
D       10.2.160.0 [90/20640000] via 172.16.124.2, 00:07:34, Serial0/0/1
D       10.3.160.0 [90/20640000] via 172.16.124.3, 00:11:54, Serial0/0/1
C       10.1.160.0 is directly connected, Loopback161


EAST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/19 is subnetted, 18 subnets
C       10.2.0.0 is directly connected, Loopback1
D       10.3.0.0 [90/41152000] via 172.16.124.1, 00:04:56, Serial0/0/1
D       10.1.0.0 [90/40640000] via 172.16.124.1, 00:07:14, Serial0/0/1
C       10.2.32.0 is directly connected, Loopback33
D       10.3.32.0 [90/41152000] via 172.16.124.1, 00:04:56, Serial0/0/1
D       10.1.32.0 [90/40640000] via 172.16.124.1, 00:07:14, Serial0/0/1
C       10.2.64.0 is directly connected, Loopback65
D       10.3.64.0 [90/41152000] via 172.16.124.1, 00:04:56, Serial0/0/1
D       10.1.64.0 [90/40640000] via 172.16.124.1, 00:07:14, Serial0/0/1
C       10.2.96.0 is directly connected, Loopback97
D       10.3.96.0 [90/41152000] via 172.16.124.1, 00:04:58, Serial0/0/1
D       10.1.96.0 [90/40640000] via 172.16.124.1, 00:07:17, Serial0/0/1
C       10.2.128.0 is directly connected, Loopback129
D       10.3.128.0 [90/41152000] via 172.16.124.1, 00:04:58, Serial0/0/1
D       10.1.128.0 [90/40640000] via 172.16.124.1, 00:07:17, Serial0/0/1
C       10.2.160.0 is directly connected, Loopback161
D       10.3.160.0 [90/41152000] via 172.16.124.1, 00:04:58, Serial0/0/1
D       10.1.160.0 [90/40640000] via 172.16.124.1, 00:07:17, Serial0/0/1


WEST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/0
     10.0.0.0/19 is subnetted, 18 subnets
D       10.2.0.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.0.0 is directly connected, Loopback1
D       10.1.0.0 [90/40640000] via 172.16.124.1, 00:12:29, Serial0/0/0
D       10.2.32.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.32.0 is directly connected, Loopback33
D       10.1.32.0 [90/40640000] via 172.16.124.1, 00:12:29, Serial0/0/0
D       10.2.64.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.64.0 is directly connected, Loopback65
D       10.1.64.0 [90/40640000] via 172.16.124.1, 00:12:29, Serial0/0/0
D       10.2.96.0 [90/41152000] via 172.16.124.1, 00:05:50, Serial0/0/0
C       10.3.96.0 is directly connected, Loopback97
D       10.1.96.0 [90/40640000] via 172.16.124.1, 00:12:30, Serial0/0/0
D       10.2.128.0 [90/41152000] via 172.16.124.1, 00:05:52, Serial0/0/0
C       10.3.128.0 is directly connected, Loopback129
D       10.1.128.0 [90/40640000] via 172.16.124.1, 00:12:30, Serial0/0/0
D       10.2.160.0 [90/41152000] via 172.16.124.1, 00:05:52, Serial0/0/0
C       10.3.160.0 is directly connected, Loopback161
D       10.1.160.0 [90/40640000] via 172.16.124.1, 00:12:30, Serial0/0/0


HQ#tclsh     // TCL SCRIPT
HQ(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.33.1
+>(tcl)#10.1.65.1
+>(tcl)#10.1.97.1
+>(tcl)#10.1.129.1
+>(tcl)#10.1.161.1
+>(tcl)#172.16.124.1
+>(tcl)#10.2.1.1
+>(tcl)#10.2.33.1
+>(tcl)#10.2.65.1
+>(tcl)#10.2.97.1
+>(tcl)#10.2.129.1
+>(tcl)#10.2.161.1
+>(tcl)#172.16.124.2
+>(tcl)#10.3.1.1
+>(tcl)#10.3.33.1
+>(tcl)#10.3.65.1
+>(tcl)#10.3.97.1
+>(tcl)#10.3.129.1
+>(tcl)#10.3.161.1
+>(tcl)#172.16.124.3
+>(tcl)#} { ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.65.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.97.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.129.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.161.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/84/88 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.65.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.97.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.129.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.161.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.65.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.97.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.129.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.161.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms


HQ(config)#router eigrp 1
HQ(config-router)#neighbor ?
  A.B.C.D  Neighbor address

HQ(config-router)#neighbor 172.16.124.2 ?
  Async               Async interface
  Auto-Template       Auto-Template interface
  BVI                 Bridge-Group Virtual Interface
  CDMA-Ix             CDMA Ix interface
  CTunnel             CTunnel interface
  Dialer              Dialer interface
  FastEthernet        FastEthernet IEEE 802.3
  Lex                 Lex interface
  Loopback            Loopback interface
  MFR                 Multilink Frame Relay bundle interface
  Multilink           Multilink-group interface
  Null                Null interface
  SSLVPN-VIF          SSLVPN Virtual Interface
  Serial              Serial
  Tunnel              Tunnel interface
  Vif                 PGM Multicast Host interface
  Virtual-Dot11Radio  Virtual dot11 interface
  Virtual-PPP         Virtual PPP interface
  Virtual-Template    Virtual Template interface
  Virtual-TokenRing   Virtual TokenRing
  vmi                 Virtual Multipoint Interface

HQ(config-router)#neighbor 172.16.124.2 serial0/0/1  // NOT ALL FRAME RELAY SUPPORTS MULTICAST
*Oct 26 13:07:07.423: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.2 (Serial0/0/1) is down: Static peer configured
*Oct 26 13:07:07.423: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.3 (Serial0/0/1) is down: Static peer configured
HQ(config-router)#neighbor 172.16.124.3 serial0/0/1  // SENDS UNICAST INSTEAD OF MULTICAST ON A PER-INTERFACE BASIS


EAST(config)#router eigrp 1
EAST(config-router)#neighbor 172.16.124.1 serial0/0/1


WEST(config)#router eigrp 1
WEST(config-router)#neighbor 172.16.124.1 serial0/0/0


HQ#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.124.3            Se0/0/1          136 00:01:35   48  1422  0  14
0   172.16.124.2            Se0/0/1          160 00:02:05   63  1422  0  14


EAST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/1          169 00:02:34   54  2280  0  24


WEST#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.124.1            Se0/0/0          123 00:01:53   86  2280  0  24


HQ(config)#interface serial0/0/0
HQ(config-if)#ip summary-address eigrp 1 ?
  A.B.C.D  IP address

HQ(config-if)#ip summary-address eigrp 1 10.1.0.0 ?
  A.B.C.D  IP network mask

HQ(config-if)#ip summary-address eigrp 1 10.1.0.0 255.255.0.0 ?


EAST(config)#interface serial0/0/1
EAST(config-if)#ip summary-address eigrp 1 10.2.0.0 255.255.0.0
EAST(config-if)#
*Oct 26 11:59:20.927: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/1) is resync:summary configured


WEST(config)#interface serial0/0/0
WEST(config-if)#ip summary-address eigrp 1 10.3.0.0 255.255.0.0
*Oct 26 12:36:52.907: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial0/0/0) is resync:summary configured


HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
D       10.2.0.0/16 [90/20640000] via 172.16.124.2, 00:03:29, Serial0/0/1
D       10.3.0.0/16 [90/20640000] via 172.16.124.3, 00:02:19, Serial0/0/1
C       10.1.0.0/19 is directly connected, Loopback1
C       10.1.32.0/19 is directly connected, Loopback33
C       10.1.64.0/19 is directly connected, Loopback65
C       10.1.96.0/19 is directly connected, Loopback97
C       10.1.128.0/19 is directly connected, Loopback129
C       10.1.160.0/19 is directly connected, Loopback161


EAST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/1
     10.0.0.0/8 is variably subnetted, 14 subnets, 3 masks
C       10.2.0.0/19 is directly connected, Loopback1
D       10.2.0.0/16 is a summary, 00:02:27, Null0
D       10.3.0.0/16 [90/41152000] via 172.16.124.1, 00:01:17, Serial0/0/1
D       10.1.0.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.32.0/19 is directly connected, Loopback33
D       10.1.32.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.64.0/19 is directly connected, Loopback65
D       10.1.64.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.96.0/19 is directly connected, Loopback97
D       10.1.96.0/19 [90/40640000] via 172.16.124.1, 00:07:52, Serial0/0/1
C       10.2.128.0/19 is directly connected, Loopback129
D       10.1.128.0/19 [90/40640000] via 172.16.124.1, 00:07:55, Serial0/0/1
C       10.2.161.0/29 is directly connected, Loopback161
D       10.1.160.0/19 [90/40640000] via 172.16.124.1, 00:07:55, Serial0/0/1


WEST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 14 subnets, 2 masks
D       10.2.0.0/16 [90/41152000] via 172.16.124.1, 00:01:25, Serial0/0/0
C       10.3.0.0/19 is directly connected, Loopback1
D       10.3.0.0/16 is a summary, 00:00:15, Null0
D       10.1.0.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.32.0/19 is directly connected, Loopback33
D       10.1.32.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.64.0/19 is directly connected, Loopback65
D       10.1.64.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.96.0/19 is directly connected, Loopback97
D       10.1.96.0/19 [90/40640000] via 172.16.124.1, 00:06:20, Serial0/0/0
C       10.3.128.0/19 is directly connected, Loopback129
D       10.1.128.0/19 [90/40640000] via 172.16.124.1, 00:06:22, Serial0/0/0
C       10.3.160.0/19 is directly connected, Loopback161
D       10.1.160.0/19 [90/40640000] via 172.16.124.1, 00:06:22, Serial0/0/0

No comments:

Post a Comment