Sunday, January 18, 2015

Redistribution Between EIGRP and OSPF

I've been doing CCNP ROUTE (v1.0) labs relentlessly for the last couple of months and I enjoyed every moment of it. I was able to understand the foundation and intricacies of different routing protocols and it also helps me get better at my networking job.

I'm already halfway through my quick CCDP journey and performing the ROUTE labs helped me reinforce some of the advance routing concepts. I'll be doing labs for CCNP SWITCH next and I'm currently modifying my home lab.

In this lab, I did a redistribution between EIGRP and OSPF. Redistribution is very common in an enterprise especially if there's an acquisition or merger between companies. At work, we've got different redistribution points, such as between RIP and OSPF as well as OSPF and BGP.


R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 172.16.0.0
R1(config-router)#network 192.168.48.0
R1(config-router)#network 192.168.49.0
R1(config-router)#network 192.168.50.0
R1(config-router)#network 192.168.51.0
R1(config-router)#network 192.168.70.0

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.12.2             Se0/0/0           11 00:00:48   27  2280  0  3

R1#show ip route eigrp
     172.16.0.0/24 is subnetted, 4 subnets
D       172.16.23.0 [90/41024000] via 172.16.12.2, 00:00:52, Serial0/0/0
D       172.16.100.0 [90/40640000] via 172.16.12.2, 00:00:52, Serial0/0/0


R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 172.16.0.0
R2(config-router)#
*Dec 21 09:38:46.827: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.1 (Serial0/0/0) is up: new adjacency

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.12.1             Se0/0/0           13 00:00:11   38  2280  0  3

R2#show ip route eigrp
     172.16.0.0/24 is subnetted, 4 subnets
D       172.16.1.0 [90/40640000] via 172.16.12.1, 00:00:18, Serial0/0/0
D    192.168.51.0/24 [90/40640000] via 172.16.12.1, 00:00:18, Serial0/0/0
D    192.168.50.0/24 [90/40640000] via 172.16.12.1, 00:00:18, Serial0/0/0
D    192.168.49.0/24 [90/40640000] via 172.16.12.1, 00:00:18, Serial0/0/0
D    192.168.70.0/24 [90/40640000] via 172.16.12.1, 00:00:18, Serial0/0/0
D    192.168.48.0/24 [90/40640000] via 172.16.12.1, 00:00:18, Serial0/0/0


R2#show ip eigrp ?
  <1-65535>   Autonomous System
  accounting  IP-EIGRP Accounting
  interfaces  IP-EIGRP interfaces
  neighbors   IP-EIGRP neighbors
  topology    IP-EIGRP Topology Table
  traffic     IP-EIGRP Traffic Statistics
  vrf         Select a VPN Routing/Forwarding instance

R2#show ip eigrp interfaces    // BOTH SERIAL INTERFACES ARE ENABLED FOR EIGRP BECAUSE OF CLASSFUL NETWORK COMMAND USED
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0/0            1        0/0        38      10/380        552           0  
Se0/0/1            0        0/0         0      10/10           0           0  
Lo100              0        0/0         0       0/1            0           0


R2(config)#router eigrp 1
R2(config-router)#passive-interface serial0/0/1

R2#show ip eigrp interfaces
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0/0            1        0/0        38      10/380        552           0
Lo100              0        0/0         0       0/1            0           0

R2#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Passive Interface(s):
    Serial0/0/1   
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.12.1           90      00:04:08
  Distance: internal 90 external 170


R1(config)#interface s0/0/0
R1(config-if)#ip summary-address ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  rip    Routing Information Protocol (RIP)

R1(config-if)#ip summary-address eigrp ?
  <1-65535>  Autonomous system number

R1(config-if)#ip summary-address eigrp 1 ?
  A.B.C.D  IP address

R1(config-if)#ip summary-address eigrp 1 192.168.48.0 ?
  A.B.C.D  IP network mask

R1(config-if)#ip summary-address eigrp 1 192.168.48.0 255.255.254.0
R1(config-if)#
*Dec 21 11:03:10.863: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.2 (Serial0/0/0) is resync:summary configured

R1#show ip route eigrp
     172.16.0.0/24 is subnetted, 4 subnets
D       172.16.23.0 [90/41024000] via 172.16.12.2, 00:07:08, Serial0/0/0
D       172.16.100.0 [90/40640000] via 172.16.12.2, 00:07:08, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:00:20, Null0   

R1#show ip route 192.168.48.0 255.255.254.0
Routing entry for 192.168.48.0/23, supernet
  Known via "eigrp 1", distance 5, metric 128256, type internal  
  Redistributing via eigrp 1
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 128256, traffic share count is 1
      Total delay is 5000 microseconds, minimum bandwidth is 10000000 Kbit
      Reliability 255/255, minimum MTU 1514 bytes
      Loading 1/255, Hops 0


R2(config)#interface loopback100
R2(config-if)#ip ospf 1 area 10
R2(config-if)#ip ospf network point-to-point
R2(config-if)#interface s0/0/1
R2(config-if)#ip ospf 1 area 0
*Dec 21 09:49:06.715: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.40.1 on Serial0/0/1 from LOADING to FULL, Loading Done

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.40.1      0   FULL/  -        00:00:36    172.16.23.3     Serial0/0/1


R3(config)#interface s0/0/1
R3(config-if)#ip ospf 1 area 0
R3(config-if)#interface loopback0
R3(config-if)#ip ospf 1 area 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback20
R3(config-if)#ip ospf 1 area 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback25
R3(config-if)#ip ospf 1 area 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback30
R3(config-if)#ip ospf 1 area 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback35
R3(config-if)#ip ospf 1 area 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback40
R3(config-if)#ip ospf 1 area 0
R3(config-if)#ip ospf network point-to-point

R3(config-if)#interface loopback8
R3(config-if)#ip ospf 1 area 20
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback9
R3(config-if)#ip ospf 1 area 20
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback10
R3(config-if)#ip ospf 1 area 20
R3(config-if)#ip ospf network point-to-point
R3(config-if)#interface loopback11
R3(config-if)#ip ospf 1 area 20
R3(config-if)#ip ospf network point-to-point

R3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.100.1      0   FULL/  -        00:00:31    172.16.23.2     Serial0/0/1


R2#show ip route ospf
O    192.168.30.0/24 [110/1563] via 172.16.23.3, 00:04:44, Serial0/0/1
O IA 192.168.8.0/24 [110/1563] via 172.16.23.3, 00:03:50, Serial0/0/1
O    192.168.25.0/24 [110/1563] via 172.16.23.3, 00:04:44, Serial0/0/1
O IA 192.168.9.0/24 [110/1563] via 172.16.23.3, 00:03:50, Serial0/0/1
O IA 192.168.10.0/24 [110/1563] via 172.16.23.3, 00:03:40, Serial0/0/1
O    192.168.40.0/24 [110/1563] via 172.16.23.3, 00:04:24, Serial0/0/1
     172.16.0.0/24 is subnetted, 6 subnets
O       172.16.3.0 [110/1563] via 172.16.23.3, 00:05:04, Serial0/0/1
O IA 192.168.11.0/24 [110/1563] via 172.16.23.3, 00:03:40, Serial0/0/1
O    192.168.20.0/24 [110/1563] via 172.16.23.3, 00:04:54, Serial0/0/1
O    192.168.35.0/24 [110/1563] via 172.16.23.3, 00:04:34, Serial0/0/1


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O    192.168.30.0/24 [110/1563] via 172.16.23.3, 00:06:10, Serial0/0/1
O IA 192.168.8.0/24 [110/1563] via 172.16.23.3, 00:05:16, Serial0/0/1
O    192.168.25.0/24 [110/1563] via 172.16.23.3, 00:06:10, Serial0/0/1
O IA 192.168.9.0/24 [110/1563] via 172.16.23.3, 00:05:16, Serial0/0/1
O IA 192.168.10.0/24 [110/1563] via 172.16.23.3, 00:05:06, Serial0/0/1
O    192.168.40.0/24 [110/1563] via 172.16.23.3, 00:05:50, Serial0/0/1
     172.16.0.0/24 is subnetted, 6 subnets
C       172.16.23.0 is directly connected, Serial0/0/1
C       172.16.12.0 is directly connected, Serial0/0/0
D       172.16.1.0 [90/40640000] via 172.16.12.1, 00:17:46, Serial0/0/0
C       172.16.2.0 is directly connected, Loopback0
O       172.16.3.0 [110/1563] via 172.16.23.3, 00:06:30, Serial0/0/1
C       172.16.100.0 is directly connected, Loopback100
O IA 192.168.11.0/24 [110/1563] via 172.16.23.3, 00:05:08, Serial0/0/1
O    192.168.20.0/24 [110/1563] via 172.16.23.3, 00:06:22, Serial0/0/1
D    192.168.51.0/24 [90/40640000] via 172.16.12.1, 00:17:48, Serial0/0/0
D    192.168.50.0/24 [90/40640000] via 172.16.12.1, 00:17:48, Serial0/0/0
O    192.168.35.0/24 [110/1563] via 172.16.23.3, 00:06:02, Serial0/0/1
D    192.168.70.0/24 [90/40640000] via 172.16.12.1, 00:17:48, Serial0/0/0
D    192.168.48.0/23 [90/40640000] via 172.16.12.1, 00:11:00, Serial0/0/0


R3(config)#router ospf 1
R3(config-router)#area 20 ?
  authentication  Enable authentication
  default-cost    Set the summary default-cost of a NSSA/stub area
  filter-list     Filter networks between OSPF areas
  nssa            Specify a NSSA area
  range           Summarize routes matching address/mask (border routers only)
  sham-link       Define a sham link and its parameters
  stub            Specify a stub area
  virtual-link    Define a virtual link and its parameters

R3(config-router)#area 20 range ?
  A.B.C.D  IP address to match

R3(config-router)#area 20 range 192.168.8.0 ?
  A.B.C.D  IP mask for address

R3(config-router)#area 20 range 192.168.8.0 255.255.252.0


R2#show ip route ospf
O    192.168.30.0/24 [110/1563] via 172.16.23.3, 00:07:28, Serial0/0/1
O    192.168.25.0/24 [110/1563] via 172.16.23.3, 00:07:28, Serial0/0/1
O    192.168.40.0/24 [110/1563] via 172.16.23.3, 00:07:08, Serial0/0/1
     172.16.0.0/24 is subnetted, 6 subnets
O       172.16.3.0 [110/1563] via 172.16.23.3, 00:07:48, Serial0/0/1
O    192.168.20.0/24 [110/1563] via 172.16.23.3, 00:07:38, Serial0/0/1
O    192.168.35.0/24 [110/1563] via 172.16.23.3, 00:07:18, Serial0/0/1
O IA 192.168.8.0/22 [110/1563] via 172.16.23.3, 00:00:11, Serial0/0/1  


R2(config)#router ospf 1
R2(config-router)#redistribute ?
  bgp             Border Gateway Protocol (BGP)
  connected       Connected
  eigrp           Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis            ISO IS-IS
  iso-igrp        IGRP for OSI networks
  maximum-prefix  Maximum number of prefixes redistributed to protocol
  metric          Metric for redistributed routes
  metric-type     OSPF/IS-IS exterior metric type for redistributed routes
  mobile          Mobile routes
  odr             On Demand stub Routes
  ospf            Open Shortest Path First (OSPF)
  rip             Routing Information Protocol (RIP)
  route-map       Route map reference
  static          Static routes
  subnets         Consider subnets for redistribution into OSPF
  tag             Set tag for routes redistributed into OSPF
  <cr>

R2(config-router)#redistribute eigrp ?
  <1-65535>  Autonomous system number

R2(config-router)#redistribute eigrp 1 ?
  metric       Metric for redistributed routes
  metric-type  OSPF/IS-IS exterior metric type for redistributed routes
  route-map    Route map reference
  subnets      Consider subnets for redistribution into OSPF
  tag          Set tag for routes redistributed into OSPF
  <cr>

R2(config-router)#redistribute eigrp 1 subnets

R2(config)#router eigrp 1
R2(config-router)#redistribute ospf ?
  <1-65535>  Process ID

R2(config-router)#redistribute ospf 1 ?
  match      Redistribution of OSPF routes
  metric     Metric for redistributed routes
  route-map  Route map reference
  vrf        VPN Routing/Forwarding Instance
  <cr>

R2(config-router)#redistribute ospf 1 metric ?
  <1-4294967295>  Bandwidth metric in Kbits per second

R2(config-router)#redistribute ospf 1 metric 1000 ?
  <0-4294967295>  EIGRP delay metric, in 10 microsecond units

R2(config-router)#redistribute ospf 1 metric 1000 100 ?
  <0-255>  EIGRP reliability metric where 255 is 100% reliable

R2(config-router)#redistribute ospf 1 metric 1000 100 255 ?
  <1-255>  EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

R2(config-router)#redistribute ospf 1 metric 1000 100 255 1 ?
  <1-65535>  EIGRP MTU of the path

R2(config-router)#redistribute ospf 1 metric 1000 100 255 1 1500

R2#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1, ospf 1   
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Passive Interface(s):
    Serial0/0/1
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.12.1           90      00:16:10
  Distance: internal 90 external 170

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.16.100.1
  It is an area border and autonomous system boundary router
  Redistributing External Routes from,
    eigrp 1, includes subnets in redistribution   
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Serial0/0/1
  Routing on Interfaces Configured Explicitly (Area 10):
    Loopback100
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.40.1         110      00:04:06
  Distance: (default is 110)


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 192.168.30.0/24 [170/40537600] via 172.16.12.2, 00:01:14, Serial0/0/0  
D EX 192.168.25.0/24 [170/40537600] via 172.16.12.2, 00:01:14, Serial0/0/0
D EX 192.168.40.0/24 [170/40537600] via 172.16.12.2, 00:01:14, Serial0/0/0
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [90/41024000] via 172.16.12.2, 00:24:06, Serial0/0/0
C       172.16.12.0 is directly connected, Serial0/0/0
C       172.16.1.0 is directly connected, Loopback0
D       172.16.2.0 [90/40640000] via 172.16.12.2, 00:08:13, Serial0/0/0
D EX    172.16.3.0 [170/40537600] via 172.16.12.2, 00:01:14, Serial0/0/0
D       172.16.100.0 [90/40640000] via 172.16.12.2, 00:24:06, Serial0/0/0
D EX 192.168.20.0/24 [170/40537600] via 172.16.12.2, 00:01:14, Serial0/0/0
C    192.168.51.0/24 is directly connected, Loopback51
C    192.168.50.0/24 is directly connected, Loopback50
D EX 192.168.35.0/24 [170/40537600] via 172.16.12.2, 00:01:16, Serial0/0/0
C    192.168.49.0/24 is directly connected, Loopback49
C    192.168.70.0/24 is directly connected, Loopback70
C    192.168.48.0/24 is directly connected, Loopback48
D EX 192.168.8.0/22 [170/40537600] via 172.16.12.2, 00:01:16, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:17:20, Null0


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.30.0/24 is directly connected, Loopback30
C    192.168.8.0/24 is directly connected, Loopback8
C    192.168.25.0/24 is directly connected, Loopback25
C    192.168.9.0/24 is directly connected, Loopback9
C    192.168.10.0/24 is directly connected, Loopback10
C    192.168.40.0/24 is directly connected, Loopback40
     172.16.0.0/24 is subnetted, 6 subnets
C       172.16.23.0 is directly connected, Serial0/0/1
O E2    172.16.12.0 [110/20] via 172.16.23.2, 00:02:58, Serial0/0/1  
O E2    172.16.1.0 [110/20] via 172.16.23.2, 00:02:58, Serial0/0/1
O E2    172.16.2.0 [110/20] via 172.16.23.2, 00:02:58, Serial0/0/1
C       172.16.3.0 is directly connected, Loopback0
O IA    172.16.100.0 [110/1563] via 172.16.23.2, 00:05:40, Serial0/0/1
C    192.168.11.0/24 is directly connected, Loopback11
C    192.168.20.0/24 is directly connected, Loopback20
O E2 192.168.51.0/24 [110/20] via 172.16.23.2, 00:03:00, Serial0/0/1
O E2 192.168.50.0/24 [110/20] via 172.16.23.2, 00:03:00, Serial0/0/1
C    192.168.35.0/24 is directly connected, Loopback35
O E2 192.168.70.0/24 [110/20] via 172.16.23.2, 00:03:00, Serial0/0/1
O    192.168.8.0/22 is a summary, 00:05:41, Null0
O E2 192.168.48.0/23 [110/20] via 172.16.23.2, 00:03:00, Serial0/0/1


R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#192.168.48.1
+>(tcl)#192.168.49.1
+>(tcl)#192.168.50.1
+>(tcl)#192.168.51.1
+>(tcl)#192.168.70.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.2.1
+>(tcl)#172.16.100.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.23.2
+>(tcl)#172.16.3.1
+>(tcl)#192.168.20.1
+>(tcl)#192.168.25.1
+>(tcl)#192.168.30.1
+>(tcl)#192.168.35.1
+>(tcl)#192.168.40.1
+>(tcl)#192.168.8.1
+>(tcl)#192.168.9.1
+>(tcl)#192.168.10.1
+>(tcl)#192.168.11.1
+>(tcl)#172.16.23.3
+>(tcl)#} { ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.48.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.51.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms


R1#show ip route eigrp
D EX 192.168.30.0/24 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0   // FILTER ROUTES USING A ROUTE MAP
D EX 192.168.25.0/24 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0  
D EX 192.168.40.0/24 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [90/41024000] via 172.16.12.2, 00:26:46, Serial0/0/0
D       172.16.2.0 [90/40640000] via 172.16.12.2, 00:10:53, Serial0/0/0
D EX    172.16.3.0 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0
D       172.16.100.0 [90/40640000] via 172.16.12.2, 00:26:46, Serial0/0/0
D EX 192.168.20.0/24 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0
D EX 192.168.35.0/24 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0
D EX 192.168.8.0/22 [170/40537600] via 172.16.12.2, 00:03:54, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:19:58, Null0


R2(config)#access-list 1 permit 192.168.25.0
R2(config)#access-list 1 permit 192.168.30.0
R2(config)#route-map SELECTED-DENY ?
  <0-65535>  Sequence to insert to/delete from existing route-map entry
  deny       Route map denies set operations
  permit     Route map permits set operations
  <cr>

R2(config)#route-map SELECTED-DENY deny ?
  <0-65535>  Sequence to insert to/delete from existing route-map entry
  <cr>

R2(config)#route-map SELECTED-DENY deny 10
R2(config-route-map)#?
Route Map configuration commands:
  continue     Continue on a different entry within the route-map
  default      Set a command to its defaults
  description  Route-map comment
  exit         Exit from route-map configuration mode
  help         Description of the interactive help system
  match        Match values from routing table
  no           Negate a command or set its defaults
  set          Set values in destination routing protocol

R2(config-route-map)#match ?
  as-path           Match BGP AS path list
  clns              CLNS information
  community         Match BGP community list
  extcommunity      Match BGP/VPN extended community list
  interface         Match first hop interface of route
  ip                IP specific information
  ipv6              IPv6 specific information
  length            Packet length
  local-preference  Local preference for route
  mdt-group         Match routes corresponding to MDT group
  metric            Match metric of route
  mpls-label        Match routes which have MPLS labels
  nlri              BGP NLRI type
  policy-list       Match IP policy list
  route-type        Match route-type of route
  source-protocol   Match source-protocol of route
  tag               Match tag of route

R2(config-route-map)#match ip ?
  address       Match address of route or match packet
  next-hop      Match next-hop address of route
  route-source  Match advertising source address of route

R2(config-route-map)#match ip address 1
R2(config-route-map)#route-map SELECTED-DENY permit 20

R2(config)#router eigrp 1
R2(config-router)#redistribute ospf 1 ?
  match      Redistribution of OSPF routes
  metric     Metric for redistributed routes
  route-map  Route map reference
  vrf        VPN Routing/Forwarding Instance
  <cr>

R2(config-router)#redistribute ospf 1 route-map ?
  WORD  Pointer to route-map entries

R2(config-router)#redistribute ospf 1 route-map SELECTED-DENY

R2#show access-list 1
Standard IP access list 1
    10 permit 192.168.25.0 (1 match)
    20 permit 192.168.30.0 (1 match)

R2#show route-map
route-map SELECTED-DENY, deny, sequence 10
  Match clauses:
    ip address (access-lists): 1
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map SELECTED-DENY, permit, sequence 20
  Match clauses:
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes


R1#show ip route eigrp     // 192.168.25.0/24 AND 192.168.30.0/24 ARE FILTERED VIA THE ROUTE MAP
D EX 192.168.40.0/24 [170/40537600] via 172.16.12.2, 00:07:36, Serial0/0/0
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [90/41024000] via 172.16.12.2, 00:30:29, Serial0/0/0
D       172.16.2.0 [90/40640000] via 172.16.12.2, 00:14:35, Serial0/0/0
D EX    172.16.3.0 [170/40537600] via 172.16.12.2, 00:07:36, Serial0/0/0
D       172.16.100.0 [90/40640000] via 172.16.12.2, 00:30:29, Serial0/0/0
D EX 192.168.20.0/24 [170/40537600] via 172.16.12.2, 00:07:36, Serial0/0/0
D EX 192.168.35.0/24 [170/40537600] via 172.16.12.2, 00:07:36, Serial0/0/0
D EX 192.168.8.0/22 [170/40537600] via 172.16.12.2, 00:07:36, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:23:41, Null0


R3#show ip route ospf
     172.16.0.0/24 is subnetted, 6 subnets
O E2    172.16.12.0 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1
O E2    172.16.1.0 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1
O E2    172.16.2.0 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1
O IA    172.16.100.0 [110/1563] via 172.16.23.2, 00:13:35, Serial0/0/1
O E2 192.168.51.0/24 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1  
O E2 192.168.50.0/24 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1  
O E2 192.168.70.0/24 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1
O    192.168.8.0/22 is a summary, 00:13:35, Null0
O E2 192.168.48.0/23 [110/20] via 172.16.23.2, 00:10:53, Serial0/0/1  


R2(config)#router ospf 1
R2(config-router)#summary-address ?
  A.B.C.D  IP summary address

R2(config-router)#summary-address 192.168.48.0 ?
  A.B.C.D  Summary mask

R2(config-router)#summary-address 192.168.48.0 255.255.252.0   // SUMMARIZE EXTERNAL ROUTES AT ASBR


R3#show ip route ospf
     172.16.0.0/24 is subnetted, 6 subnets
O E2    172.16.12.0 [110/20] via 172.16.23.2, 00:12:54, Serial0/0/1
O E2    172.16.1.0 [110/20] via 172.16.23.2, 00:12:54, Serial0/0/1
O E2    172.16.2.0 [110/20] via 172.16.23.2, 00:12:54, Serial0/0/1
O IA    172.16.100.0 [110/1563] via 172.16.23.2, 00:15:36, Serial0/0/1
O E2 192.168.70.0/24 [110/20] via 172.16.23.2, 00:12:54, Serial0/0/1
O    192.168.8.0/22 is a summary, 00:15:36, Null0
O E2 192.168.48.0/22 [110/20] via 172.16.23.2, 00:00:37, Serial0/0/1  


R1(config)#interface loopback50
R1(config-if)#shutdown
R1(config-if)#
*Dec 21 11:32:20.323: %LINK-5-CHANGED: Interface Loopback50, changed state to administratively down
*Dec 21 11:32:21.323: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback50, changed state to down

R3#traceroute 192.168.50.1

Type escape sequence to abort.
Tracing the route to 192.168.50.1

  1 172.16.23.2 12 msec 12 msec 16 msec
  2 172.16.23.2 !H  !H  *     // INDICATES NO HOST ROUTE


R2#traceroute 192.168.50.1

Type escape sequence to abort.
Tracing the route to 192.168.50.1

  1  *  *  *
  2  *  *  *
  3  *  *  *
  4  *  *  *


R1#show ip route eigrp
D EX 192.168.40.0/24 [170/40537600] via 172.16.12.2, 00:16:20, Serial0/0/0    // EIGRP EXTERNAL AD 170
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [90/41024000] via 172.16.12.2, 00:39:12, Serial0/0/0     // EIGRP INTERNAL AD 90
D       172.16.2.0 [90/40640000] via 172.16.12.2, 00:23:19, Serial0/0/0
D EX    172.16.3.0 [170/40537600] via 172.16.12.2, 00:16:20, Serial0/0/0
D       172.16.100.0 [90/40640000] via 172.16.12.2, 00:39:12, Serial0/0/0
D EX 192.168.20.0/24 [170/40537600] via 172.16.12.2, 00:16:20, Serial0/0/0
D EX 192.168.35.0/24 [170/40537600] via 172.16.12.2, 00:16:20, Serial0/0/0
D EX 192.168.8.0/22 [170/40537600] via 172.16.12.2, 00:16:20, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:32:24, Null0
D EX 192.168.48.0/22 [170/40537600] via 172.16.12.2, 00:05:20, Serial0/0/0

R1#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Address Summarization:
    192.168.48.0/23 for Serial0/0/0
      Summarizing with metric 128256
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.48.0
    192.168.49.0
    192.168.50.0
    192.168.51.0
    192.168.70.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:33:04
    172.16.12.2           90      00:03:57
  Distance: internal 90 external 170   


R1(config)#router eigrp 1
R1(config-router)#distance ?
  <1-255>  Administrative distance
  eigrp    IP-EIGRP distance

R1(config-router)#distance eigrp ?
  <1-255>  Distance for internal routes

R1(config-router)#distance eigrp 95 ?
  <1-255>  Distance for external routes

R1(config-router)#distance eigrp 95 165    // LOCALLY SIGNFICANT ON ROUTER
R1(config-router)#
*Dec 21 11:37:11.879: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.2 (Serial0/0/0) is down:route configuration changed
*Dec 21 11:37:16.279: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.2 (Serial0/0/0) is up: new adjacency

R1#show ip route eigrp
D EX 192.168.40.0/24 [165/40537600] via 172.16.12.2, 00:00:42, Serial0/0/0  
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [95/41024000] via 172.16.12.2, 00:00:42, Serial0/0/0  
D       172.16.2.0 [95/40640000] via 172.16.12.2, 00:00:42, Serial0/0/0
D EX    172.16.3.0 [165/40537600] via 172.16.12.2, 00:00:42, Serial0/0/0
D       172.16.100.0 [95/40640000] via 172.16.12.2, 00:00:42, Serial0/0/0
D EX 192.168.20.0/24 [165/40537600] via 172.16.12.2, 00:00:42, Serial0/0/0
D EX 192.168.35.0/24 [165/40537600] via 172.16.12.2, 00:00:42, Serial0/0/0
D EX 192.168.8.0/22 [165/40537600] via 172.16.12.2, 00:00:42, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:34:48, Null0
D EX 192.168.48.0/22 [165/40537600] via 172.16.12.2, 00:00:36, Serial0/0/0

R1#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Address Summarization:
    192.168.48.0/23 for Serial0/0/0
      Summarizing with metric 128256
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.48.0
    192.168.49.0
    192.168.50.0
    192.168.51.0
    192.168.70.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.12.2           95      00:01:16
  Distance: internal 95 external 165   


R2#show ip route eigrp     // EIGRP AD RETAINED
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.1.0 [90/40640000] via 172.16.12.1, 00:01:00, Serial0/0/0
D    192.168.51.0/24 [90/40640000] via 172.16.12.1, 00:01:00, Serial0/0/0
D    192.168.50.0/24 [90/40640000] via 172.16.12.1, 00:01:00, Serial0/0/0
D    192.168.70.0/24 [90/40640000] via 172.16.12.1, 00:01:00, Serial0/0/0
D    192.168.48.0/23 [90/40640000] via 172.16.12.1, 00:01:00, Serial0/0/0


R3#show ip route ospf
     172.16.0.0/24 is subnetted, 6 subnets
O E2    172.16.12.0 [110/20] via 172.16.23.2, 00:21:36, Serial0/0/1   // OSPF DEFAULT AD 110
O E2    172.16.1.0 [110/20] via 172.16.23.2, 00:02:13, Serial0/0/1
O E2    172.16.2.0 [110/20] via 172.16.23.2, 00:21:36, Serial0/0/1
O IA    172.16.100.0 [110/1563] via 172.16.23.2, 00:24:18, Serial0/0/1
O E2 192.168.70.0/24 [110/20] via 172.16.23.2, 00:02:13, Serial0/0/1
O    192.168.8.0/22 is a summary, 00:24:18, Null0
O E2 192.168.48.0/22 [110/20] via 172.16.23.2, 00:02:11, Serial0/0/1

R3(config)#router ospf 1
R3(config-router)#distance ?
  <1-255>  Administrative distance
  ospf     OSPF distance

R3(config-router)#distance ospf ?
  external    External type 5 and type 7 routes
  inter-area  Inter-area routes
  intra-area  Intra-area routes

R3(config-router)#distance ospf intra-area ?
  <1-255>  Distance for intra-area routes

R3(config-router)#distance ospf intra-area 105 ?
  external    External type 5 and type 7 routes
  inter-area  Inter-area routes
  <cr>

R3(config-router)#distance ospf intra-area 105 inter-area ?
  <1-255>  Distance for inter-area routes

R3(config-router)#distance ospf intra-area 105 inter-area 115 ?
  external  External type 5 and type 7 routes
  <cr>

R3(config-router)#distance ospf intra-area 105 inter-area 115 external ?
  <1-255>  Distance for external type 5 and type 7 routes

R3(config-router)#distance ospf intra-area 105 inter-area 115 external 175


R3#show ip route ospf
     172.16.0.0/24 is subnetted, 6 subnets
O E2    172.16.12.0 [175/20] via 172.16.23.2, 00:00:18, Serial0/0/1
O E2    172.16.1.0 [175/20] via 172.16.23.2, 00:00:18, Serial0/0/1
O E2    172.16.2.0 [175/20] via 172.16.23.2, 00:00:18, Serial0/0/1
O IA    172.16.100.0 [115/1563] via 172.16.23.2, 00:00:18, Serial0/0/1
O E2 192.168.70.0/24 [175/20] via 172.16.23.2, 00:00:18, Serial0/0/1
O    192.168.8.0/22 is a summary, 00:00:18, Null0
O E2 192.168.48.0/22 [175/20] via 172.16.23.2, 00:00:18, Serial0/0/1

R3#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.40.1
  It is an area border router
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Loopback0
    Loopback20
    Loopback25
    Loopback30
    Loopback35
    Loopback40
    Serial0/0/1
  Routing on Interfaces Configured Explicitly (Area 20):
    Loopback8
    Loopback9
    Loopback10
    Loopback11
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.40.1         110      00:00:29
    172.16.100.1         110      00:00:29
  Distance: (default is 105)  


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 192.168.40.0/24 [165/40537600] via 172.16.12.2, 00:05:14, Serial0/0/0
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [95/41024000] via 172.16.12.2, 00:05:14, Serial0/0/0
C       172.16.12.0 is directly connected, Serial0/0/0
C       172.16.1.0 is directly connected, Loopback0
D       172.16.2.0 [95/40640000] via 172.16.12.2, 00:05:14, Serial0/0/0
D EX    172.16.3.0 [165/40537600] via 172.16.12.2, 00:05:14, Serial0/0/0
D       172.16.100.0 [95/40640000] via 172.16.12.2, 00:05:14, Serial0/0/0
D EX 192.168.20.0/24 [165/40537600] via 172.16.12.2, 00:05:14, Serial0/0/0
C    192.168.51.0/24 is directly connected, Loopback51
C    192.168.50.0/24 is directly connected, Loopback50   
D EX 192.168.35.0/24 [165/40537600] via 172.16.12.2, 00:05:14, Serial0/0/0
C    192.168.49.0/24 is directly connected, Loopback49
C    192.168.70.0/24 is directly connected, Loopback70
C    192.168.48.0/24 is directly connected, Loopback48
D EX 192.168.8.0/22 [165/40537600] via 172.16.12.2, 00:05:16, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:39:22, Null0
D EX 192.168.48.0/22 [165/40537600] via 172.16.12.2, 00:05:10, Serial0/0/0


R1(config)#interface loopback 50
R1(config-if)#shutdown
*Dec 21 11:43:07.367: %LINK-5-CHANGED: Interface Loopback50, changed state to administratively down
*Dec 21 11:43:08.367: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback50, changed state to down

R1#show ip route     // 192.168.50.0/24 IS NOT IN ROUTING TABLE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 192.168.40.0/24 [165/40537600] via 172.16.12.2, 00:05:55, Serial0/0/0
     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.23.0 [95/41024000] via 172.16.12.2, 00:05:55, Serial0/0/0
C       172.16.12.0 is directly connected, Serial0/0/0
C       172.16.1.0 is directly connected, Loopback0
D       172.16.2.0 [95/40640000] via 172.16.12.2, 00:05:55, Serial0/0/0
D EX    172.16.3.0 [165/40537600] via 172.16.12.2, 00:05:55, Serial0/0/0
D       172.16.100.0 [95/40640000] via 172.16.12.2, 00:05:55, Serial0/0/0
D EX 192.168.20.0/24 [165/40537600] via 172.16.12.2, 00:05:55, Serial0/0/0
C    192.168.51.0/24 is directly connected, Loopback51
D EX 192.168.35.0/24 [165/40537600] via 172.16.12.2, 00:05:55, Serial0/0/0
C    192.168.49.0/24 is directly connected, Loopback49
C    192.168.70.0/24 is directly connected, Loopback70
C    192.168.48.0/24 is directly connected, Loopback48
D EX 192.168.8.0/22 [165/40537600] via 172.16.12.2, 00:06:17, Serial0/0/0
D    192.168.48.0/23 is a summary, 00:40:22, Null0
D EX 192.168.48.0/22 [165/40537600] via 172.16.12.2, 00:06:10, Serial0/0/0


R2#debug ip packet
IP packet debugging is on
*Dec 21 10:27:13.183: IP: tableid=0, s=0.0.0.0 (local), d=192.168.50.1 (Null0), routed via RIB
*Dec 21 10:27:13.183: IP: s=172.16.100.1 (local), d=192.168.50.1 (Null0), len 100, sending


R3#show ip route 192.168.50.1
Routing entry for 192.168.48.0/22, supernet  
  Known via "ospf 1", distance 175, metric 20, type extern 2, forward metric 1562
  Last update from 172.16.23.2 on Serial0/0/1, 00:06:21 ago
  Routing Descriptor Blocks:
  * 172.16.23.2, from 172.16.100.1, 00:06:21 ago, via Serial0/0/1
      Route metric is 20, traffic share count is 1

R3#debug ip icmp
ICMP packet debugging is on
R3#debug ip packet
IP packet debugging is on
R3#ping 192.1
*Dec 21 11:06:47.435: IP: s=172.16.23.3 (local), d=224.0.0.5 (Serial0/0/1), len 80, sending
broad/multicast
*Dec 21 11:06:47.435: IP: s=172.16.23.3 (local), d=224.0.0.5 (Serial0/0/1), len 80, sending full packet68.50.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
U  
*Dec 21 11:06:50.731: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending
*Dec 21 11:06:50.731: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending full
packet
*Dec 21 11:06:50.755: IP: s=172.16.23.2 (Serial0/0/1), d=172.16.23.3, len 56, input feature, MCI
Check(64), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Dec 21 11:06:50.755: IP: tableid=0, s=172.16.23.2 (Serial0/0/1), d=172.16.23.3 (Serial0/0/1), routed
via RIB
*Dec 21 11:06:50.755: IP: s=172.16.23.2 (Serial0/0/1), d=172.16.23.3 (Serial0/0/1), len 56, rcvd 3
*Dec 21 11:06:50.755: IP: s=172.16.23.2 (Serial0/0/1), d=172.16.23.3, len 56, stop process pak for
forus packet
*Dec 21 11:06:50.755: ICMP: dst (172.16.23.3) host unreachable rcv from 172.16.23.2   
*Dec 21 11:06:50.755: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending
*Dec 21 11:06:50.755: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending full
packet.U
*Dec 21 11:06:52.755: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending
*Dec 21 11:06:52.755: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending full
packet
*Dec 21 11:06:52.775: IP: s=172.16.23.2 (Serial0/0/1), d=172.16.23.3, len 56, input feature, MCI
Check(64), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Dec 21 11:06:52.779: IP: tableid=0, s=172.16.23.2 (Serial0/0/1), d=172.16.23.3 (Serial0/0/1), routed
via RIB
*Dec 21 11:06:52.779: IP: s=172.16.23.2 (Serial0/0/1), d=172.16.23.3 (Serial0/0/1), len 56, rcvd 3
*Dec 21 11:06:52.779: IP: s=172.16.23.2 (Serial0/0/1), d=172.16.23.3, len 56, stop process pak for
forus packet
*Dec 21 11:06:52.779: ICMP: dst (172.16.23.3) host unreachable rcv from 172.16.23.2
*Dec 21 11:06:52.779: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending
*Dec 21 11:06:52.779: IP: s=172.16.23.3 (local), d=192.168.50.1 (Serial0/0/1), len 100, sending full
packet
*Dec 21 11:06:53.223: IP: s=172.16.23.2 (Serial0/0/1), d=224.0.0.5, len 80, rcvd 0
*Dec 21 11:06:53.223: pak 65AA1980 consumed in input feature , packet consumed, MCI Check(64), rtype
0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE.U
Success rate is 0 percent (0/5)

R3#telnet 192.168.50.1
Trying 192.168.50.1 ...
% Destination unreachable; gateway or host down   // ROUTE BLACKHOLE ISSUE

No comments:

Post a Comment