I recently visited the "City of Smiles, Bangkok" for an IT project. I love their mangoes with sweet sticky rice and young coconut. Their mangoes is similar to our Philippine (Cebu) mangoes. I also noticed that you would see the image of their king scattered everywhere.
Back in my ROUTE lab, I did IP SLA and path control using tracking and floating static route. We've implemented this type of scenario at work for large sites that's dual-homed or have a secondary WAN link.
R1(config)#interface loopback0
R1(config-if)#
*Jan 1 01:32:43.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#description R1 LAN
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#interface s0/0/0
R1(config-if)#description R1 --> ISP1
R1(config-if)#ip address 209.165.201.2 255.255.255.252
R1(config-if)#clock rate 128000
R1(config-if)#bandwidth 128
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 01:33:46.195: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#interface s0/0/1
R1(config-if)#description R1 --> ISP2
R1(config-if)#ip address 209.165.202.130 255.255.255.252
R1(config-if)#bandwidth 128
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 01:34:24.539: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
ISP1(config)#interface loopback0
ISP1(config-if)#description
*Jan 1 00:17:19.591: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP1(config-if)#description Simulated Internet Web Server
ISP1(config-if)#ip address 209.165.200.254 255.255.255.255
ISP1(config-if)#interface loopback1
ISP1(config-if)#
*Jan 1 00:17:55.571: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
ISP1(config-if)#description ISP1 DNS Server
ISP1(config-if)#ip address 209.165.201.30 255.255.255.255
ISP1(config-if)#interface s0/0/0
ISP1(config-if)#description ISP1 --> R1
ISP1(config-if)#ip address 209.165.201.1 255.255.255.252
ISP1(config-if)#bandwidth 128
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 1 00:18:58.511: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 1 00:18:59.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ISP1(config-if)#do ping 209.165.201.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ISP1(config-if)#interface s0/0/1
ISP1(config-if)#description ISP1 --> ISP2
ISP1(config-if)#ip address 209.165.200.225 255.255.255.252
ISP1(config-if)#clock rate 128000
ISP1(config-if)#bandwidth 128
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 1 00:20:21.971: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 1 00:20:22.971: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
ISP2(config)#interface loopback0
ISP2(config-if)#
*Jan 1 00:58:26.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP2(config-if)#description Simulated Internet Web Server
ISP2(config-if)#ip address 209.165.200.254 255.255.255.255
ISP2(config-if)#interface loopback1
*Jan 1 00:58:59.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
ISP2(config-if)#description ISP2 DNS Server
ISP2(config-if)#ip address 209.165.202.158 255.255.255.255
ISP2(config-if)#interface s0/0/0
ISP2(config-if)#description ISP2 --> R1
ISP2(config-if)#ip address 209.165.202.129 255.255.255.252
ISP2(config-if)#clock rate 128000
ISP2(config-if)#bandwidth 128
ISP2(config-if)#no shutdown
ISP2(config-if)#
*Jan 1 00:59:59.771: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 1 01:00:00.771: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ISP2(config-if)#do ping 209.165.202.130
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.202.130, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ISP2(config-if)#interface s0/0/1
ISP2(config-if)#description ISP2 --> ISP1
ISP2(config-if)#ip address 209.165.200.226 255.255.255.252
ISP2(config-if)#bandwidth 128
ISP2(config-if)#no shutdown
ISP2(config-if)#do ping 209.165.200.225
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.200.225, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
R1#show interfaces description
Interface Status Protocol Description
Fa0/0 admin down down
Fa0/1 admin down down
Se0/0/0 up up R1 --> ISP1
Se0/0/1 up up R1 --> ISP2
Lo0 up up R1 LAN
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1
ISP1(config)#ip route 192.168.1.0 255.255.255.0 209.165.201.2
ISP1(config)#router eigrp 1
ISP1(config-router)#no auto-summary
ISP1(config-router)#network 209.165.200.224 0.0.0.3
ISP1(config-router)#network 209.165.201.0 0.0.0.31
ISP2(config)#ip route 192.168.1.0 255.255.255.0 209.165.202.130
ISP2(config)#router eigrp 1
ISP2(config-router)#no auto-summary
ISP2(config-router)#network 209.165.200.224 0.0.0.3
ISP2(config-router)#
*Jan 1 01:27:41.067: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 209.165.200.225 (Serial0/0/1) is up: new adjacency
ISP2(config-router)#network 209.165.202.128 0.0.0.31
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#209.165.200.254
+>(tcl)#209.165.201.30
+>(tcl)#209.165.202.158
+>(tcl)#} {
+>(tcl)#ping $address source 192.168.1.1
+>(tcl)#}
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.200.254, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.30, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.202.158, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#209.165.200.254
+>(tcl)#209.165.201.30
+>(tcl)#209.165.202.158
+>(tcl)#} {
+>(tcl)#trace $address source 192.168.1.1
+>(tcl)#}
Type escape sequence to abort.
Tracing the route to 209.165.200.254
1 209.165.201.1 8 msec 8 msec * // ALL TRACEROUTE GOES TO ISP1 HOP
Type escape sequence to abort.
Tracing the route to 209.165.201.30
1 209.165.201.1 8 msec 8 msec *
Type escape sequence to abort.
Tracing the route to 209.165.202.158
1 209.165.201.1 8 msec 8 msec 4 msec
2 209.165.200.226 12 msec 8 msec *
R1(config)#ip sla ?
<1-2147483647> Entry Number
enable Enable Event Notifications
ethernet-monitor IP SLAs Auto Ethernet configuration
group Group Configuration or Group Scheduling
key-chain Use MD5 authentication for IP SLAs Control Messages
logging Enable Syslog
low-memory Configure Low Water Memory Mark
reaction-configuration IP SLAs Reaction-Configuration
reaction-trigger IP SLAs Trigger Assignment
reset IP SLAs Reset
responder Enable IP SLAs Responder
restart Restart An Active Entry
schedule IP SLAs Entry Scheduling
R1(config)#ip sla 11
R1(config-ip-sla)#?
IP SLAs entry configuration commands:
dhcp DHCP Operation
dns DNS Query Operation
ethernet Ethernet Operations
exit Exit Operation Configuration
frame-relay Frame-relay Operation
ftp FTP Operation
http HTTP Operation
icmp-echo ICMP Echo Operation
icmp-jitter ICMP Jitter Operation
path-echo Path Discovered ICMP Echo Operation
path-jitter Path Discovered ICMP Jitter Operation
tcp-connect TCP Connect Operation
udp-echo UDP Echo Operation
udp-jitter UDP Jitter Operation
voip Voice Over IP Operation
R1(config-ip-sla)#icmp-echo ?
Hostname or A.B.C.D Destination IP address or hostname, broadcast disallowed
R1(config-ip-sla)#icmp-echo 209.165.201.30
R1(config-ip-sla-echo)#?
IP SLAs echo Configuration Commands:
default Set a command to its defaults
exit Exit operation configuration
frequency Frequency of an operation
history History and Distribution Data
no Negate a command or set its defaults
owner Owner of Entry
request-data-size Request data size
tag User defined tag
threshold Operation threshold in milliseconds
timeout Timeout of an operation
tos Type Of Service
verify-data Verify data
vrf Configure IP SLAs for a VPN Routing/Forwarding instance
R1(config-ip-sla-echo)#frequency ?
<1-604800> Frequency in seconds (default 60)
R1(config-ip-sla-echo)#frequency 10
R1(config-ip-sla-echo)#exit
R1(config)#ip sla ?
<1-2147483647> Entry Number
enable Enable Event Notifications
ethernet-monitor IP SLAs Auto Ethernet configuration
group Group Configuration or Group Scheduling
key-chain Use MD5 authentication for IP SLAs Control Messages
logging Enable Syslog
low-memory Configure Low Water Memory Mark
reaction-configuration IP SLAs Reaction-Configuration
reaction-trigger IP SLAs Trigger Assignment
reset IP SLAs Reset
responder Enable IP SLAs Responder
restart Restart An Active Entry
schedule IP SLAs Entry Scheduling
R1(config)#ip sla schedule ?
<1-2147483647> Entry number
R1(config)#ip sla schedule 11 ?
ageout How long to keep this Entry when inactive
life Length of time to execute in seconds
recurring Probe to be scheduled automatically every day
start-time When to start this entry
<cr>
R1(config)#ip sla schedule 11 life ?
<0-2147483647> Life seconds (default 3600)
forever continue running forever
R1(config)#ip sla schedule 11 life forever ?
ageout How long to keep this Entry when inactive
recurring Probe to be scheduled automatically every day
start-time When to start this entry
<cr>
R1(config)#ip sla schedule 11 life forever start-time ?
after Start after a certain amount of time from now
hh:mm Start time (hh:mm)
hh:mm:ss Start time (hh:mm:ss)
now Start now
pending Start pending
R1(config)#ip sla schedule 11 life forever start-time now
R1#show ip sla ?
application IP SLAs Application
authentication IP SLAs Authentication Information
auto Auto IP SLAs show commands
configuration IP SLAs Configuration
enhanced-history IP SLAs Enhanced History
ethernet-monitor IP SLAs Auto Ethernet Monitor
event-publisher IP SLAs Event Publisher
group IP SLAs Group Scheduling/Configuration
history IP SLAs History
reaction-configuration IP SLAs Reaction Configuration
reaction-trigger IP SLAs Reaction Trigger
responder IP SLAs Responder Information
statistics IP SLAs Statistics
R1#show ip sla configuration ?
<1-2147483647> Entry Number
| Output modifiers
<cr>
R1#show ip sla configuration 11
IP SLAs, Infrastructure Engine-II.
Entry number: 11
Owner:
Tag:
Type of operation to perform: icmp-echo
Target address/Source address: 209.165.201.30/0.0.0.0
Type Of Service parameter: 0x0
Request size (ARR data portion): 28
Operation timeout (milliseconds): 5000
Verify data: No
Vrf Name:
Schedule:
Operation frequency (seconds): 10 (not considered if randomly scheduled)
Next Scheduled Start Time: Start Time already passed
Group Scheduled : FALSE
Randomly Scheduled : FALSE
Life (seconds): Forever
Entry Ageout (seconds): never
Recurring (Starting Everyday): FALSE
Status of entry (SNMP RowStatus): Active
Threshold (milliseconds): 5000 (not considered if react RTT is configured)
Distribution Statistics:
Number of statistic hours kept: 2
Number of statistic distribution buckets kept: 1
Statistic distribution interval (milliseconds): 20
History Statistics:
Number of history Lives kept: 0
Number of history Buckets kept: 15
History Filter Type: None
Enhanced History:
R1#show ip sla statistics
IPSLAs Latest Operation Statistics
IPSLA operation id: 11
Type of operation: icmp-echo
Latest RTT: 7 milliseconds
Latest operation start time: *02:29:26.851 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 19
Number of failures: 0
Operation time to live: Forever
R1(config)#ip sla 22
R1(config-ip-sla)#icmp-echo 209.165.202.158 // ISP2 DNS
R1(config-ip-sla-echo)#frequency 10
R1(config-ip-sla-echo)#exit
R1(config)#ip sla schedule 22 life forever start-time now
R1#show ip sla configuration 22
IP SLAs, Infrastructure Engine-II.
Entry number: 22
Owner:
Tag:
Type of operation to perform: icmp-echo
Target address/Source address: 209.165.202.158/0.0.0.0
Type Of Service parameter: 0x0
Request size (ARR data portion): 28
Operation timeout (milliseconds): 5000
Verify data: No
Vrf Name:
Schedule:
Operation frequency (seconds): 10 (not considered if randomly scheduled)
Next Scheduled Start Time: Start Time already passed
Group Scheduled : FALSE
Randomly Scheduled : FALSE
Life (seconds): Forever
Entry Ageout (seconds): never
Recurring (Starting Everyday): FALSE
Status of entry (SNMP RowStatus): Active
Threshold (milliseconds): 5000 (not considered if react RTT is configured)
Distribution Statistics:
Number of statistic hours kept: 2
Number of statistic distribution buckets kept: 1
Statistic distribution interval (milliseconds): 20
History Statistics:
Number of history Lives kept: 0
Number of history Buckets kept: 15
History Filter Type: None
Enhanced History:
R1#show ip sla statistics 22
IPSLAs Latest Operation Statistics
IPSLA operation id: 22
Type of operation: icmp-echo
Latest RTT: 16 milliseconds
Latest operation start time: *02:31:35.067 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 6
Number of failures: 0
Operation time to live: Forever
R1(config)#no ip route 0.0.0.0 0.0.0.0 209.165.201.1
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 ?
<1-255> Distance metric for this route
name Specify name of the next hop
permanent permanent route
tag Set tag for this route
track Install route depending on tracked item
<cr>
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 5 // FLOATING STATIC ROUTE WITH AD OF 5
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [5/0] via 209.165.201.1
R1(config)#track ?
<1-500> Tracked object
resolution Tracking resolution parameters
timer Polling interval timers
R1(config)#track 1 ?
application Application
interface Select an interface to track
ip IP protocol
list Group objects in a list
stub-object Stub tracking object
R1(config)#track 1 ip ?
route IP route
sla IP Service Level Agreement
R1(config)#track 1 ip sla ?
<1-2147483647> Entry number
R1(config)#track 1 ip sla 11 ?
reachability Reachability
state Return code state
<cr>
R1(config)#track 1 ip sla 11 reachability
R1(config-track)#?
Tracking instance configuration commands:
default Set a command to its defaults
default-state Default object state
delay Tracking delay
exit Exit from tracking configuration mode
no Negate a command or set its defaults
R1(config-track)#delay ?
down Delay down change notification
up Delay up change notification
R1(config-track)#delay down ?
<0-180> Seconds to delay
R1(config-track)#delay down 10 up ?
<0-180> Seconds to delay
R1(config-track)#delay down 10 up 1
R1#debug ip routing // DEBUG ROUTING CHANGES
IP routing debugging is on
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 2 ?
name Specify name of the next hop
permanent permanent route
tag Set tag for this route
track Install route depending on tracked item
<cr>
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 2 track 1
R1(config)#
*Jan 1 02:36:57.055: RT: closer admin distance for 0.0.0.0, flushing 1 routes
*Jan 1 02:36:57.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:36:57.055: RT: add 0.0.0.0/0 via 209.165.201.1, static metric [2/0]
*Jan 1 02:36:57.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:36:57.055: RT: default path is now 0.0.0.0 via 209.165.201.1
*Jan 1 02:36:57.055: RT: new default network 0.0.0.0
*Jan 1 02:36:57.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:37:02.055: RT: NET-RED 0.0.0.0/0
R1(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [2/0] via 209.165.201.1 // ROUTE WITH BETTER (LOWER) AD OF 2
R1(config)#track 2 ip sla 22 reachability
R1(config-track)#delay down 10 up 1
R1(config-track)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.202.129 3 track 2
R1(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [2/0] via 209.165.201.1 // AD OF 2 IS BETTER THAN AD OF 3
ISP1(config)#interface loopback1
ISP1(config-if)#shutdown
ISP1(config-if)#
*Jan 1 01:27:38.019: %LINK-5-CHANGED: Interface Loopback1, changed state to administratively down
*Jan 1 01:27:39.019: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to down
R1#show debug
IP routing:
IP routing debugging is on
R1#
*Jan 1 02:45:28.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: %TRACKING-5-STATE: 1 ip sla 11 reachability Up->Down
*Jan 1 02:45:49.559: RT: del 0.0.0.0 via 209.165.201.1, static metric [2/0] // DELETES DEFAULT ROUTE WITH AD OF 2
*Jan 1 02:45:49.559: RT: delete network route to 0.0.0.0
*Jan 1 02:45:49.559: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: RT: add 0.0.0.0/0 via 209.165.202.129, static metric [3/0] // INSTALLS NEXT HIGHEST DEFAULT ROUTE TO ISP2 WITH AD OF 3
*Jan 1 02:45:49.559: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: RT: default path is now 0.0.0.0 via 209.165.202.129
*Jan 1 02:45:49.563: RT: new default network 0.0.0.0
*Jan 1 02:45:49.563: RT: NET-RED 0.0.0.0/0
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.202.129 to network 0.0.0.0
C 1.0.0.0/8 is directly connected, FastEthernet0/0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [3/0] via 209.165.202.129
R1#show ip sla statistics
IPSLAs Latest Operation Statistics
IPSLA operation id: 11
Type of operation: icmp-echo
Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *02:47:46.851 UTC Thu Jan 1 2015
Latest operation return code: No connection
Number of successes: 113
Number of failures: 16
Operation time to live: Forever
IPSLA operation id: 22
Type of operation: icmp-echo
Latest RTT: 7 milliseconds
Latest operation start time: *02:47:55.063 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 102
Number of failures: 2
Operation time to live: Forever
R1#traceroute 209.165.200.254 source 192.168.1.1
Type escape sequence to abort.
Tracing the route to 209.165.200.254
1 209.165.202.129 8 msec 8 msec * // R1 HOPS TO ISP2 TO REACH ISP1 WEB SERVER
ISP1(config)#interface loopback1
ISP1(config-if)#no shutdown
*Jan 1 01:32:08.915: %LINK-3-UPDOWN: Interface Loopback1, changed state to up
*Jan 1 01:32:09.915: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1#
*Jan 1 02:49:28.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:10.579: %TRACKING-5-STATE: 1 ip sla 11 reachability Down->Up
*Jan 1 02:50:10.579: RT: closer admin distance for 0.0.0.0, flushing 1 routes
*Jan 1 02:50:10.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:10.579: RT: add 0.0.0.0/0 via 209.165.201.1, static metric [2/0]
*Jan 1 02:50:10.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:10.579: RT: default path is now 0.0.0.0 via 209.165.201.1 // DEFAULT STATIC ROUTE IS BACK TO ISP1 WITH AD OF 2
*Jan 1 02:50:10.579: RT: new default network 0.0.0.0
*Jan 1 02:50:10.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:15.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:28.055: RT: NET-RED 0.0.0.0/0
R1#show ip sla statistics
IPSLAs Latest Operation Statistics
IPSLA operation id: 11
Type of operation: icmp-echo
Latest RTT: 8 milliseconds
Latest operation start time: *02:51:16.851 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 121
Number of failures: 29
Operation time to live: Forever
IPSLA operation id: 22
Type of operation: icmp-echo
Latest RTT: 16 milliseconds
Latest operation start time: *02:51:25.063 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 123
Number of failures: 2
Operation time to live: Forever
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
C 1.0.0.0/8 is directly connected, FastEthernet0/0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [2/0] via 209.165.201.1
R1(config-if)#
*Jan 1 01:32:43.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#description R1 LAN
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#interface s0/0/0
R1(config-if)#description R1 --> ISP1
R1(config-if)#ip address 209.165.201.2 255.255.255.252
R1(config-if)#clock rate 128000
R1(config-if)#bandwidth 128
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 01:33:46.195: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)#interface s0/0/1
R1(config-if)#description R1 --> ISP2
R1(config-if)#ip address 209.165.202.130 255.255.255.252
R1(config-if)#bandwidth 128
R1(config-if)#no shutdown
R1(config-if)#
*Jan 1 01:34:24.539: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
ISP1(config)#interface loopback0
ISP1(config-if)#description
*Jan 1 00:17:19.591: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP1(config-if)#description Simulated Internet Web Server
ISP1(config-if)#ip address 209.165.200.254 255.255.255.255
ISP1(config-if)#interface loopback1
ISP1(config-if)#
*Jan 1 00:17:55.571: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
ISP1(config-if)#description ISP1 DNS Server
ISP1(config-if)#ip address 209.165.201.30 255.255.255.255
ISP1(config-if)#interface s0/0/0
ISP1(config-if)#description ISP1 --> R1
ISP1(config-if)#ip address 209.165.201.1 255.255.255.252
ISP1(config-if)#bandwidth 128
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 1 00:18:58.511: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 1 00:18:59.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ISP1(config-if)#do ping 209.165.201.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ISP1(config-if)#interface s0/0/1
ISP1(config-if)#description ISP1 --> ISP2
ISP1(config-if)#ip address 209.165.200.225 255.255.255.252
ISP1(config-if)#clock rate 128000
ISP1(config-if)#bandwidth 128
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 1 00:20:21.971: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 1 00:20:22.971: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
ISP2(config)#interface loopback0
ISP2(config-if)#
*Jan 1 00:58:26.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP2(config-if)#description Simulated Internet Web Server
ISP2(config-if)#ip address 209.165.200.254 255.255.255.255
ISP2(config-if)#interface loopback1
*Jan 1 00:58:59.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
ISP2(config-if)#description ISP2 DNS Server
ISP2(config-if)#ip address 209.165.202.158 255.255.255.255
ISP2(config-if)#interface s0/0/0
ISP2(config-if)#description ISP2 --> R1
ISP2(config-if)#ip address 209.165.202.129 255.255.255.252
ISP2(config-if)#clock rate 128000
ISP2(config-if)#bandwidth 128
ISP2(config-if)#no shutdown
ISP2(config-if)#
*Jan 1 00:59:59.771: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 1 01:00:00.771: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ISP2(config-if)#do ping 209.165.202.130
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.202.130, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ISP2(config-if)#interface s0/0/1
ISP2(config-if)#description ISP2 --> ISP1
ISP2(config-if)#ip address 209.165.200.226 255.255.255.252
ISP2(config-if)#bandwidth 128
ISP2(config-if)#no shutdown
ISP2(config-if)#do ping 209.165.200.225
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.200.225, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
R1#show interfaces description
Interface Status Protocol Description
Fa0/0 admin down down
Fa0/1 admin down down
Se0/0/0 up up R1 --> ISP1
Se0/0/1 up up R1 --> ISP2
Lo0 up up R1 LAN
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1
ISP1(config)#ip route 192.168.1.0 255.255.255.0 209.165.201.2
ISP1(config)#router eigrp 1
ISP1(config-router)#no auto-summary
ISP1(config-router)#network 209.165.200.224 0.0.0.3
ISP1(config-router)#network 209.165.201.0 0.0.0.31
ISP2(config)#ip route 192.168.1.0 255.255.255.0 209.165.202.130
ISP2(config)#router eigrp 1
ISP2(config-router)#no auto-summary
ISP2(config-router)#network 209.165.200.224 0.0.0.3
ISP2(config-router)#
*Jan 1 01:27:41.067: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 209.165.200.225 (Serial0/0/1) is up: new adjacency
ISP2(config-router)#network 209.165.202.128 0.0.0.31
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#209.165.200.254
+>(tcl)#209.165.201.30
+>(tcl)#209.165.202.158
+>(tcl)#} {
+>(tcl)#ping $address source 192.168.1.1
+>(tcl)#}
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.200.254, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.30, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.202.158, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#209.165.200.254
+>(tcl)#209.165.201.30
+>(tcl)#209.165.202.158
+>(tcl)#} {
+>(tcl)#trace $address source 192.168.1.1
+>(tcl)#}
Type escape sequence to abort.
Tracing the route to 209.165.200.254
1 209.165.201.1 8 msec 8 msec * // ALL TRACEROUTE GOES TO ISP1 HOP
Type escape sequence to abort.
Tracing the route to 209.165.201.30
1 209.165.201.1 8 msec 8 msec *
Type escape sequence to abort.
Tracing the route to 209.165.202.158
1 209.165.201.1 8 msec 8 msec 4 msec
2 209.165.200.226 12 msec 8 msec *
R1(config)#ip sla ?
<1-2147483647> Entry Number
enable Enable Event Notifications
ethernet-monitor IP SLAs Auto Ethernet configuration
group Group Configuration or Group Scheduling
key-chain Use MD5 authentication for IP SLAs Control Messages
logging Enable Syslog
low-memory Configure Low Water Memory Mark
reaction-configuration IP SLAs Reaction-Configuration
reaction-trigger IP SLAs Trigger Assignment
reset IP SLAs Reset
responder Enable IP SLAs Responder
restart Restart An Active Entry
schedule IP SLAs Entry Scheduling
R1(config)#ip sla 11
R1(config-ip-sla)#?
IP SLAs entry configuration commands:
dhcp DHCP Operation
dns DNS Query Operation
ethernet Ethernet Operations
exit Exit Operation Configuration
frame-relay Frame-relay Operation
ftp FTP Operation
http HTTP Operation
icmp-echo ICMP Echo Operation
icmp-jitter ICMP Jitter Operation
path-echo Path Discovered ICMP Echo Operation
path-jitter Path Discovered ICMP Jitter Operation
tcp-connect TCP Connect Operation
udp-echo UDP Echo Operation
udp-jitter UDP Jitter Operation
voip Voice Over IP Operation
R1(config-ip-sla)#icmp-echo ?
Hostname or A.B.C.D Destination IP address or hostname, broadcast disallowed
R1(config-ip-sla)#icmp-echo 209.165.201.30
R1(config-ip-sla-echo)#?
IP SLAs echo Configuration Commands:
default Set a command to its defaults
exit Exit operation configuration
frequency Frequency of an operation
history History and Distribution Data
no Negate a command or set its defaults
owner Owner of Entry
request-data-size Request data size
tag User defined tag
threshold Operation threshold in milliseconds
timeout Timeout of an operation
tos Type Of Service
verify-data Verify data
vrf Configure IP SLAs for a VPN Routing/Forwarding instance
R1(config-ip-sla-echo)#frequency ?
<1-604800> Frequency in seconds (default 60)
R1(config-ip-sla-echo)#frequency 10
R1(config-ip-sla-echo)#exit
R1(config)#ip sla ?
<1-2147483647> Entry Number
enable Enable Event Notifications
ethernet-monitor IP SLAs Auto Ethernet configuration
group Group Configuration or Group Scheduling
key-chain Use MD5 authentication for IP SLAs Control Messages
logging Enable Syslog
low-memory Configure Low Water Memory Mark
reaction-configuration IP SLAs Reaction-Configuration
reaction-trigger IP SLAs Trigger Assignment
reset IP SLAs Reset
responder Enable IP SLAs Responder
restart Restart An Active Entry
schedule IP SLAs Entry Scheduling
R1(config)#ip sla schedule ?
<1-2147483647> Entry number
R1(config)#ip sla schedule 11 ?
ageout How long to keep this Entry when inactive
life Length of time to execute in seconds
recurring Probe to be scheduled automatically every day
start-time When to start this entry
<cr>
R1(config)#ip sla schedule 11 life ?
<0-2147483647> Life seconds (default 3600)
forever continue running forever
R1(config)#ip sla schedule 11 life forever ?
ageout How long to keep this Entry when inactive
recurring Probe to be scheduled automatically every day
start-time When to start this entry
<cr>
R1(config)#ip sla schedule 11 life forever start-time ?
after Start after a certain amount of time from now
hh:mm Start time (hh:mm)
hh:mm:ss Start time (hh:mm:ss)
now Start now
pending Start pending
R1(config)#ip sla schedule 11 life forever start-time now
R1#show ip sla ?
application IP SLAs Application
authentication IP SLAs Authentication Information
auto Auto IP SLAs show commands
configuration IP SLAs Configuration
enhanced-history IP SLAs Enhanced History
ethernet-monitor IP SLAs Auto Ethernet Monitor
event-publisher IP SLAs Event Publisher
group IP SLAs Group Scheduling/Configuration
history IP SLAs History
reaction-configuration IP SLAs Reaction Configuration
reaction-trigger IP SLAs Reaction Trigger
responder IP SLAs Responder Information
statistics IP SLAs Statistics
R1#show ip sla configuration ?
<1-2147483647> Entry Number
| Output modifiers
<cr>
R1#show ip sla configuration 11
IP SLAs, Infrastructure Engine-II.
Entry number: 11
Owner:
Tag:
Type of operation to perform: icmp-echo
Target address/Source address: 209.165.201.30/0.0.0.0
Type Of Service parameter: 0x0
Request size (ARR data portion): 28
Operation timeout (milliseconds): 5000
Verify data: No
Vrf Name:
Schedule:
Operation frequency (seconds): 10 (not considered if randomly scheduled)
Next Scheduled Start Time: Start Time already passed
Group Scheduled : FALSE
Randomly Scheduled : FALSE
Life (seconds): Forever
Entry Ageout (seconds): never
Recurring (Starting Everyday): FALSE
Status of entry (SNMP RowStatus): Active
Threshold (milliseconds): 5000 (not considered if react RTT is configured)
Distribution Statistics:
Number of statistic hours kept: 2
Number of statistic distribution buckets kept: 1
Statistic distribution interval (milliseconds): 20
History Statistics:
Number of history Lives kept: 0
Number of history Buckets kept: 15
History Filter Type: None
Enhanced History:
R1#show ip sla statistics
IPSLAs Latest Operation Statistics
IPSLA operation id: 11
Type of operation: icmp-echo
Latest RTT: 7 milliseconds
Latest operation start time: *02:29:26.851 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 19
Number of failures: 0
Operation time to live: Forever
R1(config)#ip sla 22
R1(config-ip-sla)#icmp-echo 209.165.202.158 // ISP2 DNS
R1(config-ip-sla-echo)#frequency 10
R1(config-ip-sla-echo)#exit
R1(config)#ip sla schedule 22 life forever start-time now
R1#show ip sla configuration 22
IP SLAs, Infrastructure Engine-II.
Entry number: 22
Owner:
Tag:
Type of operation to perform: icmp-echo
Target address/Source address: 209.165.202.158/0.0.0.0
Type Of Service parameter: 0x0
Request size (ARR data portion): 28
Operation timeout (milliseconds): 5000
Verify data: No
Vrf Name:
Schedule:
Operation frequency (seconds): 10 (not considered if randomly scheduled)
Next Scheduled Start Time: Start Time already passed
Group Scheduled : FALSE
Randomly Scheduled : FALSE
Life (seconds): Forever
Entry Ageout (seconds): never
Recurring (Starting Everyday): FALSE
Status of entry (SNMP RowStatus): Active
Threshold (milliseconds): 5000 (not considered if react RTT is configured)
Distribution Statistics:
Number of statistic hours kept: 2
Number of statistic distribution buckets kept: 1
Statistic distribution interval (milliseconds): 20
History Statistics:
Number of history Lives kept: 0
Number of history Buckets kept: 15
History Filter Type: None
Enhanced History:
R1#show ip sla statistics 22
IPSLAs Latest Operation Statistics
IPSLA operation id: 22
Type of operation: icmp-echo
Latest RTT: 16 milliseconds
Latest operation start time: *02:31:35.067 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 6
Number of failures: 0
Operation time to live: Forever
R1(config)#no ip route 0.0.0.0 0.0.0.0 209.165.201.1
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 ?
<1-255> Distance metric for this route
name Specify name of the next hop
permanent permanent route
tag Set tag for this route
track Install route depending on tracked item
<cr>
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 5 // FLOATING STATIC ROUTE WITH AD OF 5
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [5/0] via 209.165.201.1
R1(config)#track ?
<1-500> Tracked object
resolution Tracking resolution parameters
timer Polling interval timers
R1(config)#track 1 ?
application Application
interface Select an interface to track
ip IP protocol
list Group objects in a list
stub-object Stub tracking object
R1(config)#track 1 ip ?
route IP route
sla IP Service Level Agreement
R1(config)#track 1 ip sla ?
<1-2147483647> Entry number
R1(config)#track 1 ip sla 11 ?
reachability Reachability
state Return code state
<cr>
R1(config)#track 1 ip sla 11 reachability
R1(config-track)#?
Tracking instance configuration commands:
default Set a command to its defaults
default-state Default object state
delay Tracking delay
exit Exit from tracking configuration mode
no Negate a command or set its defaults
R1(config-track)#delay ?
down Delay down change notification
up Delay up change notification
R1(config-track)#delay down ?
<0-180> Seconds to delay
R1(config-track)#delay down 10 up ?
<0-180> Seconds to delay
R1(config-track)#delay down 10 up 1
R1#debug ip routing // DEBUG ROUTING CHANGES
IP routing debugging is on
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 2 ?
name Specify name of the next hop
permanent permanent route
tag Set tag for this route
track Install route depending on tracked item
<cr>
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.1 2 track 1
R1(config)#
*Jan 1 02:36:57.055: RT: closer admin distance for 0.0.0.0, flushing 1 routes
*Jan 1 02:36:57.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:36:57.055: RT: add 0.0.0.0/0 via 209.165.201.1, static metric [2/0]
*Jan 1 02:36:57.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:36:57.055: RT: default path is now 0.0.0.0 via 209.165.201.1
*Jan 1 02:36:57.055: RT: new default network 0.0.0.0
*Jan 1 02:36:57.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:37:02.055: RT: NET-RED 0.0.0.0/0
R1(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [2/0] via 209.165.201.1 // ROUTE WITH BETTER (LOWER) AD OF 2
R1(config)#track 2 ip sla 22 reachability
R1(config-track)#delay down 10 up 1
R1(config-track)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 209.165.202.129 3 track 2
R1(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [2/0] via 209.165.201.1 // AD OF 2 IS BETTER THAN AD OF 3
ISP1(config)#interface loopback1
ISP1(config-if)#shutdown
ISP1(config-if)#
*Jan 1 01:27:38.019: %LINK-5-CHANGED: Interface Loopback1, changed state to administratively down
*Jan 1 01:27:39.019: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to down
R1#show debug
IP routing:
IP routing debugging is on
R1#
*Jan 1 02:45:28.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: %TRACKING-5-STATE: 1 ip sla 11 reachability Up->Down
*Jan 1 02:45:49.559: RT: del 0.0.0.0 via 209.165.201.1, static metric [2/0] // DELETES DEFAULT ROUTE WITH AD OF 2
*Jan 1 02:45:49.559: RT: delete network route to 0.0.0.0
*Jan 1 02:45:49.559: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: RT: add 0.0.0.0/0 via 209.165.202.129, static metric [3/0] // INSTALLS NEXT HIGHEST DEFAULT ROUTE TO ISP2 WITH AD OF 3
*Jan 1 02:45:49.559: RT: NET-RED 0.0.0.0/0
*Jan 1 02:45:49.559: RT: default path is now 0.0.0.0 via 209.165.202.129
*Jan 1 02:45:49.563: RT: new default network 0.0.0.0
*Jan 1 02:45:49.563: RT: NET-RED 0.0.0.0/0
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.202.129 to network 0.0.0.0
C 1.0.0.0/8 is directly connected, FastEthernet0/0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [3/0] via 209.165.202.129
R1#show ip sla statistics
IPSLAs Latest Operation Statistics
IPSLA operation id: 11
Type of operation: icmp-echo
Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *02:47:46.851 UTC Thu Jan 1 2015
Latest operation return code: No connection
Number of successes: 113
Number of failures: 16
Operation time to live: Forever
IPSLA operation id: 22
Type of operation: icmp-echo
Latest RTT: 7 milliseconds
Latest operation start time: *02:47:55.063 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 102
Number of failures: 2
Operation time to live: Forever
R1#traceroute 209.165.200.254 source 192.168.1.1
Type escape sequence to abort.
Tracing the route to 209.165.200.254
1 209.165.202.129 8 msec 8 msec * // R1 HOPS TO ISP2 TO REACH ISP1 WEB SERVER
ISP1(config)#interface loopback1
ISP1(config-if)#no shutdown
*Jan 1 01:32:08.915: %LINK-3-UPDOWN: Interface Loopback1, changed state to up
*Jan 1 01:32:09.915: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1#
*Jan 1 02:49:28.055: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:10.579: %TRACKING-5-STATE: 1 ip sla 11 reachability Down->Up
*Jan 1 02:50:10.579: RT: closer admin distance for 0.0.0.0, flushing 1 routes
*Jan 1 02:50:10.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:10.579: RT: add 0.0.0.0/0 via 209.165.201.1, static metric [2/0]
*Jan 1 02:50:10.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:10.579: RT: default path is now 0.0.0.0 via 209.165.201.1 // DEFAULT STATIC ROUTE IS BACK TO ISP1 WITH AD OF 2
*Jan 1 02:50:10.579: RT: new default network 0.0.0.0
*Jan 1 02:50:10.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:15.579: RT: NET-RED 0.0.0.0/0
*Jan 1 02:50:28.055: RT: NET-RED 0.0.0.0/0
R1#show ip sla statistics
IPSLAs Latest Operation Statistics
IPSLA operation id: 11
Type of operation: icmp-echo
Latest RTT: 8 milliseconds
Latest operation start time: *02:51:16.851 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 121
Number of failures: 29
Operation time to live: Forever
IPSLA operation id: 22
Type of operation: icmp-echo
Latest RTT: 16 milliseconds
Latest operation start time: *02:51:25.063 UTC Thu Jan 1 2015
Latest operation return code: OK
Number of successes: 123
Number of failures: 2
Operation time to live: Forever
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 209.165.201.1 to network 0.0.0.0
C 1.0.0.0/8 is directly connected, FastEthernet0/0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
209.165.202.0/30 is subnetted, 1 subnets
C 209.165.202.128 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [2/0] via 209.165.201.1
No comments:
Post a Comment