We've deployed BGP route reflectors globally in our enterprise. For each region (ours is APAC), we installed two Cisco ASR-1002X as BGP route reflectors (the other one for redundancy). These beefy routers can easily hold thousands of megabytes of public Internet routes. This also makes our IBGP config smaller and more scalable since it doesn't need a full mesh on all IBGP peers.
I did a route reflector lab for CCNP ROUTE. I got a bit intimated doing this lab since BGP isn't my strong point but while I was already doing the configuration, it's not so bad after all. It's just a matter of having a good solid BGP foundation (from my ISP job background) that I was able to pull this off.
SanJose1(config)#interface s0/0/0
SanJose1(config-if)#ip address 192.168.1.5 255.255.255.252
SanJose1(config-if)#clock rate 128000
SanJose1(config-if)#no shutdown
SanJose1(config-if)#
*Jan 3 15:34:53.515: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
SanJose2(config)#interface loopback0
SanJose2(config-if)#
*Jan 3 14:17:39.863: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
SanJose2(config-if)#ip address 10.2.2.1 255.255.255.0
SanJose2(config-if)#interface s0/0/0
SanJose2(config-if)#ip address 192.168.1.6 255.255.255.252
SanJose2(config-if)#no shutdown
SanJose2(config-if)#
*Jan 3 14:18:14.847: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 3 14:18:15.847: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
SanJose2(config-if)#do ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
SanJose2(config-if)#interface s0/0/1
SanJose2(config-if)#ip address 172.24.1.17 255.255.255.0
SanJose2(config-if)#clock rate 128000
SanJose2(config-if)#no shutdown
SanJose2(config-if)#
*Jan 3 14:18:44.299: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 3 14:18:45.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
SanJose3(config)#interface s0/0/1
SanJose3(config-if)#ip address 172.24.1.18 255.255.255.0
SanJose3(config-if)#no shutdown
SanJose3(config-if)#do ping 172.24.1.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
SanJose1(config)#router rip
SanJose1(config-router)#version 2
SanJose1(config-router)#no auto-summary
SanJose1(config-router)#network 192.168.1.0
SanJose2(config)#router rip
SanJose2(config-router)#version 2
SanJose2(config-router)#no auto-summary
SanJose2(config-router)#network 172.24.0.0
SanJose2(config-router)#network 192.168.1.0
SanJose2(config-router)#network 10.0.0.0
SanJose3(config)#router rip
SanJose3(config-router)#version 2
SanJose3(config-router)#no auto-summary
SanJose3(config-router)#network 172.24.0.0
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:06, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:06, Serial0/0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose1#tclsh
SanJose1(tcl)#foreach address {
+>10.2.2.1
+>192.168.1.5
+>192.168.1.6
+>172.24.1.17
+>172.24.1.18
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
SanJose2(config)#router bgp 100
SanJose2(config-router)#neighbor 192.168.1.5 remote-as 100
SanJose2(config-router)#neighbor 172.24.1.18 remote-as 100
SanJose1(config)#router bgp 100
SanJose1(config-router)#neighbor 192.168.1.6 remote-as 100
SanJose1(config-router)#
*Jan 3 15:44:53.379: %BGP-5-ADJCHANGE: neighbor 192.168.1.6 Up
SanJose3(config)#router bgp 100
SanJose3(config-router)#neighbor 172.24.1.17 remote-as 100
SanJose3(config-router)#
*Jan 3 15:04:45.779: %BGP-5-ADJCHANGE: neighbor 172.24.1.17 Up
SanJose2#show ip bgp neighbors
BGP neighbor is 172.24.1.18, remote AS 100, internal link
BGP version 4, remote router ID 172.24.1.18
BGP state = Established, up for 00:00:52
Last read 00:00:52, last write 00:00:52, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 1 1
Route Refresh: 0 0
Total: 2 2
Default minimum time between advertisement runs is 0 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 0/0
Output queue size : 0
Index 2, Offset 0, Mask 0x4
2 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 0 0
Prefixes Total: 0 0
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 0, min 0
Address tracking is enabled, the RIB does have a route to 172.24.1.18
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 172.24.1.17, Local port: 179
Foreign host: 172.24.1.18, Foreign port: 14628
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x12422C):
Timer Starts Wakeups Next
Retrans 4 0 0x0
TimeWait 0 0 0x0
AckHold 3 2 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 1760080277 snduna: 1760080369 sndnxt: 1760080369 sndwnd: 16293
irs: 615136447 rcvnxt: 615136539 rcvwnd: 16293 delrcvwnd: 91
SRTT: 124 ms, RTTO: 1405 ms, RTV: 1281 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 7 (out of order: 0), with data: 3, total data bytes: 91
Sent: 6 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 3, total
data bytes: 91
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
BGP neighbor is 192.168.1.5, remote AS 100, internal link
BGP version 4, remote router ID 192.168.1.5
BGP state = Established, up for 00:01:29
Last read 00:00:39, last write 00:00:31, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 2 2
Route Refresh: 0 0
Total: 3 3
Default minimum time between advertisement runs is 0 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 2, Offset 0, Mask 0x4
2 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 0 0
Prefixes Total: 0 0
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 0, min 0
Address tracking is enabled, the RIB does have a route to 192.168.1.5
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 192.168.1.6, Local port: 51613
Foreign host: 192.168.1.5, Foreign port: 179
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x1259B8):
Timer Starts Wakeups Next
Retrans 4 0 0x0
TimeWait 0 0 0x0
AckHold 3 2 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 1 0 0x1A18C8
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 235163843 snduna: 235163935 sndnxt: 235163935 sndwnd: 16293
irs: 61301986 rcvnxt: 61302078 rcvwnd: 16293 delrcvwnd: 91
SRTT: 124 ms, RTTO: 1405 ms, RTV: 1281 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: active open
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 6 (out of order: 0), with data: 3, total data bytes: 91
Sent: 7 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 3, total
data bytes: 91
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
SanJose3(config)#interface loopback0
SanJose3(config-if)#
*Jan 3 15:07:07.631: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
SanJose3(config-if)#ip address 198.133.219.1 255.255.255.0
SanJose3(config-if)#exit
SanJose3(config)#router bgp 100
SanJose3(config-router)#network 198.133.219.0 // ADVERTISE LOOPBACK INTO BGP
SanJose2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
C 172.24.1.0 is directly connected, Serial0/0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.2.2.0 is directly connected, Loopback0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:00:33
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose2#ping 198.133.219.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
SanJose1#show ip route // SanJose1 ISN'T CONFIGURE FOR IBGP PEERING WITH SanJose3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose2(config)#router bgp 100
SanJose2(config-router)#neighbor 192.168.1.5 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
SanJose2(config-router)#neighbor 192.168.1.5 route-reflector-client // CONFIGURE SanJose2 AS ROUTE
REFLECTOR TO ELIMINATE IBGP FULL MESH
SanJose2(config-router)#neighbor 192.168.1.5 route-reflector-client
*Jan 3 14:32:54.191: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Down RR client config change
*Jan 3 14:32:57.659: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Up
SanJose2(config-router)#neighbor 172.24.1.18 route-reflector-client
SanJose2(config-router)#
*Jan 3 14:33:12.391: %BGP-5-ADJCHANGE: neighbor 172.24.1.18 Down RR client config change
*Jan 3 14:33:15.067: %BGP-5-ADJCHANGE: neighbor 172.24.1.18 Up
SanJose2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 18 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
Serial0/0/1 2 2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
172.24.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
Routing Protocol is "bgp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Route Reflector for address family IPv4 Unicast, 2 clients
Route Reflector for address family IPv6 Unicast, 2 clients
Route Reflector for address family IPv4 MDT, 2 clients
Route Reflector for address family VPNv4 Unicast, 2 clients
Route Reflector for address family VPNv6 Unicast, 2 clients
Route Reflector for address family IPv4 Multicast, 2 clients
Route Reflector for address family IPv6 Multicast, 2 clients
Route Reflector for address family NSAP Unicast, 2 clients
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
172.24.1.18
192.168.1.5
Maximum path: 1
Routing Information Sources:
Gateway Distance Last Update
172.24.1.18 200 00:02:06
Distance: external 20 internal 200 local 200
SanJose1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 17 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.6 120 00:00:00
Distance: (default is 120)
Routing Protocol is "bgp 100" // ROUTE REFLECTOR CLIENT IS UNAWARE OF BGP ROUTE REFLECTION
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
192.168.1.6
Maximum path: 1
Routing Information Sources:
Gateway Distance Last Update
192.168.1.6 200 00:02:43
Distance: external 20 internal 200 local 200
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:05, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:05, Serial0/0/0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:03:45 // RECEIVED SanJose3 LOPPBACK0 SUBNET EVEN IF NOT AN IBGP PEER; RECEIVED FROM ROUTE REFLECTOR SanJose2
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose1#ping 198.133.219.1 // CAN PING IP ADDRESS EVEN IF NEXT-HOP IP 172.24.1.18 ISN'T DIRECTLY CONNECTED
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
SanJose3(config)#router bgp 100
SanJose3(config-router)#?
Router configuration commands:
address-family Enter Address Family command mode
aggregate-address Configure BGP aggregate entries
auto-summary Enable automatic network number summarization
bgp BGP specific commands
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter networks in routing updates
exit Exit from routing protocol configuration mode
help Description of the interactive help system
maximum-paths Forward packets over multiple paths
neighbor Specify a neighbor router
network Specify a network to announce via BGP
no Negate a command or set its defaults
redistribute Redistribute information from another routing protocol
synchronization Perform IGP synchronization
table-map Map external entry attributes into routing table
template Enter template command mode
timers Adjust routing timers
SanJose3(config-router)#aggregate-address ?
A.B.C.D Aggregate address
SanJose3(config-router)#aggregate-address 198.0.0.0 ?
A.B.C.D Aggregate mask
SanJose3(config-router)#aggregate-address 198.0.0.0 255.0.0.0
SanJose2#show ip bgp 198.0.0.0
BGP routing table entry for 198.0.0.0/8, version 5
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
Advertised to update-groups:
1
Local, (aggregated by 100 172.24.1.18), (Received from a RR-client)
172.24.1.18 from 172.24.1.18 (172.24.1.18)
Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best
SanJose1#show ip route // SanJose2 REFLECTED SUPERNET ROUTE TO SanJose1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:13:19
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
B 198.0.0.0/8 [200/0] via 172.24.1.18, 00:02:01
SanJose2(config)#ip prefix-list ?
WORD Name of a prefix list
sequence-number Include/exclude sequence numbers in NVGEN
SanJose2(config)#ip prefix-list SUPERNET_ONLY ?
deny Specify packets to reject
description Prefix-list specific description
permit Specify packets to forward
seq sequence number of an entry
SanJose2(config)#ip prefix-list SUPERNET_ONLY permit ?
A.B.C.D/nn IP prefix <network>/<length>, e.g., 35.0.0.0/8
SanJose2(config)#ip prefix-list SUPERNET_ONLY permit 198.0.0.0/8
SanJose2(config)#router bgp 100
SanJose2(config-router)#neighbor 192.168.1.5 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
SanJose2(config-router)#neighbor 192.168.1.5 prefix-list ?
WORD Name of a prefix list
SanJose2(config-router)#neighbor 192.168.1.5 prefix-list SUPERNET_ONLY ?
in Filter incoming updates
out Filter outgoing updates
SanJose2(config-router)#neighbor 192.168.1.5 prefix-list SUPERNET_ONLY out // PREVENT
198.133.219.0/24 ROUTE TO REFLECT ON SanJose1
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:09, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:09, Serial0/0/0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:15:58
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
B 198.0.0.0/8 [200/0] via 172.24.1.18, 00:04:40
SanJose1#clear ip bgp * soft
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:07, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:07, Serial0/0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
B 198.0.0.0/8 [200/0] via 172.24.1.18, 00:05:05
SanJose1#tclsh
SanJose1(tcl)#foreach address {
+>10.2.2.1
+>198.133.219.1
+>192.168.1.5
+>192.168.1.6
+>172.24.1.17
+>172.24.1.18
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/44 ms
I did a route reflector lab for CCNP ROUTE. I got a bit intimated doing this lab since BGP isn't my strong point but while I was already doing the configuration, it's not so bad after all. It's just a matter of having a good solid BGP foundation (from my ISP job background) that I was able to pull this off.
SanJose1(config-if)#ip address 192.168.1.5 255.255.255.252
SanJose1(config-if)#clock rate 128000
SanJose1(config-if)#no shutdown
SanJose1(config-if)#
*Jan 3 15:34:53.515: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
SanJose2(config)#interface loopback0
SanJose2(config-if)#
*Jan 3 14:17:39.863: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
SanJose2(config-if)#ip address 10.2.2.1 255.255.255.0
SanJose2(config-if)#interface s0/0/0
SanJose2(config-if)#ip address 192.168.1.6 255.255.255.252
SanJose2(config-if)#no shutdown
SanJose2(config-if)#
*Jan 3 14:18:14.847: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 3 14:18:15.847: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
SanJose2(config-if)#do ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
SanJose2(config-if)#interface s0/0/1
SanJose2(config-if)#ip address 172.24.1.17 255.255.255.0
SanJose2(config-if)#clock rate 128000
SanJose2(config-if)#no shutdown
SanJose2(config-if)#
*Jan 3 14:18:44.299: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 3 14:18:45.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
SanJose3(config)#interface s0/0/1
SanJose3(config-if)#ip address 172.24.1.18 255.255.255.0
SanJose3(config-if)#no shutdown
SanJose3(config-if)#do ping 172.24.1.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
SanJose1(config)#router rip
SanJose1(config-router)#version 2
SanJose1(config-router)#no auto-summary
SanJose1(config-router)#network 192.168.1.0
SanJose2(config)#router rip
SanJose2(config-router)#version 2
SanJose2(config-router)#no auto-summary
SanJose2(config-router)#network 172.24.0.0
SanJose2(config-router)#network 192.168.1.0
SanJose2(config-router)#network 10.0.0.0
SanJose3(config)#router rip
SanJose3(config-router)#version 2
SanJose3(config-router)#no auto-summary
SanJose3(config-router)#network 172.24.0.0
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:06, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:06, Serial0/0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose1#tclsh
SanJose1(tcl)#foreach address {
+>10.2.2.1
+>192.168.1.5
+>192.168.1.6
+>172.24.1.17
+>172.24.1.18
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
SanJose2(config)#router bgp 100
SanJose2(config-router)#neighbor 192.168.1.5 remote-as 100
SanJose2(config-router)#neighbor 172.24.1.18 remote-as 100
SanJose1(config)#router bgp 100
SanJose1(config-router)#neighbor 192.168.1.6 remote-as 100
SanJose1(config-router)#
*Jan 3 15:44:53.379: %BGP-5-ADJCHANGE: neighbor 192.168.1.6 Up
SanJose3(config)#router bgp 100
SanJose3(config-router)#neighbor 172.24.1.17 remote-as 100
SanJose3(config-router)#
*Jan 3 15:04:45.779: %BGP-5-ADJCHANGE: neighbor 172.24.1.17 Up
SanJose2#show ip bgp neighbors
BGP neighbor is 172.24.1.18, remote AS 100, internal link
BGP version 4, remote router ID 172.24.1.18
BGP state = Established, up for 00:00:52
Last read 00:00:52, last write 00:00:52, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 1 1
Route Refresh: 0 0
Total: 2 2
Default minimum time between advertisement runs is 0 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 0/0
Output queue size : 0
Index 2, Offset 0, Mask 0x4
2 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 0 0
Prefixes Total: 0 0
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 0, min 0
Address tracking is enabled, the RIB does have a route to 172.24.1.18
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 172.24.1.17, Local port: 179
Foreign host: 172.24.1.18, Foreign port: 14628
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x12422C):
Timer Starts Wakeups Next
Retrans 4 0 0x0
TimeWait 0 0 0x0
AckHold 3 2 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 1760080277 snduna: 1760080369 sndnxt: 1760080369 sndwnd: 16293
irs: 615136447 rcvnxt: 615136539 rcvwnd: 16293 delrcvwnd: 91
SRTT: 124 ms, RTTO: 1405 ms, RTV: 1281 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 7 (out of order: 0), with data: 3, total data bytes: 91
Sent: 6 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 3, total
data bytes: 91
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
BGP neighbor is 192.168.1.5, remote AS 100, internal link
BGP version 4, remote router ID 192.168.1.5
BGP state = Established, up for 00:01:29
Last read 00:00:39, last write 00:00:31, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 2 2
Route Refresh: 0 0
Total: 3 3
Default minimum time between advertisement runs is 0 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 2, Offset 0, Mask 0x4
2 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 0 0
Prefixes Total: 0 0
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 0, min 0
Address tracking is enabled, the RIB does have a route to 192.168.1.5
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 192.168.1.6, Local port: 51613
Foreign host: 192.168.1.5, Foreign port: 179
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x1259B8):
Timer Starts Wakeups Next
Retrans 4 0 0x0
TimeWait 0 0 0x0
AckHold 3 2 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 1 0 0x1A18C8
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 235163843 snduna: 235163935 sndnxt: 235163935 sndwnd: 16293
irs: 61301986 rcvnxt: 61302078 rcvwnd: 16293 delrcvwnd: 91
SRTT: 124 ms, RTTO: 1405 ms, RTV: 1281 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: active open
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 6 (out of order: 0), with data: 3, total data bytes: 91
Sent: 7 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 3, total
data bytes: 91
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
SanJose3(config)#interface loopback0
SanJose3(config-if)#
*Jan 3 15:07:07.631: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
SanJose3(config-if)#ip address 198.133.219.1 255.255.255.0
SanJose3(config-if)#exit
SanJose3(config)#router bgp 100
SanJose3(config-router)#network 198.133.219.0 // ADVERTISE LOOPBACK INTO BGP
SanJose2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
C 172.24.1.0 is directly connected, Serial0/0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.2.2.0 is directly connected, Loopback0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:00:33
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose2#ping 198.133.219.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
SanJose1#show ip route // SanJose1 ISN'T CONFIGURE FOR IBGP PEERING WITH SanJose3
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose2(config)#router bgp 100
SanJose2(config-router)#neighbor 192.168.1.5 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
SanJose2(config-router)#neighbor 192.168.1.5 route-reflector-client // CONFIGURE SanJose2 AS ROUTE
REFLECTOR TO ELIMINATE IBGP FULL MESH
SanJose2(config-router)#neighbor 192.168.1.5 route-reflector-client
*Jan 3 14:32:54.191: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Down RR client config change
*Jan 3 14:32:57.659: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Up
SanJose2(config-router)#neighbor 172.24.1.18 route-reflector-client
SanJose2(config-router)#
*Jan 3 14:33:12.391: %BGP-5-ADJCHANGE: neighbor 172.24.1.18 Down RR client config change
*Jan 3 14:33:15.067: %BGP-5-ADJCHANGE: neighbor 172.24.1.18 Up
SanJose2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 18 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
Serial0/0/1 2 2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
172.24.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
Routing Protocol is "bgp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Route Reflector for address family IPv4 Unicast, 2 clients
Route Reflector for address family IPv6 Unicast, 2 clients
Route Reflector for address family IPv4 MDT, 2 clients
Route Reflector for address family VPNv4 Unicast, 2 clients
Route Reflector for address family VPNv6 Unicast, 2 clients
Route Reflector for address family IPv4 Multicast, 2 clients
Route Reflector for address family IPv6 Multicast, 2 clients
Route Reflector for address family NSAP Unicast, 2 clients
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
172.24.1.18
192.168.1.5
Maximum path: 1
Routing Information Sources:
Gateway Distance Last Update
172.24.1.18 200 00:02:06
Distance: external 20 internal 200 local 200
SanJose1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 17 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.6 120 00:00:00
Distance: (default is 120)
Routing Protocol is "bgp 100" // ROUTE REFLECTOR CLIENT IS UNAWARE OF BGP ROUTE REFLECTION
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
192.168.1.6
Maximum path: 1
Routing Information Sources:
Gateway Distance Last Update
192.168.1.6 200 00:02:43
Distance: external 20 internal 200 local 200
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:05, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:05, Serial0/0/0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:03:45 // RECEIVED SanJose3 LOPPBACK0 SUBNET EVEN IF NOT AN IBGP PEER; RECEIVED FROM ROUTE REFLECTOR SanJose2
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
SanJose1#ping 198.133.219.1 // CAN PING IP ADDRESS EVEN IF NEXT-HOP IP 172.24.1.18 ISN'T DIRECTLY CONNECTED
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
SanJose3(config)#router bgp 100
SanJose3(config-router)#?
Router configuration commands:
address-family Enter Address Family command mode
aggregate-address Configure BGP aggregate entries
auto-summary Enable automatic network number summarization
bgp BGP specific commands
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter networks in routing updates
exit Exit from routing protocol configuration mode
help Description of the interactive help system
maximum-paths Forward packets over multiple paths
neighbor Specify a neighbor router
network Specify a network to announce via BGP
no Negate a command or set its defaults
redistribute Redistribute information from another routing protocol
synchronization Perform IGP synchronization
table-map Map external entry attributes into routing table
template Enter template command mode
timers Adjust routing timers
SanJose3(config-router)#aggregate-address ?
A.B.C.D Aggregate address
SanJose3(config-router)#aggregate-address 198.0.0.0 ?
A.B.C.D Aggregate mask
SanJose3(config-router)#aggregate-address 198.0.0.0 255.0.0.0
SanJose2#show ip bgp 198.0.0.0
BGP routing table entry for 198.0.0.0/8, version 5
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
Advertised to update-groups:
1
Local, (aggregated by 100 172.24.1.18), (Received from a RR-client)
172.24.1.18 from 172.24.1.18 (172.24.1.18)
Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best
SanJose1#show ip route // SanJose2 REFLECTED SUPERNET ROUTE TO SanJose1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:11, Serial0/0/0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:13:19
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
B 198.0.0.0/8 [200/0] via 172.24.1.18, 00:02:01
SanJose2(config)#ip prefix-list ?
WORD Name of a prefix list
sequence-number Include/exclude sequence numbers in NVGEN
SanJose2(config)#ip prefix-list SUPERNET_ONLY ?
deny Specify packets to reject
description Prefix-list specific description
permit Specify packets to forward
seq sequence number of an entry
SanJose2(config)#ip prefix-list SUPERNET_ONLY permit ?
A.B.C.D/nn IP prefix <network>/<length>, e.g., 35.0.0.0/8
SanJose2(config)#ip prefix-list SUPERNET_ONLY permit 198.0.0.0/8
SanJose2(config)#router bgp 100
SanJose2(config-router)#neighbor 192.168.1.5 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
SanJose2(config-router)#neighbor 192.168.1.5 prefix-list ?
WORD Name of a prefix list
SanJose2(config-router)#neighbor 192.168.1.5 prefix-list SUPERNET_ONLY ?
in Filter incoming updates
out Filter outgoing updates
SanJose2(config-router)#neighbor 192.168.1.5 prefix-list SUPERNET_ONLY out // PREVENT
198.133.219.0/24 ROUTE TO REFLECT ON SanJose1
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:09, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:09, Serial0/0/0
B 198.133.219.0/24 [200/0] via 172.24.1.18, 00:15:58
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
B 198.0.0.0/8 [200/0] via 172.24.1.18, 00:04:40
SanJose1#clear ip bgp * soft
SanJose1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.24.0.0/24 is subnetted, 1 subnets
R 172.24.1.0 [120/1] via 192.168.1.6, 00:00:07, Serial0/0/0
10.0.0.0/24 is subnetted, 1 subnets
R 10.2.2.0 [120/1] via 192.168.1.6, 00:00:07, Serial0/0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/0/0
B 198.0.0.0/8 [200/0] via 172.24.1.18, 00:05:05
SanJose1#tclsh
SanJose1(tcl)#foreach address {
+>10.2.2.1
+>198.133.219.1
+>192.168.1.5
+>192.168.1.6
+>172.24.1.17
+>172.24.1.18
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.24.1.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/44 ms
No comments:
Post a Comment