I had to upgrade a new Cisco Nexus 3K switch. Upgrading the NX-OS is not a prerequisite for vPC. Here's a nice Cisco Nexus guide which I used to quickly get started and a link for the best practice configuration for the NX-OS STP extensions or the spanning-tree port type. There's a nice diagram shared in the Cisco forum showing the best practice where to configure them.
The Cisco Nexus switch platform supports In-Service Software Upgrade (ISSU) but I don't need it since the switch isn't in production yet. I used a compatible USB stick to copy both the kickstart (the Linux Kernel) and NX-OS image. The USB slot is found at the back of the chassis and it's below the CONSOLE port.
switch %$ VDC-1 %$ %IDEHSD-2-MOUNT: USB1: online // DETECTED A COMPATIBLE USB
switch# dir usb1:
<OUTPUT TRUNCATED>
32782848 Mar 23 09:18:28 2018 n3000-uk9-kickstart.6.0.2.U2.5.bin
173920429 Mar 23 09:19:36 2018 n3000-uk9.6.0.2.U2.5.bin
Usage for usb1://sup-local
1925578752 bytes used
129105920 bytes free
2054684672 bytes total
switch# copy usb1: bootflash:
Enter source filename: n3000-uk9-kickstart.6.0.2.U2.5.bin
Copy progress 100% 32782KB
<OUTPUT TRUNCATED>
Copy complete, now saving to disk (please wait)...
switch# copy usb1: bootflash:
Enter source filename: n3000-uk9.6.0.2.U2.5.bin
Copy progress 100% 32782KB
<OUTPUT TRUNCATED>
Copy complete, now saving to disk (please wait)...
switch# dir bootflash:
84 Feb 11 13:26:58 2018 20180211_132618_poap_3828_init.log
84 Mar 05 10:52:44 2018 20180305_105203_poap_3831_init.log
168 Mar 05 10:59:51 2018 20180305_105751_poap_3842_init.log
168 Mar 19 08:45:17 2018 20180319_083732_poap_3829_init.log
84 Mar 19 09:01:57 2018 20180319_090050_poap_3829_init.log
4096 May 28 08:38:57 2016 lost+found/
32782848 Mar 23 07:46:33 2018 n3000-uk9-kickstart.6.0.2.U2.5.bin
37791232 May 28 08:23:01 2016 n3000-uk9-kickstart.6.0.2.U4.1.bin
173920429 Mar 23 07:46:59 2018 n3000-uk9.6.0.2.U2.5.bin
185119072 May 28 08:23:33 2016 n3000-uk9.6.0.2.U4.1.bin
4096 Jan 29 08:26:13 2010 vdc_2/
4096 Jan 29 08:26:13 2010 vdc_3/
4096 Jan 29 08:26:13 2010 vdc_4/
4096 Jan 29 08:26:16 2010 virtual-instance-stby-sync/
568 Mar 21 08:15:24 2018 vlan.dat
Usage for bootflash://sup-local
560041984 bytes used
1335128064 bytes free
1895170048 bytes total
I performed a Fast Reload Upgrade on the Cisco Nexus 3K switches using the install all command.
switch# install ?
all Upgrade the system
license Install license
switch# install all ?
<CR>
force Force Disruptive upgrade
kickstart Boot-variable name
non-disruptive Non-Disruptive image upgrade
ssi Boot-variable name
system Boot-variable name
switch# install all kickstart ?
bootflash: Enter image uri
ftp: Enter image uri
modflash: Enter image uri
scp: Enter image uri
sftp: Enter image uri
tftp: Enter image uri
usb1: Enter image uri
volatile: Enter image uri
switch# install all kickstart bootflash:?
bootflash:///
bootflash://module-1/
bootflash://sup-1/
bootflash://sup-active/
bootflash://sup-local/
switch# install all kickstart bootflash:///?
bootflash:///20100129_154217_poap_3932_init.log
bootflash:///20160719_173151_poap_3840_init.log
bootflash:///20180211_135021_poap_3842_init.log
bootflash:///20180319_093045_poap_3840_init.log
bootflash:///license_FOC2026R31P_24_1.lic
bootflash:///lost+found
bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin
bootflash:///n3000-uk9-kickstart.6.0.2.U3.7.bin
bootflash:///n3000-uk9.6.0.2.U2.5.bin
bootflash:///n3000-uk9.6.0.2.U3.7.bin
bootflash:///vdc_2
bootflash:///vdc_3
bootflash:///vdc_4
bootflash:///vlan.dat
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin ?
<CR>
force Force Disruptive upgrade
non-disruptive Non-Disruptive image upgrade
ssi Boot-variable name
system Boot-variable name
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system ?
bootflash: Enter image uri
ftp: Enter image uri
modflash: Enter image uri
scp: Enter image uri
sftp: Enter image uri
tftp: Enter image uri
usb1: Enter image uri
volatile: Enter image uri
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:?
bootflash:///
bootflash://module-1/
bootflash://sup-1/
bootflash://sup-active/
bootflash://sup-local/
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:///?
bootflash:///20100129_154217_poap_3932_init.log
bootflash:///20160719_173151_poap_3840_init.log
bootflash:///20180211_135021_poap_3842_init.log
bootflash:///20180319_093045_poap_3840_init.log
bootflash:///license_FOC2026R31P_24_1.lic
bootflash:///lost+found
bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin
bootflash:///n3000-uk9-kickstart.6.0.2.U3.7.bin
bootflash:///n3000-uk9.6.0.2.U2.5.bin
bootflash:///n3000-uk9.6.0.2.U3.7.bin
bootflash:///vdc_2
bootflash:///vdc_3
bootflash:///vdc_4
bootflash:///vlan.dat
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:///n3000-uk9.6.0.2.U2.5.bin ?
<CR>
force Force Disruptive upgrade
non-disruptive Non-Disruptive image upgrade
ssi Boot-variable name
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:///n3000-uk9.6.0.2.U2.5.bin
Installer is forced disruptive
Verifying image bootflash:/n3000-uk9-kickstart.6.0.2.U2.5.bin for boot variable "kickstart".
[########################################] 100% -- SUCCESS
Verifying image bootflash:/n3000-uk9.6.0.2.U2.5.bin for boot variable "system".
[########################################] 100% -- SUCCESS
Verifying image type.
[########################################] 100% -- SUCCESS
Extracting "system" version from image bootflash:/n3000-uk9.6.0.2.U2.5.bin.
[########################################] 100% -- SUCCESS
Extracting "kickstart" version from image bootflash:/n3000-uk9-kickstart.6.0.2.U2.5.bin.
[########################################] 100% -- SUCCESS
Extracting "bios" version from image bootflash:/n3000-uk9.6.0.2.U2.5.bin.
[########################################] 100% -- SUCCESS
Performing module support checks.
[########################################] 100% -- SUCCESS
Notifying services about system upgrade.
[########################################] 100% -- SUCCESS
Compatibility check is done:
Module bootable Impact Install-type Reason
------ -------- -------------- ------------ ------
1 yes disruptive reset Forced by the user
Images will be upgraded according to following table:
Module Image Running-Version New-Version Upg-Required
------ ---------------- ---------------------- ---------------------- ------------
1 system 6.0(2)U3(7) 6.0(2)U2(5) yes
1 kickstart 6.0(2)U3(7) 6.0(2)U2(5) yes
1 bios v1.4.0(12/09/2013) v1.2.0(08/25/2011) no
1 power-seq v4.4 v4.4 no
Additional info for this installation:
--------------------------------------
Service "vpc" : vPC feature is enabled. Upgrade will be disruptive!!!
Switch will be reloaded for disruptive upgrade.
Do you want to continue with the installation (y/n)? [n] y
Time Stamp: Fri Mar 23 07:48:16 2018
Install is in progress, please wait.
Performing runtime checks.
[########################################] 100% -- SUCCESS
Setting boot variables.
[########################################] 100% -- SUCCESS
Performing configuration copy.
[########################################] 100% -- SUCCESS
Converting startup config.
[########################################] 100% -- SUCCESS
Time Stamp: Fri Mar 23 07:51:16 2018
Finishing the upgrade, switch will reboot in 10 seconds.
switch# [89720.651353] writing reset reason 49,
(c) Copyright 2011, Cisco Systems.
N3000 BIOS v.1.4.0, Mon 12/09/2013, 11:26 AM
GRUB Loading stage2
Image verification OK
Fastboot Memory at 0c100000 of size 201326592
Usage: init 0123POST INIT Starts at Fri Mar 23 07:52:04 UTC 2018
Starting Nexus 3000 Platform POST.....
Executing Mod 1 1 SEEPROM Test:...done (0 seconds)
Executing Mod 1 1 GigE Port Test:.done (8 seconds)
Executing Mod 1 1 PCIE Test:.................done (0 seconds)
Mod 1 1 Post Completed Successfully
POST is completed
Reconfiguring links to dev files.
ERROR: Internal disk has unrecoverable error (1); please do "init system"
.r.r.r. done.
Loading System Software Fri Mar 23 07:52:23 UTC 2018
System Software(/bootflash/n3000-uk9.6.0.2.U2.5.bin) Loaded Fri Mar 23 07:52:41 UTC 2018
ethernet switching mode
INIT: Entering runlevel: 3
Mounting other filesystems: [ OK ]
Set name-type for VLAN subsystem. Should be visible in /proc/net/vlan/config
Added VLAN with VID == 4042 to IF -:muxif:-
2018 Mar 23 07:52:47 switch %$ VDC-1 %$ %USER-0-SYSTEM_MSG: FAST REBOOT DISABLED - bcm_usd
2018 Mar 23 07:52:48 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: CLIS: loading cmd files begin - clis
2018 Mar 23 07:53:00 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: CLIS: loading cmd files end - clis
2018 Mar 23 07:53:00 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: CLIS: init begin - clis
2018 Mar 23 07:53:03 switch %$ VDC-1 %$ %IDEHSD-2-MOUNT: USB1: online
2018 Mar 23 07:53:30 switch %$ VDC-1 %$ %USER-0-SYSTEM_MSG: Starting bcm_attach - bcm_usd
2018 Mar 23 07:53:34 switch %$ VDC-1 %$ %USER-0-SYSTEM_MSG: Finished bcm_attach... - bcm_usd
2018 Mar 23 07:53:46 switch %$ VDC-1 %$ %VDC_MGR-2-VDC_ONLINE: vdc 1 has come online
The NX-OS upgrade and bootup took around 5 minutes.
switch login:<USER>
Password:<PASSWORD>
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2014, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Documents: http://www.cisco.com/en/US/products/ps9372/tsd_products_support_serie
s_home.html
Copyright (c) 2002-2014, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
Software
BIOS: version 1.4.0
loader: version N/A
kickstart: version 6.0(2)U2(5)
system: version 6.0(2)U2(5)
Power Sequencer Firmware:
Module 1: version v4.4
BIOS compile time: 12/09/2013
kickstart image file is: bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin
kickstart compile time: 5/8/2014 16:00:00 [05/09/2014 00:38:26]
system image file is: bootflash:///n3000-uk9.6.0.2.U2.5.bin
system compile time: 5/8/2014 16:00:00 [05/09/2014 02:30:06]
Hardware
cisco Nexus 3048 Chassis ("48x1GE + 4x10G Supervisor")
Intel(R) Celeron(R) CPU P450 with 3785120 kB of memory.
Processor Board ID FOC20261234
Device name: switch
bootflash: 2007040 kB
Kernel uptime is 0 day(s), 0 hour(s), 2 minute(s), 16 second(s)
Last reset at 651345 usecs after Fri Mar 23 07:51:26 2018
Reason: Disruptive upgrade
System version: 6.0(2)U3(7)
Service:
plugin
Core Plugin, Ethernet Plugin
After the NX-OS upgrade, I've configured a virtual PortChannel (vPC) which is a Nexus virtualization feature that allows a downstream device (server, router, switch, firewall, etc) to have separate uplinks appear as a single logical interface (port-channel). I've connected a direct cable between the Nexus switch's MGMT0 interface and started configuring vPC first on Nexus Switch 2.
switch2# configure terminal
switch2(config)# feature vpc
switch2(config)# vpc domain 1
switch2(config-vpc-domain)# peer-keepalive destination 10.10.12.253 source 10.10.12.254
Note:
--------:: Management VRF will be used as the default VRF ::--------
switch2(config-vpc-domain)# peer-switch 2018 Mar 23 07:54:39 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 0, VPC peer keep-alive send has failed
2018 Mar 23 07:54:39 switch2 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_DISABLED: vPC peer-switch configuration is disabled. Please make sure to change spanning tree "bridge" priority as per the recommended guidelines.
switch2(config-vpc-domain)# 2018 Mar 23 07:54:40 switch2 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_ENABLED: vPC peer-switch configuration is enabled. Please make sure to configure spanning tree "bridge" priority as per recommended guidelines to make vPC peer-switch operational.
switch2(config-vpc-domain)# vrf context management
switch2(config-vrf)# ip route 0.0.0.0/0 10.10.12.1
switch2(config-vrf)# 2018 Mar 23 07:54:59 switch2 %$ VDC-1 %$ %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port Po12 MST: 0.
switch2(config-vrf)# interface mgmt0
switch2(config-if)# vrf member management
switch2(config-if)# ip address 10.10.21.254/24
switch2(config-if)# 2018 Mar 23 07:55:07 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
I've configured the last ports on both Nexus switches: interface 47 and 48 as a Layer 2 port-channel (LACP EtherChannel) interface.
switch2(config-if)# show run interface port-channel12
!Command: show running-config interface port-channel12
!Time: Fri Mar 23 07:55:17 2018
version 6.0(2)U2(5)
interface port-channel12
switchport mode trunk
spanning-tree port type network
switch2(config-if)# show run interface e1/47
!Command: show running-config interface Ethernet1/47
!Time: Fri Mar 23 07:55:31 2018
version 6.0(2)U2(5)
interface Ethernet1/47
switchport mode trunk
channel-group 12 mode active
switch2(config-if)# show run interface e1/47 [J8
!Command: show running-config interface Ethernet1/48
!Time: Fri Mar 23 07:55:34 2018
version 6.0(2)U2(5)
interface Ethernet1/48
switchport mode trunk
channel-group 12 mode active
switch2(config-if)# 2018 Mar 23 07:55:39 switch2 %$ VDC-1 %$ last message repeated 16 times
switch2(config-if)# interface port-channel12
switch2(config-if)# vpc peer-link
Please note that spanning tree port type is changed to "network" port type on vPC peer-link.
This will enable spanning tree Bridge Assuranc e on vPC peer-link provided the STP Bridge Assurance(which is enabled by default) is not disabled.
switch2(config-if)# 2018 Mar 23 07:55:53 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
2018 Mar 23 07:55:57 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch2(config-if)# 2018 Mar 23 07:56:01 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch2(config-if)# end
switch2# 2018 Mar 23 07:56:03 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch2# show run vpc
!Command: show running-config vpc
!Time: Fri Mar 23 07:57:13 2018
version 6.0(2)U2(5)
feature vpc
vpc domain 1
peer-switch
peer-keepalive destination 10.10.12.253 source 10.10.12.254
interface port-channel12
vpc peer-link
switch2# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer link is down
vPC keep-alive status : Suspended (Destination IP not reachable)
Configuration consistency status : failed
Per-vlan consistency status : success
Configuration inconsistency reason: Consistency Check Not Performed
Type-2 consistency status : failed
Type-2 inconsistency reason : QoSMgr type-1 configuration incompatible
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Disabled (due to peer configuration)
Auto-recovery status : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po12 up -
Next, I've configured Nexus Switch 1 and gave a higher role priority number.
switch1(config)# feature vpc
switch1(config)# vpc domain 1
switch1(config-vpc-domain)# 2018 Mar 23 08:16:34 switch1 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 0, VPC peer keep-alive send has failed
2018 Mar 23 08:16:34 switch1 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_DISABLED: vPC peer-switch configuration is disabled. Please make sure to change spanning tree "bridge" priority as per the recommended guidelines.
switch1(config-vpc-domain)# 2018 Mar 23 08:16:53
switch1 %$ VDC-1 %$ %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port Po12 MST: 0.
switch1(config-vpc-domain)# role priority 1000
Warning:
!!:: vPCs will be flapped on current primary vPC switch while attempting role change ::!!
Note:
--------:: Change will take effect after user has re-initd the vPC peer-link ::--------
switch1(config-vpc-domain)# peer-keepalive destination 10.10.12.254 source 10.10.12.253
Note:
--------:: Management VRF will be used as the default VRF ::--------
switch1(config-vpc-domain)# peer-switch
switch1(config-vpc-domain)# 2018 Mar 23 08:17:10 switch1 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_ENABLED: vPC peer-switch configuration is enabled. Please make sure to configure spanning tree "bridge" priority as per recommended guidelines to make vPC peer-switch operational.
switch1(config-vpc-domain)# vrf context management
switch1(config-vrf)# ip route 0.0.0.0/0 10.10.12.1
switch1(config-vrf)# interface mgmt0
switch1(config-if)# vrf member management
switch1(config-if)# ip address 10.10.12.253/24
switch1(config-if)# 2018 Mar 23 08:17:42 switch1 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch1(config-if)# end
switch1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer link not configured
vPC keep-alive status : peer is alive
Configuration consistency status : failed
Per-vlan consistency status : failed
Configuration inconsistency reason: vPC peer-link does not exist
Type-2 consistency status : failed
Type-2 inconsistency reason : vPC peer-link does not exist
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Disabled (due to peer configuration)
Auto-recovery status : Disabled
switch1# show run interface e1/47
!Command: show running-config interface Ethernet1/47
!Time: Fri Mar 23 08:18:16 2018
version 6.0(2)U2(5)
interface Ethernet1/47
switchport mode trunk
channel-group 12 mode active
switch1# show run interface e1/48
!Command: show running-config interface Ethernet1/48
!Time: Fri Mar 23 08:18:19 2018
version 6.0(2)U2(5)
interface Ethernet1/48
switchport mode trunk
channel-group 12 mode active
switch1# show run interface port-channel12
!Time: Fri Mar 23 08:18:20 2018
version 6.0(2)U2(5)
interface port-channel12
switchport mode trunk
spanning-tree port type network
switch1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch1(config)# interface port-channel12
switch1(config-if)# vpc peer-link
Please note that spanning tree port type is changed to "network" port type on vPC peer-link. This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP Bridge Assurance (which is enabled by default) is not disabled.
switch1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer link is down
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po12 up -
switch1# show run vpc
!Command: show running-config vpc
!Time: Fri Mar 23 08:19:31 2018
version 6.0(2)U2(5)
feature vpc
vpc domain 1
peer-switch
role priority 1000
peer-keepalive destination 10.10.12.254 source 10.10.12.253
interface port-channel12
vpc peer-link
switch1# show vpc role
vPC Role status
----------------------------------------------------
vPC role : primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:3a:7d:b3:27:01
vPC local role-priority : 1000
switch1# show vpc peer-keepalive
vPC keep-alive status : peer is alive
--Peer is alive for : (179) seconds, (418) msec
--Send status : Success
--Last send at : 2018.03.23 08:20:41 403 ms
--Sent on interface : mgmt0
--Receive status : Success
--Last receive at : 2018.03.23 08:20:41 404 ms
--Received on interface : mgmt0
--Last update from peer : (0) seconds, (249) msec
vPC Keep-alive parameters
--Destination : 10.10.12.254
--Keepalive interval : 1000 msec
--Keepalive timeout : 5 seconds
--Keepalive hold timeout : 3 seconds
--Keepalive vrf : management
--Keepalive udp port : 3200
--Keepalive tos : 192
It took around 3-5 minutes for the vPC peer-link adjacency to establish.
switch1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po12 up 1,100
The Cisco Nexus switch platform supports In-Service Software Upgrade (ISSU) but I don't need it since the switch isn't in production yet. I used a compatible USB stick to copy both the kickstart (the Linux Kernel) and NX-OS image. The USB slot is found at the back of the chassis and it's below the CONSOLE port.
switch %$ VDC-1 %$ %IDEHSD-2-MOUNT: USB1: online // DETECTED A COMPATIBLE USB
switch# dir usb1:
<OUTPUT TRUNCATED>
32782848 Mar 23 09:18:28 2018 n3000-uk9-kickstart.6.0.2.U2.5.bin
173920429 Mar 23 09:19:36 2018 n3000-uk9.6.0.2.U2.5.bin
Usage for usb1://sup-local
1925578752 bytes used
129105920 bytes free
2054684672 bytes total
switch# copy usb1: bootflash:
Enter source filename: n3000-uk9-kickstart.6.0.2.U2.5.bin
Copy progress 100% 32782KB
<OUTPUT TRUNCATED>
Copy complete, now saving to disk (please wait)...
switch# copy usb1: bootflash:
Enter source filename: n3000-uk9.6.0.2.U2.5.bin
Copy progress 100% 32782KB
<OUTPUT TRUNCATED>
Copy complete, now saving to disk (please wait)...
switch# dir bootflash:
84 Feb 11 13:26:58 2018 20180211_132618_poap_3828_init.log
84 Mar 05 10:52:44 2018 20180305_105203_poap_3831_init.log
168 Mar 05 10:59:51 2018 20180305_105751_poap_3842_init.log
168 Mar 19 08:45:17 2018 20180319_083732_poap_3829_init.log
84 Mar 19 09:01:57 2018 20180319_090050_poap_3829_init.log
4096 May 28 08:38:57 2016 lost+found/
32782848 Mar 23 07:46:33 2018 n3000-uk9-kickstart.6.0.2.U2.5.bin
37791232 May 28 08:23:01 2016 n3000-uk9-kickstart.6.0.2.U4.1.bin
173920429 Mar 23 07:46:59 2018 n3000-uk9.6.0.2.U2.5.bin
185119072 May 28 08:23:33 2016 n3000-uk9.6.0.2.U4.1.bin
4096 Jan 29 08:26:13 2010 vdc_2/
4096 Jan 29 08:26:13 2010 vdc_3/
4096 Jan 29 08:26:13 2010 vdc_4/
4096 Jan 29 08:26:16 2010 virtual-instance-stby-sync/
568 Mar 21 08:15:24 2018 vlan.dat
Usage for bootflash://sup-local
560041984 bytes used
1335128064 bytes free
1895170048 bytes total
I performed a Fast Reload Upgrade on the Cisco Nexus 3K switches using the install all command.
switch# install ?
all Upgrade the system
license Install license
switch# install all ?
<CR>
force Force Disruptive upgrade
kickstart Boot-variable name
non-disruptive Non-Disruptive image upgrade
ssi Boot-variable name
system Boot-variable name
switch# install all kickstart ?
bootflash: Enter image uri
ftp: Enter image uri
modflash: Enter image uri
scp: Enter image uri
sftp: Enter image uri
tftp: Enter image uri
usb1: Enter image uri
volatile: Enter image uri
switch# install all kickstart bootflash:?
bootflash:///
bootflash://module-1/
bootflash://sup-1/
bootflash://sup-active/
bootflash://sup-local/
switch# install all kickstart bootflash:///?
bootflash:///20100129_154217_poap_3932_init.log
bootflash:///20160719_173151_poap_3840_init.log
bootflash:///20180211_135021_poap_3842_init.log
bootflash:///20180319_093045_poap_3840_init.log
bootflash:///license_FOC2026R31P_24_1.lic
bootflash:///lost+found
bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin
bootflash:///n3000-uk9-kickstart.6.0.2.U3.7.bin
bootflash:///n3000-uk9.6.0.2.U2.5.bin
bootflash:///n3000-uk9.6.0.2.U3.7.bin
bootflash:///vdc_2
bootflash:///vdc_3
bootflash:///vdc_4
bootflash:///vlan.dat
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin ?
<CR>
force Force Disruptive upgrade
non-disruptive Non-Disruptive image upgrade
ssi Boot-variable name
system Boot-variable name
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system ?
bootflash: Enter image uri
ftp: Enter image uri
modflash: Enter image uri
scp: Enter image uri
sftp: Enter image uri
tftp: Enter image uri
usb1: Enter image uri
volatile: Enter image uri
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:?
bootflash:///
bootflash://module-1/
bootflash://sup-1/
bootflash://sup-active/
bootflash://sup-local/
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:///?
bootflash:///20100129_154217_poap_3932_init.log
bootflash:///20160719_173151_poap_3840_init.log
bootflash:///20180211_135021_poap_3842_init.log
bootflash:///20180319_093045_poap_3840_init.log
bootflash:///license_FOC2026R31P_24_1.lic
bootflash:///lost+found
bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin
bootflash:///n3000-uk9-kickstart.6.0.2.U3.7.bin
bootflash:///n3000-uk9.6.0.2.U2.5.bin
bootflash:///n3000-uk9.6.0.2.U3.7.bin
bootflash:///vdc_2
bootflash:///vdc_3
bootflash:///vdc_4
bootflash:///vlan.dat
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:///n3000-uk9.6.0.2.U2.5.bin ?
<CR>
force Force Disruptive upgrade
non-disruptive Non-Disruptive image upgrade
ssi Boot-variable name
switch# install all kickstart bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin system bootflash:///n3000-uk9.6.0.2.U2.5.bin
Installer is forced disruptive
Verifying image bootflash:/n3000-uk9-kickstart.6.0.2.U2.5.bin for boot variable "kickstart".
[########################################] 100% -- SUCCESS
Verifying image bootflash:/n3000-uk9.6.0.2.U2.5.bin for boot variable "system".
[########################################] 100% -- SUCCESS
Verifying image type.
[########################################] 100% -- SUCCESS
Extracting "system" version from image bootflash:/n3000-uk9.6.0.2.U2.5.bin.
[########################################] 100% -- SUCCESS
Extracting "kickstart" version from image bootflash:/n3000-uk9-kickstart.6.0.2.U2.5.bin.
[########################################] 100% -- SUCCESS
Extracting "bios" version from image bootflash:/n3000-uk9.6.0.2.U2.5.bin.
[########################################] 100% -- SUCCESS
Performing module support checks.
[########################################] 100% -- SUCCESS
Notifying services about system upgrade.
[########################################] 100% -- SUCCESS
Compatibility check is done:
Module bootable Impact Install-type Reason
------ -------- -------------- ------------ ------
1 yes disruptive reset Forced by the user
Images will be upgraded according to following table:
Module Image Running-Version New-Version Upg-Required
------ ---------------- ---------------------- ---------------------- ------------
1 system 6.0(2)U3(7) 6.0(2)U2(5) yes
1 kickstart 6.0(2)U3(7) 6.0(2)U2(5) yes
1 bios v1.4.0(12/09/2013) v1.2.0(08/25/2011) no
1 power-seq v4.4 v4.4 no
Additional info for this installation:
--------------------------------------
Service "vpc" : vPC feature is enabled. Upgrade will be disruptive!!!
Switch will be reloaded for disruptive upgrade.
Do you want to continue with the installation (y/n)? [n] y
Time Stamp: Fri Mar 23 07:48:16 2018
Install is in progress, please wait.
Performing runtime checks.
[########################################] 100% -- SUCCESS
Setting boot variables.
[########################################] 100% -- SUCCESS
Performing configuration copy.
[########################################] 100% -- SUCCESS
Converting startup config.
[########################################] 100% -- SUCCESS
Time Stamp: Fri Mar 23 07:51:16 2018
Finishing the upgrade, switch will reboot in 10 seconds.
switch# [89720.651353] writing reset reason 49,
(c) Copyright 2011, Cisco Systems.
N3000 BIOS v.1.4.0, Mon 12/09/2013, 11:26 AM
GRUB Loading stage2
Image verification OK
Fastboot Memory at 0c100000 of size 201326592
Usage: init 0123POST INIT Starts at Fri Mar 23 07:52:04 UTC 2018
Starting Nexus 3000 Platform POST.....
Executing Mod 1 1 SEEPROM Test:...done (0 seconds)
Executing Mod 1 1 GigE Port Test:.done (8 seconds)
Executing Mod 1 1 PCIE Test:.................done (0 seconds)
Mod 1 1 Post Completed Successfully
POST is completed
Reconfiguring links to dev files.
ERROR: Internal disk has unrecoverable error (1); please do "init system"
.r.r.r. done.
Loading System Software Fri Mar 23 07:52:23 UTC 2018
System Software(/bootflash/n3000-uk9.6.0.2.U2.5.bin) Loaded Fri Mar 23 07:52:41 UTC 2018
ethernet switching mode
INIT: Entering runlevel: 3
Mounting other filesystems: [ OK ]
Set name-type for VLAN subsystem. Should be visible in /proc/net/vlan/config
Added VLAN with VID == 4042 to IF -:muxif:-
2018 Mar 23 07:52:47 switch %$ VDC-1 %$ %USER-0-SYSTEM_MSG: FAST REBOOT DISABLED - bcm_usd
2018 Mar 23 07:52:48 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: CLIS: loading cmd files begin - clis
2018 Mar 23 07:53:00 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: CLIS: loading cmd files end - clis
2018 Mar 23 07:53:00 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: CLIS: init begin - clis
2018 Mar 23 07:53:03 switch %$ VDC-1 %$ %IDEHSD-2-MOUNT: USB1: online
2018 Mar 23 07:53:30 switch %$ VDC-1 %$ %USER-0-SYSTEM_MSG: Starting bcm_attach - bcm_usd
2018 Mar 23 07:53:34 switch %$ VDC-1 %$ %USER-0-SYSTEM_MSG: Finished bcm_attach... - bcm_usd
2018 Mar 23 07:53:46 switch %$ VDC-1 %$ %VDC_MGR-2-VDC_ONLINE: vdc 1 has come online
The NX-OS upgrade and bootup took around 5 minutes.
switch login:<USER>
Password:<PASSWORD>
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2014, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Documents: http://www.cisco.com/en/US/products/ps9372/tsd_products_support_serie
s_home.html
Copyright (c) 2002-2014, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
Software
BIOS: version 1.4.0
loader: version N/A
kickstart: version 6.0(2)U2(5)
system: version 6.0(2)U2(5)
Power Sequencer Firmware:
Module 1: version v4.4
BIOS compile time: 12/09/2013
kickstart image file is: bootflash:///n3000-uk9-kickstart.6.0.2.U2.5.bin
kickstart compile time: 5/8/2014 16:00:00 [05/09/2014 00:38:26]
system image file is: bootflash:///n3000-uk9.6.0.2.U2.5.bin
system compile time: 5/8/2014 16:00:00 [05/09/2014 02:30:06]
Hardware
cisco Nexus 3048 Chassis ("48x1GE + 4x10G Supervisor")
Intel(R) Celeron(R) CPU P450 with 3785120 kB of memory.
Processor Board ID FOC20261234
Device name: switch
bootflash: 2007040 kB
Kernel uptime is 0 day(s), 0 hour(s), 2 minute(s), 16 second(s)
Last reset at 651345 usecs after Fri Mar 23 07:51:26 2018
Reason: Disruptive upgrade
System version: 6.0(2)U3(7)
Service:
plugin
Core Plugin, Ethernet Plugin
After the NX-OS upgrade, I've configured a virtual PortChannel (vPC) which is a Nexus virtualization feature that allows a downstream device (server, router, switch, firewall, etc) to have separate uplinks appear as a single logical interface (port-channel). I've connected a direct cable between the Nexus switch's MGMT0 interface and started configuring vPC first on Nexus Switch 2.
switch2# configure terminal
switch2(config)# feature vpc
switch2(config)# vpc domain 1
switch2(config-vpc-domain)# peer-keepalive destination 10.10.12.253 source 10.10.12.254
Note:
--------:: Management VRF will be used as the default VRF ::--------
switch2(config-vpc-domain)# peer-switch 2018 Mar 23 07:54:39 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 0, VPC peer keep-alive send has failed
2018 Mar 23 07:54:39 switch2 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_DISABLED: vPC peer-switch configuration is disabled. Please make sure to change spanning tree "bridge" priority as per the recommended guidelines.
switch2(config-vpc-domain)# 2018 Mar 23 07:54:40 switch2 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_ENABLED: vPC peer-switch configuration is enabled. Please make sure to configure spanning tree "bridge" priority as per recommended guidelines to make vPC peer-switch operational.
switch2(config-vpc-domain)# vrf context management
switch2(config-vrf)# ip route 0.0.0.0/0 10.10.12.1
switch2(config-vrf)# 2018 Mar 23 07:54:59 switch2 %$ VDC-1 %$ %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port Po12 MST: 0.
switch2(config-vrf)# interface mgmt0
switch2(config-if)# vrf member management
switch2(config-if)# ip address 10.10.21.254/24
switch2(config-if)# 2018 Mar 23 07:55:07 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
I've configured the last ports on both Nexus switches: interface 47 and 48 as a Layer 2 port-channel (LACP EtherChannel) interface.
switch2(config-if)# show run interface port-channel12
!Command: show running-config interface port-channel12
!Time: Fri Mar 23 07:55:17 2018
version 6.0(2)U2(5)
interface port-channel12
switchport mode trunk
spanning-tree port type network
switch2(config-if)# show run interface e1/47
!Command: show running-config interface Ethernet1/47
!Time: Fri Mar 23 07:55:31 2018
version 6.0(2)U2(5)
interface Ethernet1/47
switchport mode trunk
channel-group 12 mode active
switch2(config-if)# show run interface e1/47 [J8
!Command: show running-config interface Ethernet1/48
!Time: Fri Mar 23 07:55:34 2018
version 6.0(2)U2(5)
interface Ethernet1/48
switchport mode trunk
channel-group 12 mode active
switch2(config-if)# 2018 Mar 23 07:55:39 switch2 %$ VDC-1 %$ last message repeated 16 times
switch2(config-if)# interface port-channel12
switch2(config-if)# vpc peer-link
Please note that spanning tree port type is changed to "network" port type on vPC peer-link.
This will enable spanning tree Bridge Assuranc e on vPC peer-link provided the STP Bridge Assurance(which is enabled by default) is not disabled.
switch2(config-if)# 2018 Mar 23 07:55:53 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
2018 Mar 23 07:55:57 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch2(config-if)# 2018 Mar 23 07:56:01 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch2(config-if)# end
switch2# 2018 Mar 23 07:56:03 switch2 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch2# show run vpc
!Command: show running-config vpc
!Time: Fri Mar 23 07:57:13 2018
version 6.0(2)U2(5)
feature vpc
vpc domain 1
peer-switch
peer-keepalive destination 10.10.12.253 source 10.10.12.254
interface port-channel12
vpc peer-link
switch2# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer link is down
vPC keep-alive status : Suspended (Destination IP not reachable)
Configuration consistency status : failed
Per-vlan consistency status : success
Configuration inconsistency reason: Consistency Check Not Performed
Type-2 consistency status : failed
Type-2 inconsistency reason : QoSMgr type-1 configuration incompatible
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Disabled (due to peer configuration)
Auto-recovery status : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po12 up -
Next, I've configured Nexus Switch 1 and gave a higher role priority number.
switch1(config)# feature vpc
switch1(config)# vpc domain 1
switch1(config-vpc-domain)# 2018 Mar 23 08:16:34 switch1 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 0, VPC peer keep-alive send has failed
2018 Mar 23 08:16:34 switch1 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_DISABLED: vPC peer-switch configuration is disabled. Please make sure to change spanning tree "bridge" priority as per the recommended guidelines.
switch1(config-vpc-domain)# 2018 Mar 23 08:16:53
switch1 %$ VDC-1 %$ %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port Po12 MST: 0.
switch1(config-vpc-domain)# role priority 1000
Warning:
!!:: vPCs will be flapped on current primary vPC switch while attempting role change ::!!
Note:
--------:: Change will take effect after user has re-initd the vPC peer-link ::--------
switch1(config-vpc-domain)# peer-keepalive destination 10.10.12.254 source 10.10.12.253
Note:
--------:: Management VRF will be used as the default VRF ::--------
switch1(config-vpc-domain)# peer-switch
switch1(config-vpc-domain)# 2018 Mar 23 08:17:10 switch1 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_ENABLED: vPC peer-switch configuration is enabled. Please make sure to configure spanning tree "bridge" priority as per recommended guidelines to make vPC peer-switch operational.
switch1(config-vpc-domain)# vrf context management
switch1(config-vrf)# ip route 0.0.0.0/0 10.10.12.1
switch1(config-vrf)# interface mgmt0
switch1(config-if)# vrf member management
switch1(config-if)# ip address 10.10.12.253/24
switch1(config-if)# 2018 Mar 23 08:17:42 switch1 %$ VDC-1 %$ %VPC-2-PEER_KEEP_ALIVE_SEND_FAIL: In domain 1, VPC peer keep-alive send has failed
switch1(config-if)# end
switch1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer link not configured
vPC keep-alive status : peer is alive
Configuration consistency status : failed
Per-vlan consistency status : failed
Configuration inconsistency reason: vPC peer-link does not exist
Type-2 consistency status : failed
Type-2 inconsistency reason : vPC peer-link does not exist
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Disabled (due to peer configuration)
Auto-recovery status : Disabled
switch1# show run interface e1/47
!Command: show running-config interface Ethernet1/47
!Time: Fri Mar 23 08:18:16 2018
version 6.0(2)U2(5)
interface Ethernet1/47
switchport mode trunk
channel-group 12 mode active
switch1# show run interface e1/48
!Command: show running-config interface Ethernet1/48
!Time: Fri Mar 23 08:18:19 2018
version 6.0(2)U2(5)
interface Ethernet1/48
switchport mode trunk
channel-group 12 mode active
switch1# show run interface port-channel12
!Time: Fri Mar 23 08:18:20 2018
version 6.0(2)U2(5)
interface port-channel12
switchport mode trunk
spanning-tree port type network
switch1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch1(config)# interface port-channel12
switch1(config-if)# vpc peer-link
Please note that spanning tree port type is changed to "network" port type on vPC peer-link. This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP Bridge Assurance (which is enabled by default) is not disabled.
switch1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer link is down
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po12 up -
switch1# show run vpc
!Command: show running-config vpc
!Time: Fri Mar 23 08:19:31 2018
version 6.0(2)U2(5)
feature vpc
vpc domain 1
peer-switch
role priority 1000
peer-keepalive destination 10.10.12.254 source 10.10.12.253
interface port-channel12
vpc peer-link
switch1# show vpc role
vPC Role status
----------------------------------------------------
vPC role : primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:3a:7d:b3:27:01
vPC local role-priority : 1000
switch1# show vpc peer-keepalive
vPC keep-alive status : peer is alive
--Peer is alive for : (179) seconds, (418) msec
--Send status : Success
--Last send at : 2018.03.23 08:20:41 403 ms
--Sent on interface : mgmt0
--Receive status : Success
--Last receive at : 2018.03.23 08:20:41 404 ms
--Received on interface : mgmt0
--Last update from peer : (0) seconds, (249) msec
vPC Keep-alive parameters
--Destination : 10.10.12.254
--Keepalive interval : 1000 msec
--Keepalive timeout : 5 seconds
--Keepalive hold timeout : 3 seconds
--Keepalive vrf : management
--Keepalive udp port : 3200
--Keepalive tos : 192
It took around 3-5 minutes for the vPC peer-link adjacency to establish.
switch1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po12 up 1,100
No comments:
Post a Comment