Friday, April 5, 2019

Manipulating BGP Local Preference and MED

The BGP Local Preference (Local_Pref) PA gives the routers inside a single AS a value that they can set per-route and advertise to all iBGP routers inside the AS, so that all routers in the AS agree about which router is the best exit point for packets destined for that prefix. By design, Local_Pref can be set by routers as they receive eBGP routes by using an inbound route map. The routers then advertise the Local_Pref in iBGP updates. As a result, all the routers in the same AS can then make the same choice of which route is best, agreeing as to which router to use to exit the AS for each prefix.

To set the Local_Pref, a router can use the neighbor <neighbor-ip> route-map in BGP subcommand. Typically, a router uses this command with the inbound direction for routes received from eBGP peers. Then, with no additional configuration required, the router then advertises the Local_Pref to any iBGP peers.


With a dual-homed design, at least two links exist between an enterprise and its ISP. The enterprise can announce to the ISP a value Multi-Exit Discriminator (MED) that tells the ISP which path into the enterprise is best. As a result, the ISP can discriminate between the multiple exit points
from that ISP to the enterprise. Because MED lets the enterprise ASN tell just the neighboring ASN which link into the enterprise to use, engineers typically use MED when advertising an enterprise’s public IP address space. Those inbound routes into the enterprise from the ISP typically consist of
either one, or a few, public IP address ranges.

MED configuration usually occurs on the routers in the AS that want to control inbound routes from the neighboring AS. The show ip bgp command output refer to MED as metric. Note that the route map uses the set metric command, rather than set med (which does not exist). The output for the show ip bgp command, the output lists MED under the heading metric. Specifically, note that
even the show ip route command lists the MED value in brackets as the metric for the BGP route.


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 0
R1(config-if)#
*Jul 17 09:42:44.487: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 192.168.100.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface serial 2/0
R1(config-if)#ip address 192.168.1.5 255.255.255.252
R1(config-if)#no shut
R1(config-if)#
*Jul 17 09:43:48.511: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R1(config-if)#
*Jul 17 09:43:49.519: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R1(config-if)#
R1(config-if)#interface serial 2/2
R1(config-if)#ip address 192.168.1.1 255.255.255.252
R1(config-if)#no shut
R1(config-if)#
*Jul 17 09:44:16.047: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R1(config-if)#
*Jul 17 09:44:16.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to down
*Jul 17 09:44:17.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to up
R1(config-if)#end
R1#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface loop 0
R2(config-if)#
*Jul 17 09:45:16.487: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip addres 172.16.64.1 255.255.255.0
R2(config-if)#
R2(config-if)#interface serial 2/0
R2(config-if)#ip address 192.168.1.6 255.255.255.252
R2(config-if)#no shut
R2(config-if)#
*Jul 17 09:45:53.903: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R2(config-if)#
*Jul 17 09:45:54.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#
R2(config-if)#do ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/28 ms
R2(config-if)#
R2(config-if)#interface serial 2/1
R2(config-if)#ip address 172.16.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
*Jul 17 09:46:43.211: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R2(config-if)#
*Jul 17 09:46:44.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R2(config-if)#end
R2#


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface loop 0
R3(config-if)#
*Jul 17 09:47:17.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.16.32.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface serial 2/1
R3(config-if)#ip address 172.16.1.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#
*Jul 17 09:47:55.323: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R3(config-if)#
*Jul 17 09:47:56.331: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R3(config-if)#
R3(config-if)#do ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/23/36 ms
R3(config-if)#
R3(config-if)#interface serial 2/2
R3(config-if)#ip address 192.168.1.2 255.255.255.252
R3(config-if)#no shut
R3(config-if)#
*Jul 17 09:48:25.555: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R3(config-if)#
*Jul 17 09:48:26.563: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to up
R3(config-if)#  
R3(config-if)#do ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/25/36 ms
R3(config-if)#
R3(config-if)#end
R3#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 1       // IOS 15 DEFAULTS TO EIGRP no auto-summary
R2(config-router)#network 172.16.0.0
R2(config-router)#end
R2#
*Jul 17 09:50:32.627: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (Serial2/1) is up: new adjacency


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 1
R3(config-router)#network 172.16.0.0
R3(config-router)#
*Jul 17 09:50:32.999: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.1 (Serial2/1) is up: new adjacency
R3(config-router)#end
R3#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 64512 
R2(config-router)#neighbor 172.16.32.1 remote-as 64512      // CONFIGURE IBGP PEER
R2(config-router)#neighbor 172.16.32.1 update-source loop 0    // CONFIGURE IF MULTIPLE PATHS EXIST
R2(config-router)#end
R2#
*Jul 17 09:53:09.299: %BGP-5-ADJCHANGE: neighbor 172.16.32.1 Up


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router bgp 64512
R3(config-router)#neighbor 172.16.64.1 remote-as 64512
R3(config-router)#neighbor 172.16.64.1 update-source loop 0
*Jul 17 09:53:09.667: %BGP-5-ADJCHANGE: neighbor 172.16.64.1 Up
R3(config-router)#end
R3#


R3#show ip bgp neighbors
BGP neighbor is 172.16.64.1,  remote AS 64512, internal link       // NOTICE internal link FOR IBGP
  BGP version 4, remote router ID 172.16.64.1
  BGP state = Established, up for 00:01:52
  Last read 00:00:07, last write 00:00:06, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is not multisession capable (disabled)
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Enhanced Refresh Capability: advertised and received
    Multisession Capability:
    Stateful switchover support enabled: NO for session 1
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
   
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                1          1
    Keepalives:             4          4
    Route Refresh:          0          0
    Total:                  6          6
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  Session: 172.16.64.1
  BGP table version 1, neighbor version 1/0
  Output queue size : 0
  Index 1, Advertise bit 0
  1 update-group member
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                                       Sent       Rcvd
        Refresh activity:              ----       ----
          Refresh Start-of-RIB          0          0
          Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 172.16.64.1
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0           
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 172.16.32.1, Local port: 179
Foreign host: 172.16.64.1, Foreign port: 30331
Connection tableid (VRF): 0
Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0xDB824):
Timer          Starts    Wakeups            Next
Retrans             5          0             0x0
TimeWait            0          0             0x0
AckHold             5          2             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss:  512159364  snduna:  512159521  sndnxt:  512159521
irs: 2436045535  rcvnxt: 2436045692

sndwnd:  16228  scale:      0  maxrcvwnd:  16384
rcvwnd:  16228  scale:      0  delrcvwnd:    156
         
SRTT: 487 ms, RTTO: 3168 ms, RTV: 2681 ms, KRTT: 0 ms
minRTT: 12 ms, maxRTT: 1000 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 12 (out of order: 0), with data: 6, total data bytes: 156
Sent: 11 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 6, total data bytes: 156

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x6A3CA688  FREE


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 200
R1(config-router)#neighbor 192.168.1.6 remote-as 64512      // CONFIGURE EBGP PEER
R1(config-router)#neighbor 192.168.1.2 remote-as 64512      // NO NEED FOR update-source SINCE EBGP ARE COMMONLY POINT-TO-POINT LINKS (DIRECTLY CONNECTED)
R1(config-router)#network 192.168.100.0
R1(config-router)#end
R1#
*Jul 17 09:58:48.955: %BGP-5-ADJCHANGE: neighbor 192.168.1.6 Up
R1#
*Jul 17 10:03:49.043: %BGP-5-ADJCHANGE: neighbor 192.168.1.2 Up


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ip route 172.16.0.0 255.255.0.0 null0
R2(config)#
R2(config)#router bgp 64512
R2(config-router)#neighbor 192.168.1.5 remote-as 200
R2(config-router)#
*Jul 17 09:58:48.855: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Up
R2(config-router)#
R2(config-router)#network 172.16.0.0
R2(config-router)#end
R2#
*Jul 17 09:59:02.679: %SYS-5-CONFIG_I: Configured from console by console
R2#
R2#show ip bgp neighbors
BGP neighbor is 172.16.32.1,  remote AS 64512, internal link
  BGP version 4, remote router ID 172.16.32.1
  BGP state = Established, up for 00:06:02
  Last read 00:00:42, last write 00:00:13, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is not multisession capable (disabled)
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Enhanced Refresh Capability: advertised and received
    Multisession Capability:
    Stateful switchover support enabled: NO for session 1
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
   
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                3          1
    Keepalives:             8          8
    Route Refresh:          0          0
    Total:                 12         10
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  Session: 172.16.32.1
  BGP table version 3, neighbor version 3/0
  Output queue size : 0
  Index 1, Advertise bit 0
  1 update-group member
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          0
    Prefixes Total:                 2          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 1, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                                       Sent       Rcvd
        Refresh activity:              ----       ----
          Refresh Start-of-RIB          0          0
          Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 172.16.32.1
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0           
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 172.16.64.1, Local port: 30331
Foreign host: 172.16.32.1, Foreign port: 179
Connection tableid (VRF): 0
Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x119AF0):
Timer          Starts    Wakeups            Next
Retrans            12          0             0x0
TimeWait            0          0             0x0
AckHold             9          6             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            1          0        0x153AF8
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss: 2436045535  snduna: 2436045883  sndnxt: 2436045883
irs:  512159364  rcvnxt:  512159597

sndwnd:  16037  scale:      0  maxrcvwnd:  16384
rcvwnd:  16152  scale:      0  delrcvwnd:    232
         
SRTT: 798 ms, RTTO: 2221 ms, RTV: 1423 ms, KRTT: 0 ms
minRTT: 12 ms, maxRTT: 1000 ms, ACK hold: 200 ms
Status Flags: active open
Option Flags: nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 21 (out of order: 0), with data: 10, total data bytes: 232
Sent: 22 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 12, total data bytes: 347

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x6A3B5468  FREE

BGP neighbor is 192.168.1.5,  remote AS 200, external link      // NOTICE external link FOR EBGP
  BGP version 4, remote router ID 192.168.100.1
  BGP state = Established, up for 00:00:22
  Last read 00:00:22, last write 00:00:22, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is not multisession capable (disabled)
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Enhanced Refresh Capability: advertised and received
    Multisession Capability:
    Stateful switchover support enabled: NO for session 1
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
   
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                1          2
    Keepalives:             2          2
    Route Refresh:          0          0
    Total:                  4          5
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  Session: 192.168.1.5
  BGP table version 3, neighbor version 2/3
  Output queue size : 0
  Index 2, Advertise bit 1
  2 update-group member
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          1 (Consumes 64 bytes)
    Prefixes Total:                 0          1
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              1        n/a
    Total:                                1          0
  Number of NLRIs in the update sent: max 0, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                                       Sent       Rcvd
        Refresh activity:              ----       ----
          Refresh Start-of-RIB          0          0
          Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 192.168.1.5
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0           
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 192.168.1.6, Local port: 179
Foreign host: 192.168.1.5, Foreign port: 61203
Connection tableid (VRF): 0
Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x119AF8):
Timer          Starts    Wakeups            Next
Retrans             3          0             0x0
TimeWait            0          0             0x0
AckHold             3          0             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss: 3505144302  snduna: 3505144421  sndnxt: 3505144421
irs:   52768916  rcvnxt:   52769089

sndwnd:  16266  scale:      0  maxrcvwnd:  16384
rcvwnd:  16212  scale:      0  delrcvwnd:    172

SRTT: 330 ms, RTTO: 3159 ms, RTV: 2829 ms, KRTT: 0 ms
minRTT: 12 ms, maxRTT: 1000 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
         
Datagrams (max data segment is 1460 bytes):
Rcvd: 8 (out of order: 0), with data: 4, total data bytes: 172
Sent: 7 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 4, total data bytes: 118

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x6A3B5388  FREE


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ip route 172.16.0.0 255.255.0.0 null0
R3(config)#router bgp 64512
R3(config-router)#neighbor 192.168.1.1 remote-as 200
R3(config-router)#network 172.16.0.0
R3(config-router)#
*Jul 17 10:03:49.279: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up
R3(config-router)#end
R3#
*Jul 17 10:04:01.287: %SYS-5-CONFIG_I: Configured from console by console
R3#
R3#show ip bgp ?
  A.B.C.D            Network in the BGP routing table to display
  A.B.C.D/nn         IP prefix <network>/<length>, e.g., 35.0.0.0/8
  all                All address families
  cidr-only          Display only routes with non-natural netmasks
  community          Display routes matching the communities
  community-list     Display routes matching the community-list
  dampening          Display detailed information about dampening
  extcommunity-list  Display routes matching the extcommunity-list
  filter-list        Display routes conforming to the filter-list
  import             Display route topology import / export activity
  inconsistency      Display all inconsistent paths
  inconsistent-as    Display only routes with inconsistent origin ASs
  injected-paths     Display all injected paths
  ipv4               Address family
  ipv6               Address family
  l2vpn              Address family
  labels             Display Labels for IPv4 NLRI specific information
  neighbors          Detailed information on TCP and BGP neighbor connections
  nexthops           Nexthop address table
  nsap               Address family
  oer-paths          Display all oer controlled paths
  paths              Path information
  peer-group         Display information on peer-groups
  pending-prefixes   Display prefixes pending deletion
  prefix-list        Display routes matching the prefix-list
  quote-regexp       Display routes matching the AS path "regular expression"
  regexp             Display routes matching the AS path regular expression
  replication        Display replication status of update-group(s)
  rib-failure        Display bgp routes that failed to install in the routing
                     table (RIB)
  route-map          Display routes matching the route-map
  route-server       Route server information
  rpki               Display RPKI Neighbor Cache
  rtfilter           Address family
  summary            Summary of BGP neighbor status
  template           Display peer-policy/peer-session templates
  topology           Routing topology instance
  update-group       Display information on update-groups
  update-sources     Update source interface table
  va                 Display virtual aggregation prefixes
  version            Display prefixes with matching version numbers
  vpnv4              Address family
  vpnv6              Address family
  |                  Output modifiers
  <cr>
         
R3#show ip bgp summary        // ALTERNATE COMMAND TO VERIFY BGP NEIGHBOR STATUS
BGP router identifier 172.16.32.1, local AS number 64512
BGP table version is 4, main routing table version 4
2 network entries using 296 bytes of memory
4 path entries using 256 bytes of memory
4/2 BGP path/bestpath attribute entries using 544 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1120 total bytes of memory
BGP activity 2/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.64.1     4        64512      17      17        4    0    0 00:11:00        2
192.168.1.1     4          200       7       5        2    0    0 00:00:20        1


R1#clear ip bgp ?
  *                Clear all peers
  <1-4294967295>   Clear peers with the AS number
  <1.0-XX.YY>      Clear peers with the AS number
  A.B.C.D          BGP neighbor address to clear
  X:X:X:X::X       BGP neighbor address to clear
  all              All address families
  dampening        Clear route flap dampening information
  external         Clear all external peers
  flap-statistics  Clear route flap statistics
  internal         Clear BGP internal statistics counters
  ipv4             Address family
  ipv6             Address family
  l2vpn            Address family
  nsap             Address family
  peer-group       Clear all members of peer-group
  rtfilter         Address family
  sso              SSO related
  table-map        Update BGP table-map configuration
  topology         Routing topology instance
  update-group     Clear all members of update-group
  vpnv4            Address family
  vpnv6            Address family
         
R1#clear ip bgp *
R1#
*Jul 17 10:05:46.763: %BGP-5-ADJCHANGE: neighbor 192.168.1.2 Down User reset
*Jul 17 10:05:46.767: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.2 IPv4 Unicast topology base removed from session  User reset
*Jul 17 10:05:46.771: %BGP-5-ADJCHANGE: neighbor 192.168.1.6 Down User reset
*Jul 17 10:05:46.775: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.6 IPv4 Unicast topology base removed from session  User reset
R1#
*Jul 17 10:05:47.851: %BGP-5-ADJCHANGE: neighbor 192.168.1.6 Up
*Jul 17 10:05:47.851: %BGP-5-ADJCHANGE: neighbor 192.168.1.2 Up
R1#
R1#ping 172.16.64.1        // R2 DON'T HAVE RETURN PATH TO R1 SOURCE IP 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.64.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
R1#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
R1#ping 172.16.32.1      // PING IS OK SINCE BEST PATH IS VIA R3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.32.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/24 ms
R1#
R1#ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms


R1#show ip bgp      // BEST PATH TO 172.16.0.0/16 IS VIA R3
BGP table version is 3, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *   172.16.0.0       192.168.1.6              0             0 64512 i
 *>                   192.168.1.2              0             0 64512 i
 *>  192.168.100.0    0.0.0.0                  0         32768 i


R1#ping 172.16.1.1 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/15/28 ms
R1#
R1#ping 172.16.32.1 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.32.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/24 ms
R1#
R1#ping 172.16.1.2 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/24 ms
R1#
R1#ping 172.16.64.1 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.64.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/20/28 ms


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 200
R1(config-router)#network 192.168.1.0 mask 255.255.255.252    // R2 AND R3 DON'T KNOW EACH OTHERS EBGP PEERING LINKS
R1(config-router)#network 192.168.1.4 mask 255.255.255.252
R1(config-router)#end
R1#
*Jul 17 10:12:47.475: %SYS-5-CONFIG_I: Configured from console by console
R1#
R1#show ip bgp         // R1 (ISP) INJECTS /30 WAN LINKS TO R2 AND R3
BGP table version is 5, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *   172.16.0.0       192.168.1.6              0             0 64512 i
 *>                   192.168.1.2              0             0 64512 i
 *>  192.168.1.0/30   0.0.0.0                  0         32768 i
 *>  192.168.1.4/30   0.0.0.0                  0         32768 i
 *>  192.168.100.0    0.0.0.0                  0         32768 i


R2#show ip bgp
BGP table version is 7, local router ID is 172.16.64.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 172.16.0.0       172.16.32.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 * i 192.168.1.0/30   192.168.1.1              0    100      0 200 i
 *>                   192.168.1.5              0             0 200 i
 r i 192.168.1.4/30   192.168.1.1              0    100      0 200 i
 r>                   192.168.1.5              0             0 200 i
 * i 192.168.100.0    192.168.1.1              0    100      0 200 i
 *>                   192.168.1.5              0             0 200 i


R3#show ip bgp
BGP table version is 8, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  172.16.0.0       0.0.0.0                  0         32768 i
 * i                  172.16.64.1              0    100      0 i
 r i 192.168.1.0/30   192.168.1.5              0    100      0 200 i
 r>                   192.168.1.1              0             0 200 i
 * i 192.168.1.4/30   192.168.1.5              0    100      0 200 i
 *>                   192.168.1.1              0             0 200 i
 * i 192.168.100.0    192.168.1.5              0    100      0 200 i
 *>                   192.168.1.1              0             0 200 i



R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 200
R1(config-router)#no network 192.168.1.0 mask 255.255.255.252    // NOT ALWAYS DESIRABLE FOR ISP TO ADVERTISE EBGP WAN LINKS
R1(config-router)#no network 192.168.1.4 mask 255.255.255.252
R1(config-router)#exit
R1(config)#interface serial 2/2
R1(config-if)#shut
R1(config-if)#
*Jul 17 10:17:57.303: %BGP-5-ADJCHANGE: neighbor 192.168.1.2 Down Interface flap
*Jul 17 10:17:57.303: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.2 IPv4 Unicast topology base removed from session  Interface flap
R1(config-if)#
*Jul 17 10:17:59.267: %LINK-5-CHANGED: Interface Serial2/2, changed state to administratively down
*Jul 17 10:18:00.267: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to down


R3#    
*Jul 17 10:18:30.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to down
*Jul 17 10:18:30.103: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Down Interface flap
*Jul 17 10:18:30.103: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.1 IPv4 Unicast topology base removed from session  Interface flap
R3#
R3#show ip bgp      // EBGP NEXT HOP IS CARRIED IN IBGP UNCHANGED
BGP table version is 13, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  172.16.0.0       0.0.0.0                  0         32768 i
 * i                  172.16.64.1              0    100      0 i
 * i 192.168.100.0    192.168.1.5              0    100      0 200 i
R3#
R3#show ip route       // R3 DOESN'T HAVE 192.168.100/24 (VIA 192.168.1.5) IN ITS ROUTING TABLE
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.2/32 is directly connected, Serial2/1
C        172.16.32.0/24 is directly connected, Loopback0
L        172.16.32.1/32 is directly connected, Loopback0
D        172.16.64.0/24 [90/2297856] via 172.16.1.1, 00:28:16, Serial2/1


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 64512
R2(config-router)#neighbor 172.16.32.1 next-hop-self     // ADVERTISE IBGP PEER AS NEXT HOP ROUTER FOR EXTERNAL ROUTES
R2(config-router)#end
R2#
*Jul 17 10:21:24.611: %SYS-5-CONFIG_I: Configured from console by console
R2#
*Jul 17 10:21:55.551: %BGP-5-ADJCHANGE: neighbor 172.16.32.1 Down Peer closed the session
*Jul 17 10:21:55.555: %BGP_SESSION-5-ADJCHANGE: neighbor 172.16.32.1 IPv4 Unicast topology base removed from session  Peer closed the session
R2#c
*Jul 17 10:21:56.635: %BGP-5-ADJCHANGE: neighbor 172.16.32.1 Up
R2#
R2#clear ip bgp *       // FOR NEW BGP POLICY TO TAKE EFFECT (NON-DISRUPTIVE)
R2#
*Jul 17 10:22:01.127: %BGP-5-ADJCHANGE: neighbor 172.16.32.1 Down User reset
*Jul 17 10:22:01.131: %BGP_SESSION-5-ADJCHANGE: neighbor 172.16.32.1 IPv4 Unicast topology base removed from session  User reset
*Jul 17 10:22:01.135: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Down User reset
*Jul 17 10:22:01.139: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.5 IPv4 Unicast topology base removed from session  User reset
*Jul 17 10:22:01.963: %BGP-5-ADJCHANGE: neighbor 172.16.32.1 Up
*Jul 17 10:22:01.979: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Up


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router bgp 64512
R3(config-router)#neighbor 172.16.64.1 next-hop-self
R3(config-router)#end
R3#
*Jul 17 10:21:50.231: %SYS-5-CONFIG_I: Configured from console by console
R3#clear ip bgp *
R3#
*Jul 17 10:21:55.907: %BGP-5-ADJCHANGE: neighbor 172.16.64.1 Down User reset
*Jul 17 10:21:55.911: %BGP_SESSION-5-ADJCHANGE: neighbor 172.16.64.1 IPv4 Unicast topology base removed from session  User reset
R3#
*Jul 17 10:21:56.995: %BGP-5-ADJCHANGE: neighbor 172.16.64.1 Up
R3#
*Jul 17 10:22:01.555: %BGP-5-ADJCHANGE: neighbor 172.16.64.1 Down Peer closed the session
*Jul 17 10:22:01.555: %BGP_SESSION-5-ADJCHANGE: neighbor 172.16.64.1 IPv4 Unicast topology base removed from session  Peer closed the session
*Jul 17 10:22:02.335: %BGP-5-ADJCHANGE: neighbor 172.16.64.1 Up


R3#show ip bgp
BGP table version is 3, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 172.16.0.0       172.16.64.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>i 192.168.100.0    172.16.64.1              0    100      0 200 i
R3#
R3#show ip route       // 192.168.100.0/24 IS DISPLAYED IN ROUTING TABLE SINCE R3 KNOWS HOW TO REACH 172.16.64.1 (R2)
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.2/32 is directly connected, Serial2/1
C        172.16.32.0/24 is directly connected, Loopback0
L        172.16.32.1/32 is directly connected, Loopback0
D        172.16.64.0/24 [90/2297856] via 172.16.1.1, 00:33:01, Serial2/1
B     192.168.100.0/24 [200/0] via 172.16.64.1, 00:00:26


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface serial 2/2
R1(config-if)#no shut
R1(config-if)#
*Jul 17 10:24:15.635: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R1(config-if)#
*Jul 17 10:24:16.643: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2, changed state to up
R1(config-if)#
*Jul 17 10:24:21.087: %BGP-5-ADJCHANGE: neighbor 192.168.1.2 Up


R3#
*Jul 17 10:24:21.367: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up
R3#
R3#show ip route       // R3 DYNAMICALLY LEARNS 192.168.100.0/24 ROUTE VIA R1 EBGP PEER
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.2/32 is directly connected, Serial2/1
C        172.16.32.0/24 is directly connected, Loopback0
L        172.16.32.1/32 is directly connected, Loopback0
D        172.16.64.0/24 [90/2297856] via 172.16.1.1, 00:34:18, Serial2/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial2/2
L        192.168.1.2/32 is directly connected, Serial2/2
B     192.168.100.0/24 [20/0] via 192.168.1.1, 00:00:30


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#route-map PRIMARY_IN permit 10
R2(config-route-map)#set ?
  as-path           Prepend string for a BGP AS-path attribute
  automatic-tag     Automatically compute TAG value
  clns              OSI summary address
  comm-list         set BGP community list (for deletion)
  community         BGP community attribute
  dampening         Set BGP route flap dampening parameters
  default           Set default information
  extcomm-list      Set BGP/VPN extended community list (for deletion)
  extcommunity      BGP extended community attribute
  global            Set to global routing table
  interface         Output interface
  ip                IP specific information
  ipv6              IPv6 specific information
  level             Where to import route
  local-preference  BGP local preference path attribute
  metric            Metric value for destination routing protocol
  metric-type       Type of metric for destination routing protocol
  mpls-label        Set MPLS label for prefix
  origin            BGP origin code
  tag               Tag value for destination routing protocol
  traffic-index     BGP traffic classification number for accounting
  vrf               Define VRF name
  weight            BGP weight for routing table

R2(config-route-map)#set local-preference ?
  <0-4294967295>  Preference value

R2(config-route-map)#set local-preference 150     // LOCAL PREF ATTRIBUTE TO MANIPULATE OUTBOUND TRAFFIC FROM AS; SHARED BETWEEN IBGP NEIGHBORS; HIGHER IS PREFERRED
R2(config-route-map)#exit
R2(config)#router bgp 64512
R2(config-router)#neighbor 192.168.1.5 ?
  activate                 Enable the Address Family for this Neighbor
  advertise                Advertise to this neighbor
  advertise-map            specify route-map for conditional advertisement
  advertisement-interval   Minimum interval between sending BGP routing updates
  allowas-in               Accept as-path with my AS present in it
  capability               Advertise capability to the peer
  default-originate        Originate default route to this neighbor
  description              Neighbor specific description
  disable-connected-check  one-hop away EBGP peer using loopback address
  distribute-list          Filter updates to/from this neighbor
  dmzlink-bw               Propagate the DMZ link bandwidth
  ebgp-multihop            Allow EBGP neighbors not on directly connected
                           networks
  fall-over                session fall on peer route lost
  filter-list              Establish BGP filters
  ha-mode                  high availability mode
  inherit                  Inherit a template
  local-as                 Specify a local-as number
  maximum-prefix           Maximum number of prefixes accepted from this peer
  next-hop-self            Disable the next hop calculation for this neighbor
  next-hop-unchanged       Propagate next hop unchanged for iBGP paths to this
                           neighbor
  password                 Set a password
  peer-group               Member of the peer-group
  prefix-list              Filter updates to/from this neighbor
  remote-as                Specify a BGP neighbor
  remove-private-as        Remove private AS number from outbound updates
  route-map                Apply route map to neighbor
  route-reflector-client   Configure a neighbor as Route Reflector client
  route-server-client      Configure a neighbor as Route Server client
  send-community           Send Community attribute to this neighbor
  send-label               Send NLRI + MPLS Label to this peer
  shutdown                 Administratively shut down this neighbor
  slow-peer                Configure slow-peer
  soft-reconfiguration     Per neighbor soft reconfiguration
  soo                      Site-of-Origin extended community
  timers                   BGP per neighbor timers
  translate-update         Translate Update to MBGP format
  transport                Transport options
  ttl-security             BGP ttl security check
  unsuppress-map           Route-map to selectively unsuppress suppressed
                           routes
  update-source            Source of routing updates
  version                  Set the BGP version to match a neighbor
  weight                   Set default weight for routes from this neighbor
         
R2(config-router)#neighbor 192.168.1.5 route-map ?
  WORD  Name of route map

R2(config-router)#neighbor 192.168.1.5 route-map PRIMARY_IN ?
  in   Apply map to incoming routes
  out  Apply map to outbound routes

R2(config-router)#neighbor 192.168.1.5 route-map PRIMARY_IN in
R2(config-router)#end
R2#
*Jul 17 13:29:15.579: %SYS-5-CONFIG_I: Configured from console by console
R2#clear ip bgp * soft


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#route-map SECONDARY_IN permit 10
R3(config-route-map)#set local-preference 125
R3(config-route-map)#exit
R3(config)#router bgp 64512
R3(config-router)#neighbor 192.168.1.1 route-map SECONDARY_IN in
R3(config-router)#end
R3#
*Jul 17 13:29:58.327: %SYS-5-CONFIG_I: Configured from console by console
R3#clear ip bgp * soft


R2#show ip bgp
BGP table version is 4, local router ID is 172.16.64.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 172.16.0.0       172.16.32.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>  192.168.100.0    192.168.1.5              0    150      0 200 i         // PREFER VIA R1 EBGP PEER SINCE HIGHER LOCAL PREF


R3#show ip bgp
BGP table version is 5, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 172.16.0.0       172.16.64.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *   192.168.100.0    192.168.1.1              0    125      0 200 i
 *>i                  172.16.64.1              0    150      0 200 i        // HOP VIA R2 SINCE next-hop-self IS CONFIGURED


R1#show ip bgp      // ASYMMETRIC ROUTING IS COMMON IN BGP
BGP table version is 10, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *   172.16.0.0       192.168.1.2              0             0 64512 i
 *>                   192.168.1.6              0             0 64512 i
 *>  192.168.100.0    0.0.0.0                  0         32768 i


R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     172.16.0.0/16 [20/0] via 192.168.1.6, 03:11:13
      192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial2/2
L        192.168.1.1/32 is directly connected, Serial2/2
C        192.168.1.4/30 is directly connected, Serial2/0
L        192.168.1.5/32 is directly connected, Serial2/0
      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/24 is directly connected, Loopback0
L        192.168.100.1/32 is directly connected, Loopback0


R2#ping
Protocol [ip]:
Target IP address: 192.168.100.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.64.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record     // TYPE record TO VIEW HOP BY HOP IP TRACE AND ITS RETURN PATH
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.64.1
Packet has IP options:  Total option bytes= 39, padded length=40
 Record route: <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)

Reply to request 0 (32 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)          // R1
   (172.16.64.1) <*>    // BRACKET IS EXIT INTERFACE; RETURN PATH IS VIA R2 (SYMMETRIC PATH: R2 > R1 > R2)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 1 (20 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.64.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 2 (16 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.64.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 3 (16 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.64.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 4 (20 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.64.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/32 ms


R3#ping
Protocol [ip]:
Target IP address: 192.168.100.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.32.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.32.1
Packet has IP options:  Total option bytes= 39, padded length=40
 Record route: <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)

Reply to request 0 (28 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.1.1)        // R2
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 1 (12 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 2 (8 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 3 (28 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 4 (8 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.5)
   (172.16.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/28 ms


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#route-map PRIMARY_MED_OUT permit 10
R2(config-route-map)#set metric ?
  +/-<metric>     Add or subtract metric
  <0-4294967295>  Metric value or Bandwidth in Kbits per second

R2(config-route-map)#set metric 75       // MED IS FOR INBOUND PATH MANIPULATION; SHARED BETWEEN EBGP NEIGHBORS; LOWER IS PREFERRED
R2(config-route-map)#exit
R2(config)#router bgp 64512
R2(config-router)#neighbor 192.168.1.5 route-map PRIMARY_MED_OUT out
R2(config-router)#end
R2#
*Jul 17 13:55:02.290: %SYS-5-CONFIG_I: Configured from console by console
R2#clear ip bgp * soft


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#route-map SECONDARY_MED_OUT permit 10
R3(config-route-map)#set metric 50      // PREFER R3 FOR INBOUND ROUTES
R3(config-route-map)#exit
R3(config)#router bgp 64512
R3(config-router)#neighbor 192.168.1.1 route-map SECONDARY_MED_OUT out
R3(config-router)#end
R3#
*Jul 17 13:56:27.378: %SYS-5-CONFIG_I: Configured from console by console
R3#clear ip bgp * soft


R2#show ip bgp       
BGP table version is 4, local router ID is 172.16.64.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 172.16.0.0       172.16.32.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>  192.168.100.0    192.168.1.5              0    150      0 200 i


R3#show ip bgp       
BGP table version is 5, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 172.16.0.0       172.16.64.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *   192.168.100.0    192.168.1.1              0    125      0 200 i
 *>i                  172.16.64.1              0    150      0 200 i


R3#ping
Protocol [ip]:
Target IP address: 192.168.100.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 172.16.32.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.32.1
Packet has IP options:  Total option bytes= 39, padded length=40
 Record route: <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)

Reply to request 0 (56 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.1)       // R1
   (172.16.32.1) <*>         // R3 > R1 > R3
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 1 (16 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 2 (8 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 3 (16 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 4 (8 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (172.16.1.2)
   (192.168.1.6)
   (192.168.100.1)
   (192.168.1.1)
   (172.16.32.1) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/56 ms


R1#show ip bgp    // R1 (ISP) PREFER R3 TO REACH 172.16.0.0/16 SINCE R3 ADVERTISED A LOWER MED (50)
BGP table version is 12, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  172.16.0.0       192.168.1.2             50             0 64512 i          // LOWER METRIC (50) PREFFERED
 *                    192.168.1.6             75             0 64512 i
 *>  192.168.100.0    0.0.0.0                  0         32768 i


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 200
R1(config-router)#neighbor 192.168.1.6 default-originate       // INJECT DEFAULT ROUTE IN BGP
R1(config-router)#neighbor 192.168.1.2 default-originate
R1(config-router)#exit
R1(config)#interface loop 10
R1(config-if)#
*Jul 17 14:11:50.942: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback10, changed state to up
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#end
R1#


R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.1.5 to network 0.0.0.0

B*    0.0.0.0/0 [20/0] via 192.168.1.5, 00:00:07
      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.1/32 is directly connected, Serial2/1
D        172.16.32.0/24 [90/2297856] via 172.16.1.2, 04:22:17, Serial2/1
C        172.16.64.0/24 is directly connected, Loopback0
L        172.16.64.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.4/30 is directly connected, Serial2/0
L        192.168.1.6/32 is directly connected, Serial2/0
B     192.168.100.0/24 [20/0] via 192.168.1.5, 00:42:35


R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 172.16.64.1 to network 0.0.0.0

B*    0.0.0.0/0 [200/0] via 172.16.64.1, 00:00:31
      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.2/32 is directly connected, Serial2/1
C        172.16.32.0/24 is directly connected, Loopback0
L        172.16.32.1/32 is directly connected, Loopback0
D        172.16.64.0/24 [90/2297856] via 172.16.1.1, 04:22:41, Serial2/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial2/2
L        192.168.1.2/32 is directly connected, Serial2/2
B     192.168.100.0/24 [200/0] via 172.16.64.1, 00:42:59

R3#show ip bgp
BGP table version is 7, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 0.0.0.0          172.16.64.1              0    150      0 200 i         // DEFAULT ROUTE PREFER VIA R2 SINCE HIGHER LOCAL PREF
 *                    192.168.1.1                   125      0 200 i
 * i 172.16.0.0       172.16.64.1              0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *   192.168.100.0    192.168.1.1              0    125      0 200 i
 *>i                  172.16.64.1              0    150      0 200 i


R3#traceroute 10.0.0.1
Type escape sequence to abort.
Tracing the route to 10.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.1.1 24 msec 16 msec 20 msec
  2 192.168.1.5 [AS 200] 16 msec 32 msec 28 msec


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface serial 2/0
R1(config-if)#shut
R1(config-if)#
*Jul 17 14:14:55.542: %BGP-5-ADJCHANGE: neighbor 192.168.1.6 Down Interface flap
*Jul 17 14:14:55.542: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.6 IPv4 Unicast topology base removed from session  Interface flap
R1(config-if)#
*Jul 17 14:14:57.514: %LINK-5-CHANGED: Interface Serial2/0, changed state to administratively down
*Jul 17 14:14:58.514: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to down


R2# 
*Jul 17 14:15:25.178: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to down
*Jul 17 14:15:25.214: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Down Interface flap
*Jul 17 14:15:25.214: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.5 IPv4 Unicast topology base removed from session  Interface flap
R2#
R2#show ip route      // DEFAULT ROUTE HOPS VIA R3 DUE TO next-hop-self BETWEEN IBGP PEERS
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 172.16.32.1 to network 0.0.0.0

B*    0.0.0.0/0 [200/0] via 172.16.32.1, 00:00:06
      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.1/32 is directly connected, Serial2/1
D        172.16.32.0/24 [90/2297856] via 172.16.1.2, 04:24:59, Serial2/1
C        172.16.64.0/24 is directly connected, Loopback0
L        172.16.64.1/32 is directly connected, Loopback0
B     192.168.100.0/24 [200/0] via 172.16.32.1, 00:00:06


R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

B*    0.0.0.0/0 [20/0] via 192.168.1.1, 00:00:30
      172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
S        172.16.0.0/16 is directly connected, Null0
C        172.16.1.0/24 is directly connected, Serial2/1
L        172.16.1.2/32 is directly connected, Serial2/1
C        172.16.32.0/24 is directly connected, Loopback0
L        172.16.32.1/32 is directly connected, Loopback0
D        172.16.64.0/24 [90/2297856] via 172.16.1.1, 04:25:23, Serial2/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial2/2
L        192.168.1.2/32 is directly connected, Serial2/2
B     192.168.100.0/24 [20/0] via 192.168.1.1, 00:00:30


R2#traceroute 10.0.0.1      // HOP VIA R3 TO REACH 10.0.0.1
Type escape sequence to abort.
Tracing the route to 10.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.1.2 20 msec 20 msec 20 msec
  2 192.168.1.1 [AS 200] 20 msec 60 msec 24 msec


No comments:

Post a Comment