The OSPF stub router feature provides network engineers with a very simple way to enable the function of flooding default routes inside an area, with those default routes driving IP packets back toward the ABRs attached to that area. ABRs in stub areas advertise a default route into the stub area. At the same time, the ABR chooses to not advertise external routes (Type 5 LSAs) into the area. Similarly, the ABR chooses to not advertise interarea routes (in Type 3 LSAs) into the area. As a result, all routers in the stub area can still route to the destinations (based on default route information), and the routers require less memory and processing.
The following summarizes the features of a stub area:
* ABRs create a default route, using a Type 3 LSA, listing subnet 0.0.0.0 and mask
0.0.0.0, and flood that into the stub area.
* ABRs do not flood Type 5 LSAs into the stub area.
* ABRs might not flood other Type 3 LSAs into the area.
* The default route has a metric of 1 unless otherwise configured using the router sub-command
area <area-num> default-cost <cost>
* Routers inside stub areas cannot redistribute external routes into the stubby area,
because that would require a Type 5 LSA in the area.
* All routers in the area must be configured to be stubby; if not, neighbor relationships
cannot form between potential neighbors based on this mismatched configuration.
The following summarizes the features of a stub area:
* ABRs create a default route, using a Type 3 LSA, listing subnet 0.0.0.0 and mask
0.0.0.0, and flood that into the stub area.
* ABRs do not flood Type 5 LSAs into the stub area.
* ABRs might not flood other Type 3 LSAs into the area.
* The default route has a metric of 1 unless otherwise configured using the router sub-command
area <area-num> default-cost <cost>
* Routers inside stub areas cannot redistribute external routes into the stubby area,
because that would require a Type 5 LSA in the area.
* All routers in the area must be configured to be stubby; if not, neighbor relationships
cannot form between potential neighbors based on this mismatched configuration.
R1#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#interface
loop 0
R1(config-if)#
*Jun 29
10:05:00.731: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to up
R1(config-if)#ip
address 192.168.1.1 255.255.255.0
R1(config-if)#ipv6
address 2001:db8:cafe:1::1/64
R1(config-if)#
R1(config-if)#interface
serial 2/0
R1(config-if)#ip
address 192.168.2.1 255.255.255.252
R1(config-if)#ipv6
address 2001:db8:cafe:2::1/64
R1(config-if)#no
shut
R1(config-if)#
*Jun 29
10:07:20.179: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R1(config-if)#
*Jun 29
10:07:21.191: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0,
changed state to up
R1(config-if)#end
R1#
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#interface
loop 0
R2(config-if)#
*Jun 29
10:06:34.531: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to up
R2(config-if)#ip
address 192.168.3.1 255.255.255.0
R2(config-if)#ipv6
address 2001:db8:cafe:3::1/64
R2(config-if)#
R2(config-if)#interface
serial 2/0
R2(config-if)#ip
address 192.168.2.2 255.255.255.252
R2(config-if)#ipv6
address 2001:db8:cafe:2::2/64
R2(config-if)#no
shut
R2(config-if)#
*Jun 29
10:07:44.547: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R2(config-if)#
*Jun 29
10:07:45.559: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0,
changed state to up
R2(config-if)#do
ping 192.168.2.1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/23/36 ms
R2(config-if)#do
ping 2001:DB8:CAFE:2::1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8:CAFE:2::1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 12/17/24 ms
R2(config-if)#interface
serial 2/1
R2(config-if)#
*Jun 29
10:07:53.943: %IPV6_ND-6-DUPLICATE_INFO: DAD attempt detected for
2001:DB8:CAFE:2::2 on Serial2/0
R2(config-if)#ip
address 192.168.4.1 255.255.255.252
R2(config-if)#ipv6
address 2001:db8:cafe:4::1/64
R2(config-if)#no
shut
R2(config-if)#
*Jun 29
10:08:34.563: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R2(config-if)#
*Jun 29
10:08:35.575: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1,
changed state to up
R2(config-if)#
R2(config-if)#end
R2#
R3#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R3(config)#interface
loop 0
R3(config-if)#
*Jun 29
10:13:26.015: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to up
R3(config-if)#ip
address 192.168.5.1 255.255.255.0
R3(config-if)#ipv6
address 2001:db8:cafe:5::1/64
R3(config-if)#
R3(config-if)#interface
serial 2/1
R3(config-if)#ip
address 192.168.4.2 255.255.255.252
R3(config-if)#ipv6
address 2001:db8:cafe:4::2/64
R3(config-if)#no
shut
R3(config-if)#
*Jun 29
10:14:41.407: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R3(config-if)#
*Jun 29
10:14:42.419: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1,
changed state to up
R3(config-if)#do
ping 192.168.4.1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.4.1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 20/22/24 ms
R3(config-if)#
R3(config-if)#do
ping 2001:db8:cafe:4::1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8:CAFE:4::1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms
R3(config-if)#
R3(config-if)#interface
serial 2/2
R3(config-if)#ip
address 192.168.77.2 255.255.255.0
R3(config-if)#ipv6
address 2001:db8:feed:77::2/64
R3(config-if)#no
shut
R3(config-if)#
*Jun 29
10:15:56.795: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R3(config-if)#
*Jun 29
10:15:57.807: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2,
changed state to up
R3(config-if)#end
R3#
R4#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R4(config)#interface
loop 0
R4(config-if)#
*Jun 29
10:15:00.819: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to up
R4(config-if)#ip
address 192.168.99.1 255.255.255.0
R4(config-if)#ipv6
address 2001:db8:99:1::1/64
R4(config-if)#
R4(config-if)#interface
serial 2/2
R4(config-if)#ip
address 192.168.77.1 255.255.255.0
R4(config-if)#ipv6
address 2001:db8:feed:77::1/64
R4(config-if)#no
shut
R4(config-if)#
*Jun 29
10:15:56.571: %LINK-3-UPDOWN: Interface Serial2/2, changed state to up
R4(config-if)#
*Jun 29
10:15:57.583: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/2,
changed state to up
R4(config-if)#do
ping 192.168.77.2
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.77.2, timeout is 2 seconds:
.!!!!
Success
rate is 80 percent (4/5), round-trip min/avg/max = 8/37/80 ms
R4(config-if)#
R4(config-if)#do
ping 2001:db8:feed:77::2
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8:FEED:77::2, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R4(config-if)#ipv6
unicast-routing
R4(config-if)#ipv6
route 2001:db8:cafe::/48 2001:db8:feed:77::2
R4(config-if)#ip
route 0.0.0.0 0.0.0.0 192.168.77.2
R1#show
ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset
administratively down down
FastEthernet1/0 unassigned YES unset
administratively down down
FastEthernet1/1 unassigned YES unset
administratively down down
Serial2/0 192.168.2.1 YES manual up up
Serial2/1 unassigned YES unset
administratively down down
Serial2/2 unassigned YES unset
administratively down down
Serial2/3 unassigned YES unset
administratively down down
Loopback0 192.168.1.1 YES manual up up
R1#
R1#show
ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet1/0 [administratively down/down]
unassigned
FastEthernet1/1 [administratively down/down]
unassigned
Serial2/0 [up/up]
FE80::C801:15FF:FEB0:0
2001:DB8:CAFE:2::1
2001:DB8:CAFE:2::2
Serial2/1 [administratively down/down]
unassigned
Serial2/2 [administratively down/down]
unassigned
Serial2/3 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::C801:15FF:FEB0:0
2001:DB8:CAFE:1::1
R2#show
ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset
administratively down down
FastEthernet1/0 unassigned YES unset
administratively down down
FastEthernet1/1 unassigned YES unset
administratively down down
Serial2/0 192.168.2.2 YES manual up up
Serial2/1 192.168.4.1 YES manual up up
Serial2/2 unassigned YES unset
administratively down down
Serial2/3 unassigned YES unset
administratively down down
Loopback0 192.168.3.1 YES manual up up
R2#
R2#show
ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet1/0 [administratively down/down]
unassigned
FastEthernet1/1 [administratively down/down]
unassigned
Serial2/0 [up/up]
FE80::C802:16FF:FECC:0
2001:DB8:CAFE:2::2
Serial2/1 [up/up]
FE80::C802:16FF:FECC:0
2001:DB8:CAFE:4::1
Serial2/2 [administratively down/down]
unassigned
Serial2/3 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::C802:16FF:FECC:0
2001:DB8:CAFE:3::1
R3#show
ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet1/0 [administratively down/down]
unassigned
FastEthernet1/1 [administratively down/down]
unassigned
Serial2/0 [administratively down/down]
unassigned
Serial2/1 [up/up]
FE80::C803:1BFF:FE10:0
2001:DB8:CAFE:4::2
Serial2/2 [up/up]
FE80::C803:1BFF:FE10:0
2001:DB8:FEED:77::2
Serial2/3 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::C803:1BFF:FE10:0
2001:DB8:CAFE:5::1
R4#show
ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet1/0 [administratively down/down]
unassigned
FastEthernet1/1 [administratively down/down]
unassigned
Serial2/0 [administratively down/down]
unassigned
Serial2/1 [administratively down/down]
unassigned
Serial2/2 [up/up]
FE80::C804:10FF:FE70:0
2001:DB8:FEED:77::1
Serial2/3 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::C804:10FF:FE70:0
2001:DB8:99:1::1
R1#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#router
ospf 1
R1(config-router)#router-id
1.1.1.1
R1(config-router)#
R1(config-router)#interface
serial 2/0
R1(config-if)#ip
ospf ?
<1-65535> Process ID
authentication Enable authentication
authentication-key Authentication password (key)
bfd Enable BFD on this interface
cost Interface cost
database-filter Filter OSPF LSA during synchronization
and flooding
dead-interval Interval after which a neighbor is
declared dead
demand-circuit OSPF Demand Circuit
flood-reduction OSPF Flood Reduction
hello-interval Time between HELLO packets
lls Link-local Signaling (LLS)
support
message-digest-key Message digest authentication password (key)
mtu-ignore Ignores the MTU in DBD packets
network Network type
prefix-suppression OSPF prefix suppression
priority Router priority
resync-timeout Interval after which adjacency is reset
if oob-resync is
not started
retransmit-interval Time between retransmitting lost link state
advertisements
shutdown Set OSPF protocol's state to
disable under current
interface
transmit-delay Link state transmit delay
ttl-security TTL security check
R1(config-if)#ip
ospf 1 ?
area
Set the OSPF area ID
R1(config-if)#ip
ospf 1 area ?
<0-4294967295> OSPF area ID as a decimal value
A.B.C.D OSPF area ID in IP address format
R1(config-if)#ip
ospf 1 area 51 // OSPFv2 INTERFACE COMMAND AVAILABLE IN IOS 12.3(11)T ABOVE
R1(config-if)#
R1(config-if)#interface
loop 0
R1(config-if)#ip
ospf 1 area 51
R1(config-if)#end
R1#
*Jun 29
10:29:50.879: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial2/0 from LOADING
to FULL, Loading Done
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#router
ospf 1
R2(config-router)#router-id
2.2.2.2
R2(config-router)#
R2(config-router)#interface
loop 0
R2(config-if)#ip
ospf 1 area 0
R2(config-if)#
R2(config-if)#interface
serial 2/1
R2(config-if)#ip
ospf 1 area 0
R2(config-if)#
R2(config-if)#interface
serial 2/0
R2(config-if)#ip
ospf 1 area 51
R2(config-if)#
*Jun 29 10:27:30.883:
%OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial2/0 from LOADING to FULL,
Loading Done
R2(config-if)#end
R2#
*Jun 29
10:28:48.691: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial2/1 from LOADING
to FULL, Loading Done
R3#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R3(config)#router
ospf 1
R3(config-router)#router-id
3.3.3.3
R3(config-router)#
R3(config-router)#interface
loop 0
R3(config-if)#ip
ospf 1 area 0
R3(config-if)#
R3(config-if)#interface
serial 2/1
R3(config-if)#ip
ospf 1 area 0
R3(config-if)#
*Jun 29 10:30:48.803:
%OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial2/1 from LOADING to FULL,
Loading Done
R1#show
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
2.2.2.2 0
FULL/ - 00:00:36 192.168.2.2 Serial2/0
R2#show
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
3.3.3.3 0
FULL/ - 00:00:34 192.168.4.2 Serial2/1
1.1.1.1 0
FULL/ - 00:00:34 192.168.2.1 Serial2/0
R3#show
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
2.2.2.2 0
FULL/ - 00:00:33 192.168.4.1 Serial2/1
R3#show
ip route
Codes: L
- local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route, H - NHRP, l - LISP
+ - replicated route, % - next hop
override
Gateway
of last resort is not set
192.168.1.0/32 is subnetted, 1 subnets
O IA 192.168.1.1 [110/129] via 192.168.4.1,
00:02:05, Serial2/1
192.168.2.0/30 is subnetted, 1 subnets
O IA 192.168.2.0 [110/128] via 192.168.4.1,
00:02:05, Serial2/1
192.168.3.0/32 is subnetted, 1 subnets
O 192.168.3.1 [110/65] via 192.168.4.1,
00:02:05, Serial2/1
192.168.4.0/24 is variably subnetted, 2
subnets, 2 masks
C 192.168.4.0/30 is directly connected,
Serial2/1
L 192.168.4.2/32 is directly connected,
Serial2/1
192.168.5.0/24 is variably subnetted, 2
subnets, 2 masks
C 192.168.5.0/24 is directly connected,
Loopback0
L 192.168.5.1/32 is directly connected,
Loopback0
192.168.77.0/24 is variably subnetted, 2
subnets, 2 masks
C 192.168.77.0/24 is directly connected,
Serial2/2
L 192.168.77.2/32 is directly connected,
Serial2/2
R2#show
ip route
Codes: L
- local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route, H - NHRP, l - LISP
+ - replicated route, % - next hop
override
Gateway
of last resort is not set
192.168.1.0/32 is subnetted, 1 subnets
O 192.168.1.1 [110/65] via 192.168.2.1,
00:11:32, Serial2/0
192.168.2.0/24 is variably subnetted, 2
subnets, 2 masks
C 192.168.2.0/30 is directly connected,
Serial2/0
L 192.168.2.2/32 is directly connected,
Serial2/0
192.168.3.0/24 is variably subnetted, 2
subnets, 2 masks
C 192.168.3.0/24 is directly connected,
Loopback0
L 192.168.3.1/32 is directly connected,
Loopback0
192.168.4.0/24 is variably subnetted, 2
subnets, 2 masks
C 192.168.4.0/30 is directly connected,
Serial2/1
L 192.168.4.1/32 is directly connected,
Serial2/1
192.168.5.0/32 is subnetted, 1 subnets
O 192.168.5.1 [110/65] via 192.168.4.2,
00:10:19, Serial2/1
R3#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R3(config)#ip
route 0.0.0.0 0.0.0.0 192.168.77.1
R3(config)#router
ospf 1
R3(config-router)#default-information
originate // PROPAGATE STATIC DEFAULT ROUTE INTO OSPFv2
R3#show
ip route ?
Hostname or A.B.C.D Network to display information about or
hostname
bgp Border Gateway Protocol (BGP)
connected Connected
dhcp Show routes added by DHCP
Server or Relay
eigrp Enhanced Interior Gateway
Routing Protocol (EIGRP)
isis ISO IS-IS
lisp Locator ID Separation Protocol
(LISP)
list IP Access list
loops RIB routes forming loops
mobile Mobile routes
multicast Multicast global information
next-hop-override Show next-hop-overrides too
nhrp Next Hop Resolution Protocol
(NHRP)
odr On Demand stub Routes
ospf Open Shortest Path First
(OSPF)
ospfv3 OSPFv3
profile IP routing table profile
repair-paths Show repair paths too
rip Routing Information Protocol
(RIP)
static Static routes
summary Summary of all routes
supernets-only Show supernet entries only
tag Route Tag
track-table Tracked static table
vrf Display routes from a VPN
Routing/Forwarding instance
| Output modifiers
<cr>
R3#show
ip route static
Codes: L
- local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route, H - NHRP, l - LISP
+ - replicated route, % - next hop
override
Gateway
of last resort is 192.168.77.1 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.77.1
R3#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R3(config)#ip
route 192.168.99.0 255.255.255.0 192.168.77.1
R3(config)#router
ospf 1
R3(config-router)#redistribute
static ?
metric
Metric for redistributed routes
metric-type
OSPF/IS-IS exterior metric type for redistributed routes
nssa-only
Limit redistributed routes to NSSA areas
route-map
Route map reference
subnets
Consider subnets for redistribution into OSPF
tag
Set tag for routes redistributed into OSPF
<cr>
R3(config-router)#redistribute
static subnets // THE subnets KEYWORD INCLUDES SPECIFIC ROUTES (NOT CLASSFUL NETWORKS)
R1#show
ip route ospf
Codes: L
- local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route, H - NHRP, l - LISP
+ - replicated route, % - next hop
override
Gateway
of last resort is 192.168.2.2 to network 0.0.0.0
O*E2 0.0.0.0/0 [110/1] via 192.168.2.2, 00:54:34,
Serial2/0
192.168.3.0/32 is subnetted, 1 subnets
O IA 192.168.3.1 [110/65] via 192.168.2.2,
01:08:41, Serial2/0
192.168.4.0/30 is subnetted, 1 subnets
O IA 192.168.4.0 [110/128] via 192.168.2.2,
01:08:41, Serial2/0
192.168.5.0/32 is subnetted, 1 subnets
O IA 192.168.5.1 [110/129] via 192.168.2.2,
01:07:24, Serial2/0
O E2 192.168.99.0/24 [110/20] via 192.168.2.2,
00:52:44, Serial2/0
R1#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#router
ospf 1
R1(config-router)#?
Router
configuration commands:
address-family Enter Address Family command mode
area OSPF area parameters
auto-cost Calculate OSPF interface cost
according to bandwidth
bfd BFD configuration commands
capability Enable specific OSPF feature
compatible OSPF compatibility list
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
discard-route Enable or disable discard-route
installation
distance Define an administrative
distance
distribute-list Filter networks in routing updates
domain-id OSPF domain-id
domain-tag OSPF domain-tag
event-log OSPF Event Logging
exit Exit from routing protocol
configuration mode
help Description of the
interactive help system
ignore Do not complain about specific
event
interface-id Source of the interface ID
ispf Enable incremental SPF
computation
limit Limit a specific OSPF feature
local-rib-criteria Enable or disable usage of local RIB as
route criteria
log-adjacency-changes Log changes in adjacency state
max-lsa maximum number of LSAs OSPF
process will receive
max-metric Set maximum metric
maximum-paths Forward packets over multiple paths
mpls Configure MPLS routing
protocol parameters
neighbor Specify a neighbor router
network Enable routing on an IP network
no Negate a command or set
its defaults
nsf Non-stop forwarding
passive-interface Suppress routing updates on an interface
prefix-suppression OSPF prefix suppression
priority OSPF topology priority
queue-depth OSPF Hello/Router process queue
depth
redistribute Redistribute information from
another routing protocol
router-id router-id for this OSPF process
shutdown Shutdown the OSPF protocol under
the current instance
snmp Modify snmp parameters
summary-address Configure IP address summaries
timers Adjust routing timers
traffic-share How to compute traffic share over
alternate paths
ttl-security TTL security check
R1(config-router)#area
?
<0-4294967295> OSPF area ID as a decimal value
A.B.C.D OSPF area ID in IP address format
R1(config-router)#area
51 ?
authentication Enable authentication
capability Enable area specific capability
default-cost Set the summary default-cost of a NSSA/stub
area
filter-list Filter networks between OSPF areas
nssa Specify a NSSA area
range Summarize routes matching
address/mask (border routers only)
sham-link Define a sham link and its parameters
stub Specify a stub area
virtual-link Define a virtual link and its parameters
R1(config-router)#area
51 stub // OSPF ADJACENCY WILL BOUNCE
R1(config-router)#
*Jun 29 11:40:20.027:
%OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial2/0 from FULL to DOWN, Neighbor
Down: Adjacency forced to reset
*Jun 29 11:40:53.283:
%OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial2/0 from LOADING to FULL,
Loading Done
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#router
ospf 1
R2(config-router)#area
51 stub
R2(config-router)#
*Jun 29 11:38:32.755:
%OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial2/0 from FULL to DOWN, Neighbor
Down: Adjacency forced to reset
*Jun 29 11:38:33.287:
%OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial2/0 from LOADING to FULL,
Loading Done
R1#show
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
2.2.2.2 0
FULL/ - 00:00:33 192.168.2.2 Serial2/0
R2#show
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
3.3.3.3 0
FULL/ - 00:00:36 192.168.4.2 Serial2/1
1.1.1.1 0
FULL/ - 00:00:36 192.168.2.1 Serial2/0
R1#show
ip route ospf // R1 STUB AREA WILL NOT ACCEPT EXTERNAL ROUTES
Codes: L
- local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route, H - NHRP, l - LISP
+ - replicated route, % - next hop
override
Gateway
of last resort is 192.168.2.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 192.168.2.2, 00:01:49,
Serial2/0
192.168.3.0/32 is subnetted, 1 subnets
O IA 192.168.3.1 [110/65] via 192.168.2.2,
00:01:49, Serial2/0
192.168.4.0/30 is subnetted, 1 subnets
O IA 192.168.4.0 [110/128] via 192.168.2.2,
00:01:49, Serial2/0
192.168.5.0/32 is subnetted, 1 subnets
O IA 192.168.5.1 [110/129] via 192.168.2.2,
00:01:49, Serial2/0
R2#show
ip ospf
Routing Process "ospf 1" with ID
2.2.2.2
Start time: 00:28:46.228, Time elapsed:
01:15:10.384
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Event-log enabled, Maximum number of events:
1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with
maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs
10000 msecs
Maximum wait time between two consecutive SPFs
10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 2. Checksum Sum
0x0172F8
Number of opaque AS LSA 0. Checksum Sum
0x000000
Number of DCbitless external and opaque AS LSA
0
Number of DoNotAge external and opaque AS LSA
0
Number of areas in this router is 2. 1 normal
1 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 2
(1 loopback)
Area has no authentication
SPF algorithm last executed
00:02:57.856 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 4. Checksum Sum 0x0296CA
Number of opaque link LSA 0. Checksum
Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 51
Number of interfaces in this area is 1
It is a stub area
Generates stub default route with cost
1
Area has no authentication
SPF algorithm last executed
00:02:47.848 ago
SPF algorithm executed 4 times
Area ranges are
Number of LSA 6. Checksum Sum 0x042FCC
Number of opaque link LSA 0. Checksum
Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
R2#show
ip ospf database
OSPF Router with ID (2.2.2.2)
(Process ID 1)
Router Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 654 0x80000006 0x00FE2C 3
3.3.3.3 3.3.3.3 1806 0x80000004 0x009391 3
Summary Net Link States (Area
0)
Link
ID ADV Router Age Seq# Checksum
192.168.1.1 2.2.2.2 342 0x80000001 0x001375
192.168.2.0 2.2.2.2 654 0x80000003 0x00F198
Router Link States (Area 51)
Link
ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 352 0x80000007 0x008BB3 3
2.2.2.2 2.2.2.2 346 0x80000005 0x00A611 2
Summary Net Link States (Area
51)
Link
ID ADV Router Age Seq# Checksum
0.0.0.0 2.2.2.2 352 0x80000001 0x0075C0
192.168.3.1 2.2.2.2 352 0x80000004 0x009233
192.168.4.0 2.2.2.2 352 0x80000004 0x00F791
192.168.5.1 2.2.2.2 352 0x80000004 0x00FE84
Type-5 AS External Link States
Link
ID ADV Router Age Seq# Checksum Tag
0.0.0.0 3.3.3.3 1806 0x80000002 0x00DEC6 1
192.168.99.0 3.3.3.3 1806 0x80000002 0x009432 0
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#router
ospf 1
R2(config-router)#area
51 stub ?
no-ext-capability Do not send domain specific capabilities into
stub area
no-summary Do not send summary LSA into stub area
<cr>
R2(config-router)#area
51 stub no-summary // TOTALLY STUBBY AREA
R1#show
ip route ospf // NO OSPF INTER-AREA AND EXTERNAL ROUTES IN OSPF TOTALLY STUBBY AREA
Codes: L
- local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route, H - NHRP, l - LISP
+ - replicated route, % - next hop
override
Gateway
of last resort is 192.168.2.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 192.168.2.2, 00:00:16,
Serial2/0
R1#show
ip ospf database
OSPF Router with ID (1.1.1.1)
(Process ID 1)
Router Link States (Area 51)
Link
ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 464 0x80000007 0x008BB3 3
2.2.2.2 2.2.2.2 461 0x80000005 0x00A611 2
Summary Net Link States (Area
51)
Link ID ADV Router Age Seq# Checksum
0.0.0.0 2.2.2.2 44 0x80000003 0x0071C2
R1#show
ipv6 interface brief // COMMAND TO VIEW GLOBAL UNICAST AND LINK-LOCAL ADDRESS
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet1/0 [administratively down/down]
unassigned
FastEthernet1/1 [administratively down/down]
unassigned
Serial2/0 [up/up]
FE80::C801:15FF:FEB0:0
2001:DB8:CAFE:2::1
2001:DB8:CAFE:2::2
Serial2/1 [administratively down/down]
unassigned
Serial2/2 [administratively down/down]
unassigned
Serial2/3 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::C801:15FF:FEB0:0
2001:DB8:CAFE:1::1
R1#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#ipv6
unicast-routing // ENABLE IPv6 ROUTING (AND IPv6 CEF); DISABLED BY DEFAULT
R1(config)#end
R1#
*Jun 29
15:12:53.514: %SYS-5-CONFIG_I: Configured from console by console
R1#show
ipv6 cef
::/0
no route
::/127
discard
2001:DB8:CAFE:1::/64
attached to Loopback0
2001:DB8:CAFE:1::1/128
receive for Loopback0
2001:DB8:CAFE:2::/64
attached to Serial2/0
2001:DB8:CAFE:2::1/128
receive for Serial2/0
FE80::/10
receive for Null0
FF00::/8
multicast
R1#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#ipv6
router ospf 2
R1(config-rtr)#router-id
1.1.1.1
R1(config-rtr)#
R1(config-rtr)#interface
loop 0
R1(config-if)#ipv6
ospf 2 area 51
R1(config-if)#
R1(config-if)#interface
serial 2/0
R1(config-if)#ipv6
ospf 2 area 51
R1(config-if)#
*Jun 29 15:15:47.202:
%OSPFv3-5-ADJCHG: Process 2, Nbr 2.2.2.2 on Serial2/0 from LOADING to FULL,
Loading Done
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#ipv6
unicast-routing
R2(config)#ipv6
router ospf 2
R2(config-rtr)#router-id
2.2.2.2
R2(config-rtr)#
R2(config-rtr)#interface
serial 2/0
R2(config-if)#ipv6
ospf 2 area 51
R2(config-if)#
*Jun 29 15:13:27.166:
%OSPFv3-5-ADJCHG: Process 2, Nbr 1.1.1.1 on Serial2/0 from LOADING to FULL,
Loading Done
R2(config-if)#
R2(config-if)#interface
loop 0
R2(config-if)#ipv6
ospf 2 area 0
R2(config-if)#
R2(config-if)#interface
serial 2/1
R2(config-if)#ipv6
ospf 2 area 0
R2(config-if)#
*Jun 29 15:15:03.898:
%OSPFv3-5-ADJCHG: Process 2, Nbr 192.168.5.1 on Serial2/1 from LOADING to FULL,
Loading Done
R3#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R3(config)#ipv6
unicast
R3(config)#ipv6
router ospf 2
R3(config-rtr)#
R3(config-rtr)#interface
loop 0
R3(config-if)#ipv6
ospf 2 area 0
R3(config-if)#
R3(config-if)#interface
serial 2/1
R3(config-if)#ipv6
ospf 2 area 0
R3(config-if)#
*Jun 29 15:17:04.078:
%OSPFv3-5-ADJCHG: Process 2, Nbr 2.2.2.2 on Serial2/1 from LOADING to FULL,
Loading Done
R2#show
ipv6 ospf neighbor
OSPFv3 Router with ID (2.2.2.2)
(Process ID 2)
Neighbor
ID Pri State Dead Time Interface ID Interface
192.168.5.1 0
FULL/ - 00:00:36 7 Serial2/1
1.1.1.1 0
FULL/ - 00:00:37 6 Serial2/0
R2#
*Jun 29 15:17:37.806:
%OSPFv3-5-ADJCHG: Process 2, Nbr 3.3.3.3 on Serial2/1 from LOADING to FULL,
Loading Done
R3#show
ipv6 ospf // IPv6 COMMAND TO VIEW OSPFv3 ROUTER-ID
Routing Process "ospfv3 2" with ID 192.168.5.1
Event-log enabled, Maximum number of events:
1000, Mode: cyclic
Router is not originating router-LSAs with
maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs
10000 msecs
Maximum wait time between two consecutive SPFs
10000 msecs
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum
0x000000
Number of areas in this router is 1. 1 normal
0 stub 0 nssa
Graceful restart helper support enabled
Reference bandwidth unit is 100 mbps
RFC1583 compatibility enabled
Area BACKBONE(0)
Number of interfaces in this area is 2
SPF algorithm executed 2 times
Number of LSA 8. Checksum Sum 0x052115
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
R3(config)#ipv6
router ospf 2
R3(config-rtr)#router-id
3.3.3.3
% OSPFv3: Reload or use
"clear ipv6 ospf process" command, for this to take effect
R3(config-rtr)#do
clear ipv6 ospf 2 process // COMMAND TO RESET OSPFv3 32-BIT ROUTER-ID
Reset
selected OSPFv3 processes? [no]: y
R3(config-rtr)#
*Jun 29 15:19:37.982:
%OSPFv3-5-ADJCHG: Process 2, Nbr 2.2.2.2 on Serial2/1 from LOADING to FULL,
Loading Done
R2#show
ipv6 ospf neighbor
OSPFv3 Router with ID (2.2.2.2)
(Process ID 2)
Neighbor
ID Pri State Dead Time Interface ID Interface
3.3.3.3 0
FULL/ - 00:00:35 7 Serial2/1
1.1.1.1 0
FULL/ - 00:00:33 6 Serial2/0
R1#show
ipv6 route ospf
IPv6
Routing Table - default - 8 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
OI 2001:DB8:CAFE:3::1/128 [110/64]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:4::/64 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:5::1/128 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/0
R2#show
ipv6 route ospf
IPv6
Routing Table - default - 9 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
O 2001:DB8:CAFE:1::1/128 [110/64]
via FE80::C801:15FF:FEB0:0, Serial2/0
O 2001:DB8:CAFE:5::1/128 [110/64]
via FE80::C803:1BFF:FE10:0, Serial2/1
R3#show
ipv6 route ospf
IPv6
Routing Table - default - 9 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
OI 2001:DB8:CAFE:1::1/128 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/1
OI 2001:DB8:CAFE:2::/64 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/1
O 2001:DB8:CAFE:3::1/128 [110/64]
via FE80::C802:16FF:FECC:0, Serial2/1
R3#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R3(config)#ipv6
route ::/0 2001:db8:feed:77::1
R3(config)#ipv6
route 2001:db8:99:1::/64 2001:db8:feed:77::1
R3(config)#ipv6
router ospf 2
R3(config-rtr)#?
area OSPF area parameters
auto-cost Calculate OSPF interface cost
according to bandwidth
bfd BFD configuration commands
compatible Compatibility list
default Set a command to its defaults
default-information Distribution of default information
default-metric Set metric of redistributed routes
discard-route Enable or disable discard-route
installation
distance Administrative distance
distribute-list Filter networks in routing updates
event-log Event Logging
exit Exit from IPv6 routing
protocol configuration mode
graceful-restart Graceful-restart options
interface-id Source of the interface ID
log-adjacency-changes Log changes in adjacency state
manet Specify MANET OSPF parameters
max-lsa Maximum number of non
self-generated LSAs to accept
max-metric Set maximum metric
maximum-paths Forward packets over multiple paths
no Negate a command or set
its defaults
passive-interface Suppress routing updates on an interface
queue-depth Hello/Router process queue depth
redistribute Redistribute IPv6 prefixes from
another routing
protocol
router-id router-id for this OSPF process
snmp Modify snmp parameters
summary-prefix Configure IPv6 summary prefix
table-map Map external entry attributes
into routing table
timers Adjust routing timers
R3(config-rtr)#default-information
?
originate
Distribute default route
R3(config-rtr)#default-information
originate
R3(config-rtr)#redistribute
static
R3(config-rtr)#end
R3#
*Jun 29
15:25:21.946: %SYS-5-CONFIG_I: Configured from console by console
R3#show
ipv6 route static
IPv6
Routing Table - default - 11 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
S ::/0 [1/0]
via 2001:DB8:FEED:77::1
S 2001:DB8:99:1::/64 [1/0]
via 2001:DB8:FEED:77::1
R1#show
ipv6 route ospf // VERIFY DEFAULT ROUTE AND REDISTRIBUTED STATIC ROUTE
IPv6
Routing Table - default - 10 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
OE2 ::/0 [110/1], tag 2
via FE80::C802:16FF:FECC:0, Serial2/0
OE2 2001:DB8:99:1::/64 [110/20]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:3::1/128 [110/64]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:4::/64 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:5::1/128 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/0
R1#ping
2001:db8:99:1::1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8:99:1::1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 44/46/48 ms
R1#traceroute
2001:db8:99:1::1
Type
escape sequence to abort.
Tracing
the route to 2001:DB8:99:1::1
1 2001:DB8:CAFE:2::2 20 msec 28 msec 16 msec
2 2001:DB8:CAFE:4::2 8 msec 28 msec 36 msec
3 2001:DB8:FEED:77::1 48 msec 52 msec 60 msec
R1#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#ipv6
router ospf 2
R1(config-rtr)#area
51 stub // SIMILAR TO OSPFv2
R1(config-rtr)#
*Jun 29
15:28:08.610: %OSPFv3-5-ADJCHG: Process 2, Nbr 2.2.2.2 on Serial2/0 from FULL
to DOWN, Neighbor Down: Adjacency forced to reset
R1(config-rtr)#
*Jun 29 15:28:33.130:
%OSPFv3-5-ADJCHG: Process 2, Nbr 2.2.2.2 on Serial2/0 from LOADING to FULL,
Loading Done
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#ipv6
router ospf 2
R2(config-rtr)#area
51 stub
R2(config-rtr)#]
*Jun 29
15:26:12.834: %OSPFv3-5-ADJCHG: Process 2, Nbr 1.1.1.1 on Serial2/0 from FULL
to DOWN, Neighbor Down: Adjacency forced to reset
*Jun 29 15:26:13.086:
%OSPFv3-5-ADJCHG: Process 2, Nbr 1.1.1.1 on Serial2/0 from LOADING to FULL,
Loading Done
R1#show
ipv6 ospf neighbor
OSPFv3 Router with ID (1.1.1.1)
(Process ID 2)
Neighbor
ID Pri State Dead Time Interface ID Interface
2.2.2.2 0
FULL/ - 00:00:38 6 Serial2/0
R2#show
ipv6 ospf neighbor
OSPFv3 Router with ID (2.2.2.2)
(Process ID 2)
Neighbor
ID Pri State Dead Time Interface ID Interface
3.3.3.3 0
FULL/ - 00:00:37 7 Serial2/1
1.1.1.1 0
FULL/ - 00:00:35 6 Serial2/0
R1#show
ipv6 route ospf
IPv6
Routing Table - default - 9 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
OI ::/0 [110/65]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:3::1/128 [110/64]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:4::/64 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/0
OI 2001:DB8:CAFE:5::1/128 [110/128]
via FE80::C802:16FF:FECC:0, Serial2/0
R2#conf t
Enter
configuration commands, one per line.
End with CNTL/Z.
R2(config)#ipv6
router ospf 2
R2(config-rtr)#area
51 stub no-summary // TOTALLY STUBBY AREA
R1#show
ipv6 route ospf
IPv6
Routing Table - default - 6 entries
Codes: C
- Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile
Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA
- ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP
external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr
- Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 -
OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2, l - LISP
OI ::/0 [110/65]
via FE80::C802:16FF:FECC:0, Serial2/0
R2#show
ipv6 ospf
Routing Process "ospfv3 2" with ID
2.2.2.2
Event-log enabled, Maximum number of events:
1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with
maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs
10000 msecs
Maximum wait time between two consecutive SPFs
10000 msecs
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 2. Checksum Sum
0x010131
Number of areas in this router is 2. 1 normal
1 stub 0 nssa
Graceful restart helper support enabled
Reference bandwidth unit is 100 mbps
RFC1583 compatibility enabled
Area BACKBONE(0)
Number of interfaces in this area is 2
SPF algorithm executed 9 times
Number of LSA 8. Checksum Sum 0x04CA5B
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 51
Number of interfaces in this area is 1
It is a stub area, no summary LSA in
this area
Generates stub default route with cost
1
SPF algorithm executed 6 times
Number of LSA 7. Checksum Sum 0x033964
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
No comments:
Post a Comment