Saturday, December 1, 2018

Configuring Route Summarization and Redistribution Between EIGRP and OSPF

Configuring EIGRP Route Summarization

After you have made those design choices, configuring route summarization requires the addition of a few instances of the following interface subcommand:

ip summary-address eigrp <asn> <prefix> <subnet-mask>

When configured on an interface, the router changes its logic for the EIGRP Update messages sent out the interface, as follows:

* The router brings down, and then back up, all EIGRP neighbors reachable on that interface, effectively causing neighbors to forget previous topology information and to listen to new information (when the neighborships recover).

* When the neighborships recover, the router advertises the summary route, per the ip summary-address command, assuming that the router has at least one route whose address range is inside the range of the summary route.

* The router does not advertise the subordinate routes. (The term subordinate route refers to the routes whose address ranges are inside the range of addresses defined by the summary route.)

* The router adds a route to its own routing table, for the summary prefix/prefix length, with an outgoing interface of null0.


Manual Summarization at ABRs

The generic version of the command is listed next, followed by some notes about the various parameters:

area <area-id> range <ip-address> <mask> [ cost <cost> ]

* The configured area number refers to the area where the subnets exist; the summary will be advertised into all other areas connected to the ABR.

* The ABR compares the summary route’s range of addresses with all intra-area OSPF routes, in the origin area, for which the ABR is creating Type 3 LSAs. If at least one subordinate subnet exists (subnets that sit inside the range), the ABR advertises the summary route as a Type 3 LSA.

* The ABR does not advertise the subordinate subnet’s Type 3 LSAs.

* The ABR assigns a metric for the summary route’s Type 3 LSA, by default, to match the best metric among all subordinate subnets.

* The area range command can also explicitly set the cost of the summary.

* If no subordinate subnets exist, the ABR does not advertise the summary.


Manual Summarization at ASBRs

If you add the summary-address <prefix> <mask> OSPF subcommand, OSPF will then attempt to summarize the external routes by creating a Type 5 LSA for the summary route, and by no longer advertising the Type 5 LSAs for the subordinate subnets. When looking for potential subordinate subnets inside the summary, the ASBR looks at all routes being redistributed into OSPF from all outside route sources, and if any subordinate subnets exist, the ASBR performs the route summarization.

Notably, this command works very much like the area range command on ABRs, with the main exception being that the summary-address command cannot explicitly set the metric of the summary route. The list of features is as follows:

* The ASBR compares the summary route’s range of addresses with all routes redistributed into OSPF on that ASBR to find any subordinate subnets (subnets that sit inside the summary route range). If at least one subordinate subnet exists, the ASBR advertises the summary route.

* The ASBR does not advertise the subordinate subnets. To create the summary, the ASBR actually creates a Type 5 LSA for the summary route.

* The ASBR assigns the summary route the same metric as the lowest metric route among all subordinate subnets.

* If no subordinate subnets exist, the ASBR does not advertise the summary.

* Unlike the area range command, the summary-address command cannot be used to directly set the metric of the summary route.

The summary-address subcommand defines the summary route on the ASBR, with similar syntax and parameters as compared to the area range command seen on ABRs.


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 0
R1(config-if)#
*Jul  1 22:12:56.191: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface loop 48
R1(config-if)#
*Jul  1 22:13:21.447: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback48, changed state to up
R1(config-if)#ip address 192.168.48.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface loop 49                   
R1(config-if)#
*Jul  1 22:13:34.239: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback49, changed state to up
R1(config-if)#ip address 192.168.49.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface loop 50                   
R1(config-if)#
*Jul  1 22:13:47.199: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback50, changed state to up
R1(config-if)#ip address 192.168.50.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface loop 51                   
R1(config-if)#
*Jul  1 22:13:59.019: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback51, changed state to up
R1(config-if)#ip address 192.168.51.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface loop 70                   
R1(config-if)#
*Jul  1 22:14:16.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback70, changed state to up
R1(config-if)#ip address 192.168.70.1 255.255.255.0
R1(config-if)#
R1(config-if)#interface serial 2/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#
*Jul  1 22:15:02.375: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
*Jul  1 22:15:03.383: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R1(config-if)#end
R1#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface loop 0
R2(config-if)#
*Jul  1 22:12:55.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 172.16.2.1 255.255.255.0
R2(config-if)#
R2(config-if)#interface loop 100                
R2(config-if)#
*Jul  1 22:13:17.747: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R2(config-if)#ip address 172.16.100.1 255.255.255.0
R2(config-if)#
R2(config)#interface serial 2/0                
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
*Jul  1 22:13:56.383: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R2(config-if)#
*Jul  1 22:13:57.391: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#do ping 172.16.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/20 ms
R2(config-if)#
R2(config-if)#interface serial 2/1
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
*Jul  1 22:14:38.135: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R2(config-if)#
*Jul  1 22:14:39.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R2(config-if)#end
R2#


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface loop 0
R3(config-if)#
*Jul  1 22:17:05.819: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.16.3.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 20                 
R3(config-if)#
*Jul  1 22:17:36.943: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback20, changed state to up
R3(config-if)#ip address 192.168.20.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 25                   
R3(config-if)#
*Jul  1 22:18:03.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback25, changed state to up
R3(config-if)#ip address 192.168.25.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 30                   
R3(config-if)#
*Jul  1 22:18:15.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback30, changed state to up
R3(config-if)#ip address 192.168.30.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 35                   
R3(config-if)#
*Jul  1 22:18:32.531: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback35, changed state to up
R3(config-if)#ip address 192.168.35.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 40                   
R3(config-if)#
*Jul  1 22:18:45.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback40, changed state to up
R3(config-if)#ip address 192.168.40.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 8                    
R3(config-if)#
*Jul  1 22:19:06.359: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback8, changed state to up
R3(config-if)#ip address 192.168.8.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 9                   
R3(config-if)#
*Jul  1 22:19:23.027: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback9, changed state to up
R3(config-if)#ip address 192.168.9.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 10                  
R3(config-if)#
*Jul  1 22:19:36.079: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback10, changed state to up
R3(config-if)#ip address 192.168.10.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface loop 11                   
R3(config-if)#
*Jul  1 22:19:47.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback11, changed state to up
R3(config-if)#ip address 192.168.11.1 255.255.255.0
R3(config-if)#
R3(config)#interface serial 2/1
R3(config-if)#ip address 172.16.23.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)
*Jul  2 10:12:33.077: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R3(config-if)
*Jul  2 10:12:34.085: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R3(config-if)#do ping 172.16.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/32 ms
R3(config-if)#end
R3#


R1#tclsh       // TCP SCRIPT
R1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#192.168.48.1
+>(tcl)#192.168.49.1
+>(tcl)#192.168.50.1
+>(tcl)#192.168.51.1
+>(tcl)#192.168.70.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.2.1
+>(tcl)#172.16.100.1
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#172.16.3.1
+>(tcl)#192.168.8.1
+>(tcl)#192.168.9.1
+>(tcl)#192.168.10.1
+>(tcl)#192.168.11.1
+>(tcl)#192.168.20.1
+>(tcl)#192.168.25.1
+>(tcl)#192.168.30.1
+>(tcl)#192.168.35.1
+>(tcl)#192.168.40.1
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:       // R1 DIRECTLY CONNECTED ROUTES
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.48.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.51.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/41/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:        // NO STATIC OR DYNAMIC ROUTING CONFIGURED YET
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.9.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.11.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1(tcl)#


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 172.16.0.0
R1(config-router)#network 192.168.0.0 0.0.255.255
R1(config-router)#end
R1#
*Jul  2 09:48:53.409: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.12.2 (Serial2/0) is up: new adjacency


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 172.16.0.0
R2(config-router)#
*Jul  2 09:45:53.641: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.12.1 (Serial2/0) is up: new adjacency


R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   172.16.12.2             Se2/0                    11 00:00:45   50   300  0  3
R1#
R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
D        172.16.2.0/24 [90/2297856] via 172.16.12.2, 00:00:51, Serial2/0
D        172.16.100.0/24 [90/2297856] via 172.16.12.2, 00:00:51, Serial2/0


R2#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   172.16.12.1             Se2/0                    13 00:03:25   26   156  0  3
R2#
R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
D        172.16.1.0/24 [90/2297856] via 172.16.12.1, 00:03:31, Serial2/0
D     192.168.48.0/24 [90/2297856] via 172.16.12.1, 00:03:31, Serial2/0
D     192.168.49.0/24 [90/2297856] via 172.16.12.1, 00:03:31, Serial2/0
D     192.168.50.0/24 [90/2297856] via 172.16.12.1, 00:03:31, Serial2/0
D     192.168.51.0/24 [90/2297856] via 172.16.12.1, 00:03:31, Serial2/0
D     192.168.70.0/24 [90/2297856] via 172.16.12.1, 00:03:31, Serial2/0


R1#tclsh      R1 CAN REACH ALL NETWORKS IN THE EIGRP ROUTING DOMAIN
R1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#192.168.48.1
+>(tcl)#192.168.49.1
+>(tcl)#192.168.50.1
+>(tcl)#192.168.51.1
+>(tcl)#192.168.70.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.2.1
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.48.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.51.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/28/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.48.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.51.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/20/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface serial 2/0
R1(config-if)#ip s?        
sap              security  service  split-horizon
summary-address 

R1(config-if)#ip summary-address ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  rip    Routing Information Protocol (RIP)

R1(config-if)#ip summary-address eigrp ?
  <1-65535>  AS number

R1(config-if)#ip summary-address eigrp 1 ?
  A.B.C.D     Summary IP address
  A.B.C.D/nn  Summary <network>/<length>, e.g. 192.168.0.0/16

R1(config-if)#ip summary-address eigrp 1 192.168.48.0 ?      
  A.B.C.D  IP network mask

R1(config-if)#ip summary-address eigrp 1 192.168.48.0 255.255.254.0     // SUMMARIZE CONTIGUOUS EIGRP ROUTES
R1(config-if)#
*Jul  2 09:56:50.613: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.12.2 (Serial2/0) is resync: summary configured
R1(config-if)#end
R1#
*Jul  2 09:57:03.649: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
D        172.16.2.0/24 [90/2297856] via 172.16.12.2, 00:08:15, Serial2/0
D        172.16.100.0/24 [90/2297856] via 172.16.12.2, 00:08:15, Serial2/0
D     192.168.48.0/23 is a summary, 00:00:18, Null0
R1#
R1#show ip route 192.168.48.0 255.255.254.0
Routing entry for 192.168.48.0/23, supernet
  Known via "eigrp 1", distance 5, metric 128256, type internal     // EIGRP SUMMARY ROUTE AD IS 5
  Redistributing via eigrp 1
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 128256, traffic share count is 1
      Total delay is 5000 microseconds, minimum bandwidth is 8000000 Kbit
      Reliability 255/255, minimum MTU 1514 bytes
      Loading 1/255, Hops 0

R2#
*Jul  2 09:53:50.901: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.12.1 (Serial2/0) is resync: peer graceful-restart
R2#
R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
D        172.16.1.0/24 [90/2297856] via 172.16.12.1, 00:09:53, Serial2/0
D     192.168.48.0/23 [90/2297856] via 172.16.12.1, 00:01:56, Serial2/0
D     192.168.50.0/24 [90/2297856] via 172.16.12.1, 00:09:53, Serial2/0
D     192.168.51.0/24 [90/2297856] via 172.16.12.1, 00:09:53, Serial2/0
D     192.168.70.0/24 [90/2297856] via 172.16.12.1, 00:09:53, Serial2/0
R2#
R2#ping 192.168.49.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/44 ms


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface loop 100
R2(config-if)#ip ospf network ?
  broadcast            Specify OSPF broadcast multi-access network
  non-broadcast        Specify OSPF NBMA network
  point-to-multipoint  Specify OSPF point-to-multipoint network
  point-to-point       Specify OSPF point-to-point network

R2(config-if)#ip ospf network point-to-point
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#network 172.16.23.0 0.0.0.255 area 0
R2(config-router)#network 172.16.100.0 0.0.0.255 area 10
R2(config-router)#end
R2#
*Jul  2 10:10:56.209: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.40.1 on Serial2/1 from LOADING to FULL, Loading Done


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config-if)#interface range loop 8 - 11
R3(config-if-range)#ip ospf network point-to-point
R3(config-if-range)#
R3(config)#interface range loop 0, loop 25, loop 30, loop 35, loop 40
R3(config-if-range)#ip ospf network point-to-point                 
R3(config-if-range)#exit
R3(config)#router ospf 1
R3(config-router)#network 172.16.0.0 0.0.255.255 area 0
R3(config-router)#network 192.168.0.0 0.0.255.255 area 0
R3(config-router)#network 192.168.8.0 0.0.3.255 area 20
R3(config-router)#
R3#
*Jul  2 10:12:36.637: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.100.1 on Serial2/1 from LOADING to FULL, Loading Done


R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.40.1      0   FULL/  -        00:00:38    172.16.23.3     Serial2/1
R2#
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
O        172.16.3.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O IA  192.168.8.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O IA  192.168.9.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O IA  192.168.10.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O IA  192.168.11.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O     192.168.20.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O     192.168.25.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O     192.168.30.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O     192.168.35.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1
O     192.168.40.0/24 [110/65] via 172.16.23.3, 00:04:58, Serial2/1


R3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.100.1      0   FULL/  -        00:00:31    172.16.23.2     Serial2/1
R3#
R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
O IA     172.16.100.0/24 [110/65] via 172.16.23.2, 00:06:04, Serial2/1


R2#tclsh       // R2 CAN REACH ALL NETWORKS IN THE OSPF ROUTING DOMAIN
R2(tcl)#foreach address {
+>(tcl)#172.16.100.1
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#172.16.3.1
+>(tcl)#192.168.8.1
+>(tcl)#192.168.9.1
+>(tcl)#192.168.10.1
+>(tcl)#192.168.11.1
+>(tcl)#192.168.20.1
+>(tcl)#192.168.25.1
+>(tcl)#192.168.30.1
+>(tcl)#192.168.35.1
+>(tcl)#192.168.40.1
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#area ?
  <0-4294967295>  OSPF area ID as a decimal value
  A.B.C.D         OSPF area ID in IP address format

R3(config-router)#area 20 ?
  authentication  Enable authentication
  capability      Enable area specific capability
  default-cost    Set the summary default-cost of a NSSA/stub area
  filter-list     Filter networks between OSPF areas
  nssa            Specify a NSSA area
  range           Summarize routes matching address/mask (border routers only)
  sham-link       Define a sham link and its parameters
  stub            Specify a stub area
  virtual-link    Define a virtual link and its parameters

R3(config-router)#area 20 range ?
  A.B.C.D  IP address to match

R3(config-router)#area 20 range 192.168.8.0 ?
  A.B.C.D  IP mask for address

R3(config-router)#area 20 range 192.168.8.0 255.255.252.0    // SUMMARIZE ROUTES IN ABR


R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
O        172.16.3.0/24 [110/65] via 172.16.23.3, 00:13:44, Serial2/1
O IA  192.168.8.0/22 [110/65] via 172.16.23.3, 00:01:15, Serial2/1
O     192.168.20.0/24 [110/65] via 172.16.23.3, 00:13:44, Serial2/1
O     192.168.25.0/24 [110/65] via 172.16.23.3, 00:13:44, Serial2/1
O     192.168.30.0/24 [110/65] via 172.16.23.3, 00:13:44, Serial2/1
O     192.168.35.0/24 [110/65] via 172.16.23.3, 00:13:44, Serial2/1
O     192.168.40.0/24 [110/65] via 172.16.23.3, 00:13:44, Serial2/1


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#redistribute ?
  bgp             Border Gateway Protocol (BGP)
  connected       Connected
  eigrp           Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis            ISO IS-IS
  iso-igrp        IGRP for OSI networks
  lisp            Locator ID Separation Protocol (LISP)
  maximum-prefix  Maximum number of prefixes redistributed to protocol
  mobile          Mobile routes
  odr             On Demand stub Routes
  ospf            Open Shortest Path First (OSPF)
  ospfv3          OSPFv3
  rip             Routing Information Protocol (RIP)
  static          Static routes

R2(config-router)#redistribute eigrp ?
  <1-65535>  AS number

R2(config-router)#redistribute eigrp 1 ?
  metric       Metric for redistributed routes
  metric-type  OSPF/IS-IS exterior metric type for redistributed routes
  nssa-only    Limit redistributed routes to NSSA areas
  route-map    Route map reference
  subnets      Consider subnets for redistribution into OSPF
  tag          Set tag for routes redistributed into OSPF
  <cr>

R2(config-router)#redistribute eigrp 1 subnets   // OSPF REDISTRIBUTE CLASSFUL NETWORKS BY DEFAULT; NEED TO ADD KEYWORD subnets TO REDISTRIBUTE CLASSLESS ROUTES
R2(config-router)#
R2(config-router)#exit
R2(config)#router eigrp 1
R2(config-router)#redistribute ?
  bgp        Border Gateway Protocol (BGP)
  connected  Connected
  eigrp      Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis       ISO IS-IS
  mobile     Mobile routes
  odr        On Demand stub Routes
  ospf       Open Shortest Path First (OSPF)
  rip        Routing Information Protocol (RIP)
  static     Static routes

R2(config-router)#redistribute ospf ?
  <1-65535>  Process ID

R2(config-router)#redistribute ospf 1 ?
  match      Redistribution of OSPF routes
  metric     Metric for redistributed routes
  route-map  Route map reference
  <cr>

R2(config-router)#redistribute ospf 1 metric ?
  <1-4294967295>  Bandwidth metric in Kbits per second

R2(config-router)#redistribute ospf 1 metric 10000 ?
  <0-4294967295>  EIGRP delay metric, in 10 microsecond units

R2(config-router)#redistribute ospf 1 metric 10000 100 ?
  <0-255>  EIGRP reliability metric where 255 is 100% reliable

R2(config-router)#redistribute ospf 1 metric 10000 100 255 ?
  <1-255>  EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

R2(config-router)#redistribute ospf 1 metric 10000 100 255 1 ?
  <1-65535>  EIGRP MTU of the path

R2(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500       // NEED TO SPECIFY EIGRP SEED METRIC
R2(config-router)#end
R2#
*Jul  2 10:43:29.040: %SYS-5-CONFIG_I: Configured from console by console
R2#
R2#show ip protocols      // VERIFY REDISTRIBUTION
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: ospf 1
  EIGRP-IPv4 Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 172.16.100.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.12.1           90      00:49:44
  Distance: internal 90 external 170

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.16.100.1
  It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    eigrp 1, includes subnets in redistribution
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.23.0 0.0.0.255 area 0
    172.16.100.0 0.0.0.255 area 10
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.40.1         110      00:07:40
  Distance: (default is 110)


R1#show ip route      // VERIFY OSPF REDISTRIBUTED ROUTES; EIGRP EXTERNAL ROUTES
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C        172.16.1.0/24 is directly connected, Loopback0
L        172.16.1.1/32 is directly connected, Loopback0
D        172.16.2.0/24 [90/2297856] via 172.16.12.2, 01:06:55, Serial2/0
D EX     172.16.3.0/24 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
C        172.16.12.0/24 is directly connected, Serial2/0
L        172.16.12.1/32 is directly connected, Serial2/0
D        172.16.23.0/24 [90/2681856] via 172.16.12.2, 00:29:27, Serial2/0
D        172.16.100.0/24 [90/2297856] via 172.16.12.2, 01:06:55, Serial2/0
D EX  192.168.8.0/22 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
D EX  192.168.20.0/24 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
D EX  192.168.25.0/24 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
D EX  192.168.30.0/24 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
D EX  192.168.35.0/24 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
D EX  192.168.40.0/24 [170/2195456] via 172.16.12.2, 00:13:00, Serial2/0
D     192.168.48.0/23 is a summary, 00:58:58, Null0
      192.168.48.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.48.0/24 is directly connected, Loopback48
L        192.168.48.1/32 is directly connected, Loopback48
      192.168.49.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.49.0/24 is directly connected, Loopback49
L        192.168.49.1/32 is directly connected, Loopback49
      192.168.50.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.50.0/24 is directly connected, Loopback50
L        192.168.50.1/32 is directly connected, Loopback50
      192.168.51.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.51.0/24 is directly connected, Loopback51
L        192.168.51.1/32 is directly connected, Loopback51
      192.168.70.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.70.0/24 is directly connected, Loopback70
L        192.168.70.1/32 is directly connected, Loopback70


R3#show ip route      // VERIFY EIGRP REDISTRIBUTED ROUTES; OSPF EXTERNAL TYPE 2 (DEFAULT) WITH METRIC OF 20 (DEFAULT)
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
O E2     172.16.1.0/24 [110/20] via 172.16.23.2, 00:14:54, Serial2/1
O E2     172.16.2.0/24 [110/20] via 172.16.23.2, 00:14:54, Serial2/1
C        172.16.3.0/24 is directly connected, Loopback0
L        172.16.3.1/32 is directly connected, Loopback0
O E2     172.16.12.0/24 [110/20] via 172.16.23.2, 00:14:54, Serial2/1
C        172.16.23.0/24 is directly connected, Serial2/1
L        172.16.23.3/32 is directly connected, Serial2/1
O IA     172.16.100.0/24 [110/65] via 172.16.23.2, 00:18:18, Serial2/1
O     192.168.8.0/22 is a summary, 00:18:18, Null0
      192.168.8.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.8.0/24 is directly connected, Loopback8
L        192.168.8.1/32 is directly connected, Loopback8
      192.168.9.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.9.0/24 is directly connected, Loopback9
L        192.168.9.1/32 is directly connected, Loopback9
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, Loopback10
L        192.168.10.1/32 is directly connected, Loopback10
      192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.11.0/24 is directly connected, Loopback11
L        192.168.11.1/32 is directly connected, Loopback11
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, Loopback20
L        192.168.20.1/32 is directly connected, Loopback20
      192.168.25.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.25.0/24 is directly connected, Loopback25
L        192.168.25.1/32 is directly connected, Loopback25
      192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.30.0/24 is directly connected, Loopback30
L        192.168.30.1/32 is directly connected, Loopback30
      192.168.35.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.35.0/24 is directly connected, Loopback35
L        192.168.35.1/32 is directly connected, Loopback35
      192.168.40.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.40.0/24 is directly connected, Loopback40
L        192.168.40.1/32 is directly connected, Loopback40
O E2  192.168.48.0/23 [110/20] via 172.16.23.2, 00:14:54, Serial2/1
O E2  192.168.50.0/24 [110/20] via 172.16.23.2, 00:14:54, Serial2/1
O E2  192.168.51.0/24 [110/20] via 172.16.23.2, 00:14:54, Serial2/1
O E2  192.168.70.0/24 [110/20] via 172.16.23.2, 00:14:54, Serial2/1


R1#tclsh      // R1 SHOULD HAVE FULL NETWORK CONNECTIVITY AFTER REDISTRIBUTION
R1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#192.168.48.1
+>(tcl)#192.168.49.1
+>(tcl)#192.168.50.1
+>(tcl)#192.168.51.1
+>(tcl)#192.168.70.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.2.1
+>(tcl)#172.16.100.1
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#172.16.3.1
+>(tcl)#192.168.8.1
+>(tcl)#192.168.9.1
+>(tcl)#192.168.10.1
+>(tcl)#192.168.11.1
+>(tcl)#192.168.20.1
+>(tcl)#192.168.25.1
+>(tcl)#192.168.30.1
+>(tcl)#192.168.35.1
+>(tcl)#192.168.40.1
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.48.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.51.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/17/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/17/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/27/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/22/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/25/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/26/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/26/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/25/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/25/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/22/32 ms


R3#show ip route ospf | inc E2
       E1 - OSPF external type 1, E2 - OSPF external type 2
O E2     172.16.1.0/24 [110/20] via 172.16.23.2, 00:17:51, Serial2/1
O E2     172.16.2.0/24 [110/20] via 172.16.23.2, 00:17:51, Serial2/1
O E2     172.16.12.0/24 [110/20] via 172.16.23.2, 00:17:51, Serial2/1
O E2  192.168.48.0/23 [110/20] via 172.16.23.2, 00:17:51, Serial2/1
O E2  192.168.50.0/24 [110/20] via 172.16.23.2, 00:17:51, Serial2/1
O E2  192.168.51.0/24 [110/20] via 172.16.23.2, 00:17:51, Serial2/1
O E2  192.168.70.0/24 [110/20] via 172.16.23.2, 00:17:51, Serial2/1


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#summary-address 192.168.48.0 255.255.252.0      // SUMMARIZE EXTERNAL ROUTES AT ASBR ROUTER (R2)


R3#show ip route ospf | inc E2
       E1 - OSPF external type 1, E2 - OSPF external type 2
O E2     172.16.1.0/24 [110/20] via 172.16.23.2, 00:20:08, Serial2/1
O E2     172.16.2.0/24 [110/20] via 172.16.23.2, 00:20:08, Serial2/1
O E2     172.16.12.0/24 [110/20] via 172.16.23.2, 00:20:08, Serial2/1
O E2  192.168.48.0/22 [110/20] via 172.16.23.2, 00:00:15, Serial2/1
O E2  192.168.70.0/24 [110/20] via 172.16.23.2, 00:20:08, Serial2/1


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 50
R1(config-if)#shut
R1(config-if)#
*Jul  2 11:03:29.416: %LINK-5-CHANGED: Interface Loopback50, changed state to administratively down
*Jul  2 11:03:30.416: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback50, changed state to down


R3#traceroute 192.168.50.1
Type escape sequence to abort.
Tracing the route to 192.168.50.1
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.23.2 16 msec 36 msec 44 msec
  2 172.16.23.2 !H  !H  !H


R2#traceroute 192.168.50.1
Type escape sequence to abort.
Tracing the route to 192.168.50.1
VRF info: (vrf in name/id, vrf out name/id)
  1  *  *  *
  2  *  *  *
  3  *  *  *

No comments:

Post a Comment