Friday, February 8, 2019

Configuring BGP with Default Routing

There are four common BGP/ISP designs:
* Single-homed (1 link per ISP, 1 ISP)
* Dual-homed (2+ links per ISP, 1 ISP)
* Single-multihomed (1 link per ISP, 2+ ISPs)
* Dual-multihomed (2+ links per ISP, 2+ ISPs)

Single-homed designs often use one of two options for routing to and from the Internet:
* Use static routes (default in the enterprise, and a static route for the enterprise’s public address range at the ISP).
* Use BGP, but only to exchange a default route (ISP to enterprise) and a route for the enterprise’s public prefix (enterprise to ISP). For a dual-homed case, the second link gives the enterprise a choice.

The common cases when using defaults works well, ignoring BGP, are:
* To prefer one Internet connection over another for all destinations, but when the better ISP connection fails, all traffic reroutes over the secondary connection.
* To treat both Internet connections as equal, sending packets for some destinations out each path. However, when one fails, all traffic reroutes over the one still-working path.

A single-multihomed topology means a single link per ISP, but multiple (at least two) ISPs.

The last general category of Internet access topologies is called dual-multihomed. With this design, two or more ISPs are used, with two or more connections to each. A number of different routers can be used.

To help reduce the memory requirements of receiving full BGP updates (BGP updates that include all routes), some ISPs give you three basic options for what routes the ISP advertises:
* Default route only: The ISP advertises a default route with BGP, but no other routes.
* Full updates: The ISP sends you the entire BGP table.
* Partial updates: The ISP sends you routes for prefixes that might be better reached through that ISP, but not all routes, plus a default route (to use as needed instead of the purposefully omitted routes).


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 0
R1(config-if)#
*Jul 13 10:33:16.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#         
R1(config-if)#interface serial 2/0
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#no shut
R1(config-if)#
*Jul 13 10:33:51.027: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R1(config-if)#
*Jul 13 10:33:52.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R1(config-if)#end
R1#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface loop 0
R2(config-if)#
*Jul 13 10:34:30.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 192.168.0.1 255.255.255.0
R2(config-if)#
R2(config-if)#interface loop 1                   
R2(config-if)#
*Jul 13 10:34:45.047: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#
R2(config-if)#interface serial 2/0
R2(config-if)#ip address 10.0.0.2 255.255.255.252
R2(config-if)#no shut
R2(config-if)#
*Jul 13 10:35:16.503: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
R2(config-if)#
*Jul 13 10:35:17.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#
R2(config-if)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/36/64 ms
R2(config-if)#
R2(config-if)#interface serial 2/1
R2(config-if)#ip address 172.16.0.2 255.255.255.252
R2(config-if)#no shut
R2(config-if)#
*Jul 13 10:35:47.583: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R2(config-if)#
*Jul 13 10:35:48.591: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R2(config-if)#end
R2#


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface loop 0   
R3(config-if)#
*Jul 13 10:36:34.551: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.16.1.1 255.255.255.0
R3(config-if)#
R3(config-if)#interface serial 2/1
R3(config-if)#ip address 172.16.0.1 255.255.255.252
R3(config-if)#no shut
R3(config-if)#
*Jul 13 10:37:12.879: %LINK-3-UPDOWN: Interface Serial2/1, changed state to up
R3(config-if)#
*Jul 13 10:37:13.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/1, changed state to up
R3(config-if)#
R3(config-if)#do ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms
R3(config-if)#end
R3#


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp ?
  <1-4294967295>  Autonomous system number
  <1.0-XX.YY>     Autonomous system number

R1(config)#router bgp 200
R1(config-router)#?
Router configuration commands:
  address-family        Enter Address Family command mode
  aggregate-address     Configure BGP aggregate entries
  auto-summary          Enable automatic network number summarization
  bgp                   BGP specific commands
  default               Set a command to its defaults
  default-information   Control distribution of default information
  default-metric        Set metric of redistributed routes
  distance              Define an administrative distance
  distribute-list       Filter networks in routing updates
  exit                  Exit from routing protocol configuration mode
  help                  Description of the interactive help system
  maximum-paths         Forward packets over multiple paths
  neighbor              Specify a neighbor router
  network               Specify a network to announce via BGP
  no                    Negate a command or set its defaults
  redistribute          Redistribute information from another routing protocol
  route-server-context  Enter route server context command mode
  scope                 Enter scope command mode
  snmp                  Modify snmp parameters
  synchronization       Perform IGP synchronization
  table-map             Map external entry attributes into routing table
  template              Enter template command mode
  timers                Adjust routing timers

R1(config-router)#neighbor ?
  A.B.C.D     Neighbor address
  WORD        Neighbor tag
  X:X:X:X::X  Neighbor IPv6 address

R1(config-router)#neighbor 10.0.0.2 ?
  activate                 Enable the Address Family for this Neighbor
  advertise                Advertise to this neighbor
  advertise-map            specify route-map for conditional advertisement
  advertisement-interval   Minimum interval between sending BGP routing updates
  allowas-in               Accept as-path with my AS present in it
  capability               Advertise capability to the peer
  default-originate        Originate default route to this neighbor
  description              Neighbor specific description
  disable-connected-check  one-hop away EBGP peer using loopback address
  distribute-list          Filter updates to/from this neighbor
  dmzlink-bw               Propagate the DMZ link bandwidth
  ebgp-multihop            Allow EBGP neighbors not on directly connected
                           networks
  fall-over                session fall on peer route lost
  filter-list              Establish BGP filters
  ha-mode                  high availability mode
  inherit                  Inherit a template
  local-as                 Specify a local-as number
  maximum-prefix           Maximum number of prefixes accepted from this peer
  next-hop-self            Disable the next hop calculation for this neighbor
  next-hop-unchanged       Propagate next hop unchanged for iBGP paths to this
                           neighbor
  password                 Set a password
  peer-group               Member of the peer-group
  prefix-list              Filter updates to/from this neighbor
  remote-as                Specify a BGP neighbor
  remove-private-as        Remove private AS number from outbound updates
  route-map                Apply route map to neighbor
  route-reflector-client   Configure a neighbor as Route Reflector client
  route-server-client      Configure a neighbor as Route Server client
  send-community           Send Community attribute to this neighbor
  send-label               Send NLRI + MPLS Label to this peer
  shutdown                 Administratively shut down this neighbor
  slow-peer                Configure slow-peer
  soft-reconfiguration     Per neighbor soft reconfiguration
  soo                      Site-of-Origin extended community
  timers                   BGP per neighbor timers
  translate-update         Translate Update to MBGP format
  transport                Transport options
  ttl-security             BGP ttl security check
  unsuppress-map           Route-map to selectively unsuppress suppressed
                           routes
  update-source            Source of routing updates
  version                  Set the BGP version to match a neighbor
  weight                   Set default weight for routes from this neighbor
         
R1(config-router)#neighbor 10.0.0.2 remote-as ?
  <1-4294967295>  AS of remote neighbor
  <1.0-XX.YY>     AS of remote neighbor

R1(config-router)#neighbor 10.0.0.2 remote-as 100      // CONFIGURE EBGP NEIGHBOR
R1(config-router)#network 10.1.1.0 mask ? 
  A.B.C.D  Network mask

R1(config-router)#network 10.1.1.0 mask 255.255.255.0
R1(config-router)#end
R1#
*Jul 13 10:41:55.611: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Up


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router bgp 300
R3(config-router)#neighbor 172.16.0.2 remote-as 100
R3(config-router)#network 172.16.1.0 mask 255.255.255.0
R3(config-router)#end
R3#
*Jul 13 10:42:16.983: %BGP-5-ADJCHANGE: neighbor 172.16.0.2 Up


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 100
R2(config-router)#neighbor 10.0.0.1 remote-as 200
R2(config-router)#
*Jul 13 10:41:54.911: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Up
R2(config-router)# 
R2(config-router)#neighbor 172.16.0.1 remote-as 300
R2(config-router)#
*Jul 13 10:42:16.603: %BGP-5-ADJCHANGE: neighbor 172.16.0.1 Up
R2(config-router)#
R2(config-router)#network 192.168.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#end
R2#


R2#show ip route     // VERIFY BGP ROUTES FROM ISP1 AND ISP2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.2/32 is directly connected, Serial2/0
B        10.1.1.0/24 [20/0] via 10.0.0.1, 00:01:46
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.2/32 is directly connected, Serial2/1
B        172.16.1.0/24 [20/0] via 172.16.0.1, 00:01:26
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1


R2#tclsh
R2(tcl)#foreach address {
+>(tcl)#10.0.0.1
+>(tcl)#10.0.0.2
+>(tcl)#10.1.1.1
+>(tcl)#172.16.0.1
+>(tcl)#172.16.0.2
+>(tcl)#172.16.1.1
+>(tcl)#192.168.0.1
+>(tcl)#192.168.1.1
+>(tcl)#} {
+>(tcl)#ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/28/52 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/14/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/26/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms


R2#show ip bgp      // VERIFY BGP TABLE
BGP table version is 5, local router ID is 192.168.1.1      // LOCAL-ID IS THE HIGHEST LOOPBACK IP
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      10.0.0.1                 0             0 200 i
 *>  172.16.1.0/24    172.16.0.1               0             0 300 i
 *>  192.168.0.0      0.0.0.0                  0         32768 i
 *>  192.168.1.0      0.0.0.0                  0         32768 i


R1#show ip bgp
BGP table version is 5, local router ID is 10.1.1.1     // NOTICE BGP TABLE VERSION IS ALSO 5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      0.0.0.0                  0         32768 i
 *>  172.16.1.0/24    10.0.0.2                               0 100 300 i
 *>  192.168.0.0      10.0.0.2                 0             0 100 i
 *>  192.168.1.0      10.0.0.2                 0             0 100 i


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 0
R1(config-if)#shut
R1(config-if)#
*Jul 13 10:47:59.903: %LINK-5-CHANGED: Interface Loopback0, changed state to administratively down
*Jul 13 10:48:00.903: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to down


R2#show ip bgp
BGP table version is 6, local router ID is 192.168.1.1      // BGP TABLE INCREMENTED TO 6 SINCE ISP1 NETWORK 10.1.1.0/24 WAS REMOVED IN THE BGP TABLE
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  172.16.1.0/24    172.16.0.1               0             0 300 i
 *>  192.168.0.0      0.0.0.0                  0         32768 i
 *>  192.168.1.0      0.0.0.0                  0         32768 i


R1(config)#interface loop 0
R1(config-if)#no shut
R1(config-if)#
*Jul 13 10:49:16.295: %LINK-3-UPDOWN: Interface Loopback0, changed state to up
*Jul 13 10:49:17.295: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up


R1#show ip bgp
BGP table version is 7, local router ID is 10.1.1.1     //  BGP TABLE VERSION INCREMENTED AGAIN
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      0.0.0.0                  0         32768 i
 *>  172.16.1.0/24    10.0.0.2                               0 100 300 i
 *>  192.168.0.0      10.0.0.2                 0             0 100 i
 *>  192.168.1.0      10.0.0.2                 0             0 100 i


R2#show ip bgp
BGP table version is 7, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      10.0.0.1                 0             0 200 i
 *>  172.16.1.0/24    172.16.0.1               0             0 300 i
 *>  192.168.0.0      0.0.0.0                  0         32768 i
 *>  192.168.1.0      0.0.0.0                  0         32768 i


R2#show ip bgp ?
  A.B.C.D            Network in the BGP routing table to display
  A.B.C.D/nn         IP prefix <network>/<length>, e.g., 35.0.0.0/8
  all                All address families
  cidr-only          Display only routes with non-natural netmasks
  community          Display routes matching the communities
  community-list     Display routes matching the community-list
  dampening          Display detailed information about dampening
  extcommunity-list  Display routes matching the extcommunity-list
  filter-list        Display routes conforming to the filter-list
  import             Display route topology import / export activity
  inconsistency      Display all inconsistent paths
  inconsistent-as    Display only routes with inconsistent origin ASs
  injected-paths     Display all injected paths
  ipv4               Address family
  ipv6               Address family
  l2vpn              Address family
  labels             Display Labels for IPv4 NLRI specific information
  neighbors          Detailed information on TCP and BGP neighbor connections
  nexthops           Nexthop address table
  nsap               Address family
  oer-paths          Display all oer controlled paths
  paths              Path information
  peer-group         Display information on peer-groups
  pending-prefixes   Display prefixes pending deletion
  prefix-list        Display routes matching the prefix-list
  quote-regexp       Display routes matching the AS path "regular expression"
  regexp             Display routes matching the AS path regular expression
  replication        Display replication status of update-group(s)
  rib-failure        Display bgp routes that failed to install in the routing
                     table (RIB)
  route-map          Display routes matching the route-map
  route-server       Route server information
  rpki               Display RPKI Neighbor Cache
  rtfilter           Address family
  summary            Summary of BGP neighbor status
  template           Display peer-policy/peer-session templates
  topology           Routing topology instance
  update-group       Display information on update-groups
  update-sources     Update source interface table
  va                 Display virtual aggregation prefixes
  version            Display prefixes with matching version numbers
  vpnv4              Address family
  vpnv6              Address family
  |                  Output modifiers
  <cr>
         
R2#show ip bgp neighbors
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.1.1.1
  BGP state = Established, up for 00:08:43       // ESTABLISHED BGP STATE IS GOOD AND NOTICE UPTIME
  Last read 00:00:22, last write 00:00:30, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is not multisession capable (disabled)
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Enhanced Refresh Capability: advertised and received
    Multisession Capability:
    Stateful switchover support enabled: NO for session 1
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
   
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                5          4
    Keepalives:             9         10
    Route Refresh:          0          0
    Total:                 15         15
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  Session: 10.0.0.1
  BGP table version 7, neighbor version 7/0
  Output queue size : 0
  Index 1, Advertise bit 0
  1 update-group member
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               4          1 (Consumes 64 bytes)
    Prefixes Total:                 5          2
    Implicit Withdraw:              0          0
    Explicit Withdraw:              1          1
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              1        n/a
    Invalid Path:                         1        n/a
    Total:                                2          0
  Number of NLRIs in the update sent: max 2, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                                       Sent       Rcvd
        Refresh activity:              ----       ----
          Refresh Start-of-RIB          0          0
          Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 10.0.0.1
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0           
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 10.0.0.2, Local port: 59509
Foreign host: 10.0.0.1, Foreign port: 179
Connection tableid (VRF): 0
Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x129728):
Timer          Starts    Wakeups            Next
Retrans            15          0             0x0
TimeWait            0          0             0x0
AckHold            13          8             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            1          0        0x13C300
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss: 3629964154  snduna: 3629964593  sndnxt: 3629964593
irs: 2070890835  rcvnxt: 2070891241

sndwnd:  15946  scale:      0  maxrcvwnd:  16384
rcvwnd:  15979  scale:      0  delrcvwnd:    405

SRTT: 865 ms, RTTO: 1866 ms, RTV: 1001 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 1000 ms, ACK hold: 200 ms
Status Flags: active open
Option Flags: nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 28 (out of order: 0), with data: 14, total data bytes: 405
Sent: 27 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 15, total data bytes: 438

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x6A3C13B0  FREE

BGP neighbor is 172.16.0.1,  remote AS 300, external link
  BGP version 4, remote router ID 172.16.1.1
  BGP state = Established, up for 00:08:21
  Last read 00:00:41, last write 00:00:22, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is not multisession capable (disabled)
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Enhanced Refresh Capability: advertised and received
    Multisession Capability:
    Stateful switchover support enabled: NO for session 1
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
   
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                6          2
    Keepalives:             9         10
    Route Refresh:          0          0
    Total:                 18         13
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  Session: 172.16.0.1
  BGP table version 7, neighbor version 7/0
  Output queue size : 0
  Index 1, Advertise bit 0
  1 update-group member
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               4          1 (Consumes 64 bytes)
    Prefixes Total:                 5          1
    Implicit Withdraw:              0          0
    Explicit Withdraw:              1          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              1        n/a
    Invalid Path:                         1        n/a
    Total:                                2          0
  Number of NLRIs in the update sent: max 2, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: 00:08:21
  Last Sent Refresh End-of-rib: 00:08:21
  Refresh-Out took 0 seconds
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                                       Sent       Rcvd
        Refresh activity:              ----       ----
          Refresh Start-of-RIB          1          0
          Refresh End-of-RIB            1          0

  Address tracking is enabled, the RIB does have a route to 172.16.0.1
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0           
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 172.16.0.2, Local port: 179
Foreign host: 172.16.0.1, Foreign port: 56007
Connection tableid (VRF): 0
Maximum output segment queue size: 50
         
Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x12972C):
Timer          Starts    Wakeups            Next
Retrans            14          0             0x0
TimeWait            0          0             0x0
AckHold            11          8             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss:  505751287  snduna:  505751823  sndnxt:  505751823
irs: 3618503986  rcvnxt: 3618504311

sndwnd:  15849  scale:      0  maxrcvwnd:  16384
rcvwnd:  16060  scale:      0  delrcvwnd:    324

SRTT: 846 ms, RTTO: 1975 ms, RTV: 1129 ms, KRTT: 0 ms
minRTT: 16 ms, maxRTT: 1000 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 27 (out of order: 0), with data: 12, total data bytes: 324
Sent: 27 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 16, total data bytes: 535

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x6A3C12D0  FREE


R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 1 subnets
B        10.1.1.0 [20/0] via 172.16.0.2, 00:04:00      // ISP1 NETWORK
      172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.1/32 is directly connected, Serial2/1
C        172.16.1.0/24 is directly connected, Loopback0
L        172.16.1.1/32 is directly connected, Loopback0
B     192.168.0.0/24 [20/0] via 172.16.0.2, 00:10:20
B     192.168.1.0/24 [20/0] via 172.16.0.2, 00:10:20


R3#traceroute 10.1.1.1      // TRACEROUTE FAILS SINCE ISP1 DON'T HAVE A ROUTE TO 172.16.0.0/30
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.0.2 20 msec 16 msec 20 msec
  2  *  *  *
  3  *  *  *
  4  *

R3#traceroute 10.1.1.1 source 172.16.1.1      // ISP2 TRANSITS VIA R2 TO REACH 10.1.1.0/24
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.0.2 8 msec 20 msec 12 msec
  2 10.0.0.1 16 msec 16 msec 20 msec


R1#show ip bgp     // ISP1 BGP TABLE DOESN'T HAVE 172.16.0.0/30
BGP table version is 5, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      0.0.0.0                  0         32768 i
 *>  172.16.1.0/24    10.0.0.2                               0 100 300 i
 *>  192.168.0.0      10.0.0.2                 0             0 100 i
 *>  192.168.1.0      10.0.0.2                 0             0 100 i



R2#conf t      // CONFIGURE R2 TO ONLY ADVERTISE NETWORKS IN OWN AS
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#access-list 1 permit 192.168.0.0 0.0.1.255
R2(config)#
R2(config)#router bgp 100         
R2(config-router)#neighbor 10.0.0.1 ?
  activate                 Enable the Address Family for this Neighbor
  advertise                Advertise to this neighbor
  advertise-map            specify route-map for conditional advertisement
  advertisement-interval   Minimum interval between sending BGP routing updates
  allowas-in               Accept as-path with my AS present in it
  capability               Advertise capability to the peer
  default-originate        Originate default route to this neighbor
  description              Neighbor specific description
  disable-connected-check  one-hop away EBGP peer using loopback address
  distribute-list          Filter updates to/from this neighbor
  dmzlink-bw               Propagate the DMZ link bandwidth
  ebgp-multihop            Allow EBGP neighbors not on directly connected
                           networks
  fall-over                session fall on peer route lost
  filter-list              Establish BGP filters
  ha-mode                  high availability mode
  inherit                  Inherit a template
  local-as                 Specify a local-as number
  maximum-prefix           Maximum number of prefixes accepted from this peer
  next-hop-self            Disable the next hop calculation for this neighbor
  next-hop-unchanged       Propagate next hop unchanged for iBGP paths to this
                           neighbor
  password                 Set a password
  peer-group               Member of the peer-group
  prefix-list              Filter updates to/from this neighbor
  remote-as                Specify a BGP neighbor
  remove-private-as        Remove private AS number from outbound updates
  route-map                Apply route map to neighbor
  route-reflector-client   Configure a neighbor as Route Reflector client
  route-server-client      Configure a neighbor as Route Server client
  send-community           Send Community attribute to this neighbor
  send-label               Send NLRI + MPLS Label to this peer
  shutdown                 Administratively shut down this neighbor
  slow-peer                Configure slow-peer
  soft-reconfiguration     Per neighbor soft reconfiguration
  soo                      Site-of-Origin extended community
  timers                   BGP per neighbor timers
  translate-update         Translate Update to MBGP format
  transport                Transport options
  ttl-security             BGP ttl security check
  unsuppress-map           Route-map to selectively unsuppress suppressed
                           routes
  update-source            Source of routing updates
  version                  Set the BGP version to match a neighbor
  weight                   Set default weight for routes from this neighbor
         
R2(config-router)#neighbor 10.0.0.1 distribute-list ?
  <1-199>      IP access list number
  <1300-2699>  IP access list number (expanded range)
  WORD         IP Access-list name

R2(config-router)#neighbor 10.0.0.1 distribute-list 1 ?
  in   Filter incoming updates
  out  Filter outgoing updates

R2(config-router)#neighbor 10.0.0.1 distribute-list 1 out
R2(config-router)#neighbor 172.16.0.1 distribute-list 1 out
R2(config-router)#end
R2#


R3#show ip route     // NO ISP1 BGP NETWORK                   
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.1/32 is directly connected, Serial2/1
C        172.16.1.0/24 is directly connected, Loopback0
L        172.16.1.1/32 is directly connected, Loopback0
B     192.168.0.0/24 [20/0] via 172.16.0.2, 00:23:11
B     192.168.1.0/24 [20/0] via 172.16.0.2, 00:23:11


R1#show ip route      // NO ISP2 BGP NETWORK
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.1/32 is directly connected, Serial2/0
C        10.1.1.0/24 is directly connected, Loopback0
L        10.1.1.1/32 is directly connected, Loopback0
B     192.168.0.0/24 [20/0] via 10.0.0.2, 00:23:42
B     192.168.1.0/24 [20/0] via 10.0.0.2, 00:23:42


R2#show ip route      // CONFIGURE PRIMARY AND SECONDARY ISP DEFAULT ROUTE
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.2/32 is directly connected, Serial2/0
B        10.1.1.0/24 [20/0] via 10.0.0.1, 00:18:25
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.2/32 is directly connected, Serial2/1
B        172.16.1.0/24 [20/0] via 172.16.0.1, 00:25:25
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1
R2#
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 ?
  <1-255>    Distance metric for this route
  multicast  multicast route
  name       Specify name of the next hop
  permanent  permanent route
  tag        Set tag for this route
  track      Install route depending on tracked item
  <cr>

R2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 210      // PRIMARY DEFAULT STATIC ROUTE
R2(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220    // SECONDARY FLOATING STATIC ROUTE
R2(config)#end
R2#
*Jul 13 11:08:45.503: %SYS-5-CONFIG_I: Configured from console by console
R2#
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.0.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [210/0] via 10.0.0.1
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.2/32 is directly connected, Serial2/0
B        10.1.1.0/24 [20/0] via 10.0.0.1, 00:19:34
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.2/32 is directly connected, Serial2/1
B        172.16.1.0/24 [20/0] via 172.16.0.1, 00:26:34
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface loop 100
R1(config-if)#
*Jul 13 11:09:52.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R1(config-if)#ip address 192.168.100.1 255.255.255.0


R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.0.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [210/0] via 10.0.0.1
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.2/32 is directly connected, Serial2/0
B        10.1.1.0/24 [20/0] via 10.0.0.1, 00:21:12
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.2/32 is directly connected, Serial2/1
B        172.16.1.0/24 [20/0] via 172.16.0.1, 00:28:12
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1


R2#ping 192.168.100.1 source 192.168.1.1       // PING WORKS VIA ISP1 DEFAULT ROUTE
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/24 ms


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#no ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
R2(config)#no ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
R2(config)#end   
R2#


R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 200
R1(config-router)#neighbor 10.0.0.2 ?      
  activate                 Enable the Address Family for this Neighbor
  advertise                Advertise to this neighbor
  advertise-map            specify route-map for conditional advertisement
  advertisement-interval   Minimum interval between sending BGP routing updates
  allowas-in               Accept as-path with my AS present in it
  capability               Advertise capability to the peer
  default-originate        Originate default route to this neighbor
  description              Neighbor specific description
  disable-connected-check  one-hop away EBGP peer using loopback address
  distribute-list          Filter updates to/from this neighbor
  dmzlink-bw               Propagate the DMZ link bandwidth
  ebgp-multihop            Allow EBGP neighbors not on directly connected
                           networks
  fall-over                session fall on peer route lost
  filter-list              Establish BGP filters
  ha-mode                  high availability mode
  inherit                  Inherit a template
  local-as                 Specify a local-as number
  maximum-prefix           Maximum number of prefixes accepted from this peer
  next-hop-self            Disable the next hop calculation for this neighbor
  next-hop-unchanged       Propagate next hop unchanged for iBGP paths to this
                           neighbor
  password                 Set a password
  peer-group               Member of the peer-group
  prefix-list              Filter updates to/from this neighbor
  remote-as                Specify a BGP neighbor
  remove-private-as        Remove private AS number from outbound updates
  route-map                Apply route map to neighbor
  route-reflector-client   Configure a neighbor as Route Reflector client
  route-server-client      Configure a neighbor as Route Server client
  send-community           Send Community attribute to this neighbor
  send-label               Send NLRI + MPLS Label to this peer
  shutdown                 Administratively shut down this neighbor
  slow-peer                Configure slow-peer
  soft-reconfiguration     Per neighbor soft reconfiguration
  soo                      Site-of-Origin extended community
  timers                   BGP per neighbor timers
  translate-update         Translate Update to MBGP format
  transport                Transport options
  ttl-security             BGP ttl security check
  unsuppress-map           Route-map to selectively unsuppress suppressed
                           routes
  update-source            Source of routing updates
  version                  Set the BGP version to match a neighbor
  weight                   Set default weight for routes from this neighbor
         
R1(config-router)#neighbor 10.0.0.2 default-originate    // PROPAGATE DEFAULT ROUTE VIA BGP


R2#show ip route       // DEFAULT ROUTE NOT YET SHOWING
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.2/32 is directly connected, Serial2/0
B        10.1.1.0/24 [20/0] via 10.0.0.1, 00:24:15
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.2/32 is directly connected, Serial2/1
B        172.16.1.0/24 [20/0] via 172.16.0.1, 00:31:15
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1


R1#clear ip bgp ?       // FORCE BGP UPDATE
  *                Clear all peers
  <1-4294967295>   Clear peers with the AS number
  <1.0-XX.YY>      Clear peers with the AS number
  A.B.C.D          BGP neighbor address to clear
  X:X:X:X::X       BGP neighbor address to clear
  all              All address families
  dampening        Clear route flap dampening information
  external         Clear all external peers
  flap-statistics  Clear route flap statistics
  internal         Clear BGP internal statistics counters
  ipv4             Address family
  ipv6             Address family
  l2vpn            Address family
  nsap             Address family
  peer-group       Clear all members of peer-group
  rtfilter         Address family
  sso              SSO related
  table-map        Update BGP table-map configuration
  topology         Routing topology instance
  update-group     Clear all members of update-group
  vpnv4            Address family
  vpnv6            Address family
         
R1#clear ip bgp 10.0.0.2       // PREFER TO ISSUE clear ip bgp * <in | out> TO PERFORM BGP DATABASE SYNC WITHOUT DISRUPTING BGP ADJACENCY, MODERN IOS VERSION SUPPORTS BGP ROUTE REFRESH FEATURE
R1#
*Jul 13 11:13:57.907: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Down User reset
*Jul 13 11:13:57.911: %BGP_SESSION-5-ADJCHANGE: neighbor 10.0.0.2 IPv4 Unicast topology base removed from session  User reset
*Jul 13 11:13:58.139: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Up


R2#
*Jul 13 11:13:57.223: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Down Peer closed the session
*Jul 13 11:13:57.223: %BGP_SESSION-5-ADJCHANGE: neighbor 10.0.0.1 IPv4 Unicast topology base removed from session  Peer closed the session
*Jul 13 11:13:57.455: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Up
R2#
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.0.0.1 to network 0.0.0.0

B*    0.0.0.0/0 [20/0] via 10.0.0.1, 00:00:09
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.0.0.0/30 is directly connected, Serial2/0
L        10.0.0.2/32 is directly connected, Serial2/0
B        10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:09
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Serial2/1
L        172.16.0.2/32 is directly connected, Serial2/1
B        172.16.1.0/24 [20/0] via 172.16.0.1, 00:31:50
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1


R2#ping 192.168.100.1 source 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/28/52 ms

No comments:

Post a Comment