Here's a link in creating a Port-channel interface in a Cisco ASR 1001-X router. You'll need to configure first the Port-channel interface before bundling the individual ports, which is the reverse process in a switch.
ASR1K#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
ASR1K(config)#interface range GigabitEthernet0/0/1-2
ASR1K(config-if-range)#no shutdown
ASR1K(config-if-range)#channel-group 1 mode active
Channel-group 1 is not configured.
% Range command terminated because it failed on GigabitEthernet0/0/1
ASR1K(config-if)#do show run interface GigabitEthernet0/0/1
Building configuration...
Current configuration : 86 bytes
!
interface GigabitEthernet0/0/1
no ip address
no negotiation auto
cdp enable
Create the Port-channel interface first. I created a Layer 3 Port-channel in this case.
ASR1K(config)#interface Port-channel ?
<1-64> Port-channel interface number
ASR1K(config-if)# no shutdown
ASR1K(config-if)# ip address 10.1.1.1 255.255.255.252
ASR1K(config-if)#do sh run int po1
Building configuration...
Current configuration : 464 bytes
!
interface Port-channel1
ip address 10.1.1.1 255.255.255.252
After the Port-channel interface is configured, you can configure/bundle the individual ports next.
ASR1K(config-if)#interface range GigabitEthernet0/0/1-2
ASR1K(config-if-range)#channel-group ?
<1-64> Channel group number
ASR1K(config-if-range)#channel-group 1 ?
link Assign a link identifier used for load-balancing
mode Etherchannel Mode of the interface
<cr> <cr>
ASR1K(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally
passive Enable LACP only if a LACP device is detected
<cr> <cr>
ASR1K(config-if-range)#channel-group 1 mode active
ASR1K(config-if-range)#do sh run int g0/0/1
Building configuration...
Current configuration : 122 bytes
!
interface GigabitEthernet0/0/1
no ip address
negotiation auto
cdp enable
channel-group 1 mode active
ASR1K(config-if-range)#do sh run int g0/0/2
Building configuration...
Current configuration : 122 bytes
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
cdp enable
channel-group 1 mode active
ASR1K#show etherchannel ?
load-balancing Load Balance method
summary Ether channel summary
ASR1K#show etherchannel summary
Flags: D - down P/bndl - bundled in port-channel
I - stand-alone s/susp - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) LACP Gi0/0/4(bndl) Gi0/0/5(bndl)
RU - L3 port-channel UP State
SU - L2 port-channel UP state
P/bndl - Bundled
S/susp - Suspended
Here's a link to configure a Bidirectional Forwarding Detection (BFD) in a Cisco ASR 1001-X. You configure first a BFD template and then apply it to the Port-Channel interface.
ASR1K#configure terminal
ASR1K(config)#bfd?
bfd bfd-template
ASR1K(config)#bfd ?
fast-timers-on-slow-interface Allow fast timers on slow interfaces
l2cos L2 COS value to be used for BFD packets over VLAN interfaces
l3cos L3 COS value to be used for BFD packets
map configure bfd map entry for multi-hop sessions
slow-timers Change slow timers used by BFD
snmp Provides snmp ralated information that are specific to BFD
ASR1K(config)#bfd-template ?
multi-hop multi-hop template
single-hop Single-hop template
ASR1K(config)#bfd-template single-hop ?
WORD BFD template name
ASR1K(config)#bfd-template single-hop BFD ?
<cr> <cr>
ASR1K(config)#bfd-template single-hop BFD
ASR1K(config-bfd)#?
BFD template configuration commands:
authentication Authentication type
dampening Enable session dampening
default Set a command to its defaults
echo Use echo adjunct as bfd detection mechanism
exit Exit from BFD template configuration mode
interval Transmit interval between BFD packets
no Negate a command or set its defaults
ASR1K(config-bfd)#interval ?
both Minimum transmit and receive interval capability
microseconds Specify BFD timers in microseconds
min-tx Minimum transmit interval capability
ASR1K(config-bfd)#interval min-tx ?
<4-9999> Milliseconds
ASR1K(config-bfd)#interval min-tx 150 ?
min-rx Minimum receive interval capability
ASR1K(config-bfd)#interval min-tx 150 min-rx ?
<4-9999> Milliseconds
ASR1K(config-bfd)#interval min-tx 150 min-rx 150 ?
multiplier Multiplier value used to compute holddown
<cr> <cr>
ASR1K(config-bfd)#interval min-tx 150 min-rx 150 multiplier ?
<3-50> value used to multiply the interval
ASR1K(config-bfd)#interval min-tx 150 min-rx 150 multiplier 3 ?
<cr> <cr>
ASR1K(config-bfd)#interval min-tx 150 min-rx 150 multiplier 3
ASR1K(config-if)#interface Port-channel1
ASR1K(config-if)#port-channel ?
bfd Enable BFD feature
load-balance Configure load-balancing for egress traffic
ASR1K(config-if)#port-channel bfd ?
destination Destination IP Address
ASR1K(config-if)#port-channel bfd destination ?
ipv4 IPV4 Address
ipv6 IPV6 address
ASR1K(config-if)#port-channel bfd destination ipv4 ?
A.B.C.D IP Address
ASR1K(config-if)#port-channel bfd destination ipv4 10.1.1.2 ?
WORD name of the template
ASR1K(config-if)#port-channel bfd destination ipv4 10.1.1.2 BFD ?
<cr> <cr>
ASR1K(config-if)#port-channel bfd destination ipv4 10.1.1.2 BFD
ASR1K1(config-if)#do sh run int po1
Building configuration...
Current configuration : 518 bytes
!
interface Port-channel1
ip address 10.1.1.1 255.255.255.252
port-channel bfd destination ipv4 10.1.1.2 BFD
end
No comments:
Post a Comment