I recently configured a multihomed BGP site at work and I had fun doing BGP configuration and troubleshooting with Telstra. It was quite a challenging setup since we're doing BGP over IPsec VPN.
The BGP labs in CCNP ROUTE helped me understand and made me confident in dealing with this massive external gateway protocol. This was the initial BGP lab I did for ROUTE and played around with its attributes on succeeding labs.
ISP1(config)#interface loopback0
ISP1(config-if)#
*Jan 2 23:55:28.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP1(config-if)#description ISP1 Internet Network
ISP1(config-if)#ip address 10.1.1.1 255.255.255.0
ISP1(config-if)#interface s0/0/0
ISP1(config-if)#description ISP1 --> Int'l Travel Agency
ISP1(config-if)#ip address 10.0.0.1 255.255.255.252
ISP1(config-if)#clock rate 128000
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 2 23:56:39.903: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
ITA(config)#interface loopback0
ITA(config-if)#
*Jan 2 22:39:17.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ITA(config-if)#description Core Router network Link 1
ITA(config-if)#ip address 192.168.0.1 255.255.255.0
ITA(config-if)#interface loopback1
ITA(config-if)#
*Jan 2 22:39:53.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
ITA(config-if)#description Core router network Link 2
ITA(config-if)#ip address 192.168.1.1 255.255.255.0
ITA(config-if)#interface s0/0/0
ITA(config-if)#description Int'l Travel Agency --> ISP1
ITA(config-if)#ip address 10.0.0.2 255.255.255.252
ITA(config-if)#no shutdown
ITA(config-if)#
*Jan 2 22:40:49.115: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 2 22:40:50.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ITA(config-if)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ITA(config-if)#interface s0/0/1
ITA(config-if)#description Int'l Travel Agency --> ISP2
ITA(config-if)#ip address 172.16.0.2 255.255.255.252
ITA(config-if)#clock rate 128000
ITA(config-if)#no shutdown
ITA(config-if)#
*Jan 2 22:41:30.147: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 2 22:41:31.147: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
ISP2(config)#interface loopback0
ISP2(config-if)#
*Jan 2 23:19:32.215: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP2(config-if)#description ISP2 Internet Network
ISP2(config-if)#ip address 172.16.1.1 255.255.255.0
ISP2(config-if)#interface s0/0/1
ISP2(config-if)#description ISP2 --> Int'l Travel Agency
ISP2(config-if)#ip address 172.16.0.1 255.255.255.252
ISP2(config-if)#no shutdown
ISP2(config-if)#do ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
ISP1(config)#router bgp 200
ISP1(config-router)#?
Router configuration commands:
address-family Enter Address Family command mode
aggregate-address Configure BGP aggregate entries
auto-summary Enable automatic network number summarization
bgp BGP specific commands
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter networks in routing updates
exit Exit from routing protocol configuration mode
help Description of the interactive help system
maximum-paths Forward packets over multiple paths
neighbor Specify a neighbor router
network Specify a network to announce via BGP
no Negate a command or set its defaults
redistribute Redistribute information from another routing protocol
synchronization Perform IGP synchronization
table-map Map external entry attributes into routing table
template Enter template command mode
timers Adjust routing timers
ISP1(config-router)#neighbor ?
A.B.C.D Neighbor address
WORD Neighbor tag
X:X:X:X::X Neighbor IPv6 address
ISP1(config-router)#neighbor 10.0.0.2 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
ISP1(config-router)#neighbor 10.0.0.2 remote-as ?
<1-65535> AS of remote neighbor
<1.0-XX.YY> 4 octets AS of remote neighbor
ISP1(config-router)#neighbor 10.0.0.2 remote-as 100
ISP1(config-router)#network ?
A.B.C.D Network number
ISP1(config-router)#network 10.1.1.0 ?
backdoor Specify a BGP backdoor route
mask Network mask
nlri Specify nlri type for network
route-map Route-map to modify the attributes
<cr>
ISP1(config-router)#network 10.1.1.0 mask ?
A.B.C.D Network mask
ISP1(config-router)#network 10.1.1.0 mask 255.255.255.0
ISP2(config)#router bgp 300
ISP2(config-router)#neighbor 172.16.0.2 remote-as 100
ISP2(config-router)#network 172.16.1.0 mask 255.255.255.0
ITA(config)#router bgp 100
ITA(config-router)#neighbor 10.0.0.1 remote-as 200
ITA(config-router)#
*Jan 2 22:46:42.867: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Up
ITA(config-router)#neighbor 172.16.0.1 remote-as 300
ITA(config-router)#
*Jan 2 22:46:59.227: %BGP-5-ADJCHANGE: neighbor 172.16.0.1 Up
ITA(config-router)#network 192.168.0.0
ITA(config-router)#network 182.168.1.0
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:00:04 // TOOK FEW SECONDS TO SHOW IN ROUTING TABLE
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:04
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
ITA#tclsh
ITA(tcl)#foreach address {
+>10.0.0.1
+>10.0.0.2
+>10.1.1.1
+>172.16.0.1
+>172.16.0.2
+>172.16.1.1
+>192.168.0.1
+>192.168.1.1
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
ITA#show ip bgp
BGP table version is 4, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 10.0.0.1 0 0 200 i // * INDICATES VALID ROUTE; > INDICATES BEST ROUTE
*> 172.16.1.0/24 172.16.0.1 0 0 300 i
*> 192.168.0.0 0.0.0.0 0 32768 i
ISP1#show ip bgp
BGP table version is 4, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*> 172.16.1.0/24 10.0.0.2 0 100 300 i
*> 192.168.0.0 10.0.0.2 0 0 100 i
ISP1(config)#interface loopback0
ISP1(config-if)#shutdown
ISP1(config-if)#
*Jan 3 00:11:18.987: %LINK-5-CHANGED: Interface Loopback0, changed state to administratively down
*Jan 3 00:11:19.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to down
ITA#show ip bgp
BGP table version is 5, local router ID is 192.168.1.1 // BGP TABLE VERSION INCREMENTED BY 1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.0/24 172.16.0.1 0 0 300 i
*> 192.168.0.0 0.0.0.0 0 32768 i
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 3 00:13:42.099: %LINK-3-UPDOWN: Interface Loopback0, changed state to up
*Jan 3 00:13:43.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ITA#show ip bgp neighbors
BGP neighbor is 10.0.0.1, remote AS 200, external link
BGP version 4, remote router ID 10.1.1.1
BGP state = Established, up for 00:09:24
Last read 00:00:24, last write 00:00:24, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 5 3
Keepalives: 9 9
Route Refresh: 0 0
Total: 15 13
Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 6, neighbor version 6/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 3 1 (Consumes 52 bytes)
Prefixes Total: 4 2
Implicit Withdraw: 0 0
Explicit Withdraw: 1 1
Used as bestpath: n/a 1
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 1, min 0
Address tracking is enabled, the RIB does have a route to 10.0.0.1
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 10.0.0.2, Local port: 179
Foreign host: 10.0.0.1, Foreign port: 48476
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x199E0C):
Timer Starts Wakeups Next
Retrans 14 0 0x0
TimeWait 0 0 0x0
AckHold 13 10 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 975151708 snduna: 975152167 sndnxt: 975152167 sndwnd: 15926
irs: 2048523709 rcvnxt: 2048524069 rcvwnd: 16025 delrcvwnd: 359
SRTT: 254 ms, RTTO: 619 ms, RTV: 365 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 24 (out of order: 0), with data: 13, total data bytes: 359
Sent: 24 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 13, total data bytes: 458
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
BGP neighbor is 172.16.0.1, remote AS 300, external link
BGP version 4, remote router ID 172.16.1.1
BGP state = Established, up for 00:09:14
Last read 00:00:21, last write 00:00:31, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 5 1
Keepalives: 9 10
Route Refresh: 0 0
Total: 15 12
Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 6, neighbor version 6/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 3 1 (Consumes 52 bytes)
Prefixes Total: 4 1
Implicit Withdraw: 0 0
Explicit Withdraw: 1 0
Used as bestpath: n/a 1
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 1, min 0
Address tracking is enabled, the RIB does have a route to 172.16.0.1
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 172.16.0.2, Local port: 32730
Foreign host: 172.16.0.1, Foreign port: 179
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x19B6D4):
Timer Starts Wakeups Next
Retrans 14 0 0x0
TimeWait 0 0 0x0
AckHold 11 10 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 1 0 0x1A5C68
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 3823006640 snduna: 3823007099 sndnxt: 3823007099 sndwnd: 15926
irs: 124273748 rcvnxt: 124274046 rcvwnd: 16087 delrcvwnd: 297
SRTT: 254 ms, RTTO: 619 ms, RTV: 365 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: active open
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 25 (out of order: 0), with data: 12, total data bytes: 297
Sent: 25 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 13, total data bytes: 458
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
ISP2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
C 172.16.1.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
B 10.1.1.0 [20/0] via 172.16.0.2, 00:02:38 // ITA ADVERTISES ISP1 NETWORK, ISP2 MIGHT MIGHT ROUTE TRANSIT TO ITA
B 192.168.0.0/24 [20/0] via 172.16.0.2, 00:10:31
ITA(config)#access-list 1 permit 192.168.0.0 0.0.1.255
ITA(config)#router bgp 100
ITA(config-router)#neighbor 10.0.0.1 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
ITA(config-router)#neighbor 10.0.0.1 distribute-list ?
<1-199> IP access list number
<1300-2699> IP access list number (expanded range)
WORD IP Access-list name
ITA(config-router)#neighbor 10.0.0.1 distribute-list 1 ?
in Filter incoming updates
out Filter outgoing updates
ITA(config-router)#neighbor 10.0.0.1 distribute-list 1 out // ROUTE FILTER TO ADVERTISE ITA NETWORKS ONLY
ITA(config-router)#neighbor 172.16.0.1 distribute-list 1 out
ISP2#show ip route // NETWORK TO 10.1.1.0 WAS GONE AND NO NEED TO ISSUE clear ip bgp COMMAND; CURRENT IOS SUPPORTS ROUTE REFRESH CAPABILITY THAT REPLACES INBOUND SOFT RECONFIGURATION FEATURE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
C 172.16.1.0/24 is directly connected, Loopback0
B 192.168.0.0/24 [20/0] via 172.16.0.2, 00:15:29
ISP1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Loopback0
C 10.0.0.0/30 is directly connected, Serial0/0/0
B 192.168.0.0/24 [20/0] via 10.0.0.2, 00:17:32
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:18:52
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:10:59
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
ITA(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
ITA(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
ITA(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:19:57
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:12:04
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
ISP1(config)#interface loopback 100
ISP1(config-if)#
*Jan 3 00:26:18.527: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
ISP1(config-if)#ip address 192.168.100.1 255.255.255.0 // UNADVERTISED NETWORK
ITA#show ip route // 192.168.100.0/24 DOESN'T SHOW ON THE ROUTING TABLE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:21:31
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:13:37
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
ITA#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ITA#traceroute 192.168.100.1
Type escape sequence to abort.
Tracing the route to 192.168.100.1
1 10.0.0.1 4 msec * 4 msec // HOPS VIA ISP1
ITA(config)#no ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
ITA(config)#no ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
ISP1(config)#router bgp 200
ISP1(config-router)#network 192.168.100.0 // ADVERTISE NEW NETWORK VIA BGP
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:06:20
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:06:20
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:03:21
ITA(config)#ip default-network 192.168.100.0
ITA(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 192.168.100.0 // USED ONLY WITH CLASSFUL NETWORKS
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:07:06
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:07:06
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:04:07
ITA(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220 // ISP2 AS BACKUP ROUTE
ITA(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:08:50
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:08:50
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:05:51 // NEED TO ISSUE clear ip bgp
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:10:47
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:04
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:04
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:12:07
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:01:24
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:01:24 // PREFERRED ROUTE SINCE EBGP ADMIN DISTANCE IS 20
S* 0.0.0.0/0 [220/0] via 172.16.0.1 // STILL SHOWS UP IN ROUTING TABLE; WILL ACT AS THE DEFAULT BACKUP ROUTE ONLY IF THE 192.168.100.0/24 NETWORK IS UNAVAILABLE DUE TO FAULT OR MISCONFIG OR WHILE BGP RESYNC WITH ISP1
ITA#tclsh
ITA(tcl)#foreach address {
+>10.0.0.1
+>10.0.0.2
+>10.1.1.1
+>172.16.0.1
+>172.16.0.2
+>172.16.1.1
+>192.168.0.1
+>192.168.1.1
+>192.168.100.1
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ITA(config)#ip default-network 192.168.100.0
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:20:51
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:49
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:49
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ISP1(config)#router bgp 200
ISP1(config-router)#neighbor 10.0.0.2 default-originate // ALTERNATE OPTION INJECTING DEFAULT ROUTE IN BGP
ISP1#clear ip bgp 10.0.0.2
ISP1#
*Jan 3 00:57:18.111: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Down User reset
*Jan 3 00:57:22.743: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Up
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:22:17
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:15
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:15
B* 0.0.0.0/0 [20/0] via 10.0.0.1, 00:00:15
The BGP labs in CCNP ROUTE helped me understand and made me confident in dealing with this massive external gateway protocol. This was the initial BGP lab I did for ROUTE and played around with its attributes on succeeding labs.
ISP1(config)#interface loopback0
ISP1(config-if)#
*Jan 2 23:55:28.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP1(config-if)#description ISP1 Internet Network
ISP1(config-if)#ip address 10.1.1.1 255.255.255.0
ISP1(config-if)#interface s0/0/0
ISP1(config-if)#description ISP1 --> Int'l Travel Agency
ISP1(config-if)#ip address 10.0.0.1 255.255.255.252
ISP1(config-if)#clock rate 128000
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 2 23:56:39.903: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
ITA(config)#interface loopback0
ITA(config-if)#
*Jan 2 22:39:17.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ITA(config-if)#description Core Router network Link 1
ITA(config-if)#ip address 192.168.0.1 255.255.255.0
ITA(config-if)#interface loopback1
ITA(config-if)#
*Jan 2 22:39:53.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
ITA(config-if)#description Core router network Link 2
ITA(config-if)#ip address 192.168.1.1 255.255.255.0
ITA(config-if)#interface s0/0/0
ITA(config-if)#description Int'l Travel Agency --> ISP1
ITA(config-if)#ip address 10.0.0.2 255.255.255.252
ITA(config-if)#no shutdown
ITA(config-if)#
*Jan 2 22:40:49.115: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 2 22:40:50.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ITA(config-if)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ITA(config-if)#interface s0/0/1
ITA(config-if)#description Int'l Travel Agency --> ISP2
ITA(config-if)#ip address 172.16.0.2 255.255.255.252
ITA(config-if)#clock rate 128000
ITA(config-if)#no shutdown
ITA(config-if)#
*Jan 2 22:41:30.147: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 2 22:41:31.147: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
ISP2(config)#interface loopback0
ISP2(config-if)#
*Jan 2 23:19:32.215: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP2(config-if)#description ISP2 Internet Network
ISP2(config-if)#ip address 172.16.1.1 255.255.255.0
ISP2(config-if)#interface s0/0/1
ISP2(config-if)#description ISP2 --> Int'l Travel Agency
ISP2(config-if)#ip address 172.16.0.1 255.255.255.252
ISP2(config-if)#no shutdown
ISP2(config-if)#do ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
ISP1(config)#router bgp 200
ISP1(config-router)#?
Router configuration commands:
address-family Enter Address Family command mode
aggregate-address Configure BGP aggregate entries
auto-summary Enable automatic network number summarization
bgp BGP specific commands
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter networks in routing updates
exit Exit from routing protocol configuration mode
help Description of the interactive help system
maximum-paths Forward packets over multiple paths
neighbor Specify a neighbor router
network Specify a network to announce via BGP
no Negate a command or set its defaults
redistribute Redistribute information from another routing protocol
synchronization Perform IGP synchronization
table-map Map external entry attributes into routing table
template Enter template command mode
timers Adjust routing timers
ISP1(config-router)#neighbor ?
A.B.C.D Neighbor address
WORD Neighbor tag
X:X:X:X::X Neighbor IPv6 address
ISP1(config-router)#neighbor 10.0.0.2 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
ISP1(config-router)#neighbor 10.0.0.2 remote-as ?
<1-65535> AS of remote neighbor
<1.0-XX.YY> 4 octets AS of remote neighbor
ISP1(config-router)#neighbor 10.0.0.2 remote-as 100
ISP1(config-router)#network ?
A.B.C.D Network number
ISP1(config-router)#network 10.1.1.0 ?
backdoor Specify a BGP backdoor route
mask Network mask
nlri Specify nlri type for network
route-map Route-map to modify the attributes
<cr>
ISP1(config-router)#network 10.1.1.0 mask ?
A.B.C.D Network mask
ISP1(config-router)#network 10.1.1.0 mask 255.255.255.0
ISP2(config)#router bgp 300
ISP2(config-router)#neighbor 172.16.0.2 remote-as 100
ISP2(config-router)#network 172.16.1.0 mask 255.255.255.0
ITA(config)#router bgp 100
ITA(config-router)#neighbor 10.0.0.1 remote-as 200
ITA(config-router)#
*Jan 2 22:46:42.867: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Up
ITA(config-router)#neighbor 172.16.0.1 remote-as 300
ITA(config-router)#
*Jan 2 22:46:59.227: %BGP-5-ADJCHANGE: neighbor 172.16.0.1 Up
ITA(config-router)#network 192.168.0.0
ITA(config-router)#network 182.168.1.0
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:00:04 // TOOK FEW SECONDS TO SHOW IN ROUTING TABLE
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:04
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
ITA#tclsh
ITA(tcl)#foreach address {
+>10.0.0.1
+>10.0.0.2
+>10.1.1.1
+>172.16.0.1
+>172.16.0.2
+>172.16.1.1
+>192.168.0.1
+>192.168.1.1
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
ITA#show ip bgp
BGP table version is 4, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 10.0.0.1 0 0 200 i // * INDICATES VALID ROUTE; > INDICATES BEST ROUTE
*> 172.16.1.0/24 172.16.0.1 0 0 300 i
*> 192.168.0.0 0.0.0.0 0 32768 i
ISP1#show ip bgp
BGP table version is 4, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*> 172.16.1.0/24 10.0.0.2 0 100 300 i
*> 192.168.0.0 10.0.0.2 0 0 100 i
ISP1(config)#interface loopback0
ISP1(config-if)#shutdown
ISP1(config-if)#
*Jan 3 00:11:18.987: %LINK-5-CHANGED: Interface Loopback0, changed state to administratively down
*Jan 3 00:11:19.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to down
ITA#show ip bgp
BGP table version is 5, local router ID is 192.168.1.1 // BGP TABLE VERSION INCREMENTED BY 1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.0/24 172.16.0.1 0 0 300 i
*> 192.168.0.0 0.0.0.0 0 32768 i
ISP1(config-if)#no shutdown
ISP1(config-if)#
*Jan 3 00:13:42.099: %LINK-3-UPDOWN: Interface Loopback0, changed state to up
*Jan 3 00:13:43.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ITA#show ip bgp neighbors
BGP neighbor is 10.0.0.1, remote AS 200, external link
BGP version 4, remote router ID 10.1.1.1
BGP state = Established, up for 00:09:24
Last read 00:00:24, last write 00:00:24, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 5 3
Keepalives: 9 9
Route Refresh: 0 0
Total: 15 13
Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 6, neighbor version 6/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 3 1 (Consumes 52 bytes)
Prefixes Total: 4 2
Implicit Withdraw: 0 0
Explicit Withdraw: 1 1
Used as bestpath: n/a 1
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 1, min 0
Address tracking is enabled, the RIB does have a route to 10.0.0.1
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 10.0.0.2, Local port: 179
Foreign host: 10.0.0.1, Foreign port: 48476
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x199E0C):
Timer Starts Wakeups Next
Retrans 14 0 0x0
TimeWait 0 0 0x0
AckHold 13 10 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 975151708 snduna: 975152167 sndnxt: 975152167 sndwnd: 15926
irs: 2048523709 rcvnxt: 2048524069 rcvwnd: 16025 delrcvwnd: 359
SRTT: 254 ms, RTTO: 619 ms, RTV: 365 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 24 (out of order: 0), with data: 13, total data bytes: 359
Sent: 24 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 13, total data bytes: 458
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
BGP neighbor is 172.16.0.1, remote AS 300, external link
BGP version 4, remote router ID 172.16.1.1
BGP state = Established, up for 00:09:14
Last read 00:00:21, last write 00:00:31, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
New ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 5 1
Keepalives: 9 10
Route Refresh: 0 0
Total: 15 12
Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 6, neighbor version 6/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 3 1 (Consumes 52 bytes)
Prefixes Total: 4 1
Implicit Withdraw: 0 0
Explicit Withdraw: 1 0
Used as bestpath: n/a 1
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 1, min 0
Address tracking is enabled, the RIB does have a route to 172.16.0.1
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 172.16.0.2, Local port: 32730
Foreign host: 172.16.0.1, Foreign port: 179
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0x19B6D4):
Timer Starts Wakeups Next
Retrans 14 0 0x0
TimeWait 0 0 0x0
AckHold 11 10 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 1 0 0x1A5C68
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0
iss: 3823006640 snduna: 3823007099 sndnxt: 3823007099 sndwnd: 15926
irs: 124273748 rcvnxt: 124274046 rcvwnd: 16087 delrcvwnd: 297
SRTT: 254 ms, RTTO: 619 ms, RTV: 365 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: active open
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 25 (out of order: 0), with data: 12, total data bytes: 297
Sent: 25 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 13, total data bytes: 458
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0
ISP2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
C 172.16.1.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
B 10.1.1.0 [20/0] via 172.16.0.2, 00:02:38 // ITA ADVERTISES ISP1 NETWORK, ISP2 MIGHT MIGHT ROUTE TRANSIT TO ITA
B 192.168.0.0/24 [20/0] via 172.16.0.2, 00:10:31
ITA(config)#access-list 1 permit 192.168.0.0 0.0.1.255
ITA(config)#router bgp 100
ITA(config-router)#neighbor 10.0.0.1 ?
activate Enable the Address Family for this Neighbor
advertise-map specify route-map for conditional advertisement
advertisement-interval Minimum interval between sending BGP routing updates
allowas-in Accept as-path with my AS present in it
capability Advertise capability to the peer
default-originate Originate default route to this neighbor
description Neighbor specific description
disable-connected-check one-hop away EBGP peer using loopback address
distribute-list Filter updates to/from this neighbor
dmzlink-bw Propagate the DMZ link bandwidth
ebgp-multihop Allow EBGP neighbors not on directly connected
networks
fall-over session fall on peer route lost
filter-list Establish BGP filters
inherit Inherit a template
local-as Specify a local-as number
maximum-prefix Maximum number of prefixes accepted from this peer
next-hop-self Disable the next hop calculation for this neighbor
next-hop-unchanged Propagate next hop unchanged for iBGP paths to this
neighbor
password Set a password
peer-group Member of the peer-group
prefix-list Filter updates to/from this neighbor
remote-as Specify a BGP neighbor
remove-private-as Remove private AS number from outbound updates
route-map Apply route map to neighbor
route-reflector-client Configure a neighbor as Route Reflector client
send-community Send Community attribute to this neighbor
send-label Send NLRI + MPLS Label to this peer
shutdown Administratively shut down this neighbor
soft-reconfiguration Per neighbor soft reconfiguration
timers BGP per neighbor timers
translate-update Translate Update to MBGP format
transport Transport options
ttl-security BGP ttl security check
unsuppress-map Route-map to selectively unsuppress suppressed
routes
update-source Source of routing updates
version Set the BGP version to match a neighbor
weight Set default weight for routes from this neighbor
ITA(config-router)#neighbor 10.0.0.1 distribute-list ?
<1-199> IP access list number
<1300-2699> IP access list number (expanded range)
WORD IP Access-list name
ITA(config-router)#neighbor 10.0.0.1 distribute-list 1 ?
in Filter incoming updates
out Filter outgoing updates
ITA(config-router)#neighbor 10.0.0.1 distribute-list 1 out // ROUTE FILTER TO ADVERTISE ITA NETWORKS ONLY
ITA(config-router)#neighbor 172.16.0.1 distribute-list 1 out
ISP2#show ip route // NETWORK TO 10.1.1.0 WAS GONE AND NO NEED TO ISSUE clear ip bgp COMMAND; CURRENT IOS SUPPORTS ROUTE REFRESH CAPABILITY THAT REPLACES INBOUND SOFT RECONFIGURATION FEATURE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
C 172.16.1.0/24 is directly connected, Loopback0
B 192.168.0.0/24 [20/0] via 172.16.0.2, 00:15:29
ISP1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Loopback0
C 10.0.0.0/30 is directly connected, Serial0/0/0
B 192.168.0.0/24 [20/0] via 10.0.0.2, 00:17:32
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:18:52
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:10:59
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
ITA(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
ITA(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
ITA(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:19:57
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:12:04
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
ISP1(config)#interface loopback 100
ISP1(config-if)#
*Jan 3 00:26:18.527: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
ISP1(config-if)#ip address 192.168.100.1 255.255.255.0 // UNADVERTISED NETWORK
ITA#show ip route // 192.168.100.0/24 DOESN'T SHOW ON THE ROUTING TABLE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:21:31
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:13:37
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
ITA#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ITA#traceroute 192.168.100.1
Type escape sequence to abort.
Tracing the route to 192.168.100.1
1 10.0.0.1 4 msec * 4 msec // HOPS VIA ISP1
ITA(config)#no ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
ITA(config)#no ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
ISP1(config)#router bgp 200
ISP1(config-router)#network 192.168.100.0 // ADVERTISE NEW NETWORK VIA BGP
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:06:20
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:06:20
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:03:21
ITA(config)#ip default-network 192.168.100.0
ITA(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 192.168.100.0 // USED ONLY WITH CLASSFUL NETWORKS
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:07:06
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:07:06
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:04:07
ITA(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220 // ISP2 AS BACKUP ROUTE
ITA(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:08:50
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:08:50
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:05:51 // NEED TO ISSUE clear ip bgp
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:10:47
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:04
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:04
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:12:07
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:01:24
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:01:24 // PREFERRED ROUTE SINCE EBGP ADMIN DISTANCE IS 20
S* 0.0.0.0/0 [220/0] via 172.16.0.1 // STILL SHOWS UP IN ROUTING TABLE; WILL ACT AS THE DEFAULT BACKUP ROUTE ONLY IF THE 192.168.100.0/24 NETWORK IS UNAVAILABLE DUE TO FAULT OR MISCONFIG OR WHILE BGP RESYNC WITH ISP1
ITA#tclsh
ITA(tcl)#foreach address {
+>10.0.0.1
+>10.0.0.2
+>10.1.1.1
+>172.16.0.1
+>172.16.0.2
+>172.16.1.1
+>192.168.0.1
+>192.168.1.1
+>192.168.100.1
+>} {
+>ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
ITA(config)#ip default-network 192.168.100.0
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:20:51
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:49
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:49
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ISP1(config)#router bgp 200
ISP1(config-router)#neighbor 10.0.0.2 default-originate // ALTERNATE OPTION INJECTING DEFAULT ROUTE IN BGP
ISP1#clear ip bgp 10.0.0.2
ISP1#
*Jan 3 00:57:18.111: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Down User reset
*Jan 3 00:57:22.743: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Up
ITA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:22:17
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:15
C 10.0.0.0/30 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:15
B* 0.0.0.0/0 [20/0] via 10.0.0.1, 00:00:15
No comments:
Post a Comment