We rarely use (or haven't used) EtherChannel in our data center core switches since we're running 1-GigabitEthernet and 10-GigabitEthernet fiber trunks all over the place. I always use the command below on a Nexus switch to check if the SFP/GBIC was detected and if the transmit (Tx) and receive (Rx) signals are within nominal range.
NEXUS# show interface eth1/1 transceiver details
Ethernet1/1
transceiver is present
type is 10Gbase-SR
name is CISCO-FINISAR
part number is FTLX8571D3ABC-C2
revision is A
serial number is FNS18283XYZ
nominal bitrate is 10300 MBit/sec
Link length supported for 50/125um OM2 fiber is 82 m
Link length supported for 62.5/125um fiber is 26 m
Link length supported for 50/125um OM3 fiber is 300 m
cisco id is --
cisco extended id number is 4
SFP Detail Diagnostics Information (internal calibration)
----------------------------------------------------------------------------
Current Alarms Warnings
Measurement High Low High Low
----------------------------------------------------------------------------
Temperature 50.44 C 75.00 C -5.00 C 70.00 C 0.00 C
Voltage 3.30 V 3.63 V 2.97 V 3.46 V 3.13 V
Current 8.23 mA 11.80 mA 4.00 mA 10.80 mA 5.00 mA
Tx Power -2.44 dBm 1.69 dBm -11.30 dBm -1.30 dBm -7.30 dBm
Rx Power -2.76 dBm 1.99 dBm -13.97 dBm -1.00 dBm -9.91 dBm
----------------------------------------------------------------------------
Note: ++ high-alarm; + high-warning; -- low-alarm; - low-warning
Below is the CCNP SWITCH EtherChannel lab that I did during my CCDP studies.
DLS1(config)#interface range fastethernet0/7-12
DLS1(config-if-range)#switchport trunk encapsulation dot1q
DLS1(config-if-range)#switchport mode trunk
DLS1(config-if-range)#end
DLS1#
*Mar 1 00:12:21.712: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to down
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to down
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to down
*Mar 1 00:12:22.148: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:12:22.148: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
*Mar 1 00:12:25.118: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up
*Mar 1 00:12:25.134: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
*Mar 1 00:12:25.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
*Mar 1 00:12:25.168: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
*Mar 1 00:12:25.185: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up
*Mar 1 00:12:25.193: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up
ALS1(config)#interface range fastethernet0/1-2
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS1(config-if-range)#
00:14:57: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
00:14:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
00:15:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:15:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
ALS1(config-if-range)#interface range fastethernet0/4-5
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS1(config-if-range)#
00:15:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
00:15:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to down
ALS1(config-if-range)#
00:15:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:15:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up
ALS1(config-if-range)#interface range fastethernet0/7-8
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS2(config)#interface range fastethernet0/1-2
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#interface range fastethernet0/4-5
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#interface range fastethernet0/7-8
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#
00:17:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to down
00:17:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
ALS2(config-if-range)#
00:17:31: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up
00:17:31: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
DLS2(config)#interface range fastethernet0/7-12
DLS2(config-if-range)#switchport trunk encapsulation dot1q
DLS2(config-if-range)#switchport mode trunk
ALS1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/2 on 802.1q trunking 1
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/2 1-4094
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,100,110
Fa0/2 1,100,110
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Port Vlans allowed and active in management domain
Fa0/8 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 none
Fa0/2 none
Fa0/4 none
Fa0/5 none
Fa0/7 1,100,110
Fa0/8 none
ALS2#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/2 on 802.1q trunking 1
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/2 1-4094
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,100,110
Fa0/2 1,100,110
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Port Vlans allowed and active in management domain
Fa0/8 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1,100,110
Fa0/2 1,100,110
Fa0/4 1,100,110
Fa0/5 none
Fa0/7 none
Fa0/8 none
ALS1(config)#interface range fastethernet0/1-2
ALS1(config-if-range)#shutdown // SHUTDOWN PORTS BEFORE CONFIGURING ETHERCHANNEL; MIGHT GO IN ERR-DISABLE STATE
ALS1(config-if-range)#
00:22:27: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
00:22:27: %LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
ALS1(config-if-range)#channel-group ?
<1-48> Channel group number
ALS1(config-if-range)#channel-group 1 ?
mode Etherchannel Mode of the interface
ALS1(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
ALS1(config-if-range)#channel-group 1 mode desirable // ACTIVELY NEGoTIATE PAgP ETHERCHANNEL LINK
Creating a port-channel interface Port-channel 1
ALS2(config)#interface range fastethernet0/1-2
ALS2(config-if-range)#shutdown
ALS2(config-if-range)#
00:22:05: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
00:22:05: %LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
00:22:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
ALS2(config-if-range)#
00:22:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
ALS2(config)#interface range f0/1-2
ALS2(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
ALS1(config)#interface ?
Async Async interface
BVI Bridge-Group Virtual Interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Filter Filter interface
Filtergroup Filter Group interface
GigabitEthernet GigabitEthernet IEEE 802.3z
Group-Async Async Group interface
Lex Lex interface
Loopback Loopback interface
Null Null interface
Port-channel Ethernet Channel of interfaces
Portgroup Portgroup interface
Pos-channel POS Channel of interfaces
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing
Vlan Catalyst Vlans
fcpa Fiber Channel
range interface range command
ALS1(config)#interface port-channel ?
<1-48> Port-channel interface number
ALS1(config)#interface port-channel 1
ALS1(config-if)#switchport ?
access Set access mode characteristics of the interface
backup Set backup for the interface
block Disable forwarding of unknown uni/multi cast addresses
host Set port host
mode Set trunking mode of the interface
nonegotiate Device will not engage in negotiation protocol on this
interface
port-security Security related command
priority Set appliance 802.1p priority
protected Configure an interface to be a protected port
trunk Set trunking characteristics of the interface
voice Voice appliance attributes
<cr>
ALS1(config-if)#switchport mode ?
access Set trunking mode to ACCESS unconditionally
dot1q-tunnel set trunking mode to TUNNEL unconditionally
dynamic Set trunking mode to dynamically negotiate access or trunk mode
trunk Set trunking mode to TRUNK unconditionally
ALS1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk"
mode.
ALS1(config-if)#switchport trunk encapsulation dot1q
ALS1(config-if)#switchport mode trunk // CREATE LAYER 2 LOGICAL ETHERCHANNEL TRUNK
ALS2(config)#interface port-channel1
ALS2(config-if)#switchport trunk encapsulation dot1q
ALS2(config-if)#switchport mode trunk
ALS1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Fa0/1(D) Fa0/2(D) // LAYER 2 ETHERCHANNEL LINK; PORTS ARE DOWN
ALS1(config)#interface range fastethernet0/1-2
ALS1(config-if-range)#no shutdown
ALS1(config-if-range)#
00:29:29: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
00:29:29: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
ALS2(config)#interface range fastethernet0/1-2
ALS2(config-if-range)#no shutdown
ALS2(config-if-range)#
00:29:55: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:29:55: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
ALS2(config-if-range)#
00:30:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
00:30:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
ALS2(config-if-range)#
00:30:02: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:30:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
ALS2#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)
ALS1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)
ALS1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Po1 on 802.1q trunking 1 // PORT CHANNEL AS ONE LOGICAL TRUNK
Port Vlans allowed on trunk
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Po1 1-4094
Port Vlans allowed and active in management domain
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Fa0/8 1,100,110
Po1 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Port Vlans in spanning tree forwarding state and not pruned
Fa0/4 none
Fa0/5 none
Fa0/7 1,100,110
Fa0/8 none
Po1 none
ALS1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0016.c756.6180
Cost 19
Port 8 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 6416.8dec.a700
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Altn BLK 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Root FWD 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Altn BLK 12 128.56 P2p // ALS2 FE PORTS 1 AND 2 WERE FIRS UNSHUT
VLAN0100
Spanning tree enabled protocol ieee
Root ID Priority 32868
Address 0016.c756.6180
Cost 19
Port 8 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
Address 6416.8dec.a700
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Altn BLK 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Root FWD 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Altn BLK 12 128.56 P2p
VLAN0110
Spanning tree enabled protocol ieee
Root ID Priority 32878
Address 0016.c756.6180
Cost 19
Port 8 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32878 (priority 32768 sys-id-ext 110)
Address 6416.8dec.a700
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Altn BLK 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Root FWD 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Altn BLK 12 128.56 P2p
ALS2#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Po1 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Po1 1-4094
Port Vlans allowed and active in management domain
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Fa0/8 1,100,110
Po1 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Port Vlans in spanning tree forwarding state and not pruned
Fa0/4 1,100,110
Fa0/5 none
Fa0/7 none
Fa0/8 none
Po1 1,100,110
ALS2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0016.c756.6180
Cost 19
Port 5 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0022.5684.1380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Altn BLK 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Desg FWD 12 128.56 P2p
VLAN0100
Spanning tree enabled protocol ieee
Root ID Priority 32868
Address 0016.c756.6180
Cost 19
Port 5 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
Address 0022.5684.1380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Altn BLK 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Desg FWD 12 128.56 P2p
VLAN0110
Spanning tree enabled protocol ieee
Root ID Priority 32878
Address 0016.c756.6180
Cost 19
Port 5 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32878 (priority 32768 sys-id-ext 110)
Address 0022.5684.1380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Altn BLK 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Desg FWD 12 128.56 P2p
DLS1(config)#interface range fastethernet0/7-8
DLS1(config-if-range)#shutdown
DLS1(config-if-range)#
*Mar 1 00:35:04.743: %LINK-5-CHANGED: Interface FastEthernet0/7, changed state to administratively
down
*Mar 1 00:35:04.768: %LINK-5-CHANGED: Interface FastEthernet0/8, changed state to administratively
down
*Mar 1 00:35:05.750: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state
to down
DLS1(config-if-range)#
*Mar 1 00:35:05.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state
to down
DLS1(config-if-range)#channel-group ?
<1-48> Channel group number
DLS1(config-if-range)#channel-group 2 ?
mode Etherchannel Mode of the interface
DLS1(config-if-range)#channel-group 2 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
DLS1(config-if-range)#channel-group 2 mode active // ACTIVELY NEGOTIATES LACP TRUNK
Creating a port-channel interface Port-channel 2
ALS1(config)#interface range fastethernet0/7-8
ALS1(config-if-range)#shutdown
ALS1(config-if-range)#
00:37:19: %LINK-5-CHANGED: Interface FastEthernet0/7, changed state to administratively down
00:37:19: %LINK-5-CHANGED: Interface FastEthernet0/8, changed state to administratively down
ALS1(config-if-range)#channel-group 2 mode active
Creating a port-channel interface Port-channel 2
ALS1(config-if-range)#no shutdown
ALS1(config-if-range)#
00:37:50: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to down
00:37:50: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down
DLS1(config)#interface range fastethernet0/7-8
DLS1(config-if-range)#no shutdown
DLS1(config-if-range)#
*Mar 1 00:37:39.094: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to up
*Mar 1 00:37:39.102: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
DLS1(config-if-range)#
*Mar 1 00:37:46.484: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up
*Mar 1 00:37:46.501: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
DLS1(config-if-range)#
*Mar 1 00:37:47.465: %LINK-3-UPDOWN: Interface Port-channel2, changed state to up
*Mar 1 00:37:48.472: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed state to up
DLS1(config-if-range)#exit
DLS1(config)#interface port-channel2
DLS1(config-if)#switchport trunk encapsulation dot1q
DLS1(config-if)#switchport mode trunk
ALS1(config)#interface port-channel2
ALS1(config-if)#switchport trunk encapsulation dot1q
ALS1(config-if)#switchport mode trunk
ALS1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)
2 Po2(SU) LACP Fa0/7(P) Fa0/8(P) // LAYER 2 ETHERCHANNEL LINK
DLS1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Fa0/7(P) Fa0/8(P)
DLS1(config)#interface range fastethernet0/11-12
DLS1(config-if-range)#no switchport // CREATE A LAYER 3/ROUTED PORT
DLS1(config-if-range)#
*Mar 1 00:43:45.726: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:43:45.776: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
DLS1(config-if-range)#
*Mar 1 00:43:47.748: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to up
*Mar 1 00:43:47.798: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
*Mar 1 00:43:48.754: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state
to up
DLS1(config-if-range)#
*Mar 1 00:43:48.805: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state
to up
DLS1(config-if-range)#channel-group 3 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
DLS1(config-if-range)#channel-group 3 mode desirable
Creating a port-channel interface Port-channel 3
DLS1(config-if-range)#
*Mar 1 00:44:03.602: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state
to down
*Mar 1 00:44:03.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state
to down
DLS1(config-if-range)#
*Mar 1 00:44:11.840: %EC-5-L3DONTBNDL1: Fa0/12 suspended: PAgP not enabled on the remote port.
*Mar 1 00:44:12.360: %EC-5-L3DONTBNDL1: Fa0/11 suspended: PAgP not enabled on the remote port.
DLS1(config-if-range)#exit
DLS1(config)#interface port-channel3
DLS1(config-if)#no switchport
DLS1(config-if)#ip address 10.0.0.1 255.255.255.0 // CREATE A LAYER 3 ETHERCHANNEL LINK
DLS2(config)#interface range fastethernet0/11-12
DLS2(config-if-range)#no switchport
DLS2(config-if-range)#
*Mar 1 00:47:23.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:47:23.654: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
DLS2(config-if-range)#
*Mar 1 00:47:25.617: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to up
*Mar 1 00:47:25.675: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
*Mar 1 00:47:26.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up
DLS2(config-if-range)#
*Mar 1 00:47:26.682: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up
DLS2(config-if-range)#channel-group 3 mode desirable
Creating a port-channel interface Port-channel 3
DLS2(config-if-range)#
*Mar 1 00:47:40.313: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:47:40.322: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
DLS2(config-if-range)#
*Mar 1 00:47:42.318: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel3, changed state to up
*Mar 1 00:47:42.973: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up
*Mar 1 00:47:43.258: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up
DLS2(config-if-range)#
*Mar 1 00:47:43.962: %LINK-3-UPDOWN: Interface Port-channel3, changed state to up
DLS2(config-if-range)#exit
DLS2(config)#interface port-channel3
DLS2(config-if)#no switchport
DLS2(config-if)#ip address 10.0.0.2
% Incomplete command.
DLS2(config-if)#ip address 10.0.0.2 255.255.255.0
DLS2(config-if)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms
DLS2#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
3 Po3(RU) PAgP Fa0/11(P) Fa0/12(P) // LAYER 3 ETHERCHANNEL LINK
DLS1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-mac // DEFAULT METHOD; VARIES ON SWITCH PLATFORMS
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
IPv4: Source MAC address
IPv6: Source MAC address
ALS1(config)#port-channel ?
load-balance Load Balancing method
ALS1(config)#port-channel load-balance ?
dst-ip Dst IP Addr
dst-mac Dst Mac Addr
src-dst-ip Src XOR Dst IP Addr
src-dst-mac Src XOR Dst Mac Addr
src-ip Src IP Addr
src-mac Src Mac Addr
ALS1(config)#port-channel load-balance src-dst-mac
ALS1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-mac
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination MAC address
IPv6: Source XOR Destination MAC address
NEXUS# show interface eth1/1 transceiver details
Ethernet1/1
transceiver is present
type is 10Gbase-SR
name is CISCO-FINISAR
part number is FTLX8571D3ABC-C2
revision is A
serial number is FNS18283XYZ
nominal bitrate is 10300 MBit/sec
Link length supported for 50/125um OM2 fiber is 82 m
Link length supported for 62.5/125um fiber is 26 m
Link length supported for 50/125um OM3 fiber is 300 m
cisco id is --
cisco extended id number is 4
SFP Detail Diagnostics Information (internal calibration)
----------------------------------------------------------------------------
Current Alarms Warnings
Measurement High Low High Low
----------------------------------------------------------------------------
Temperature 50.44 C 75.00 C -5.00 C 70.00 C 0.00 C
Voltage 3.30 V 3.63 V 2.97 V 3.46 V 3.13 V
Current 8.23 mA 11.80 mA 4.00 mA 10.80 mA 5.00 mA
Tx Power -2.44 dBm 1.69 dBm -11.30 dBm -1.30 dBm -7.30 dBm
Rx Power -2.76 dBm 1.99 dBm -13.97 dBm -1.00 dBm -9.91 dBm
----------------------------------------------------------------------------
Note: ++ high-alarm; + high-warning; -- low-alarm; - low-warning
Below is the CCNP SWITCH EtherChannel lab that I did during my CCDP studies.
DLS1(config)#interface range fastethernet0/7-12
DLS1(config-if-range)#switchport trunk encapsulation dot1q
DLS1(config-if-range)#switchport mode trunk
DLS1(config-if-range)#end
DLS1#
*Mar 1 00:12:21.712: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to down
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to down
*Mar 1 00:12:22.140: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to down
*Mar 1 00:12:22.148: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:12:22.148: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
*Mar 1 00:12:25.118: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up
*Mar 1 00:12:25.134: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
*Mar 1 00:12:25.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
*Mar 1 00:12:25.168: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
*Mar 1 00:12:25.185: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up
*Mar 1 00:12:25.193: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up
ALS1(config)#interface range fastethernet0/1-2
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS1(config-if-range)#
00:14:57: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
00:14:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
00:15:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:15:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
ALS1(config-if-range)#interface range fastethernet0/4-5
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS1(config-if-range)#
00:15:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
00:15:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to down
ALS1(config-if-range)#
00:15:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:15:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up
ALS1(config-if-range)#interface range fastethernet0/7-8
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS2(config)#interface range fastethernet0/1-2
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#interface range fastethernet0/4-5
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#interface range fastethernet0/7-8
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#
00:17:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to down
00:17:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
ALS2(config-if-range)#
00:17:31: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up
00:17:31: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
DLS2(config)#interface range fastethernet0/7-12
DLS2(config-if-range)#switchport trunk encapsulation dot1q
DLS2(config-if-range)#switchport mode trunk
ALS1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/2 on 802.1q trunking 1
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/2 1-4094
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,100,110
Fa0/2 1,100,110
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Port Vlans allowed and active in management domain
Fa0/8 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 none
Fa0/2 none
Fa0/4 none
Fa0/5 none
Fa0/7 1,100,110
Fa0/8 none
ALS2#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/2 on 802.1q trunking 1
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/2 1-4094
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,100,110
Fa0/2 1,100,110
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Port Vlans allowed and active in management domain
Fa0/8 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1,100,110
Fa0/2 1,100,110
Fa0/4 1,100,110
Fa0/5 none
Fa0/7 none
Fa0/8 none
ALS1(config)#interface range fastethernet0/1-2
ALS1(config-if-range)#shutdown // SHUTDOWN PORTS BEFORE CONFIGURING ETHERCHANNEL; MIGHT GO IN ERR-DISABLE STATE
ALS1(config-if-range)#
00:22:27: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
00:22:27: %LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
ALS1(config-if-range)#channel-group ?
<1-48> Channel group number
ALS1(config-if-range)#channel-group 1 ?
mode Etherchannel Mode of the interface
ALS1(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
ALS1(config-if-range)#channel-group 1 mode desirable // ACTIVELY NEGoTIATE PAgP ETHERCHANNEL LINK
Creating a port-channel interface Port-channel 1
ALS2(config)#interface range fastethernet0/1-2
ALS2(config-if-range)#shutdown
ALS2(config-if-range)#
00:22:05: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
00:22:05: %LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
00:22:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
ALS2(config-if-range)#
00:22:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
ALS2(config)#interface range f0/1-2
ALS2(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
ALS1(config)#interface ?
Async Async interface
BVI Bridge-Group Virtual Interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Filter Filter interface
Filtergroup Filter Group interface
GigabitEthernet GigabitEthernet IEEE 802.3z
Group-Async Async Group interface
Lex Lex interface
Loopback Loopback interface
Null Null interface
Port-channel Ethernet Channel of interfaces
Portgroup Portgroup interface
Pos-channel POS Channel of interfaces
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing
Vlan Catalyst Vlans
fcpa Fiber Channel
range interface range command
ALS1(config)#interface port-channel ?
<1-48> Port-channel interface number
ALS1(config)#interface port-channel 1
ALS1(config-if)#switchport ?
access Set access mode characteristics of the interface
backup Set backup for the interface
block Disable forwarding of unknown uni/multi cast addresses
host Set port host
mode Set trunking mode of the interface
nonegotiate Device will not engage in negotiation protocol on this
interface
port-security Security related command
priority Set appliance 802.1p priority
protected Configure an interface to be a protected port
trunk Set trunking characteristics of the interface
voice Voice appliance attributes
<cr>
ALS1(config-if)#switchport mode ?
access Set trunking mode to ACCESS unconditionally
dot1q-tunnel set trunking mode to TUNNEL unconditionally
dynamic Set trunking mode to dynamically negotiate access or trunk mode
trunk Set trunking mode to TRUNK unconditionally
ALS1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk"
mode.
ALS1(config-if)#switchport trunk encapsulation dot1q
ALS1(config-if)#switchport mode trunk // CREATE LAYER 2 LOGICAL ETHERCHANNEL TRUNK
ALS2(config)#interface port-channel1
ALS2(config-if)#switchport trunk encapsulation dot1q
ALS2(config-if)#switchport mode trunk
ALS1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Fa0/1(D) Fa0/2(D) // LAYER 2 ETHERCHANNEL LINK; PORTS ARE DOWN
ALS1(config)#interface range fastethernet0/1-2
ALS1(config-if-range)#no shutdown
ALS1(config-if-range)#
00:29:29: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
00:29:29: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
ALS2(config)#interface range fastethernet0/1-2
ALS2(config-if-range)#no shutdown
ALS2(config-if-range)#
00:29:55: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:29:55: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
ALS2(config-if-range)#
00:30:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
00:30:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
ALS2(config-if-range)#
00:30:02: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:30:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
ALS2#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)
ALS1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)
ALS1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Po1 on 802.1q trunking 1 // PORT CHANNEL AS ONE LOGICAL TRUNK
Port Vlans allowed on trunk
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Po1 1-4094
Port Vlans allowed and active in management domain
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Fa0/8 1,100,110
Po1 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Port Vlans in spanning tree forwarding state and not pruned
Fa0/4 none
Fa0/5 none
Fa0/7 1,100,110
Fa0/8 none
Po1 none
ALS1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0016.c756.6180
Cost 19
Port 8 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 6416.8dec.a700
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Altn BLK 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Root FWD 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Altn BLK 12 128.56 P2p // ALS2 FE PORTS 1 AND 2 WERE FIRS UNSHUT
VLAN0100
Spanning tree enabled protocol ieee
Root ID Priority 32868
Address 0016.c756.6180
Cost 19
Port 8 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
Address 6416.8dec.a700
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Altn BLK 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Root FWD 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Altn BLK 12 128.56 P2p
VLAN0110
Spanning tree enabled protocol ieee
Root ID Priority 32878
Address 0016.c756.6180
Cost 19
Port 8 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32878 (priority 32768 sys-id-ext 110)
Address 6416.8dec.a700
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Altn BLK 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Root FWD 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Altn BLK 12 128.56 P2p
ALS2#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/4 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Po1 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/4 1-4094
Fa0/5 1-4094
Fa0/7 1-4094
Fa0/8 1-4094
Po1 1-4094
Port Vlans allowed and active in management domain
Fa0/4 1,100,110
Fa0/5 1,100,110
Fa0/7 1,100,110
Fa0/8 1,100,110
Po1 1,100,110
Port Vlans in spanning tree forwarding state and not pruned
Port Vlans in spanning tree forwarding state and not pruned
Fa0/4 1,100,110
Fa0/5 none
Fa0/7 none
Fa0/8 none
Po1 1,100,110
ALS2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0016.c756.6180
Cost 19
Port 5 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0022.5684.1380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Altn BLK 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Desg FWD 12 128.56 P2p
VLAN0100
Spanning tree enabled protocol ieee
Root ID Priority 32868
Address 0016.c756.6180
Cost 19
Port 5 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32868 (priority 32768 sys-id-ext 100)
Address 0022.5684.1380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Altn BLK 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Desg FWD 12 128.56 P2p
VLAN0110
Spanning tree enabled protocol ieee
Root ID Priority 32878
Address 0016.c756.6180
Cost 19
Port 5 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32878 (priority 32768 sys-id-ext 110)
Address 0022.5684.1380
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.5 P2p
Fa0/5 Altn BLK 19 128.6 P2p
Fa0/7 Altn BLK 19 128.8 P2p
Fa0/8 Altn BLK 19 128.9 P2p
Po1 Desg FWD 12 128.56 P2p
DLS1(config)#interface range fastethernet0/7-8
DLS1(config-if-range)#shutdown
DLS1(config-if-range)#
*Mar 1 00:35:04.743: %LINK-5-CHANGED: Interface FastEthernet0/7, changed state to administratively
down
*Mar 1 00:35:04.768: %LINK-5-CHANGED: Interface FastEthernet0/8, changed state to administratively
down
*Mar 1 00:35:05.750: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state
to down
DLS1(config-if-range)#
*Mar 1 00:35:05.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state
to down
DLS1(config-if-range)#channel-group ?
<1-48> Channel group number
DLS1(config-if-range)#channel-group 2 ?
mode Etherchannel Mode of the interface
DLS1(config-if-range)#channel-group 2 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
DLS1(config-if-range)#channel-group 2 mode active // ACTIVELY NEGOTIATES LACP TRUNK
Creating a port-channel interface Port-channel 2
ALS1(config)#interface range fastethernet0/7-8
ALS1(config-if-range)#shutdown
ALS1(config-if-range)#
00:37:19: %LINK-5-CHANGED: Interface FastEthernet0/7, changed state to administratively down
00:37:19: %LINK-5-CHANGED: Interface FastEthernet0/8, changed state to administratively down
ALS1(config-if-range)#channel-group 2 mode active
Creating a port-channel interface Port-channel 2
ALS1(config-if-range)#no shutdown
ALS1(config-if-range)#
00:37:50: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to down
00:37:50: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down
DLS1(config)#interface range fastethernet0/7-8
DLS1(config-if-range)#no shutdown
DLS1(config-if-range)#
*Mar 1 00:37:39.094: %LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to up
*Mar 1 00:37:39.102: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
DLS1(config-if-range)#
*Mar 1 00:37:46.484: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up
*Mar 1 00:37:46.501: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
DLS1(config-if-range)#
*Mar 1 00:37:47.465: %LINK-3-UPDOWN: Interface Port-channel2, changed state to up
*Mar 1 00:37:48.472: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed state to up
DLS1(config-if-range)#exit
DLS1(config)#interface port-channel2
DLS1(config-if)#switchport trunk encapsulation dot1q
DLS1(config-if)#switchport mode trunk
ALS1(config)#interface port-channel2
ALS1(config-if)#switchport trunk encapsulation dot1q
ALS1(config-if)#switchport mode trunk
ALS1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/1(P) Fa0/2(P)
2 Po2(SU) LACP Fa0/7(P) Fa0/8(P) // LAYER 2 ETHERCHANNEL LINK
DLS1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Fa0/7(P) Fa0/8(P)
DLS1(config)#interface range fastethernet0/11-12
DLS1(config-if-range)#no switchport // CREATE A LAYER 3/ROUTED PORT
DLS1(config-if-range)#
*Mar 1 00:43:45.726: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:43:45.776: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
DLS1(config-if-range)#
*Mar 1 00:43:47.748: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to up
*Mar 1 00:43:47.798: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
*Mar 1 00:43:48.754: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state
to up
DLS1(config-if-range)#
*Mar 1 00:43:48.805: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state
to up
DLS1(config-if-range)#channel-group 3 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
DLS1(config-if-range)#channel-group 3 mode desirable
Creating a port-channel interface Port-channel 3
DLS1(config-if-range)#
*Mar 1 00:44:03.602: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state
to down
*Mar 1 00:44:03.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state
to down
DLS1(config-if-range)#
*Mar 1 00:44:11.840: %EC-5-L3DONTBNDL1: Fa0/12 suspended: PAgP not enabled on the remote port.
*Mar 1 00:44:12.360: %EC-5-L3DONTBNDL1: Fa0/11 suspended: PAgP not enabled on the remote port.
DLS1(config-if-range)#exit
DLS1(config)#interface port-channel3
DLS1(config-if)#no switchport
DLS1(config-if)#ip address 10.0.0.1 255.255.255.0 // CREATE A LAYER 3 ETHERCHANNEL LINK
DLS2(config)#interface range fastethernet0/11-12
DLS2(config-if-range)#no switchport
DLS2(config-if-range)#
*Mar 1 00:47:23.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:47:23.654: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
DLS2(config-if-range)#
*Mar 1 00:47:25.617: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to up
*Mar 1 00:47:25.675: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
*Mar 1 00:47:26.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up
DLS2(config-if-range)#
*Mar 1 00:47:26.682: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up
DLS2(config-if-range)#channel-group 3 mode desirable
Creating a port-channel interface Port-channel 3
DLS2(config-if-range)#
*Mar 1 00:47:40.313: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
*Mar 1 00:47:40.322: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down
DLS2(config-if-range)#
*Mar 1 00:47:42.318: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel3, changed state to up
*Mar 1 00:47:42.973: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up
*Mar 1 00:47:43.258: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up
DLS2(config-if-range)#
*Mar 1 00:47:43.962: %LINK-3-UPDOWN: Interface Port-channel3, changed state to up
DLS2(config-if-range)#exit
DLS2(config)#interface port-channel3
DLS2(config-if)#no switchport
DLS2(config-if)#ip address 10.0.0.2
% Incomplete command.
DLS2(config-if)#ip address 10.0.0.2 255.255.255.0
DLS2(config-if)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms
DLS2#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
3 Po3(RU) PAgP Fa0/11(P) Fa0/12(P) // LAYER 3 ETHERCHANNEL LINK
DLS1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-mac // DEFAULT METHOD; VARIES ON SWITCH PLATFORMS
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
IPv4: Source MAC address
IPv6: Source MAC address
ALS1(config)#port-channel ?
load-balance Load Balancing method
ALS1(config)#port-channel load-balance ?
dst-ip Dst IP Addr
dst-mac Dst Mac Addr
src-dst-ip Src XOR Dst IP Addr
src-dst-mac Src XOR Dst Mac Addr
src-ip Src IP Addr
src-mac Src Mac Addr
ALS1(config)#port-channel load-balance src-dst-mac
ALS1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-mac
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination MAC address
IPv6: Source XOR Destination MAC address
No comments:
Post a Comment