This was the last ROUTE lab I did for IPv6, which is about 6to4 Tunneling. It's been fun and extremely challenging doing the ROUTE labs, which has been a valuable complement to my CCDP studies.
R1(config)#interface loopback0
R1(config-if)#
*Jan 10 09:17:39.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#ipv6 address FEC0::1:1/112
R1(config-if)#interface s0/0/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
R1(config-if)#
*Jan 10 09:18:22.851: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R2(config)#interface loopback0
R2(config-if)#
*Jan 10 08:00:41.891: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#interface s0/0/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
R2(config-if)#
*Jan 10 08:01:20.703: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 10 08:01:21.703: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#do ping 172.16.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/60 ms
R2(config-if)#interface s0/0/1
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#clockrate 64000
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
R2(config-if)#
*Jan 10 08:01:59.139: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 10 08:02:00.139: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R3(config)#interface loopback0
R3(config-if)#
*Jan 10 08:40:01.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 10.1.3.1 255.255.255.0
R3(config-if)#ipv6 address FEC0::3:1/112
R3(config-if)#interface s0/0/1
R3(config-if)#ip address 172.16.23.3 255.255.255.0
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
R3(config-if)#do ping 172.16.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 10.0.0.0
R1(config-router)#network 172.16.0.0
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 10.0.0.0
R2(config-router)#network 172.16.0.0
*Jan 10 08:04:44.787: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.1 (Serial0/0/0) is up: new adjacency
R3(config)#router eigrp 1
R3(config-router)#
R3(config-router)#
R3(config-router)#network 10.0.0.0
R3(config-router)#network 172.16.0.0
*Jan 10 08:42:39.551: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.23.2 (Serial0/0/1) is up: new adjacency
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.12.2 Se0/0/0 13 00:01:20 21 2280 0 9
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 172.16.23.3 Se0/0/1 11 00:01:08 24 2280 0 3
0 172.16.12.1 Se0/0/0 10 00:01:38 20 2280 0 3
R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.23.2 Se0/0/1 13 00:00:19 27 2280 0 8
R1(config)#interface loopback11
R1(config-if)#
*Jan 10 09:26:03.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback11, changed state to up
R1(config-if)#ipv6 address 2002:AC10:0C01:11::1/64
R1(config-if)#interface loopback12
R1(config-if)#
*Jan 10 09:26:27.523: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback12, changed state to up
R1(config-if)#ipv6 address 2002:AC10:0C01:12::1/64
R1(config-if)#do show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet0/1 [administratively down/down]
unassigned
Serial0/0/0 [up/up]
unassigned
Serial0/0/1 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::20A:B8FF:FEF8:8392
FEC0::1:1
Loopback11 [up/up]
FE80::20A:B8FF:FEF8:8392
2002:AC10:C01:11::1
Loopback12 [up/up]
FE80::20A:B8FF:FEF8:8392
2002:AC10:C01:12::1
R3(config)#interface loopback31
R3(config-if)#
*Jan 10 08:46:31.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback31, changed state to up
R3(config-if)#ipv6 address 2002:AC10:1703:31::1/64
R3(config-if)#interface loopback32
R3(config-if)#
*Jan 10 08:46:51.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback32, changed state to up
R3(config-if)#ipv6 address 2002:AC10:1703:32::1/64
R3(config-if)#do show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet0/1 [administratively down/down]
unassigned
Serial0/0/0 [administratively down/down]
unassigned
Serial0/0/1 [up/up]
unassigned
Loopback0 [up/up]
FE80::21B:D5FF:FE05:9B3A
FEC0::3:1
Loopback31 [up/up]
FE80::21B:D5FF:FE05:9B3A
2002:AC10:1703:31::1
Loopback32 [up/up]
FE80::21B:D5FF:FE05:9B3A
2002:AC10:1703:32::1
R1(config)#interface tunnel0
R1(config-if)#
*Jan 10 09:29:59.443: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#tunnel mode ?
aurp AURP TunnelTalk AppleTalk encapsulation
cayman Cayman TunnelTalk AppleTalk encapsulation
dvmrp DVMRP multicast tunnel
eon EON compatible CLNS tunnel
gre generic route encapsulation protocol
ipip IP over IP encapsulation
ipsec IPSec tunnel encapsulation
iptalk Apple IPTalk encapsulation
ipv6 Generic packet tunneling in IPv6
ipv6ip IPv6 over IP encapsulation
mpls MPLS encapsulations
nos IP over IP encapsulation (KA9Q/NOS compatible)
rbscp RBSCP in IP tunnel
R1(config-if)#tunnel mode ipv6ip ?
6to4 IPv6 automatic tunnelling using 6to4
auto-tunnel IPv6 automatic tunnelling using IPv4 compatible addresses
isatap IPv6 automatic tunnelling using ISATAP
<cr>
R1(config-if)#tunnel mode ipv6ip 6to4
R1(config-if)#
*Jan 10 09:31:01.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1(config-if)#ipv6 address 2002:AC10:0C01:1::1/64 // 6to4 TUNNEL USES SPECIAL IPv6 ADDRESS 2002::/16; AC10:0C01 = 172 IS AC, 16 IS 10, 12 IS C AND 1 IS 1
R1(config-if)#tunnel source serial0/0/0 // NO NEED FOR TUNNEL DESTINATION BECAUSE IT'S NOT A POINT-TO-POINT LINK
R1(config-if)#exit
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 route ?
X:X:X:X::X/<0-128> IPv6 prefix
vrf IPv6 Routing table
R1(config)#ipv6 route 2002::/16 ?
Async Async interface
Auto-Template Auto-Template interface
BVI Bridge-Group Virtual Interface
CDMA-Ix CDMA Ix interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Lex Lex interface
Loopback Loopback interface
MFR Multilink Frame Relay bundle interface
Multilink Multilink-group interface
Null Null interface
SSLVPN-VIF SSLVPN Virtual Interface
Serial Serial
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-Dot11Radio Virtual dot11 interface
Virtual-PPP Virtual PPP interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing
X:X:X:X::X IPv6 address of next-hop
vmi Virtual Multipoint Interface
R1(config)#ipv6 route 2002::/16 tunnel0
R3(config)#interface tunnel0
R3(config-if)#
*Jan 10 08:55:33.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R3(config-if)#tunnel mode ipv6ip 6to4
R3(config-if)#ipv6 address 2002:AC10:1703:1::3/64
R3(config-if)#tunnel source s0/0/1
R3(config-if)#
*Jan 10 08:56:04.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R3(config-if)#exit
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 route 2002::/16 tunnel0
R3#ping 2002:AC10:1703:1::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:1::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
R3#ping 2002:AC10:1703:31::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:31::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
R3#ping 2002:AC10:1703:32::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:32::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
R3#ping 2002:AC10:0C01:11::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:11::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
R3#ping 2002:AC10:0C01:12::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
R1(config)#ipv6 route FEC0::3:0/112 2002:AC10:1703:1::3
R3(config)#ipv6 route FEC0::1:0/112 2002:AC10:C01:1::1
R1#show ipv6 route
IPv6 Routing Table - Default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S 2002::/16 [1/0]
via Tunnel0, directly connected
C 2002:AC10:C01:1::/64 [0/0]
via Tunnel0, directly connected
L 2002:AC10:C01:1::1/128 [0/0]
via Tunnel0, receive
C 2002:AC10:C01:11::/64 [0/0]
via Loopback11, directly connected
L 2002:AC10:C01:11::1/128 [0/0]
via Loopback11, receive
C 2002:AC10:C01:12::/64 [0/0]
via Loopback12, directly connected
L 2002:AC10:C01:12::1/128 [0/0]
via Loopback12, receive
C FEC0::1:0/112 [0/0]
via Loopback0, directly connected
L FEC0::1:1/128 [0/0]
via Loopback0, receive
S FEC0::3:0/112 [1/0]
via 2002:AC10:1703:1::3
L FF00::/8 [0/0]
via Null0, receive
R3#show ipv6 route
IPv6 Routing Table - Default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S 2002::/16 [1/0]
via Tunnel0, directly connected
C 2002:AC10:1703:1::/64 [0/0]
via Tunnel0, directly connected
L 2002:AC10:1703:1::3/128 [0/0]
via Tunnel0, receive
C 2002:AC10:1703:31::/64 [0/0]
via Loopback31, directly connected
L 2002:AC10:1703:31::1/128 [0/0]
via Loopback31, receive
C 2002:AC10:1703:32::/64 [0/0]
via Loopback32, directly connected
L 2002:AC10:1703:32::1/128 [0/0]
via Loopback32, receive
S FEC0::1:0/112 [1/0]
via 2002:AC10:C01:1::1
C FEC0::3:0/112 [0/0]
via Loopback0, directly connected
L FEC0::3:1/128 [0/0]
via Loopback0, receive
L FF00::/8 [0/0]
via Null0, receive
R1#ping FEC0::3:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
R3#ping FEC0::1:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#FEC0::1:1
+>(tcl)#FEC0::3:1 2002:AC10:C01:1::1
+>(tcl)#2002:AC10:1703:1::3
+>(tcl)#2002:AC10:1703:31::1
+>(tcl)#2002:AC10:1703:32::1
+>(tcl)#2002:AC10:0C01:11::1
+>(tcl)#2002:AC10:0C01:12::1
+>(tcl)#} {
+>(tcl)#ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:1::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:31::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:32::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:11::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
R1(config)#interface loopback0
R1(config-if)#
*Jan 10 09:17:39.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#ipv6 address FEC0::1:1/112
R1(config-if)#interface s0/0/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
R1(config-if)#
*Jan 10 09:18:22.851: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R2(config)#interface loopback0
R2(config-if)#
*Jan 10 08:00:41.891: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#interface s0/0/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
R2(config-if)#
*Jan 10 08:01:20.703: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan 10 08:01:21.703: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#do ping 172.16.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/60 ms
R2(config-if)#interface s0/0/1
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#clockrate 64000
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
R2(config-if)#
*Jan 10 08:01:59.139: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan 10 08:02:00.139: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R3(config)#interface loopback0
R3(config-if)#
*Jan 10 08:40:01.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 10.1.3.1 255.255.255.0
R3(config-if)#ipv6 address FEC0::3:1/112
R3(config-if)#interface s0/0/1
R3(config-if)#ip address 172.16.23.3 255.255.255.0
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
R3(config-if)#do ping 172.16.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 10.0.0.0
R1(config-router)#network 172.16.0.0
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 10.0.0.0
R2(config-router)#network 172.16.0.0
*Jan 10 08:04:44.787: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.1 (Serial0/0/0) is up: new adjacency
R3(config)#router eigrp 1
R3(config-router)#
R3(config-router)#
R3(config-router)#network 10.0.0.0
R3(config-router)#network 172.16.0.0
*Jan 10 08:42:39.551: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.23.2 (Serial0/0/1) is up: new adjacency
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.12.2 Se0/0/0 13 00:01:20 21 2280 0 9
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 172.16.23.3 Se0/0/1 11 00:01:08 24 2280 0 3
0 172.16.12.1 Se0/0/0 10 00:01:38 20 2280 0 3
R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.23.2 Se0/0/1 13 00:00:19 27 2280 0 8
R1(config)#interface loopback11
R1(config-if)#
*Jan 10 09:26:03.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback11, changed state to up
R1(config-if)#ipv6 address 2002:AC10:0C01:11::1/64
R1(config-if)#interface loopback12
R1(config-if)#
*Jan 10 09:26:27.523: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback12, changed state to up
R1(config-if)#ipv6 address 2002:AC10:0C01:12::1/64
R1(config-if)#do show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet0/1 [administratively down/down]
unassigned
Serial0/0/0 [up/up]
unassigned
Serial0/0/1 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::20A:B8FF:FEF8:8392
FEC0::1:1
Loopback11 [up/up]
FE80::20A:B8FF:FEF8:8392
2002:AC10:C01:11::1
Loopback12 [up/up]
FE80::20A:B8FF:FEF8:8392
2002:AC10:C01:12::1
R3(config)#interface loopback31
R3(config-if)#
*Jan 10 08:46:31.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback31, changed state to up
R3(config-if)#ipv6 address 2002:AC10:1703:31::1/64
R3(config-if)#interface loopback32
R3(config-if)#
*Jan 10 08:46:51.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback32, changed state to up
R3(config-if)#ipv6 address 2002:AC10:1703:32::1/64
R3(config-if)#do show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
unassigned
FastEthernet0/1 [administratively down/down]
unassigned
Serial0/0/0 [administratively down/down]
unassigned
Serial0/0/1 [up/up]
unassigned
Loopback0 [up/up]
FE80::21B:D5FF:FE05:9B3A
FEC0::3:1
Loopback31 [up/up]
FE80::21B:D5FF:FE05:9B3A
2002:AC10:1703:31::1
Loopback32 [up/up]
FE80::21B:D5FF:FE05:9B3A
2002:AC10:1703:32::1
R1(config)#interface tunnel0
R1(config-if)#
*Jan 10 09:29:59.443: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#tunnel mode ?
aurp AURP TunnelTalk AppleTalk encapsulation
cayman Cayman TunnelTalk AppleTalk encapsulation
dvmrp DVMRP multicast tunnel
eon EON compatible CLNS tunnel
gre generic route encapsulation protocol
ipip IP over IP encapsulation
ipsec IPSec tunnel encapsulation
iptalk Apple IPTalk encapsulation
ipv6 Generic packet tunneling in IPv6
ipv6ip IPv6 over IP encapsulation
mpls MPLS encapsulations
nos IP over IP encapsulation (KA9Q/NOS compatible)
rbscp RBSCP in IP tunnel
R1(config-if)#tunnel mode ipv6ip ?
6to4 IPv6 automatic tunnelling using 6to4
auto-tunnel IPv6 automatic tunnelling using IPv4 compatible addresses
isatap IPv6 automatic tunnelling using ISATAP
<cr>
R1(config-if)#tunnel mode ipv6ip 6to4
R1(config-if)#
*Jan 10 09:31:01.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1(config-if)#ipv6 address 2002:AC10:0C01:1::1/64 // 6to4 TUNNEL USES SPECIAL IPv6 ADDRESS 2002::/16; AC10:0C01 = 172 IS AC, 16 IS 10, 12 IS C AND 1 IS 1
R1(config-if)#tunnel source serial0/0/0 // NO NEED FOR TUNNEL DESTINATION BECAUSE IT'S NOT A POINT-TO-POINT LINK
R1(config-if)#exit
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 route ?
X:X:X:X::X/<0-128> IPv6 prefix
vrf IPv6 Routing table
R1(config)#ipv6 route 2002::/16 ?
Async Async interface
Auto-Template Auto-Template interface
BVI Bridge-Group Virtual Interface
CDMA-Ix CDMA Ix interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Lex Lex interface
Loopback Loopback interface
MFR Multilink Frame Relay bundle interface
Multilink Multilink-group interface
Null Null interface
SSLVPN-VIF SSLVPN Virtual Interface
Serial Serial
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-Dot11Radio Virtual dot11 interface
Virtual-PPP Virtual PPP interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing
X:X:X:X::X IPv6 address of next-hop
vmi Virtual Multipoint Interface
R1(config)#ipv6 route 2002::/16 tunnel0
R3(config)#interface tunnel0
R3(config-if)#
*Jan 10 08:55:33.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R3(config-if)#tunnel mode ipv6ip 6to4
R3(config-if)#ipv6 address 2002:AC10:1703:1::3/64
R3(config-if)#tunnel source s0/0/1
R3(config-if)#
*Jan 10 08:56:04.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R3(config-if)#exit
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 route 2002::/16 tunnel0
R3#ping 2002:AC10:1703:1::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:1::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
R3#ping 2002:AC10:1703:31::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:31::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
R3#ping 2002:AC10:1703:32::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:32::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
R3#ping 2002:AC10:0C01:11::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:11::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
R3#ping 2002:AC10:0C01:12::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
R1(config)#ipv6 route FEC0::3:0/112 2002:AC10:1703:1::3
R3(config)#ipv6 route FEC0::1:0/112 2002:AC10:C01:1::1
R1#show ipv6 route
IPv6 Routing Table - Default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S 2002::/16 [1/0]
via Tunnel0, directly connected
C 2002:AC10:C01:1::/64 [0/0]
via Tunnel0, directly connected
L 2002:AC10:C01:1::1/128 [0/0]
via Tunnel0, receive
C 2002:AC10:C01:11::/64 [0/0]
via Loopback11, directly connected
L 2002:AC10:C01:11::1/128 [0/0]
via Loopback11, receive
C 2002:AC10:C01:12::/64 [0/0]
via Loopback12, directly connected
L 2002:AC10:C01:12::1/128 [0/0]
via Loopback12, receive
C FEC0::1:0/112 [0/0]
via Loopback0, directly connected
L FEC0::1:1/128 [0/0]
via Loopback0, receive
S FEC0::3:0/112 [1/0]
via 2002:AC10:1703:1::3
L FF00::/8 [0/0]
via Null0, receive
R3#show ipv6 route
IPv6 Routing Table - Default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S 2002::/16 [1/0]
via Tunnel0, directly connected
C 2002:AC10:1703:1::/64 [0/0]
via Tunnel0, directly connected
L 2002:AC10:1703:1::3/128 [0/0]
via Tunnel0, receive
C 2002:AC10:1703:31::/64 [0/0]
via Loopback31, directly connected
L 2002:AC10:1703:31::1/128 [0/0]
via Loopback31, receive
C 2002:AC10:1703:32::/64 [0/0]
via Loopback32, directly connected
L 2002:AC10:1703:32::1/128 [0/0]
via Loopback32, receive
S FEC0::1:0/112 [1/0]
via 2002:AC10:C01:1::1
C FEC0::3:0/112 [0/0]
via Loopback0, directly connected
L FEC0::3:1/128 [0/0]
via Loopback0, receive
L FF00::/8 [0/0]
via Null0, receive
R1#ping FEC0::3:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
R3#ping FEC0::1:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#FEC0::1:1
+>(tcl)#FEC0::3:1 2002:AC10:C01:1::1
+>(tcl)#2002:AC10:1703:1::3
+>(tcl)#2002:AC10:1703:31::1
+>(tcl)#2002:AC10:1703:32::1
+>(tcl)#2002:AC10:0C01:11::1
+>(tcl)#2002:AC10:0C01:12::1
+>(tcl)#} {
+>(tcl)#ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:1::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:31::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:32::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:11::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
No comments:
Post a Comment