Thursday, April 2, 2015

Using Manual IPv6 Tunnels with EIGRP for IPv6

I went to Perth Western Australia a month ago to install some Cisco gears and groomed the cabling in our data center. It was very hot when I was there (around 35 degrees Celsius) and I miss the cool weather during winter season. I always look for their Australian beef steak whenever I get the chance to visit this place. Even their McDonald's beef hamburger over there is very tasty.



This is another IPv6 lab that I did when studying for CCDP.


R1(config)#interface loopback0
R1(config-if)#
*Jan 10 00:28:25.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#ipv6 address FEC0::1:1/112
R1(config-if)#interface s0/0/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#clockrate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
R1(config-if)#
*Jan 10 00:29:09.659: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down


R2(config)#interface loopback0
R2(config-if)#
*Jan  9 23:11:21.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#interface s0/0/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
R2(config-if)#
*Jan  9 23:11:50.107: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jan  9 23:11:51.107: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#do ping 172.16.12.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
R2(config-if)#interface s0/0/1
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#clockrate 64000
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
R2(config-if)#
*Jan  9 23:12:24.871: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jan  9 23:12:25.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up


R3(config)#interface loopback0
R3(config-if)#
*Jan  9 23:50:21.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 10.1.3.1 255.255.255.0
R3(config-if)#ipv6 address FEC0::3:1/112
R3(config-if)#interface s0/0/1
R3(config-if)#ip address 172.16.23.3 255.255.255.0
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
R3(config-if)#do ping 172.16.23.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms


R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 10.0.0.0
R1(config-router)#network 172.16.0.0


R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 10.0.0.0
R2(config-router)#network 172.16.0.0
R2(config-router)#
*Jan  9 23:15:42.875: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.1 (Serial0/0/0) is up: new adjacency


R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#network 10.0.0.0
R3(config-router)#network 172.16.0.0
R3(config-router)#
*Jan  9 23:53:35.843: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.23.2 (Serial0/0/1) is up: new adjacency


R1(config)#interface tunnel0  
R1(config-if)#
*Jan 10 00:35:16.119: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#tunnel mode ?
  aurp    AURP TunnelTalk AppleTalk encapsulation
  cayman  Cayman TunnelTalk AppleTalk encapsulation
  dvmrp   DVMRP multicast tunnel
  eon     EON compatible CLNS tunnel
  gre     generic route encapsulation protocol
  ipip    IP over IP encapsulation
  ipsec   IPSec tunnel encapsulation
  iptalk  Apple IPTalk encapsulation
  ipv6    Generic packet tunneling in IPv6
  ipv6ip  IPv6 over IP encapsulation
  mpls    MPLS encapsulations
  nos     IP over IP encapsulation (KA9Q/NOS compatible)
  rbscp   RBSCP in IP tunnel

R1(config-if)#tunnel mode ipv6ip
R1(config-if)#tunnel source s0/0/0
R1(config-if)#tunnel destination 172.16.23.3
R1(config-if)#
*Jan 10 00:36:02.483: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1(config-if)#ipv6 address FEC0::13:1/112


R3(config)#interface tunnel0   // TUNNEL NUMBER IS LOCALLY SIGNIFICANT
R3(config-if)#
*Jan  9 23:56:12.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R3(config-if)#tunnel mode ipv6ip
R3(config-if)#tunnel source s0/0/1
R3(config-if)#tunnel destination 172.16.12.1
R3(config-if)#
*Jan  9 23:56:53.759: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R3(config-if)#ipv6 address FEC0::13:3/112   // TUNNEL DOESN'T REQUIRE GLOBAL UNICAST ADDRESSCAN; USE ipv6 enable COMMAND INSTEAD OF UNICAST IPv6 ADDRESS

R3#ping 172.16.12.1   // R1 WAN IP

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
R3#ping FEC0::13:1   // R1 TUNNEL0 IP

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::13:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms


R1#ping 172.16.23.3   // R3 WAN IP

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
R1#ping FEC0::13:3    // R3 TUNNEL0 IP

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::13:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms


R1(config)#ipv6 unicast-routing   // ENABLE IPv6 ROUTING
R1(config)#interface loopback0
R1(config-if)#ipv6 eigrp 100    // ENABLE EIGRP FOR IPv6 ON INTERFACE LEVEL LIKE IN OSPF
R1(config-if)#interface tunnel0
R1(config-if)#ipv6 eigrp 100


R3(config)#ipv6 unicast-routing
R3(config)#interface loopback0
R3(config-if)#ipv6 eigrp 100
R3(config-if)#interface tunnel0
R3(config-if)#ipv6 eigrp 100


R1#show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 100
% EIGRP 100 is in SHUTDOWN   // IPv6 EIGRP ROUTING IS SHUTDOWN BY DEFAULT

R1(config)#ipv6 ?
  access-list        Configure access lists
  cef                Cisco Express Forwarding for IPv6
  cga                Configure IPv6 certified generated address
  dhcp               Configure IPv6 DHCP
  general-prefix     Configure a general IPv6 prefix
  hop-limit          Configure hop count limit
  host               Configure static hostnames
  icmp               Configure ICMP parameters
  inspect            Context-based Access Control Engine
  local              Specify local options
  mfib               Multicast Forwarding
  mld                Global mld commands
  mobile             Mobile IPv6
  multicast          IPv6 multicast
  multicast-routing  Enable IPv6 multicast
  nat                NAT-PT Configuration commands
  nd                 Configure IPv6 ND
  neighbor           Neighbor
  ospf               OSPF
  pim                Configure Protocol Independent Multicast
  port-map           Port to application mapping (PAM) configuration commands
  prefix-list        Build a prefix list
  route              Configure static routes
  router             Enable an IPV6 routing process
  source-route       Process packets with source routing header options
  unicast-routing    Enable unicast routing

R1(config)#ipv6 router ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
  nemo   Network Mobility (NEMO)
  ospf   Open Shortest Path First (OSPF)
  rip    IPv6 Routing Information Protocol (RIPv6)

R1(config)#ipv6 router eigrp ?
  <1-65535>  Autonomous system number

R1(config)#ipv6 router eigrp 100
R1(config-rtr)#?
  default              Set a command to its defaults
  default-information  Distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Administrative distance
  distribute-list      Filter networks in routing updates
  eigrp                EIGRP specific commands
  exit                 Exit from IPv6 routing protocol configuration mode
  maximum-paths        Forward packets over multiple paths
  metric               Modify EIGRP routing metrics and parameters
  no                   Negate a command or set its defaults
  passive-interface    Suppress routing updates on an interface
  redistribute         Redistribute IPv6 prefixes from another routing protocol
  shutdown             Shutdown protocol
  timers               Adjust routing timers
  variance             Control load balancing variance

R1(config-rtr)#no ?
  default-information  Distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Administrative distance
  distribute-list      Filter networks in routing updates
  eigrp                EIGRP specific commands
  maximum-paths        Forward packets over multiple paths
  metric               Modify EIGRP routing metrics and parameters
  passive-interface    Suppress routing updates on an interface
  redistribute         Redistribute IPv6 prefixes from another routing protocol
  shutdown             Shutdown protocol
  timers               Adjust routing timers
  variance             Control load balancing variance

R1(config-rtr)#no shutdown


R3(config)#ipv6 router eigrp 100
R3(config-rtr)#no shutdown
R3(config-rtr)#
*Jan 10 00:05:02.219: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 100: Neighbor FE80::AC10:C01 (Tunnel0) is up: new adjacency

R3#show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Tu0               11 00:00:21 1310  5000  0  3
    FE80::AC10:C01


R1#show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Tu0               12 00:00:49  104  5000  0  3
    FE80::AC10:1703


R1#ping FEC0::3:1    // R3 LOOPBACK0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms


R3#ping FEC0::1:1   // R1 LOOPBACK0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms


R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#FEC0::1:1
+>(tcl)#FEC0::3:1
+>(tcl)#FEC0::13:1
+>(tcl)#FEC0::13:3
+>(tcl)#} {
+>(tcl)#ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/68/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::13:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::13:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms

No comments:

Post a Comment